Jump to content
ErmaC

Clover General discussion

20,959 posts in this topic

Recommended Posts

If I choose kext injection control in Clover Gui, go to the folder "other", and do not change anything there, just exit this folder and injection control menu, then try to boot from selected disk, boot fails.

if I do all the same, then go into the shell, and exit from it, and only then try to boot, or try to boot from another disk, everything is fine (Clover v2.4k r4243).

Not alone. I wrote this issue above. But my english skill is not good. Thank you for report

 

Edit1.

I always used injectkext=detect

 

나의 LG-F800S 의 Tapatalk에서 보냄

Share this post


Link to post
Share on other sites
Advertisement

So, I reinstalled 10.13 (17A365) using APFS and then boot with r4243 (Legacy).

I (by default) got no 10.13 dir inside /kexts, so I mv Other > 10.13 then placed my 3rd party kexts there.

But, if using InjectKexts=Detect I was unable tp reach the desktop for unknown reason, all kexts appears on Kexts Inject Mgmt though.

Otherwise, it works well by using InjectKexts=Yes. Thanks.

(Compiled using GCC5.3 under Ubuntu 16.04, also same results from SF rev & buildclover xcode8.2)

 

#EDIT: My prev tests under 10.13.1 (17B25c) got no problem by using InjectKexts=Detect/Yes, but with HFS+, with same r4243.

bootlog.log_r4243_gcc53_ub16.04.txt.zip

Share this post


Link to post
Share on other sites

 

I have checked my 10.13 installers boot.efi and they shown as 10.12 (created from 10.12 with createinstallmedia), which is bad.

Please try this patch (added dbg infos + comment out (Entry->LoaderType == OSTYPE_OSX_INSTALLER) here).

Temporarily install mandatory kexts in /L/E/ with CSR_ALLOW_UNTRUSTED_KEXTS so you are able to reach the desktop.

 

** In xnu-4570.1.46

#define CSR_ALLOW_UNAPPROVED_KEXTS  (1 << 9)

@cecekpawon

Sorry I do not know how to insert your patch  or replace the original information in main.c file?

Share this post


Link to post
Share on other sites

@cecekpawon

Sorry I do not know how to insert your patch  or replace the original information in main.c file?

in terminal:

patch -i /path/to/4243.diff

Example:

$ patch -i /Users/rico/Downloads/4243.diff
patching file main.c

More info:

patch --help
Usage: patch [OPTION]... [ORIGFILE [PATCHFILE]]

Input options:

  -p NUM  --strip=NUM  Strip NUM leading components from file names.
  -F LINES  --fuzz LINES  Set the fuzz factor to LINES for inexact matching.
  -l  --ignore-whitespace  Ignore white space changes between patch and input.

  -c  --context  Interpret the patch as a context difference.
  -e  --ed  Interpret the patch as an ed script.
  -n  --normal  Interpret the patch as a normal difference.
  -u  --unified  Interpret the patch as a unified difference.

  -N  --forward  Ignore patches that appear to be reversed or already applied.
  -R  --reverse  Assume patches were created with old and new files swapped.

  -i PATCHFILE  --input=PATCHFILE  Read patch from PATCHFILE instead of stdin.

Output options:

  -o FILE  --output=FILE  Output patched files to FILE.
  -r FILE  --reject-file=FILE  Output rejects to FILE.

  -D NAME  --ifdef=NAME  Make merged if-then-else output using NAME.
  -E  --remove-empty-files  Remove output files that are empty after patching.

  -Z  --set-utc  Set times of patched files, assuming diff uses UTC (GMT).
  -T  --set-time  Likewise, assuming local time.

  --quoting-style=WORD   output file names using quoting style WORD.
    Valid WORDs are: literal, shell, shell-always, c, escape.
    Default is taken from QUOTING_STYLE env variable, or 'shell' if unset.

Backup and version control options:

  -b  --backup  Back up the original contents of each file.
  --backup-if-mismatch  Back up if the patch does not match exactly.
  --no-backup-if-mismatch  Back up mismatches only if otherwise requested.

  -V STYLE  --version-control=STYLE  Use STYLE version control.
	STYLE is either 'simple', 'numbered', or 'existing'.
  -B PREFIX  --prefix=PREFIX  Prepend PREFIX to backup file names.
  -Y PREFIX  --basename-prefix=PREFIX  Prepend PREFIX to backup file basenames.
  -z SUFFIX  --suffix=SUFFIX  Append SUFFIX to backup file names.

  -g NUM  --get=NUM  Get files from RCS etc. if positive; ask if negative.

Miscellaneous options:

  -t  --batch  Ask no questions; skip bad-Prereq patches; assume reversed.
  -f  --force  Like -t, but ignore bad-Prereq patches, and assume unreversed.
  -s  --quiet  --silent  Work silently unless an error occurs.
  --verbose  Output extra information about the work being done.
  --dry-run  Do not actually change any files; just print what would happen.
  --posix  Conform to the POSIX standard.

  -d DIR  --directory=DIR  Change the working directory to DIR first.
  --binary  Read and write data in binary mode (no effect on this platform).

  -v  --version  Output version info.
  --help  Output this help.

Report bugs to <bug-patch@gnu.org>.

Share this post


Link to post
Share on other sites

Hello guys,

 

Is there any relations with OsxAptioFixDrv-64.efi and CsrActiveConfig?

 

On my Asus P8H77-M LE rig I've been using OsxAptioFixDrv-64.efi for a long time and I had no problem, until Today I decided to to change the CsrActiveConfig's value from 0x67 and set it to 0x3 and I constantly get the Error Loading Kernel.

 

If I use OsxAptioFix2Drv-64.efi it will load the OS, so I wonder what could be the cause?!

 

I'm using Clover r4243

Share this post


Link to post
Share on other sites

Hello guys,

 

Is there any relations with OsxAptioFixDrv-64.efi and CsrActiveConfig?

 

On my Asus P8H77-M LE rig I've been using OsxAptioFixDrv-64.efi for a long time and I had no problem, until Today I decided to to change the CsrActiveConfig's value from 0x67 and set it to 0x3 and I constantly get the Error Loading Kernel.

 

If I use OsxAptioFix2Drv-64.efi it will load the OS, so I wonder what could be the cause?!

 

I'm using Clover r4243

exactly. with OsxAptioFixDrv-64.efi 0x67 ok and in I need to boot with 0x0 I must change to OsxAptioFix2Drv-64.efi

Share this post


Link to post
Share on other sites

 

in terminal:

patch -i /path/to/4243.diff

Example:

$ patch -i /Users/rico/Downloads/4243.diff
patching file main.c

More info:

patch --help
Usage: patch [OPTION]... [ORIGFILE [PATCHFILE]]

Input options:

  -p NUM  --strip=NUM  Strip NUM leading components from file names.
  -F LINES  --fuzz LINES  Set the fuzz factor to LINES for inexact matching.
  -l  --ignore-whitespace  Ignore white space changes between patch and input.

  -c  --context  Interpret the patch as a context difference.
  -e  --ed  Interpret the patch as an ed script.
  -n  --normal  Interpret the patch as a normal difference.
  -u  --unified  Interpret the patch as a unified difference.

  -N  --forward  Ignore patches that appear to be reversed or already applied.
  -R  --reverse  Assume patches were created with old and new files swapped.

  -i PATCHFILE  --input=PATCHFILE  Read patch from PATCHFILE instead of stdin.

Output options:

  -o FILE  --output=FILE  Output patched files to FILE.
  -r FILE  --reject-file=FILE  Output rejects to FILE.

  -D NAME  --ifdef=NAME  Make merged if-then-else output using NAME.
  -E  --remove-empty-files  Remove output files that are empty after patching.

  -Z  --set-utc  Set times of patched files, assuming diff uses UTC (GMT).
  -T  --set-time  Likewise, assuming local time.

  --quoting-style=WORD   output file names using quoting style WORD.
    Valid WORDs are: literal, shell, shell-always, c, escape.
    Default is taken from QUOTING_STYLE env variable, or 'shell' if unset.

Backup and version control options:

  -b  --backup  Back up the original contents of each file.
  --backup-if-mismatch  Back up if the patch does not match exactly.
  --no-backup-if-mismatch  Back up mismatches only if otherwise requested.

  -V STYLE  --version-control=STYLE  Use STYLE version control.
	STYLE is either 'simple', 'numbered', or 'existing'.
  -B PREFIX  --prefix=PREFIX  Prepend PREFIX to backup file names.
  -Y PREFIX  --basename-prefix=PREFIX  Prepend PREFIX to backup file basenames.
  -z SUFFIX  --suffix=SUFFIX  Append SUFFIX to backup file names.

  -g NUM  --get=NUM  Get files from RCS etc. if positive; ask if negative.

Miscellaneous options:

  -t  --batch  Ask no questions; skip bad-Prereq patches; assume reversed.
  -f  --force  Like -t, but ignore bad-Prereq patches, and assume unreversed.
  -s  --quiet  --silent  Work silently unless an error occurs.
  --verbose  Output extra information about the work being done.
  --dry-run  Do not actually change any files; just print what would happen.
  --posix  Conform to the POSIX standard.

  -d DIR  --directory=DIR  Change the working directory to DIR first.
  --binary  Read and write data in binary mode (no effect on this platform).

  -v  --version  Output version info.
  --help  Output this help.

Report bugs to <bug-patch@gnu.org>.

Thanks. I use your command. Terminal results: can't find file to patch at input line 5

Share this post


Link to post
Share on other sites

All Clover versions will not load kexts from 10.13 if the system reported 10.12.

// version in boot.efi appears as "Mac OS X 10.?"

 

Don't rely on the protocol called by boot.efi, its output is often useless.

Share this post


Link to post
Share on other sites

Thanks. I use your command. Terminal results: can't find file to patch at input line 5[/size]

cd ~/src/edk2/Clover/rEFIt_UEFI/refit
patch -i /path/to/4243.diff

Share this post


Link to post
Share on other sites

 

I have checked my 10.13 installers boot.efi and they shown as 10.12 (created from 10.12 with createinstallmedia), which is bad.

Please try this patch (added dbg infos + comment out (Entry->LoaderType == OSTYPE_OSX_INSTALLER) here).

Temporarily install mandatory kexts in /L/E/ with CSR_ALLOW_UNTRUSTED_KEXTS so you are able to reach the desktop.

 

** In xnu-4570.1.46

#define CSR_ALLOW_UNAPPROVED_KEXTS  (1 << 9)

@cecekpawon

Thanks. Great Job  :)  Prebootlog from USB Installer 10.13:  good 'GetOSversion'. USB Pendrive can boot with using kext management for 10.13 and Other older. 

 

Sorry for my english

 

cd ~/src/edk2/Clover/rEFIt_UEFI/refit
patch -i /path/to/4243.diff

@ricoc93

Thanks for your help  :)

preboot_clover_r4244_USBInstaller.log.zip

Share this post


Link to post
Share on other sites

Stop changing SIP. Jesus, you guys are so weird. "I don't understand when I enable restricted access to secure resources I can't access that resource anymore." So stop. Here's what's happening, AptioFix MOVES tables around in memory, AptioFix2 marks them as unmovable memory mapped IO space. Neither approach works 100% for every one, so you need to use the one that works, AptioFix2 should be used because it has a better approach but also it has a much higher rate of failure (and a bug relating to allocation that no one seems to be able to find). Now, if you use AptioFix, then you NEED to have SIP config set to at least 0x67, whatever for AptioFix2, it shouldn't be affected if its working. So in other words it's a matter of the mechanism that is being used to prevent the OS from doing crazy stuff to your tables. AptioFix needs to be able to move the tables (this also probably breaks NVRAM that is SMM locked), so you can't enable restrictions in SIP because they will prevent the moving from being useful...

Share this post


Link to post
Share on other sites

Stop changing SIP. Jesus, you guys are so weird. "I don't understand when I enable restricted access to secure resources I can't access that resource anymore." So stop. Here's what's happening, AptioFix MOVES tables around in memory, AptioFix2 marks them as unmovable memory mapped IO space. Neither approach works 100% for every one, so you need to use the one that works, AptioFix2 should be used because it has a better approach but also it has a much higher rate of failure (and a bug relating to allocation that no one seems to be able to find). Now, if you use AptioFix, then you NEED to have SIP config set to at least 0x67, whatever for AptioFix2, it shouldn't be affected if its working. So in other words it's a matter of the mechanism that is being used to prevent the OS from doing crazy stuff to your tables. AptioFix needs to be able to move the tables (this also probably breaks NVRAM that is SMM locked), so you can't enable restrictions in SIP because they will prevent the moving from being useful...

With all due respect Sir, Being weird doesn't even being to describe us (Me) ;):D:hysterical:

 

We all like to look around and change things and install macOS on our PCs, we like to play with things that aren't supposed to played with (I'm talking about myself no offense to our fellow members). But sometimes lack of knowledge will complicate things and that's why we are here (I guess) to learn more and seek for help (I'm talking about myself again)

 

But none the less thanks a lot for you clear and complete answer as always. :)

 

Cheers

:)

Share this post


Link to post
Share on other sites

....

Cheers

:)

... also sorry, @cyberdev.. we may better play "safe" on this, I've deleted my prev. post about SIP: Enabled and give a clear note that I'm using "Legacy". Thanks.

Share this post


Link to post
Share on other sites

 

We all like to look around and change things and install macOS on our PCs, we like to play with things that aren't supposed to played with [...]

But sometimes lack of knowledge will complicate things and that's why we are here (I guess) to learn more and seek for help

+1

 

I like to learn. I like to figure things out and I like to see the connections between a and b. For that, you'll need to play and experiment a little, since that's the way to knowledge.

 

Share this post


Link to post
Share on other sites

... also sorry, @cyberdev.. we may better play "safe" on this, I've deleted my prev. post about SIP: Enabled and give a clear note that I'm using "Legacy". Thanks.

I'm sorry, my friend but I don't quite understand what you mean by "we may better play safe".

 

+1

 

I like to learn. I like to figure things out and I like to see the connections between a and b. For that, you'll need to play and experiment a little, since that's the way to knowledge.

 

I totally agree, not knowing something created a need for asking questions and therefor science was born :) This is the whole point of experimenting with macOS and PCs.

 

If I wanted to play safe I would have bought an iMac or a MacPro. ;)

 

Let's not get carried away and stay on topic :)

Share this post


Link to post
Share on other sites

I'm sorry, my friend but I don't quite understand what you mean by "we may better play safe".

No more to explain, brother. I just follow what I think; is better. And even with simple explanation above, I also hard to understand.

So, as what my friend told me; "There're players, supporters, a coach, some referees or a manager..", but I stand as "a popcorn seller" on a soccer match.

 

#OffTopic, I even still du no how to hide some bonus entries on Clover GUI after converted my hSierra to APFS.

Share this post


Link to post
Share on other sites

Now, if you use AptioFix, then you NEED to have SIP config set to at least 0x67, whatever for AptioFix2, it shouldn't be affected if its working. So in other words it's a matter of the mechanism that is being used to prevent the OS from doing crazy stuff to your tables. AptioFix needs to be able to move the tables (this also probably breaks NVRAM that is SMM locked), so you can't enable restrictions in SIP because they will prevent the moving from being useful...

Source/explaination please?

Share this post


Link to post
Share on other sites

#OffTopic, I even still du no how to hide some bonus entries on Clover GUI after converted my hSierra to APFS.

 

this is how I hide the Preboot partition

find its GUID in the clover boot log and then name it so i can easily reference it  - to hide it!

<key>GUI</key>
<dict>
  <key>Custom</key>
  <dict>
   <key>Comment</key>
   <string>Custom Entries</string>
   <key>Entries</key>
   <array>
...
    <dict>
     <key>FullTitle</key>
     <string>Preboot</string>
     <key>Hidden</key>
     <false/>
     <key>Volume</key>
     <string>CE105F19-A28D-4A84-83D5-CDF4D547E35A</string>
    </dict>
   </array>
  </dict>
  <key>Hide</key>
  <array>
   <string>Preboot</string>
  </array>
...

Share this post


Link to post
Share on other sites

 

this is how I hide the Preboot partition

find its GUID in the clover boot log and then name it so i can easily reference it  - to hide it!

OK, otw testing. Thanks for the guide @tluck.  :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   1 member

  • Similar Content

    • By dgsga
      Can I propose a new subforum be created for the new OpenCorePkg OpenCore front end being created by vit9696 and others, it is a fantastic piece of work:
      https://github.com/acidanthera/OpenCorePkg
      Even at version 0.1 it runs my Mojave 10.14.4 setup very nearly flawlessly. It consists of a 10KB bootstrap BootX64.efi and a 200KB OpenCore.efi OS loader. All configuration is done using a very well documented config.plist 
       
       
    • By kingoffright
      Dear all,
       
      I have a external harddisk about 500GB, I installed the clover into it and the harddisk is GPT format, below is the 3 partitions details:
      FS01: EFI - disk0s1 - fat32
      FS02: install mac  image - disk0s2 -  hfs+
      FS03: install windows 10 - disk0s3 - fat32
       
      I can use this external harddisk to install Mac without issue, I use below steps to install windows 10
      enter the FS03:
      cd to efi/boot/ and excuete bootx64.efi
      after pop up the windows install screen, i click next and it shows error 'A media driver your computer needs is missing...' and the installation can not go any further.
      Firstly I use ultraiso to write the windows 10 image to a flash disk and no issue to start install window 10 so the image is working fine. Since I dont know how to write
      a wiindow installation image into harddisk partition, I used winrar extra all the files into disk0s3, am I missing some steps or actually clover not support to install windows
      by partitions, apprecating any helps.
       
    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15.1
      This post will no longer updated, go for the osxlatitude link for further updates
      Original and updated link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      On Catalina the System folder is read-only, so you need to remount in rw to modify System/Library. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.11.03: Enabled SIP caused a lots of issues so now it's disabled -> updated bootpack
      2019.11.02: Updated to 10.15.1 -> no problem when/after installing
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
×