Jump to content
ErmaC

Clover General discussion

20,226 posts in this topic

Recommended Posts

since 4239 folder Other case-sentitive

wont boot with lowercase o letter

 

Maybe because of this >>>. Try to change StrStr to StriStr.

 

I've got a dumb question, but could this be a clover problem? https://github.com/Piker-Alpha/HandyScripts/issues/7

 

IMHO you should ask the developer, he should 'watch' their project to get notified for incoming bug report.

Share this post


Link to post
Share on other sites
Advertisement

Maybe because of this >>>. Try to change StrStr to StriStr.

 

 

IMHO you should ask the developer, he should 'watch' their project to get notified for incoming bug report.

.. and how about this? (has no different for boot though). TIA.  :)

 

 
#EDIT: "CLOVER" but sometimes "Clover".

Share this post


Link to post
Share on other sites

There is no problem. You have two solutions:

1. Update BIOS to newer version.

2. Don't update BIOS. Add Clover Boot Option by second button in low row in Clover GUI. Then sure that you can boot from file /EFI/CLOVER/CLOVERX64.EFI.

Then delete file /EFI/BOOT/BOOTX64.EFI.

Boot options will never propagate any more.

Share this post


Link to post
Share on other sites

Sure you can boot fine with r4223. Slice start to enhance syscls work from r4233. I saw artur_pt doesnt has kexts loaded from "Other" dir. As far as I can remember, "Other" dir designed / should act like 'Common' folder (so Clover should read it no matter what), not just as a fallback when OS ver undetected. So, during test you can put your mandatory kext eg: FakeSMC in "Other" dir, also in OSVer dir for the rest of your kexts, to make sure Clover can read / load / disable em all / each.

 

'Common' folder (so Clover should read it no matter what), not just as a fallback when OS ver undetected.

- i saw this case. lion 10.7.5 app image and use DiskMakerX304 to make usb installer.

then boot 10.7.5 usb installer made by diskmakerx304. then format disk and install. and reboot.

clover can't detect 10.7.5 version(shown null). i check install files. but there are  any version info files in installed disk(to install 10.7.5, 2nd stage).

i used clover r4232. so i have to put fakesmc other folder. then i can install 10.7.5.

ofc restore basesystem.dmg method is no problem. diskmakerx304 method is rare case. but no need restore dmg and package folder.

 

so need to consider other folder with each os version.

also i saw fakesmc 3.4.1 and 3.5.0 difference(old osx support). need to confirm proper combination for old osx.

 

sorry for my bad english.

 

here is evidence

post-980913-0-48755800-1507393100_thumb.png

 

thanks in advance

Share this post


Link to post
Share on other sites

hello

 

i prefer don't use other folder

 

but if need also load the kext in there .. is my case .. I just renamed other folder in EFI/Clover/Kexts

 

once again nice work Slice

Share this post


Link to post
Share on other sites
#EDIT: "CLOVER" but sometimes "Clover".

 

\EFI\CLOVER should be fine.

But azlvda seems to have "other" instead of "Other" kext folder & Clover refused to read em.

 

- i saw this case.

 

Really not sure man, so Clover only read "Other" folder but not your "10.7" folder? Maybe other ppl here like can help you..

*** Maybe your installer SystemVersion.plist is in another place (check your "mac OS X Install Data" / IABootFilesSystemVersion.plist).

Edited by cecekpawon

Share this post


Link to post
Share on other sites

\EFI\CLOVER should be fine.

But azlvda seems to have "other" instead of "Other" kext folder & Clover refused to read em.

 

 

Really not sure man, so Clover only read "Other" folder but not your "10.7" folder? Maybe other ppl here like can help you..

 

Sorry for bad english.
Right. My mistakes above reply.
 
I have 10.7 with essential kexts. I used each os version folder for boot osx before.
Just found rare case.
 
if i put fakesmc3.5.0 in other folder and fakesmc3.4.1 in 10.7 folder, clover first read other folder and 10.7 folder.
then clover read two fakesmc. So i wonder last loaded fakesmc3.4.1 instead of 3.5.0 when os booting?

Share this post


Link to post
Share on other sites

Sorry to step into the discussion but may i suggest this ( -nehalem_error_disable ) boot arg being added to Clover / Configurator  ( so people get to know it ) , which i accidently discovered today by digging around AppleTyMCEDriver binary

 

LfazhyB.jpg

 

right hand side top to bottom:

 

 -nehalem_error_disable  disables the AppleTyMCEDriver 

 

offcourse works perfect in 10.13( dunno about older Versions ) and gets rid of the panic on MacPro4,1 and 5,1 at the ECC ram check.

 

Pls ignore this if it is old cheese but i couldnt find anything about it so i thought id share it.

 

And it is a nice addition to the other workarounds to this old little problem.

Share this post


Link to post
Share on other sites

\EFI\CLOVER should be fine.

But azlvda seems to have "other" instead of "Other" kext folder & Clover refused to read em.

 

 

Really not sure man, so Clover only read "Other" folder but not your "10.7" folder? Maybe other ppl here like can help you..

*** Maybe your installer SystemVersion.plist is in another place (check your "mac OS X Install Data" / IABootFilesSystemVersion.plist).

I remembered old problem with FAT32 driver usually present in UEFI BIOSes.

They may works differently and not as you expected.

Other can be accounted as 8+3 DOS name or as Windows 95 long name and just will not work.

For this case I keep in my drivers64UEFI folder this good driver

Fat-64.efi.zip

but users usually ignore it.

Share this post


Link to post
Share on other sites

I remembered old problem with FAT32 driver usually present in UEFI BIOSes.

They may works differently and not as you expected.

Other can be accounted as 8+3 DOS name or as Windows 95 long name and just will not work.

For this case I keep in my drivers64UEFI folder this good driver

attachicon.gifFat-64.efi.zip

but users usually ignore it.

I always select this drivers since is release  ;)

Share this post


Link to post
Share on other sites

0:840  0:000  skipping kext injection (not requested)

0:840  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other

0:840  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.12

 

If kext injection is disabled in plist, why is it scanning/preparing kexts?

I think it should be skipped in this situation thereby saving time and IO. If user forces injection in Clover UI, then scan.

Share this post


Link to post
Share on other sites

0:840  0:000  skipping kext injection (not requested)

0:840  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other

0:840  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.12

 

If kext injection is disabled in plist, why is it scanning/preparing kexts?

I think it should be skipped in this situation thereby saving time and IO. If user forces injection in Clover UI, then scan.

There is a contradiction. If you don't want scanning when injection disabled then you will not be able to enable one of them.

So yes, I preferred always scan kexts folders but let user to choose what to inject or not.

Share this post


Link to post
Share on other sites

Commits r4243: with or with without CloverX64.efi-4243, Clover get OSversion 10.12 when I boot from USB pen drive (10.13 only) and HDD Sierra connected: Kextd stall on AppleACPICPU and black screen

 

Commits r4243: with or with without CloverX64.efi-4243, Clover get OSversion 10.13.1 when I boot from HDD High Sierra (10.13 only) and HDD Sierra connected. Kextd stall on AppleACPICPU

 

 

Commits r4243 HDD 10.13.1 alone (10.13 folder only): with or  without CloverX64.efi-4243: No Injection -----> "Thinning failed" error. 

 

Here, new kext management don't work with 10.13 folder only

 

 

I don't understand why these issues?

 

@Matgen84,

 

I have a feeling the problem might be due to the XCODE toolchain used to compile Clover.  

 

Can you try booting with the attached r4243 compiled with GCC5.3 in Linux Mint 18.1?

 

As another test, can you also try r4238 with @cecekpawon's changes from post#14767?

r4243_GCC53.zip

Share this post


Link to post
Share on other sites

Where should I keep my kext after Post installation CLOVER/kexts/other or S/L? Somebody is saying keep it in CLOVER/kexts/other but somebody saying after the post installation move to all kexts to S/L. I really confused where to keep my kexts after post installation?

Share this post


Link to post
Share on other sites

Where should I keep my kext after Post installation CLOVER/kexts/other or S/L? Somebody is saying keep it in CLOVER/kexts/other but somebody saying after the post installation move to all kexts to S/L. I really confused where to keep my kexts after post installation?

It is your choice. My opinion that CLOVER/kexts/other  is good for testing and S/L/E is a kexts home where they should live forever and they will appear in cache so will be loaded much faster.

Share this post


Link to post
Share on other sites

i found one on official r4243.

first i don't have any kext files in others folder and -v bootargs option.

 

just go to Clover Gui, Select High Sierra disk with space bar, go to kext inject management, enter 10.13 folder.

i can see my kexts list. exit 10.13 folder and go other folder, i see there is no kexts files.

exit other folder, then without -v, boot high sierra disk. i can't boot. 

 

i see this " +++++++++++++++++++++++++++++++ "line with apple logo.

 

if -v option, i can boot. strange.

 

 

EDIT1.

i used r4232 version before. there is no problem. i followed same above written process. in syscl's method, kext inject management just located in options.

syscl's kext inject management is perfect working. i tested it.

Share this post


Link to post
Share on other sites

On my Skylake rig, if i highlight Sierra drive, press spacebar, select verbose -v then boot macOS with selected options the machine boots like its missing EmuVariableUEFI (Yes i have it) as when the OS loads i have no graphics acceleration etc.. I take it this isn't by design?

Share this post


Link to post
Share on other sites

@Matgen84,

 

I have a feeling the problem might be due to the XCODE toolchain used to compile Clover.  

 

Can you try booting with the attached r4243 compiled with GCC5.3 in Linux Mint 18.1?

 

As another test, can you also try r4238 with @cecekpawon's changes from post#14767?

Hi @fusion71au

 

r4243 compiled with GCC53--------->graphics issue on a part of Clover menu GUI

r4238 patched------------------------->kextd stall AppleACPICPU. Bad getOSVersion: 10.12 instead of 10.13 when booting from High Sierra USB pen drive and Sierra HDD connected

 

I do not have any luck at the moment  :)

 

Edit!  test with release Clover r4233 on SourceForge. Boot from USB 10.13 with HDD Sierra connected:

 

Bad getOSversion : 10.12 instead of 10.13 ----- Other folder inject 3 times. Don't see 10.13 folder for injection. See attached file

preboot_Cloverr4233_USB+HDD-connected.log.zip

Share this post


Link to post
Share on other sites

All Clover versions will not load kexts from 10.13 if the system reported 10.12.

// version in boot.efi appears as "Mac OS X 10.?"

I  have "getOS 10.12" when I boot from USB 10.13 with HDD 10.12 connected to my system. Why?

Share this post


Link to post
Share on other sites

Thank you Slice for your answer

for my unsupported CPU (Xeon 2696 V4) best clover release are 4184 and 4210. Now I am using 4210

with 4220 in my case performances are low because a previously working patch useful for people like me with EIST enabled on BIOS is not working in 4220

with 4233, with more ssd disk attache with different rev of high sierra I have a very weird behavior in useful function (kext management).

In my case, in it I can see many duplicates of same kext

4233 also produce some randomly reboot if I use High Sierra after using Windows 10

 

Commit 4185 already reverted to the state of 4184.

Check latest Clover and provide debug.log.

Share this post


Link to post
Share on other sites

Hello guys, good morning.

 

It's still necessary use the "NTFS.efi" at drivers64UEFI folder in dual-boot UEFI systems? It's a mandatory, to be more specific?

 

Thanks  :)

Share this post


Link to post
Share on other sites

Hello guys, good morning.

 

It's still necessary use the "NTFS.efi" at drivers64UEFI folder in dual-boot UEFI systems? It's a mandatory, to be more specific?

 

Thanks  :)

Hi Allan, good morning :)

 

I have a rig with dual booting Windows 10 and macOS (El Cap, Sierra, High Sierra) and I don't use NTFS.efi, So I guess having it is not mandatory. I never used it.

Share this post


Link to post
Share on other sites

If I choose kext injection control in Clover Gui, go to the folder "other", and do not change anything there, just exit this folder and injection control menu, then try to boot from selected disk, boot fails.

if I do all the same, then go into the shell, and exit from it, and only then try to boot, or try to boot from another disk, everything is fine (Clover v2.4k r4243).

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By ErmaC
      Slice is glad to present a new EFI bootloader.

      CLOVER
      Now version 2 rEFIt based.


      It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
      I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
      https://sourceforge.net/projects/cloverefiboot/?source=directory
      There is a WIKI 
      http://clover-wiki.zetam.org/
      Main features:


      If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
      Continued by blackosx and STLVNUB.
      Post#2 CloverGrower - create Clover by yourself Post#3 Downloads Post#4 Installation of the bootloader Post#5 How to do UEFI boot Post#6 How to use - common words Post#7 Calculator for Automatic DSDT fix Post#8 Instructions for GraphicsInjector Post#9 ATIConnector patching Post#10 Any kexts patching with some Samples Post#11 CustomEDID Post#12 Hiding unnecessary menu entries Post#13 Instruction for DSDT corrections to do DeviceInjection works Post#14 Development Post#15 Themes Post#16 About kexts injection Post#17 Instructions for P- and C-states generator Post#18 Patching DSDT to get Sleep working Post#19 CPU settings and geekbench Post#20 ACPI tables loading Post#21 DSDTmini Post#22 Custom SMBios Post#23 F.A.Q. Post#24 iCloudFix Post#25 Using mouse. Post#26 How to make orange icons to be metallic Post#27 How to make software RAID (by Magnifico) Post#28 How to modify InstallESD.dmg (by shiecldk) Post#29 Config.plist settings Post#30 Using extra kexts and skipping kernelcache Post#31 Choosing EFI drivers Post#32 Configuration files Post#33 Automatic config.plist creating Post#34 Custom DSDT patches Post#35 How to do sleep/wake working with UEFI BOOT Post#36 DeviceID substitution (FakeID) Post#37 Using Custom OS Icons Post#38 Hibernation Post#39 Floating regions Post#41 Property List Editor Post#42 Blocking Bad Kext Post#43 AAPL,slot-name Post#44 FakeCPUID for unsupported CPU Post#45 Multiple Boot Options - to write into UEFI BIOS boot menu Post#46 How to install Windows UEFI Post#47 How to speedup Clover boot Post#48 Info.plist patching Post#49 Arbitrary device injection Post#50 Non-Standard Legacy Boot Files Post#51 Reboot to Windows UEFI from Mac OSX Post#52 Deprecated Features Post#53 Using UDK2018 Post#54 Device Properties Post#55 Scalable themes Post#56 How to search Clover mistakes (bisection) -----------------
       
      Slice:
      I edited all posts in the thread to correspond to actual Clover revision.
      Please install Clover at least 2652 and use new instructions.
×