Jump to content
ErmaC

Clover General discussion

19,137 posts in this topic

Recommended Posts

Hi Slice.

 

Clover kext folders on FAT32 USB shown below, booting 10.7.5, 10.12.6 or 10.13 release.

 

 

 

Only kexts in /Other and /10.12 are visible in Kext Inject Management Submenu.  When select to boot into 10.13, Kext Inject Management only shows kexts in /Other, none in 10.13...

 

 

135:377  0:000  Loading boot.efi  status=Success
135:738  0:360  GetOSVersion: 10.13 (17A365)
135:785  0:000  Beginning FSInjection
FSInjectionInstall ...
- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: DCD83398
FSInjectionInstall ...
- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: DCD83398
135:785  0:000  Use origin smbios table type 1 guid.
135:786  0:000  OSVesion: 10.13, ShortOSVersion=10.13, uni-vers=10.13,
135:786  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
135:786  0:000  current kext name RealtekRTL8111.kext Match Other, while sysver: 10.13
135:786  0:000  Extra kext: EFI\CLOVER\kexts\Other\RealtekRTL8111.kext
135:855  0:069  current kext name FakeSMC.kext Match Other, while sysver: 10.13
135:855  0:000  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC.kext
135:933  0:078    |-- PlugIn kext: EFI\CLOVER\kexts\Other\FakeSMC.kext\Contents\PlugIns\IntelCPUMonitor.kext
135:961  0:028    |-- PlugIn kext: EFI\CLOVER\kexts\Other\FakeSMC.kext\Contents\PlugIns\HWInfo.kext
135:962  0:000  current kext name VoodooHDA.kext Match 10.12, while sysver: 10.13
135:962  0:000  current kext name AppleHDADisabler.kext Match 10.12, while sysver: 10.13
135:962  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.13
135:962  0:000  current kext name RealtekRTL8111.kext Match Other, while sysver: 10.13
135:962  0:000  current kext name FakeSMC.kext Match Other, while sysver: 10.13
135:962  0:000  current kext name VoodooHDA.kext Match 10.12, while sysver: 10.13
135:962  0:000  current kext name AppleHDADisabler.kext Match 10.12, while sysver: 10.13 

attachicon.gifKext Inject Management.png

attachicon.gifOther.png

attachicon.gif10.13_1.png

attachicon.gif10.13_2.png

attachicon.gif10.12_1.png

attachicon.gif10.12_2.png

 

 

 

 

 

Debug/preboot.log attached.

I understand the reason.

The list InjectKextList must be inited before enter menu. Else only first folder will be scanned.

Share this post


Link to post
Share on other sites
Advertisement

Slice, Thank you for this incredible boot loader.   We now have a few AMD CPU test kernels and because of Clover they're up and running quickly.    We have AMD Ryzen working in High Sierra, thanks to all of you in the clover community for including us CPU misfits.    You have helped many to step up to modern graphics cards and CPUS on AMD systems.

 

Clover Configurator generated boot log: bootlog.log.txt

 

Just noticed a few errors to fix, iMessage 17 chars and DummyUSB.

Share this post


Link to post
Share on other sites

4238

Same here Slice Legacy Inject won't to see any kext in 10.13/10.7/10.6 

Honestly, for my mach with dualboot macOS'es 10.11 & 10.13 by using "Other" folder only for kext injection is enough, since the kexts contents on both folders are exactly same versions... (except, EAPDCodecCommander & BTFirmwareUploader kext that on my case are not working yet under 10.13) << but the last two are not mandatory for me.  :) So, here I'm just glad to test for new clover revisions and hopefully, get more learning from them. Thanks.

Share this post


Link to post
Share on other sites

Again, for me r4238 works fine.

Kext Injection management shows the kexts in 10.13 and Other.
injection seems to go fine too.

 

post-1502423-0-97888700-1507206224_thumb.pngpost-1502423-0-08125500-1507206232_thumb.png

48:032  0:000  OSVesion: 10.13.1, ShortOSVersion=10.13, uni-vers=10.13,
48:032  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
48:032  0:000  current kext name Lilu.kext Match Other, while sysver: 10.13
48:032  0:000  Extra kext: EFI\CLOVER\kexts\Other\Lilu.kext
48:035  0:002  current kext name FakeSMC.kext Match Other, while sysver: 10.13
48:035  0:000  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC.kext
48:038  0:003  current kext name AppleALC.kext Match Other, while sysver: 10.13
48:038  0:000  Extra kext: EFI\CLOVER\kexts\Other\AppleALC.kext
48:042  0:003    |-- PlugIn kext: EFI\CLOVER\kexts\Other\AppleALC.kext\Contents\PlugIns\PinConfigs.kext
48:156  0:114  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
48:156  0:000  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
48:156  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.13
48:156  0:000  current kext name Lilu.kext Match Other, while sysver: 10.13
48:156  0:000  current kext name FakeSMC.kext Match Other, while sysver: 10.13
48:156  0:000  current kext name AppleALC.kext Match Other, while sysver: 10.13
48:156  0:000  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
48:156  0:000  Extra kext: EFI\CLOVER\kexts\10.13\USB_Injector.kext
48:162  0:005  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
48:162  0:000  Extra kext: EFI\CLOVER\kexts\10.13\IntelMausiEthernet.kext
48:171  0:008  Custom boot screen not used because entry has unset use graphics

Share this post


Link to post
Share on other sites

 

Again, for me r4238 works fine.

Kext Injection management shows the kexts in 10.13 and Other.

injection seems to go fine too.

48:035  0:000  Extra kext: EFI\CLOVER\kexts\Other\FakeSMC.kext

Yea FakeSMC  in Other

Working also here, the issue is FakeSMC /10.13

Share this post


Link to post
Share on other sites

Yea FakeSMC  in Other

Working also here, the issue is FakeSMC /10.13

 

That works too

7:422  0:000  OSVesion: 10.13.1, ShortOSVersion=10.13, uni-vers=10.13,
7:422  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
7:422  0:000  current kext name Lilu.kext Match Other, while sysver: 10.13
7:422  0:000  Extra kext: EFI\CLOVER\kexts\Other\Lilu.kext
7:425  0:002  current kext name AppleALC.kext Match Other, while sysver: 10.13
7:425  0:000  Extra kext: EFI\CLOVER\kexts\Other\AppleALC.kext
7:427  0:002    |-- PlugIn kext: EFI\CLOVER\kexts\Other\AppleALC.kext\Contents\PlugIns\PinConfigs.kext
7:538  0:110  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13
7:538  0:000  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
7:538  0:000  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
7:538  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.13
7:538  0:000  current kext name Lilu.kext Match Other, while sysver: 10.13
7:538  0:000  current kext name AppleALC.kext Match Other, while sysver: 10.13
7:538  0:000  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13
7:538  0:000  Extra kext: EFI\CLOVER\kexts\10.13\FakeSMC.kext
7:552  0:013  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
7:552  0:000  Extra kext: EFI\CLOVER\kexts\10.13\USB_Injector.kext
7:557  0:005  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
7:557  0:000  Extra kext: EFI\CLOVER\kexts\10.13\IntelMausiEthernet.kext
7:565  0:007  Custom boot screen not used because entry has unset use graphics

I guess the issue only exists if you have multiple macOS versions installed. I only have 10.13.1

 

EDIT: I'll test and see what happens if I plug my 10.12.6 SSD in. I'll also install SL/Yosemite on a seperate HDD to test.

Share this post


Link to post
Share on other sites

Yea FakeSMC  in Other

Working also here, the issue is FakeSMC /10.13

U mean, if we placed FakeSMC on /EFI/CLOVER/kexts/10.13/ it prevents another kexts on a whole folder to be injected ..?

Share this post


Link to post
Share on other sites

U mean, if we placed FakeSMC on /EFI/CLOVER/kexts/10.13/ it prevents another kexts on a whole folder to be injected ..?

No I mean FakeSMC works in Other for 10.13 High Sierra 

That works too

7:422  0:000  OSVesion: 10.13.1, ShortOSVersion=10.13, uni-vers=10.13,
7:422  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
7:422  0:000  current kext name Lilu.kext Match Other, while sysver: 10.13
7:422  0:000  Extra kext: EFI\CLOVER\kexts\Other\Lilu.kext
7:425  0:002  current kext name AppleALC.kext Match Other, while sysver: 10.13
7:425  0:000  Extra kext: EFI\CLOVER\kexts\Other\AppleALC.kext
7:427  0:002    |-- PlugIn kext: EFI\CLOVER\kexts\Other\AppleALC.kext\Contents\PlugIns\PinConfigs.kext
7:538  0:110  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13
7:538  0:000  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
7:538  0:000  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
7:538  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.13
7:538  0:000  current kext name Lilu.kext Match Other, while sysver: 10.13
7:538  0:000  current kext name AppleALC.kext Match Other, while sysver: 10.13
7:538  0:000  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13
7:538  0:000  Extra kext: EFI\CLOVER\kexts\10.13\FakeSMC.kext
7:552  0:013  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
7:552  0:000  Extra kext: EFI\CLOVER\kexts\10.13\USB_Injector.kext
7:557  0:005  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
7:557  0:000  Extra kext: EFI\CLOVER\kexts\10.13\IntelMausiEthernet.kext
7:565  0:007  Custom boot screen not used because entry has unset use graphics

I guess the issue only exists if you have multiple macOS versions installed. I only have 10.13.1

 

EDIT: I'll test and see what happens if I plug my 10.12.6 SSD in. I'll also install SL/Yosemite on a seperate HDD to test.

Are you in ESP or Legacy only

Its important to know 

Share this post


Link to post
Share on other sites

No I mean FakeSMC works in Other for 10.13 High Sierra 

Are you in ESP or Legacy only

Its important to know 

Running on Legacy-GPT Partition Scheme with ESP  :) OK, let me try first.. thanks.

Share this post


Link to post
Share on other sites

Are you in ESP or Legacy only

Its important to know 

 

ESP (RC Scripts on target volume)

 

post-1502423-0-66328700-1507207550_thumb.png

Share this post


Link to post
Share on other sites

APFS or HFS

 

Maybe issue its from APFS  :)

APFS

 

post-1502423-0-39669500-1507208286_thumb.png

 

Can you give me your Snow Leopard FakeSMC?

Share this post


Link to post
Share on other sites

On legacy EFI with clover installed to ESP.

Now 10.13.1 boots with only 10.13 in Clover/Kexts/10.13.

Others folder not needed as was happening with earlier clover versions.

Tripple booting from one disk and macOS installed on APFS volume on a HDD.

 

Just reporting

Share this post


Link to post
Share on other sites

11:451  0:000  Beginning FSInjection

FSInjectionInstall ...

- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: CDF7DA98

FSInjectionInstall ...

- Our FSI_SIMPLE_FILE_SYSTEM_PROTOCOL installed on handle: CDF7DA98

11:452  0:001  Use origin smbios table type 1 guid.

11:453  0:000  OSVesion: 10.13, ShortOSVersion=10.13, uni-vers=10.13,

11:453  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other

11:453  0:000  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13

11:453  0:000  current kext name Marvel-Injector.kext Match 10.13, while sysver: 10.13

11:453  0:000  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13

11:453  0:000  current kext name AppleALC.kext Match 10.13, while sysver: 10.13

11:453  0:000  current kext name Lilu.kext Match 10.13, while sysver: 10.13

11:453  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.13

11:453  0:000  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13

11:453  0:000  Extra kext: EFI\CLOVER\kexts\10.13\FakeSMC.kext

11:493  0:040    |-- PlugIn kext: EFI\CLOVER\kexts\10.13\FakeSMC.kext\Contents\PlugIns\CPUSensors.kext

11:496  0:003    |-- PlugIn kext: EFI\CLOVER\kexts\10.13\FakeSMC.kext\Contents\PlugIns\GPUSensors.kext

11:505  0:008    |-- PlugIn kext: EFI\CLOVER\kexts\10.13\FakeSMC.kext\Contents\PlugIns\LPCSensors.kext

11:531  0:026  current kext name Marvel-Injector.kext Match 10.13, while sysver: 10.13

11:531  0:000  Extra kext: EFI\CLOVER\kexts\10.13\Marvel-Injector.kext

11:532  0:000  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13

11:532  0:000  Extra kext: EFI\CLOVER\kexts\10.13\IntelMausiEthernet.kext

11:538  0:006  current kext name AppleALC.kext Match 10.13, while sysver: 10.13

11:538  0:000  Extra kext: EFI\CLOVER\kexts\10.13\AppleALC.kext

11:569  0:031    |-- PlugIn kext: EFI\CLOVER\kexts\10.13\AppleALC.kext\Contents\PlugIns\PinConfigs.kext

11:691  0:122  current kext name Lilu.kext Match 10.13, while sysver: 10.13

11:691  0:000  Extra kext: EFI\CLOVER\kexts\10.13\Lilu.kext

11:713  0:021  Custom boot screen not used because entry has unset use graphics

 

 

Ok got it for me FIX  here

10.13 woks 4238

My issue its comes from a Bad EFI partition on APFS Volumes 

 

But 10.6 and 10.7 not working 

Share this post


Link to post
Share on other sites

No I mean FakeSMC works in Other for 10.13 High Sierra

Well, since r4235 afaik "Other" folder is working fine for kext_inject; not only for FakeSMC but also another kexts ie. Lilu, AppleALC, ApplePS2 are loadable to boot High Sierra. The problem till r4238 is if they were placed on 10.13. Correct?

Share this post


Link to post
Share on other sites

Well, since r4235 afaik "Other" folder is working fine for kext_inject; not only for FakeSMC only but another kexts ie. Lilu, AppleALC, ApplePS2 are loadable. The problem till r2438 is if they were placed on 10.13. Correct?

No.

"10.xy" folder will work only for first main menu entry.

"Other" folder always works.

Share this post


Link to post
Share on other sites

^ Yup, I can confirm that. With 10.6 install image attached, Kext injection for 10.13 doesn't work anymore and Snow Leopard is first macOS entry (after Windows 10)

4:101  0:000  === [ ScanLoader ] ========================================
4:101  0:000  - [01]: 'EFI'
4:101  0:000  - [02]: 'Mac OS X Install DVD'
4:132  0:030          AddLoaderEntry for Volume Name=Mac OS X Install DVD
4:169  0:037      Check if volume Is Hibernated:
4:169  0:000      Check sleep image 'by signature':
4:229  0:060      using default sleep image name = \private\var\vm\sleepimage
4:249  0:019      sleepimage not found -> Not Found
4:249  0:000      hibernated: no - sign
4:249  0:000  Icon 13 decoded, pointer CC977098
4:250  0:000  getList: sysver=10.6, Short=10.6
4:250  0:000  Added mKext=FakeSMC.kext, MatchOS=10.6
4:251  0:001  getList: sysver=Other, Short=
4:254  0:002  - [03]: 'Snow Leopard'
4:255  0:001  - [09]: 'EFI'
4:258  0:003  - [12]: 'EFI'
4:261  0:003          AddLoaderEntry for Volume Name=EFI
4:261  0:000       skipped because path `PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x1,0x0,0x0)\HD(2,GPT,AD2445F4-B02A-4107-AB58-A8FAE3930F74,0xE1800,0x32000)\EFI\microsoft\Boot\bootmgfw.efii` already exists for another entry!
4:261  0:000  - [16]: 'Preboot', hidden
4:261  0:000  - [17]: 'High Sierra SSD'
4:273  0:011          AddLoaderEntry for Volume Name=High Sierra SSD
4:279  0:006      Check if volume Is Hibernated:
4:279  0:000      Check sleep image 'by signature':
4:287  0:008      using default sleep image name = \private\var\vm\sleepimage
4:292  0:004      sleepimage not found -> Not Found
4:292  0:000      hibernated: no - sign
4:292  0:000  Icon 17 decoded, pointer CC871D98
4:298  0:005  - [18]: 'Recovery'
4:300  0:001          AddLoaderEntry for Volume Name=Recovery
4:301  0:001  Icon 20 decoded, pointer CCA53C98
4:304  0:003  - [19]: 'VM'

Share this post


Link to post
Share on other sites

Well, since r4235 afaik "Other" folder is working fine for kext_inject; not only for FakeSMC but also another kexts ie. Lilu, AppleALC, ApplePS2 are loadable to boot High Sierra. The problem till r4238 is if they were placed on 10.13. Correct?

For me Yes 

But now I test to another SSD and its not work in 10.13

Something is wrong with Clover, I am not understand why 4222 woks all the way on any Folder for any OS X

 

^ Yup, I can confirm that. With 10.6 install image attached, Kext injection for 10.13 doesn't work anymore and Snow Leopard is first macOS entry (after Windows 10)

4:101  0:000  === [ ScanLoader ] ========================================
4:101  0:000  - [01]: 'EFI'
4:101  0:000  - [02]: 'Mac OS X Install DVD'
4:132  0:030          AddLoaderEntry for Volume Name=Mac OS X Install DVD
4:169  0:037      Check if volume Is Hibernated:
4:169  0:000      Check sleep image 'by signature':
4:229  0:060      using default sleep image name = \private\var\vm\sleepimage
4:249  0:019      sleepimage not found -> Not Found
4:249  0:000      hibernated: no - sign
4:249  0:000  Icon 13 decoded, pointer CC977098
4:250  0:000  getList: sysver=10.6, Short=10.6
4:250  0:000  Added mKext=FakeSMC.kext, MatchOS=10.6
4:251  0:001  getList: sysver=Other, Short=
4:254  0:002  - [03]: 'Snow Leopard'
4:255  0:001  - [09]: 'EFI'
4:258  0:003  - [12]: 'EFI'
4:261  0:003          AddLoaderEntry for Volume Name=EFI
4:261  0:000       skipped because path `PcieRoot(0x0)\Pci(0x1F,0x2)\Sata(0x1,0x0,0x0)\HD(2,GPT,AD2445F4-B02A-4107-AB58-A8FAE3930F74,0xE1800,0x32000)\EFI\microsoft\Boot\bootmgfw.efii` already exists for another entry!
4:261  0:000  - [16]: 'Preboot', hidden
4:261  0:000  - [17]: 'High Sierra SSD'
4:273  0:011          AddLoaderEntry for Volume Name=High Sierra SSD
4:279  0:006      Check if volume Is Hibernated:
4:279  0:000      Check sleep image 'by signature':
4:287  0:008      using default sleep image name = \private\var\vm\sleepimage
4:292  0:004      sleepimage not found -> Not Found
4:292  0:000      hibernated: no - sign
4:292  0:000  Icon 17 decoded, pointer CC871D98
4:298  0:005  - [18]: 'Recovery'
4:300  0:001          AddLoaderEntry for Volume Name=Recovery
4:301  0:001  Icon 20 decoded, pointer CCA53C98
4:304  0:003  - [19]: 'VM'

Try 4222 and its work

Share this post


Link to post
Share on other sites

For Clover.

 

Works for me  :thumbsup_anim:

4:048  0:000  getList: sysver=10.6, Short=10.6
4:049  0:000  Added mKext=FakeSMC.kext, MatchOS=10.6
4:050  0:001  getList: sysver=10.7, Short=10.7
4:050  0:000  getList: sysver=10.8, Short=10.8
4:050  0:000  getList: sysver=10.9, Short=10.9
4:050  0:000  getList: sysver=10.10, Short=10.10
4:050  0:000  getList: sysver=10.11, Short=10.11
4:050  0:000  getList: sysver=10.12, Short=10.12
4:051  0:000  getList: sysver=10.13, Short=10.13
4:051  0:000  Added mKext=IntelMausiEthernet.kext, MatchOS=10.13
4:051  0:000  Added mKext=USB_Injector.kext, MatchOS=10.13
4:051  0:000  Added mKext=FakeSMC.kext, MatchOS=10.13
4:052  0:001  Added mKext=AppleALC.kext, MatchOS=10.13
4:055  0:002  ---| added plugin=PinConfigs.kext, MatchOS=10.13
4:055  0:000  Added mKext=Lilu.kext, MatchOS=10.13
4:056  0:000  getList: sysver=10.14, Short=10.14
4:056  0:000  Extra kext folder of 10.14 does not found - skip
4:056  0:000  getList: sysver=10.15, Short=10.15
4:056  0:000  Extra kext folder of 10.15 does not found - skip
4:056  0:000  getList: sysver=10.16, Short=10.16
4:056  0:000  Extra kext folder of 10.16 does not found - skip
4:056  0:000  getList: sysver=10.17, Short=10.17
4:056  0:000  Extra kext folder of 10.17 does not found - skip
4:056  0:000  getList: sysver=10.18, Short=10.18
4:056  0:000  Extra kext folder of 10.18 does not found - skip
4:056  0:000  getList: sysver=10.19, Short=10.19
4:056  0:000  Extra kext folder of 10.19 does not found - skip
4:056  0:000  getList: sysver=10.20, Short=10.20
4:056  0:000  Extra kext folder of 10.20 does not found - skip

39:672  0:000  OSVesion: 10.13.1, ShortOSVersion=10.13, uni-vers=10.13,
39:672  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\Other
39:672  0:000  current kext name Lilu.kext Match 10.13, while sysver: 10.13
39:672  0:000  current kext name AppleALC.kext Match 10.13, while sysver: 10.13
39:672  0:000  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13
39:672  0:000  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
39:672  0:000  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
39:672  0:000  current kext name FakeSMC.kext Match 10.6, while sysver: 10.13
39:672  0:000  Preparing kexts injection for arch=x86_64 from EFI\CLOVER\kexts\10.13
39:672  0:000  current kext name Lilu.kext Match 10.13, while sysver: 10.13
39:672  0:000  Extra kext: EFI\CLOVER\kexts\10.13\Lilu.kext
39:675  0:002  current kext name AppleALC.kext Match 10.13, while sysver: 10.13
39:675  0:000  Extra kext: EFI\CLOVER\kexts\10.13\AppleALC.kext
39:679  0:003    |-- PlugIn kext: EFI\CLOVER\kexts\10.13\AppleALC.kext\Contents\PlugIns\PinConfigs.kext
39:789  0:110  current kext name FakeSMC.kext Match 10.13, while sysver: 10.13
39:789  0:000  Extra kext: EFI\CLOVER\kexts\10.13\FakeSMC.kext
39:802  0:013  current kext name USB_Injector.kext Match 10.13, while sysver: 10.13
39:802  0:000  Extra kext: EFI\CLOVER\kexts\10.13\USB_Injector.kext
39:807  0:005  current kext name IntelMausiEthernet.kext Match 10.13, while sysver: 10.13
39:807  0:000  Extra kext: EFI\CLOVER\kexts\10.13\IntelMausiEthernet.kext
39:814  0:006  current kext name FakeSMC.kext Match 10.6, while sysver: 10.13
39:815  0:001  Custom boot screen not used because entry has unset use graphics
39:815  0:000  Closing log

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By glasgood
      CLOVER DUAL BOOT MOJAVE & WINDOWS 10 GUIDE 
       

       
       
      INCLUDES  MBR / LEGACY BIOS  TO  GPT / EFI CONVERSION
      USING MBR2GPT TOOL
       
       
      PREREQUISITE: Two physical discs ( SSD’s or HDD’s )
       
       
       
       
       
      STEP 1 - Clover dual boot configuration 
       
      Open config.plist with Clover Configurator
       
      Boot
       Legacy = PBR Timeout = True ( will remove the Timeout countdown, from Clover boot menu)  

       
      GUI 
      Scan / Custom
       Entries = True  Tool = True  Legacy = False ( removes extra Windows 10 entries )  
      Hide Volume
      - Preboot ( macOS Preboot )
      - Recovery ( macOS Recovery )
       

       
      So at boot you will have two options: boot macOS Mojave or Windows 10 
       
       
       
       
       
       
       
      ————————————————————
       
       
      STEP 2 - Using a drive without Windows 10 installed
       
      Disconnect system drive that contains your macOS Mojave install from computer ( This is so that Windows does not overwrite existing macOS Mojave boot loader )
       
      Proceed with a Windows 10 UEFI install.  
      After installation reconnect macOS Mojave Drive, the Windows installation should now be detected and usable in Clover. 
      If Windows 10 is not detected or able to boot,  then verify you installed Windows 10 as UEFI and not MBR ---->  ( Read step 2 - For a drive with Windows 10 installed )
       
       
      OR
       
       
       
      STEP 2 - Using a drive with Windows 10 already installed
       
      Verify your Windows install is  GPT / UEFI or MBR / Legacy BIOS.   
      If Windows install is GPT UEFI then Windows 10 install is ready to use at Clover boot menu, you should be able to boot into Windows directly from Clover boot screen. 
       

       
       
      But if  Windows drive is detected at Clover boot screen, but when booting Windows you get a black screen with a cursor on the top left,
      then this is most likely because Windows drive is MBR ( Legacy BIOS ).  You can easily convert MBR to GPT using  Windows MBR2GPT tool ( this saves hours work having to reinstall Windows 10 and setting up all your applications again  ) 
       
      If Windows 10 install is MBR / Legacy BIOS  then simply convert to GPT / UEFI  following instructions below ( read video summary and view video )
       
       
      ** To use Windows 10  MBR2GPT tool  you must have Windows 10 version 1703 ( creators update  ) or later and less than 3 partitions on 
      the Windows 10 drive **
       
      Video summary:
       
      Confirm Windows 10 drive is MBR Legacy BIOS ( in Windows Disk Management ) Reboot into Windows PE ( Advanced Startup ) Convert from MBR Legacy BIOS to GPT UEFI ( using commands below ) mbr2gpt /validate mbr2gpt /convert Restart Verify Windows 10 drive has changed to GPT UEFI ( in Windows Disk Management )  
       
       
       
      After conversion Windows 10 is ready to use at the Clover boot menu 
       
       
       
      STEP 3 - Stop Windows Boot manager from overriding Clover boot manager
       
      How to stop Windows boot manager from overriding your Hackintosh Clover boot manager when using dual booting between macOS and Windows
       
       
       
       
       
       
    • By AppleBytes
      OK, I've searching for days trying to gather up the tools to make my current install work correctly. I'm well on my way. But all the links to the things I currently must have were apparently nuked "during a forum upgrade". :(
      As far as EFI Studio goes; I can find many links to it. But for Insanelymac, they're broken (due to the upgrade), or for the Netkas site, they're links to either Rapidshare, or Mediafire that also no linger exist. I see many users here indicating that they used it to tweak their DSDT. But the web (google/duckduckgo), Instanelymac, and Netkas seem to have no idea where it's gone.
      Could some kind soul please share a copy, or a link? I'm a loooong time hacker, and would love to bring it back to life. In fact, I'd love to improve it -- or at least bring it up to current times. If only I knew where it was.
      Thank you for all your time, and consideration.
       
      --Chris
       
    • By SoThOr
      This was spurred on from a discussion in the Clover General thread. Where there was a debate on bcdedit being able create/read/edit (U)EFI Boot entries. I didn't think it appropriate to post all this information there and somebody may want to make use of this and its likely to get lost in that massive thread.
       
      Out of curiosity I decided to see if I could create an EFI entry using bcdedit. What can I say I like a challenge.  Whilst is not a documented method by Microsoft, as it turns out in a round about way it IS possible to create an EFI entry using bcdedit and these are the steps I went through to add UEFI Shell located on a USB stick to the EFI entries. 
       
      Third party software is available that can create and edit UEFI entries from Windows with better support and more features. I'm just making this information available in case those options are unavailable. 
       
      DISCLAIMER - This is not a supported method. Use at your own risk. I recommend backing up your BCD/Firmware variables/settings beforehand.
       
      1) Copy {bootmgr} entry.
      C:\Windows\System32>bcdedit /copy {bootmgr} /d "UEFI Shell" The entry was successfully copied to {34e8383c-73a7-11e9-9cb0-94de8078a7b5}. 2) Edit the new entry using the new GUID bcdedit generated in the copy step.
        a) Set the device and path for UEFI shell on my USB stick.
      bcdedit /set {34e8383d-73a7-11e9-9cb0-94de8078a7b5} device partition=G: bcdedit /set {34e8383d-73a7-11e9-9cb0-94de8078a7b5} path \EFI\SHELL\SHELLX64.efi   b) Clean up some of the stuff that was copied from {bootmgr} (optional as far as I can tell, just makes things tidier in bcdedit)
      3) Put the new EFI entry first in boot order. (optional)
       
      After completing the steps above, here is what "bcdedit /enum firmware" shows:
       
      I shutdown my computer and when I turned my computer back on it booted up into UEFI Shell. After exiting the shell my PC went on to boot Windows.
      Here is the resulting dump using "bcfg boot dump -v" from that shell:
       
      You may notice that the shell shows as "Windows Boot Manager" in the bcdedit output. This I believe is because of the "WINDOWS" at the beginning of the option data that bcdedit added to the EFI Boot entry. I also believe this why bcdedit shows my Windows 8 installation as "Firmware Application" because it has no option data. I don't know how to remove this data using bcdedit nor do I know how the option data, that bcdedit adds, will affect other EFI applications.

      There might be a way to create the EFI entry without copying the Windows entry but if there is I'm unable to find any documentation on how one would do so. If you use the create command then it just puts it in the BCD and I'm unaware of a way to tell it to create it in EFI instead, other than by doing the above.
    • By cvad
      Small tool to download, compile and build the latest Clover X64 package.
       
       
       

      The script inside is editable.

       
      Enjoy...
       
      Many thanks to the comrade SunKi for help with creating the script.
       
       
       
       
       
      Best thanks - click "Rate File".
       
    • By blxkspell
      Hey!
      As I have 3 Monitors connected, my RX 570 gets arround 50°C while ideling/ web browsing etc. The problem is, that this temp is apparently just the threshold, when the fans start to spin. So the fans start spinning for a minute then they stop for a while again... This is very annoying for me as the rest of my hackintosh is nearly quiet (SSD, 120mm low RPM cpu fan, nearly silent PSU,...), especially when Im using the pc to revise for school. Does somebody know wether its possible to "change" the threshold till the fans start spinning? Like it would probably not be a problem for the gpu at all, if the temp rises to 55°C but therefore be soundless....
       
       
×