Jump to content
ErmaC

Clover General discussion

20,006 posts in this topic

Recommended Posts

@slayer2333 see at post #9, under AHCI timeout by bcc9,

 

kext editing (or use an injector), not dsdt fix

 

 

EDIT

 

or something like this?

 

<key>0</key>
<dict>
 <key>Name</key>
 <string>IOAHCIBlockStorage</string>
 <key>Find</key>
 <string>example in bcc9 script</string>
 <key>Replace</key>
 <string>example in bcc9 script</string>
</dict>

 

???? strong>ression.gif

Tried this solution but didn't work.

My problem seems to be that i have two separate hard drives (windows HDD on first AHCI controller, Mac HDD on the second), so as long as i boot on AHCI mode, Mac HDD is not detected, when booting in IDE it is detected, but of course it won't boot. Do you guys have any solution for that ? I saw someone else experiencing the same problem here : http://www.projectosx.com/forum/index.php?showtopic=2008&st=1080&p=18166entry18166 (post 1096) but i don't have his modified .efi files to see the secondary HDD. Also my PC is a laptop, and it would be a pain in the ass to disassemble it and swap the drives.

Can anyone give me a software solution to that ?

Share this post


Link to post
Share on other sites
Advertisement

@Slice,

 

At revision 723 you changed from "pointer.icns" to "pointer.png"???

 

If I leave "pointer.icns", I have no freeze at Clover's GUI but no pointer, just a square on his place...

 

If I leave "pointer.png", I have the same symptoms described by blackosx here > #102

 

If I leave both, I have working GUI and pointer...

 

:worried_anim:

 

This is a bug???

Share this post


Link to post
Share on other sites

I've been meaning to ask, recently my Recovery HD shows as an 'unknown device' graphic in the GUI. Do I need an extra icon in the themes folder for it?

 

"icons\\vol_recovery.icns"

Share this post


Link to post
Share on other sites

On my machine he´s assuming the os_mac.icns....

Thanks again.. :)

 

I'm now wondering if it's possible to detect the Recovery HD as a separate Volume and assign a separate icon for it in the GUI?

 

For now, I made myself a Recovery HD icon for the black_green theme, it not OS specific though it would be nice to have one for both Lion and ML versions . It's only a bit of fun and I would change it at a later date if proper support for it can be added. I've just re-purposed the os_mac.icns file because it's currently not used anywhere else on my machine as my OS X volumes all use the individual OS specifc icons. I guess it could be used incorrectly when say OS X 10.9 comes out, but until then I'll use this.

 

jtnnth.jpg

 

EDIT: I see while writing this, Slice posted an answer to my question above ^^^^^ - Thanks Slice :)

os_mac.icns.zip

Share this post


Link to post
Share on other sites

"icons\\vol_recovery.icns"

 

So now we should use "vol_recovery.icns" instead of "os_mac.icns" or may work with anyone of them???

Share this post


Link to post
Share on other sites

Did you tried with this new driver? > http://www.insanelym...00#entry1857504

 

Or only with the regular one included on the package???

 

Thanks, kyndder :)

As you said, the mouse still can't work under x64 Clover.

 

I haven't tried x32 Clover. The screen forze at the number "6" after I pressed "3" in order to boot in x32 Clover.

Share this post


Link to post
Share on other sites

Thanks, kyndder :)

As you said, the mouse still can't work under x64 Clover.

 

I haven't tried x32 Clover. The screen forze at the number "6" after I pressed "3" in order to boot in x32 Clover.

 

Make sure that you have "boot3" file at the root of your Clover media (may be hidden)...

 

If you don't have, extract the Clover files using the installer, rename the ia32 "boot" file to "boot3" and copy the

file at the root of the Clover media...

Share this post


Link to post
Share on other sites

Hi all,

 

I've a strange trouble since i use Clover.

My config is P5B premium Q6700 nvidia gfx, dsdt patched by me and Mountain Lion.

All works fine with Chameleon.

 

With Clover64 when i boot and immediatly reboot all is ok.

But when i boot go to sleep, awake and reboot, my computer hang after all app are closed, bios screen does'nt come.

 

Any idea to investigate this bug ?

 

Other things

When i try to patch Dsdt throught Clover it never goes to sleep because of usb4 id code injection id 2833.

When i reset it boot and alway hang before getting screen even with cameleon, i must remove battery to raz Cmos. My dsdt is patched with id code 2834 for usb4 and all goes ok.

Firewire patch does not works too.

 

Regards.

dsdt.aml.zip

config.plist.zip

Share this post


Link to post
Share on other sites

I have a weird issue. Clover is now on #1 "OS X through Clover" in boot order to load on the OS X EFI partition, but the kernel will hang (no panic) when it boots up normal. If i select the UEFI F11 boot menu and then the "OS X through Clover" option it will load fine.

Also the normal efi shell dind't work, had to use the modified one, but clover reports its UEFI > 2.3 ?

Share this post


Link to post
Share on other sites

@ alexanderq

 

Hello and thanks for clover

I have an intel hd graphics videocard which is not working and supported so after a long time i went and buy a radeon HD6450 hopefully that at last it will work my sound through hdmi which is the only conector i use and will not have anymore problems.I tried and booted with graphicinjector=yes and it detected it as HD6470 whith Burluses framebuffer which my hdmi tv dident work.So i used pithecia and again detected it as HD6470 whith 2 displays conected but i only have one hdmi and my sound is not working.Sorry for my english.

Forgot to mention that tube videos work ok for 10 seconds and then they play in slow motion.Vely slowwwwww.

 

Start reading here http://www.insanelym...ectors-to-work/

and here http://www.insanelym...al-lvds-screen/

to learn how to patch the needed KEXT to make your Graphics work properly and with the right DSDT edits you get your HDMI audio going aswell !

Share this post


Link to post
Share on other sites

@Slice

 

would you mind explaining how someone can obtain the right value for CPUType in config.plist.

I can see that Clover detects the right CPU automatically but i would like to know how to calculate the appropriate HEX on my own.

 

Thank you !!

Share this post


Link to post
Share on other sites

@Slice

 

would you mind explaining how someone can obtain the right value for CPUType in config.plist.

I can see that Clover detects the right CPU automatically but i would like to know how to calculate the appropriate HEX on my own.

 

Thank you !!

Right value is not calculable. It is done from real Mac reports as collection for many-many CPUs info.

I can tell you how Clover do this: just 80 lines of C-codes.

Share this post


Link to post
Share on other sites

Right value is not calculable. It is done from real Mac reports as collection for many-many CPUs info.

I can tell you how Clover do this: just 80 lines of C-codes.

 

Thanks for your answer !

Share this post


Link to post
Share on other sites

@ alexanderq

 

 

 

Start reading here http://www.insanelym...ectors-to-work/

and here http://www.insanelym...al-lvds-screen/

to learn how to patch the needed KEXT to make your Graphics work properly and with the right DSDT edits you get your HDMI audio going aswell !

One week im reading again and again i tried in chameleon whith pithecia and graphicsenabler=yes it worked i had qe/ci i can open dvd player and it detect it as hd6450.But in clover it detects it as hd6470 so i tried Ati conector patch whith ipomoea first

and it gave me green screen so i turned back to pithecia an Ati conector patch

00080000040 000000000000210303040400000014020000000000000000040210000000100000000000000001000001

where my sense id for hdmi is 0x4 and dvi 0x2 vga 0x1 but still i dont have sond through hdmi.Im not tring to find an easy way but i have two years now with intelhd not working so i buyed an saphire radeon hd6450 to stop trying. And becouse i have this pc as HTPC in my living room and i only want sound through hdmi or this card is useless again and i dont have the money to buy another one.i just wanted to play with OS X.

Share this post


Link to post
Share on other sites

One week im reading again and again i tried in chameleon whith pithecia and graphicsenabler=yes it worked i had qe/ci i can open dvd player and it detect it as hd6450.But in clover it detects it as hd6470 so i tried Ati conector patch whith ipomoea first

and it gave me green screen so i turned back to pithecia an Ati conector patch

00080000040 000000000000210303040400000014020000000000000000040210000000100000000000000001000001

where my sense id for hdmi is 0x4 and dvi 0x2 vga 0x1 but still i dont have sond through hdmi.Im not tring to find an easy way but i have two years now with intelhd not working so i buyed an saphire radeon hd6450 to stop trying. And becouse i have this pc as HTPC in my living room and i only want sound through hdmi or this card is useless again and i dont have the money to buy another one.i just wanted to play with OS X.

 

Ati connector patch is not enough on it's own !!

 

To make HDMI audio of your descrete graphics card working you have to make the necessary edits to your DSDT too !!

 

But all this is going OT here, so please use the search !!!

Share this post


Link to post
Share on other sites
i tried in chameleon whith pithecia and graphicsenabler=yes it worked i had qe/ci i can open dvd player and it detect it as hd6450

 

Use the command below to get the video string using Chameleon...

 

ioreg -lw0 -p IODeviceTree -n efi -r -x | grep device-properties | sed 's/.*<//;s/>.*//;'}

 

Copy the output and use as "DeviceProperties"...

 

<key>PCI</key>
<dict>
<key>StringInjector</key>
<string>Yes</string>
<key>DeviceProperties</key>
<string>[color=#ff0000]PLACE THE OUTPUT HERE[/color]</string>
<key>PCIRootUID</key>
<string>0</string>
</dict>

Share this post


Link to post
Share on other sites

Ati connector patch is not enough on it's own !!

 

To make HDMI audio of your descrete graphics card working you have to make the necessary edits to your DSDT too !!

 

But all this is going OT here, so please use the search !!!

But of course i have done the DSDT edits i have one week reading remember

Share this post


Link to post
Share on other sites

Hey Guys,

 

first of all I want to thank you for the great work and all your attainments regarding to Clover! I was testing some stuff and ran into different issues, so for that reason I really need your help.

 

So let's beginn with my system specs:

 

- CPU: Intel i5 3570K

- Motherboard: Gigabyte GA-H77-DS3H latest F7 AMI Alaska UEFI Bios

- GPU: Onboard Intel HD 4000

- OS: Only Mountain Lion 10.8.2 (12C54)

- Identifier: Mac Book Pro 9.2 because of the Chipset - Also tried iMac12.2 but it gave me AGPM issues

- Custom DSDT: Yes

 

First I've installed the non UEFI version for testing and everything seemed to work flawless. I could boot into OS X, had full CI/QE etc. Then I've tested my USB 3.0 ports but they were not working properly. When I plugged in a USB 2.0 device, nothing happened at all. Setting the ports to USB 2.0 in Bios lets them work in 2.0 mode at least.

 

This would be ok for me, because I don't own any USB 3.0 products at this time. The more annoying thing is that my screen won't wake up when I set the machine to sleep and try to wake it up if I'm using my custom DSDT. What surprises me very much, is the fact that this is not happening every time!

 

For example: I can go to sleep for about ten times without any issues. Then, the eleventh time the screen won't wake up from sleep. Without DSDT sleep seems to work well. By the way, I'm running into the same issues using the latest version of Chameleon and don't have ANY idea how to solve it! :help:

 

So far so good. After the whole testing I decided to install the UEFI version. Unfortunately it isn't even booting. :( I have the following stuff in "drivers64UEFI":

 

- DataHubDxe-64.efi

- FSInject-64.efi

- OsxAptioFixDrv-64.efi

- OsxFatBinaryDrv-64.efi

- OsxLowMemFixDrv-64.efi

- PartitionDxe-64.efi

- VBoxHfs.64.efi - also tried HFSPlus.efi, but it has no effect.

 

I've attached Clover's config.plist, my custom DSDT and the preboot.log. So if anybody could help me to solve my problems, especially the sleep issue, I would be the happiest man on Planet Earth! ;) Many thanks in advance!

 

By the way... is there any quiet boot option in Clover and is it possible to wake the system via keyboard?

 

 

*Edit*

 

 

Adding "darkwake=0" into <key>boot-args</key> isn't changing anything. :(

Clover stuff.zip

Share this post


Link to post
Share on other sites

First I've installed the non UEFI version for testing and everything seemed to work flawless. I could boot into OS X, had full CI/QE etc. Then I've tested my USB 3.0 ports but they were not working properly. When I plugged in a USB 2.0 device, nothing happened at all. Setting the ports to USB 2.0 in Bios lets them work in 2.0 mode at least.

 

You should use the non-UEFI Clover because you don't have a UEFI BIOS...

 

This would be ok for me, because I don't own any USB 3.0 products at this time. The more annoying thing is that my screen won't wake up when I set the machine to sleep and try to wake it up if I'm using my custom DSDT. What surprises me very much, is the fact that this is not happening every time!

 

For example: I can go to sleep for about ten times without any issues. Then, the eleventh time the screen won't wake up from sleep. Without DSDT sleep seems to work well. By the way, I'm running into the same issues using the latest version of Chameleon and don't have ANY idea how to solve it! :help:

 

Did you patched your AppleRTC.kext???

 

So far so good. After the whole testing I decided to install the UEFI version. Unfortunately it isn't even booting. :( I have the following stuff in "drivers64UEFI":

 

- DataHubDxe-64.efi

- FSInject-64.efi

- OsxAptioFixDrv-64.efi

- OsxFatBinaryDrv-64.efi

- OsxLowMemFixDrv-64.efi

- PartitionDxe-64.efi

- VBoxHfs.64.efi - also tried HFSPlus.efi, but it has no effect.

 

As I told above you should use Clover for BIOS boot , BTW, leave only the divers below inside of your "/EFI/drivers64UEFI" folder...

 

FSInject-64.efi

USBMouseDXE-64.efi

 

 

By the way... is there any quiet boot option in Clover and is it possible to wake the system via keyboard?

 

Set timeout to 0 at "refit.conf" file...

 

[EDIT]

 

Sorry, I did not saw that you had placed your MOBO specs...

Share this post


Link to post
Share on other sites

 

BTW, leave only the divers below inside of your "/EFI/drivers64UEFI" folder...

 

FSInject-64.efi

USBMouseDXE-64.efi

No, no. For UEFI boot definately needed in /efi/drivers64UEFI: HFSPlus (or VboxHfs) and FatBin. Then try to boot.

 

If this does not work, then add LowMemFix and try to boot.

 

If still does not work, then remove LowMemFix and add AptioFix (so, HFS, FatBin and AptioFix). aptioFix requires adding "slide=0" to boot args in config.plist.

 

If this does not work, then there is a problem.

Share this post


Link to post
Share on other sites

No, no. For UEFI boot definately needed in /efi/drivers64UEFI: HFSPlus (or VboxHfs) and FatBin.

 

 

Thanks for correcting me dmazar ...

 

I had not seen that he had UEFI BIOS, only saw when I had already answered...

 

I've never used the Clover on real UEFI...

Share this post


Link to post
Share on other sites

Hey guys,

 

thank you very much for your help!

 

@kyndder

Did you patched your AppleRTC.kext???

 

Nope' date=' not yet. If you're meaning the perl script.

 

Set timeout to 0 at "refit.conf" file...

Thank you for the info. This parameter is for quiet boot, right?

 

Sorry' date=' I did not saw that you had placed your MOBO specs...[/quote']

No problem! :) I've just updated my signature too.

 

 

@dmazar

No' date=' no. For UEFI boot definately needed in /efi/drivers64UEFI: HFSPlus (or VboxHfs) and FatBin. Then try to boot.

 

If this does not work, then add LowMemFix and try to boot.

 

If still does not work, then remove LowMemFix and add AptioFix (so, HFS, FatBin and AptioFix). aptioFix requires adding "slide=0" to boot args in config.plist.

 

If this does not work, then there is a problem.[/quote']

 

Thank you for your advise. I'll try this after work and report the results later.

Share this post


Link to post
Share on other sites

Clover cannot boot my windows 7 installed with gpt-mbr hybrid partition tables, it detects windows partition as Legacy OS but freeze in "Booting OS...". I tried to set LegacyBoot key from PBR to MBR, but it doesn't make any sense. I wonder if the Clover can only boot Windows EFI?

BTW, can I manually set a proper resolution for Clover just like Chameleon(with Graphic Mode key)?

Thanks.

Share this post


Link to post
Share on other sites

Use the command below to get the video string using Chameleon...

 

ioreg -lw0 -p IODeviceTree -n efi -r -x | grep device-properties | sed 's/.*<//;s/>.*//;'}

 

Copy the output and use as "DeviceProperties"...

 

<key>PCI</key>
<dict>
<key>StringInjector</key>
<string>Yes</string>
<key>DeviceProperties</key>
<string>[color=#ff0000]PLACE THE OUTPUT HERE[/color]</string>
<key>PCIRootUID</key>
<string>0</string>
</dict>

It gave me sed: 1: "s/.*<//;s/>.*//;}": unexpected }

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By MaLd0n
      ---TUTORIAL---

      https://olarila.com/forum/viewtopic.php?f=50&t=8685
       
      --Original Post--
       
      https://olarila.com/forum/viewtopic.php?f=97&t=11237
       
      --Bios/UEFI Settings--
       
      *Update bios/uefi to F7+*
      1- Go to M.I.T./Advanced Frequency Settings tab
       
      Extreme Memory Profile (X.M.P.) - Profile 1
       
      2- Go to BIOS tab
       
      CSM Support - Disabled
       
      3- Go to Peripherals/Thunderbolt(TM) Configuration tab
       
      Security Level - No Security
      Thunderbolt USB Support - Enabled
      GPIO3 Force Pwr - Enabled
       
      4- Go to Chipset tab
       
      Internal Graphics - Enable
       
      ---CLOVER FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI CLOVER Z390 DESIGNARE.zip
       
      ---OPENCORE FOLDER---
      *Use this folder with FULL DSDT PATCHED
      EFI OPENCORE Z390 DESIGNARE.zip
       
      ---DSDT patch requests is here---
       
      https://olarila.com/forum/viewtopic.php?f=19&t=1131
       
      ---HARDWARE---
       
      --MOBO

      GIGABYTE Z390 DESIGNARE
      -Link
      https://www.amazon.com/Z390-DESIGNARE-Gigabyte-Thunderbolt-Motherboard/dp/B07K8RJZRG/ref=sr_1_1?keywords=Z390+DESIGNARE&qid=1565492390&s=electronics&sr=1-1

      --PROCESSOR

      Intel Core i9-9900K
      -Link
      https://www.amazon.com/Intel-i9-9900K-Desktop-Processor-Unlocked/dp/B005404P9I/ref=sr_1_1_sspa?keywords=Intel+Core+i9-9900K&qid=1553358099&s=gateway&sr=8-1-spons&psc=1

      --COOLER

      CORSAIR H100i RGB PLATINUM AIO Liquid CPU Cooler
      -Link
      https://www.amazon.com/CORSAIR-H100i-PLATINUM-Liquid-Cooler/dp/B07JWB5BSN/ref=sr_1_4?keywords=WATER+COOLER+CPU&qid=1565492509&s=gateway&sr=8-4

      --MEMORY

      Corsair CMW32GX4M2C3200C16 Vengeance RGB PRO 32GB (2x16GB) DDR4 3200 (PC4-25600)
      -Link
      https://www.amazon.com/Corsair-CMW32GX4M2C3200C16-Vengeance-PC4-25600-Desktop/dp/B07GTG2T7L/ref=sr_1_15?keywords=memory+ddr4+32&qid=1553358238&s=gateway&sr=8-15

      --GPU

      MSI RX Vega 64 AIR Boost 8G OC
      -Link
      https://www.amazon.com/MSI-RX-64-AIR-8G/dp/B07DH7S1X1/ref=sr_1_2?keywords=vega+64+gigabyte&qid=1565492819&s=electronics&sr=1-2

      --SSD

      Samsung 970 EVO 1TB SSD (MZ-V7E1T0BW) NVMe M.2 V-NAND
      -Link
      https://www.amazon.com/Samsung-970-EVO-1TB-MZ-V7E1T0BW/dp/B07BN217QG/ref=sr_1_1?keywords=s+samsung+970+evo+1tb&qid=1565493002&s=electronics&sr=1-1

      --POWER SUPPLY

      EVGA Supernova 1000 P2 80+ Platinum, 1000W ECO Mode Fully Modular 
      -Link
      https://www.amazon.com/EVGA-Supernova-Platinum-Crossfire-220-P2-1000-XR/dp/B00EKJQM5E/ref=sr_1_3?keywords=power+supply+1000w&qid=1565493196&s=gateway&sr=8-3

      --WIRELESS

      TP-Link Archer T9E
      -Link
      https://www.amazon.com/TP-Link-Archer-T9E-Beamforming-Technology/dp/B00TQEX7AQ/ref=sr_1_1?keywords=TP-Link+Archer+T9E&qid=1553358397&s=gateway&sr=8-1

      --CASE

      Thermaltake Core P5 Tempered Glass Black Edition ATX Open Frame Panoramic Viewing
      -Link
      https://www.amazon.com/Thermaltake-Tempered-Panoramic-Certified-CA-1E7-00M1WN-03/dp/B01N4IGVSC/ref=sr_1_2?keywords=Thermaltake+Core+P5&qid=1565493567&s=gateway&sr=8-2

      --DSDT Patches--
      -FIX ACPI ERRORS -FIX OEM SSDTs to AVOID ERRORS AND WARNINGS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA -DMAC -REMOVE PROBLEMATIC AND UNUSED DEVICES -FIX K.P in REBOOT -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -FWHD -USBX -PMCR -PPMC -XSPI -CNVW -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES ---SCREENSHOTs---




















      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Thanks to KGP for SSDT Thunderbolt
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By kylon
      Cloud Clover Editor is an open source application that allows you to manage various Hackintosh Bootloaders configs everywhere.

      Open Cloud Clover Editor
       
      Cloud Clover Editor Wiki
      Cloud Clover Editor Sources
       
       
      Features
      Supports Clover EFI, Ozmosis, Chameleon, OpenCore GUI and Text Editor Mode CCE Bank Mobile friendly  
      Officially supported browsers
      Chrome 42+ Microsoft Edge 14+ Firefox 39+ Safari 10+ Opera 29+ Opera Mobile 12+ Chrome for Android 75+ Firefox for Android 67+  
       
      Credits
      mackie100 - took some ideas from his app Clover EFI dev team Eric Slivka - new serial number Virtual1 - new serial number cecekpawon - PHP 5.3.3 patch, , help with the ACPI Loader Mode flag and more Micky1979 - Clover flying editor  (Discontinued) crusher. - Help with the ACPI Loader Mode flag Download-Fritz - Help with the ACPI Loader Mode flag Pavo - Ozmosis fields and values stehor - Ozmosis fields and values Sherlocks - General help and support gujiangjiang - General help and support  
      Please let me know if i forgot you!
    • By gengik84
      Ciro82==>>Thanks
      Uno dei tre Requisiti:
      Hack funzionante Mac vero Macchina virtuale Impostazioni Bios per il boot:
      Cercate una voce  del tipo “Sata Mode”e settatela  in AHCI
      Secure Boot: disabilitare o altri sistemi operativi
      CSM: UEFI o LEGACY, oppure a secondo del tipo di installazione
      VT-x / VT-d disable
      *Nota: Secure boot e csm valido solo per bios UEFI
      Materiale Occorrente 
      "OS X (Versione App.Store)”
      USB 8GB  *nota: nel caso di usb superiori dovrà essere partizionata, in modo da avere una partizione su cui "lavoreremo,di questa dimensione
      ShowAllfiles 
      kext Wizard 
      Bootloader Clover_2.3k_r xxx:                   http: //sourceforge.n.../cloverefiboot/
      Clover Configurator:                                    http: //mackie100proj...a.org/download/
      FakeSmc.kext:                                            https://github.com/kozlek/HWSensors/releases
      In allegato,a fondo pagina troverete un "pacchetto" contenente : ShowAllfiles, Kext Wizard, FakeSmc.kext: 
      App alternative:
      ESP Mounter Pro: per montare la partizione EFI
      Vi illustrerò tre metodi per creare la usb, ma sono ben distinti… quindi usatene soltanto uno
      Metodo 1: “Install Mac_OS_X.command” Metodo 2: “Create Install Media di Apple” Metodo 3:  Metodo Manuale Alla fine delle preparazione dell’installer, tutti i metodi necessitano l’installazione del Bootloader Clover sulla a vostra USB.
      “CONDIZIONI OBBLIGATORIE”
      PUNTO 1: che la vostra usb sia stata preventivamente nominata USB (caratteri maiuscoli) Tabella di partizione GUID e la formattazione in  Mac esteso Journaled.
      PUNTO 2: che l’installer di OSX si trovi in Applicazioni
      Utility Disco 
      Selezionate la pendrive, andate su “partizione”, selezionate “1 partizione”, impostate Mac OS esteso journaled e date il nome USB, poi in basso cliccate su opzioni e scegliete Tabella partizione (GUID), poi “applica”.
      Immagine 
      Riporto nuovamente l’operazione sopra citata adoperando dal nuovo Utility Disco introdotto su El Capitan.
      Rimane ovviamente invariato nome della usb in ==>> USB (maiuscolo), la formattazione in Mac esteso Journaled e sia la mappa partizione in GUID
      Da utility disco selezionate la usb, cliccate su inizializza.
      dal menù a tendina scegliete la relative impostazioni
      Immagine  
      Procedura effettua da High Sierra è la stessa della precedente, l'unica attenzione e operazione da aggiungere in primis  è cliccare nel menù a tendina in alto sulla sinistra di utility disco e selezionare "mostra tutti i dispositivi"
      Immagine 
       
      =====================
        METODO 1: "Install_Mac_OS_X.Command" Lo script che trovate allegato in fondo alla guida permette la creazione dell’installer in maniera automatica
      Include la possibilità di scelta di tre versioni di osx
      Yosemite El Capitan Sierra Il risultato finale è come quello del metodo "manuale" descritto nella guida, per cui l'installazione avverrà in un solo passaggio, non in due come con il metodo createinstallmedia. 
      Offre inoltre la possibilità di inserire un kernel patchato, utile, per esempio, per chi usa AMD.
      Rimane invariato il nome dato alla usb in USB, mappa partizione e tipo di formattazione
      Se la vostra usb non sarà rinominata nel modo corretto, verrete avvisati dal terminale, quindi non dovrete far altro che apportare la relativa modifica e rilanciare nuovamente lo script
      Esempio
      ===========================
      Metodo 2 
      L'intento è quello di usare la procedura fornitaci direttamente da Apple, "createinstallmedia", introdotta  con Mavericks. 
      Tale metodo prevede l’uso del terminale che via via se ne sta perdendo il “valore e l’uso”
      Inizialmente per i neofiti potrà sembrare problematico ma alla fine non è così.
      Durante il post installazione alcune operazioni ne richiedono l’ uso.
      Perciò mi sono chiesto perchè, qualora uno volesse, non far conoscere da subito un po’ questo “strumento”???
      Per favorirvi vi ho allegato i comandi già  “pronti”, i quali li potrete copiare ed incollare sul terminale.
      A questo punto aprite il terminale, copiate ed incollate il comando sottostante e premete invio, digitate la vostra password e premete nuovamente invio.
      Comando per creare USB con Yosemite:
      sudo /Applications/Install\ OS\ X\ Yosemite.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ Yosemite.app --nointeraction  
      Comando per creare USB con El Capitan
      sudo /Applications/Install\ OS\ X\ El\ Capitan.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ OS\ X\ El\ Capitan.app --nointeraction Comando per creare USB con Sierra 
      sudo /Applications/Install\ macOS\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/USB --applicationpath /Applications/Install\ macOS\ Sierra.app/ --nointeraction Per creare USB con Hight Sierra o Mojave usate --> C_I_M (aggiornato per 10.14)
       
      Funziona con il drag & drop sul terminale, in questo caso non vi è necessità che la usb sia nominata in un determinato modo ed essendo basato su create install media ovviamente funziona da 10.9 a 10.14.... 
      BENE…IL PROCESSO DI CREAZIONE E’ INIZIATO…
      AVREMO CIRCA 20/30 MINUTI DI TEMPO LIBERO A CUI DEDICARSI A CIO’ CHE VOGLIAMO………………………………………..  
      COLGO L’OCCASIONE PER FARVI NOTARE LA VELOCITA’ E LA SICUREZZA DI QUESTO METODO
      CONFRONTATE QUESTO CON IL TERZO METODO E NOTERETE CHE CON UN SOLO PASSAGGIO, OSSIA IL COMANDO DATO AL TERMINALE, FACCIAMO IN UNA SINGOLA OPERAZIONE TUTTI I VARI STEP DESCRITTI SULL’ ALTRO METODO.
      DETTO QUESTO, MOLTO IMPORTANTE E’ SOTTOLINEARE CHE COSI’ FACENDO EVITEREMO ERRORI  DI DISTRAZIONE RIGUARDO AI PASSAGGI O FRAINTENDIMENTI.
      Immagine 
      Potete adesso passare ad installare il bootloader Clover sulla vostra usb.
      *NOTA*:
      Avendo usato questo metodo l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      =========================
      METODO "MANUALE"....  (lascio per futura memoria-Compatibile fino a 10.12)
      ==========================
      Bootloader
      **Nota:** Installazione in UEFI  dipenderà dalla scheda madre in vostro possesso, quindi se non supporta tale opzione , il bootloader dovrà essere installato in  modalità Legacy.
       Vi invito, qualora non sapeste questa informazione, a recarvi nel sito ufficiale del produttore e controllare le informazioni a riguardo
      Fatto questo dobbiamo installare  Clover sulla usb.
      A seconda del tipo di Bios o al tipo di installazione che vogliamo fare UEFI o Legacy avremo ovviamente configurazioni diverse in questa fase.
      Lanciate il pkg.
      Immagine 

       
      Cambiate la destinazione di installazione ad USB oppure Install Mac_OS_X (a secondo del tipo di creazione eseguita)
      Successivamente clicchiamo su "Ad Hoc"
      Per Installazione UEFI
      Mettete i flag   : Installazione solo per avvio UEFI
                               : installare Clover nella ESP
                               : Driver64UEFI  AptioMemory --> (consigliato) ->  Link download
       Può essere solo aggiunto manualmente scaricando dal link sopra e collocandolo nella rispettiva cartella
       NOTA: in questo caso non selezionare nessun OsxAptioFixDRV durante l'installazione di clover oppure rimuovetelo                        successivamente. 
                               : Driver64UEFI  ApfsDriverLoader --> (consigliato) --> sostituisce l'uso del driver apfs.efi
                               : Selezionate l'altri driver come da successiva immagine,
       
      *Nota: Altri driver che si possono usare  al suo posto  sono:
       informazioni 
       
      Proseguite con l’installazione.
      Immagine 
      ** Ricordate che avrete accesso a questa cartella dopo aver montato la partizione EFI**
      ===========================
      Per installazione Legacy
      Immagine 
      ===========================
      Impostazione per config.plist:
      Con clover configurator “montate” la partizione EFI della usb.
      1) Per fare questo nel menù di sinistra, cliccate su “Mount EFI”
      2) individuate la partizione relativa alla vostra usb, a questo punto montiamo la relativa partizione EFI  selezionando l’apposito pulsante “Mount Partition”
      Immagine 
      3) Successivamente cliccate su “Open Partition”.. recatevi in EFI/Clover ed aprite il config.plist
      4) Sezione ACPI: Disabilitate tutti i fix sia del menù 1 che del menù 2
      Immagine 
      5) Sezione BOOT: Sole se si sta installando Yosemite mettete il flag su kext-dev-mode=1
      Immagine 
      6) Sezione RT Variables: Se si sta installando El Capitan oppure Sierra, aggiungere i valori: BooterConfig= 0x28, CsrActiveConfig= 0x67
      Immagine 
      7) Sezione System Parameters: Su inject kext mettete YES
      Immagine 
      ===========================
      Nota: Su El Capitan, è stato introdotto SIP (System Integrity Protection)
      Info:
      ===========================
      Recatevi in EFI/Clover/kext/10.x 
      X= alla versione di osx che state installando. Per esempio se installerete Yosemite dovrete recarvi nella cartella 10.10, con El Capitan in 10.11….ecc
      Se non ci fosse tale cartella, createla e nominatela voi a “modo”.
      Copiatevi all’interno FakeSmc.kext
      *Nota se venite già da altre vostre configurazioni, oltre kext sopra citato ,potete mettere gli altri necessari per il vostro hardware
      Stessa cosa se avete DSDT e/o SSDT potete copiarli in EFI/Clover/Acpi/Patched
      Immagine 
      
      Per High Sierra:
      Scaricare il driver apfs.efi a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
       
      Per chi volesse continuare ad usare HFS vi rimando a questo post:
        Come installare High Sierra in HFS direttamente dalla usb  
      Utenti Laptop:  Nel 99% è obbligatorio disattivare la grafica discreta Nvidia/Amd per installare questo nuovo osx
                                     Quindi aggiungete --> SSDT-Disable_DGPU.aml.zip
                                     in EFI/Clover/acpi/Patched della usb
      --------------------------------------------------------------------
      Per Mojave:
      Scaricare il driver apfs.efi per 10.14 a fine guida, collocarlo:
          --> EFI/clover/Driver64UEFI se stiamo usando UEFI
      --> EFI/Clover/Driver64 se stiamo usando Legacy
      Versione di clover non antecedente a V_4015
      Volete usare HFS?
      E' possibile fare un installazione diretta su altro disco o partizione, nel caso può essere usato anche per effettuare aggiornamenti...
      nel caso guardate...
       Mojave in HFS 
       Oppure direttamente da usb  
       
      Fatto questo avrete la vostra USB bootable per installare OSX.
      ………Non scordatevi Fakesmc.kext da mettere nella relativa cartella…. senza il quale non farete mai il Boot......
      *NOTA: se usato il terminale per la creazione della usb, l'installazione si dividerà in due fasi, perciò dopo il primo riavvio e necessario far partire nuovamente l'installer, selezionare lo stesso disco senza formattarlo.
      Finita questa ulteriore fase , l'installazione sarà terminata
      **NOTA** Se avete processori Broadwell,Skylake o Kabylake...usate FakeSmc.kext e relativi sensors che trovate all'interno del secondo pacchetto.. (potete usarlo anche sui precedenti senza problemi, essendo una versione più aggiornata ha ulteriore supporto per le cpu più recenti)
      Update: Fakesmc e sensors versione 6.26
      Post installazione... post #2           
       Buon Hack….. 
      Aggiornamento:Install_Mac_OS_X.command.zip (compatibile da 10.10 a 10.12)
      le info le trovate a questo post
      Ringrazio @Ciro82 che mi ha aiutato nel preparare questa guida.
      Pacchetto.zip
      Pacchetto-2.zip
      Pacchetto-Fake+Sensors 6.26.1440.zip
      C_I_M.zip
       
       
       
       
       
       
       
       
       
       
       
       
       
    • By Alesss
      Good morning,
       
      I've the following pieces of hardware:
      - i7 6700K
      - GTX 1080
      - Asus Z170 Deluxe
      - NVME hard drives
       
      Yesterday I've successfully completed a High Sierra installation (I can't migrate to Mojave due to missing NVIDIA web drivers) but the system (even though it works correctly) seems to show a kernel panic at every shutdown/reboot.
       
      Please find the RunMe.app report attached.
       
      A couple of notes:
      - I've installed the audio kexts through the acidanthera AppleALC procedure
      - I've generated the SSDT with pikessdt script
      - Nvidia web drivers have been installed with the vulgo/webdriver.sh script that requires the WhateverGreen and the ngfxcompat=1 boot argument
      - AirportBrcmFixup.kext, BrcmFirmwareRepo.kext and BrcmPatchRAM2.kext have been used to unlock the full potential of the integrated Wi-Fi card
      - I've tried to clean nvram and motherboard CMOS with no avail
      - I've tried to update Clover to the latest version but it always results in an unbootable system
       
      It's a pity because everything seems to work correctly (USB ports, graphics, Wifi card, Continuity and so on. I haven't tried sleep but I don't use it anyway ) but this crash is fairly annoying.
       
      Thank you very much,
      Alesss
       
      Send me Ales-iMac.zip
    • By Pentothal.Z
      Hello all,
      I have a working hackintosh....ok.....but it takes a lot to boot and according to the boot.log there are a few problems.
      One of them is a black screen that stays on for a long time.
      I would like to ask anyone in this community some help to fine tune my machine.
      Boot.log and config.plist attached


      Any help would be appreciated.
      bootlog.txt
      config.plist
×