Jump to content
ErmaC

Clover General discussion

22,243 posts in this topic

Recommended Posts

 

Anyone else trying to build Clover 3203 I am getting a error,

 

CloverGrowerPro/edk2/Clover/OsxBdsDxe/BdsDxe.inf] is not found in dependent packages:

 

See below

 

Thanks!

Last login: Fri May  8 10:16:27 on console
osxfr33ks-iMac:~ osxfr33k$ cloverpro

********************************************
*              Good Morning                *
*     Welcome To CloverGrowerPro v5.0      *
*           This script by JrCs            *
*        Original script by STLVNUB        *
* Clover Credits: Slice, dmazar and others *
********************************************

running 'CloverGrowerPro.sh' on 'Yosemite'

Work Folder: /Users/osxfr33k/CloverGrowerPro
Available  : 393008 MB

No Clover Update found. Current revision: 3203

No build already done. Forcing Clover build...

Ready to build Clover 3203, Using Gcc 4.9.2
*******************************************
*    Auto-Build Full Clover rEFIt_UEFI    *
*    Revisions:   edk2: 17363             *
*               Clover: 3203              *
*    Using Flags: gcc49 x64 release       *
*******************************************

Starting >>>>New<<<< Build  Process: 10:18:11
Building CloverX64, gcc49 release
Creating new RAM disk

Initialized /dev/rdisk2 as a 256 MB case-insensitive HFS Plus volume

Using TOOLCHAIN_DIR='/Users/osxfr33k/CloverGrowerPro/toolchain'
running ./ebuild.sh -gcc49 -release -D USE_APPLE_HFSPLUS_DRIVER --x64

TOOLCHAIN_DIR: /Users/osxfr33k/CloverGrowerPro/toolchain
Initializing workspace
Loading previous configuration from $WORKSPACE/Conf/BuildEnv.sh
WORKSPACE: /Users/osxfr33k/CloverGrowerPro/edk2
EDK_TOOLS_PATH: /Users/osxfr33k/CloverGrowerPro/edk2/BaseTools

Running edk2 build for CloverX64 using the command:
build  -D USE_APPLE_HFSPLUS_DRIVER -D USE_LOW_EBDA -p Clover/Clover.dsc  -a X64 -b RELEASE -t GCC49 -n 9 

Build environment: Darwin-14.3.0-x86_64-i386-64bit
Build start time: 10:18:13, May.08 2015

WORKSPACE        = /Users/osxfr33k/CloverGrowerPro/edk2
ECP_SOURCE       = /Users/osxfr33k/CloverGrowerPro/edk2/EdkCompatibilityPkg
EDK_SOURCE       = /Users/osxfr33k/CloverGrowerPro/edk2/EdkCompatibilityPkg
EFI_SOURCE       = /Users/osxfr33k/CloverGrowerPro/edk2/EdkCompatibilityPkg
EDK_TOOLS_PATH   = /Users/osxfr33k/CloverGrowerPro/edk2/BaseTools


Architecture(s)  = X64
Build target     = RELEASE
Toolchain        = GCC49

Active Platform          = /Users/osxfr33k/CloverGrowerPro/edk2/Clover/Clover.dsc
Flash Image Definition   = /Users/osxfr33k/CloverGrowerPro/edk2/Clover/Clover.fdf

Processing meta-data ..

build.py...
/Users/osxfr33k/CloverGrowerPro/edk2/Clover/OsxBdsDxe/BdsDxe.inf(199): error 3000: PCD [gEfiIntelFrameworkModulePkgTokenSpaceGuid.PcdHardwareErrorRecordLevel] in [/Users/osxfr33k/CloverGrowerPro/edk2/Clover/OsxBdsDxe/BdsDxe.inf] is not found in dependent packages:
		/Users/osxfr33k/CloverGrowerPro/edk2/Clover/CloverPkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/MdePkg/MdePkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/MdeModulePkg/MdeModulePkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/IntelFrameworkPkg/IntelFrameworkPkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/IntelFrameworkModulePkg/IntelFrameworkModulePkg.dec
 

- Failed -
Build end time: 10:18:15, May.08 2015
Build total time: 00:00:02

Cloverx64 release  ERROR!!


Ejecting RAM disk
"disk2" unmounted.
"disk2" ejected.
osxfr33ks-iMac:~ osxfr33k$ 

test, please, 3204

Share this post


Link to post
Share on other sites
Advertisement

@slice,

 

Still get the error on the inf file.

Last login: Fri May  8 10:36:54 on ttys000
osxfr33ks-iMac:~ osxfr33k$ cloverpro

********************************************
*              Good Morning                *
*     Welcome To CloverGrowerPro v5.0      *
*           This script by JrCs            *
*        Original script by STLVNUB        *
* Clover Credits: Slice, dmazar and others *
********************************************

running 'CloverGrowerPro.sh' on 'Yosemite'

Work Folder: /Users/osxfr33k/CloverGrowerPro
Available  : 392996 MB

No Clover Update found. Current revision: 3204

No build already done. Forcing Clover build...

Ready to build Clover 3204, Using Gcc 4.9.2
*******************************************
*    Auto-Build Full Clover rEFIt_UEFI    *
*    Revisions:   edk2: 17384             *
*               Clover: 3204              *
*    Using Flags: gcc49 x64 release       *
*******************************************

Starting >>>>New<<<< Build  Process: 10:39:08
Building CloverX64, gcc49 release
Creating new RAM disk

Initialized /dev/rdisk2 as a 256 MB case-insensitive HFS Plus volume

Using TOOLCHAIN_DIR='/Users/osxfr33k/CloverGrowerPro/toolchain'
running ./ebuild.sh -gcc49 -release -D USE_APPLE_HFSPLUS_DRIVER --x64

TOOLCHAIN_DIR: /Users/osxfr33k/CloverGrowerPro/toolchain
Initializing workspace
Loading previous configuration from $WORKSPACE/Conf/BuildEnv.sh
WORKSPACE: /Users/osxfr33k/CloverGrowerPro/edk2
EDK_TOOLS_PATH: /Users/osxfr33k/CloverGrowerPro/edk2/BaseTools

Running edk2 build for CloverX64 using the command:
build  -D USE_APPLE_HFSPLUS_DRIVER -D USE_LOW_EBDA -p Clover/Clover.dsc  -a X64 -b RELEASE -t GCC49 -n 9 

Build environment: Darwin-14.3.0-x86_64-i386-64bit
Build start time: 10:39:09, May.08 2015

WORKSPACE        = /Users/osxfr33k/CloverGrowerPro/edk2
ECP_SOURCE       = /Users/osxfr33k/CloverGrowerPro/edk2/EdkCompatibilityPkg
EDK_SOURCE       = /Users/osxfr33k/CloverGrowerPro/edk2/EdkCompatibilityPkg
EFI_SOURCE       = /Users/osxfr33k/CloverGrowerPro/edk2/EdkCompatibilityPkg
EDK_TOOLS_PATH   = /Users/osxfr33k/CloverGrowerPro/edk2/BaseTools


Architecture(s)  = X64
Build target     = RELEASE
Toolchain        = GCC49

Active Platform          = /Users/osxfr33k/CloverGrowerPro/edk2/Clover/Clover.dsc
Flash Image Definition   = /Users/osxfr33k/CloverGrowerPro/edk2/Clover/Clover.fdf

Processing meta-data ..

build.py...
/Users/osxfr33k/CloverGrowerPro/edk2/Clover/OsxBdsDxe/BdsDxe.inf(204): error 3000: PCD [gEfiIntelFrameworkModulePkgTokenSpaceGuid.PcdPlatformBootTimeOut] in [/Users/osxfr33k/CloverGrowerPro/edk2/Clover/OsxBdsDxe/BdsDxe.inf] is not found in dependent packages:
		/Users/osxfr33k/CloverGrowerPro/edk2/Clover/CloverPkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/MdePkg/MdePkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/MdeModulePkg/MdeModulePkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/IntelFrameworkPkg/IntelFrameworkPkg.dec
	/Users/osxfr33k/CloverGrowerPro/edk2/IntelFrameworkModulePkg/IntelFrameworkModulePkg.dec
 

- Failed -
Build end time: 10:39:11, May.08 2015
Build total time: 00:00:02

Cloverx64 release  ERROR!!


Ejecting RAM disk
"disk2" unmounted.
"disk2" ejected.
osxfr33ks-iMac:~ osxfr33k$ 

Share this post


Link to post
Share on other sites

3204 fails...

----------------------------------------------------------------------
Ran 250 tests in 0.955s

OK

Running edk2 build for CloverX64 using the command:
build  -D USE_APPLE_HFSPLUS_DRIVER -D USE_LOW_EBDA -p Clover/Clover.dsc  -a X64 -b RELEASE -t GCC49 -n 13 

Build environment: Darwin-14.3.0-x86_64-i386-64bit
Build start time: 20:50:47, May.08 2015

WORKSPACE        = /Users/ken/clovergrowerpro/edk2
ECP_SOURCE       = /Users/ken/clovergrowerpro/edk2/EdkCompatibilityPkg
EDK_SOURCE       = /Users/ken/clovergrowerpro/edk2/EdkCompatibilityPkg
EFI_SOURCE       = /Users/ken/clovergrowerpro/edk2/EdkCompatibilityPkg
EDK_TOOLS_PATH   = /Users/ken/clovergrowerpro/edk2/BaseTools


Architecture(s)  = X64
Build target     = RELEASE
Toolchain        = GCC49

Active Platform          = /Users/ken/clovergrowerpro/edk2/Clover/Clover.dsc
Flash Image Definition   = /Users/ken/clovergrowerpro/edk2/Clover/Clover.fdf

Processing meta-data ..

build.py...
/Users/ken/clovergrowerpro/edk2/Clover/OsxBdsDxe/BdsDxe.inf(204): error 3000: PCD [gEfiIntelFrameworkModulePkgTokenSpaceGuid.PcdPlatformBootTimeOut] in [/Users/ken/clovergrowerpro/edk2/Clover/OsxBdsDxe/BdsDxe.inf] is not found in dependent packages:
		/Users/ken/clovergrowerpro/edk2/Clover/CloverPkg.dec
	/Users/ken/clovergrowerpro/edk2/MdePkg/MdePkg.dec
	/Users/ken/clovergrowerpro/edk2/MdeModulePkg/MdeModulePkg.dec
	/Users/ken/clovergrowerpro/edk2/IntelFrameworkPkg/IntelFrameworkPkg.dec
	/Users/ken/clovergrowerpro/edk2/IntelFrameworkModulePkg/IntelFrameworkModulePkg.dec
 

- Failed -
Build end time: 20:50:49, May.08 2015
Build total time: 00:00:02

Cloverx64 release  ERROR!!

Share this post


Link to post
Share on other sites

Hi all, i have a Fujitsu Lifebook E752 with Phoenix bios, i can boot from pen drive, but only in legacy mode because in UEFI mode nothing appears after boot loader countdown.

From Hard Disk i can't boot in legacy mode, only in UEFI, but nothing happens after bootloader screen.

It's a drivers problem or bios problem?

 

Thanks in advance

Share this post


Link to post
Share on other sites

Hi, I can only get my ati 5850 to show its personality if i manually select inject in the clover graphics boot menu, clover configuration wont do it?

 

Any ideas?

Share this post


Link to post
Share on other sites

Hi all,

 

I install mackintosh 10.10.3 with great help from Crushers.

Only problem that i have now is with memory.

I have installed 32GB and my mackintosh 10.10.3 see only 16GB.

I was try to replace RAM modules in different slots, reset CMOS - remove battery from motherboard,  but always the same problem.

any help would be great.

 

Clover UEFI boot

when installing I check: EmuVariableUEFIx64, OsxApatioFixDrv-64

 

config:

i7-5930 3.50GHz  6 core processor

asus x99-a Motherboard

Nvidia GeForce GTX 780 strix - 6GB / dual 2 cads / not SLI

 

thanks.

PLEASE HELP !

Share this post


Link to post
Share on other sites

PLEASE HELP !

Hi,

 

When you get into BIOS setting on power-up, how much ,memory does your Bios detect ?

 

Rgds

Share this post


Link to post
Share on other sites

Slice, why does my R9 290X 8Gb show in bdmesg as EVERGREEN family when its listed in ati.c as Southern Islands?

Share this post


Link to post
Share on other sites

I'm using Clover on Legacy BIOS: BIOS-&gt;MBR-&gt;PBR-&gt;boot-&gt;CLOVERX64.EFI-&gt; ... system, namely boot.efi-&gt;mach_kernel-&gt;Login.But OS X Disk Utility format SSD to GPT by myself,so install clover means converter GPT to Hybrid MBR(Seems like Apple's Boot Camp software for Intel-based Apple Macs creates a hybrid partition table to allow the booting of Windows (which at the time of Boot Camp's creation did not support GPT or EFI). In this system the protective partition is reduced in size to cover from sector 1 to the sector before the first regular partition included in the hybrid MBR. Additional MBR partitions are then defined to correspond to the next three GPT partitions.),right?
Seems like there is no partition entry in my SSD MBR,clover boot "boot file" by sector address,right?Because I use iBored see MBR is same as clover boot0af.Seems like this is not Hybrid MBR because Hybrid MBR need partition entry in MBR,however I create Yosemite USB installer is Hybrid MBR
because I got this on USB Flash Drive

Disk: /dev/rdisk2 geometry: 3892/255/63 [62537728 sectors]

Signature: 0xAA55

         Starting       Ending

 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

------------------------------------------------------------------------

 1: EE 1023 254  63 - 1023 254  63 [         1 -   62537727] <Unknown ID>

 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused

This is SSD

Disk: /dev/rdisk0 geometry: 15566/255/63 [250069680 sectors]

Signature: 0xAA55

         Starting       Ending

 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

------------------------------------------------------------------------

 1: EE 1023 254  63 - 1023 254  63 [         1 -  250069679] <Unknown ID>

 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused

This is HDD

Disk: /dev/rdisk1 geometry: 121601/255/63 [1953525168 sectors]

Signature: 0xAA55

         Starting       Ending

 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

------------------------------------------------------------------------

*1: 07    0  32  33 - 1023 254  63 [      2048 -  104869888] HPFS/QNX/AUX

 2: AF 1023 254  63 - 1023 254  63 [ 104872320 -  838882170] HFS+        

 3: AF 1023 254  63 - 1023 254  63 [ 943755264 -  838866944] HFS+        

 4: 07 1023 254  63 - 1023 254  63 [1782622208 -  170899456] HPFS/QNX/AUX

this is beyond my knowledge,first time I know BIOS can use pure GPT.Seems I need confirm direct from developer said that clover doesn't create Hybrid MBR only Bootstrap code.Hybrid MBR is create by Yosemite Disk Utility add FAT32 partition,format FAT32 partition as HFS+ Disk Utility auto remove Hybrid MBR.In fact Hybrid MBR is partition entry in MBR,not Bootstrap code.
And I create USB Yosemite installer format GPT installed Clover,when USB Flash Drive have Hybrid MBR,it cannot accessed by Windows 7 and Windows 8.1,but can accessed by OS X Yosemite,maybe Windows can't "see" Hybrid MBR this special GPT because it doesn't have partition entry,it pop up said USB Flash Drive need format,when it doesn't have hybrid MBR,format dialog doesn't pop up,but only I can see EFI partition,HFS+partition is not show,though I have installed MacDrive.however SSD also installed clover doesn't pop up need format,HFS+ partition is show.
If this question cannot be answered,maybe I can iBored edit disk sectors in MBR to examine if SSD is hybrid MBR.

Share this post


Link to post
Share on other sites

I've create a  widget for Clover 

Hello Clover  :)  

 

Downloads and you have this

 

open10.png

 

Install ! and this is the widget   :)

I put Six link to the widget 

 

: Clover General Discussion

: Clover AppleLife 

: Clover Tools

: Downloads (SourceForge)

: Clover Wiki

: Clover Themes

 

Its a  flipping Widget

Move the mousse right bottom and Clic to the  i thats going back to the widget

front11.jpg

 

Back side  

 

back10.jpg

 

 

Widget is attaching  to downloads

Enjoy ! 

U great ..very cool ...crazy friend..how are u?

Share this post


Link to post
Share on other sites

I'm using Clover on Legacy BIOS: BIOS->MBR->PBR->boot->CLOVERX64.EFI-> ... system, namely boot.efi->mach_kernel->Login.But OS X Disk Utility format SSD to GPT by myself,so install clover means converter GPT to Hybrid MBR(Seems like Apple's Boot Camp software for Intel-based Apple Macs creates a hybrid partition table to allow the booting of Windows (which at the time of Boot Camp's creation did not support GPT or EFI). In this system the protective partition is reduced in size to cover from sector 1 to the sector before the first regular partition included in the hybrid MBR. Additional MBR partitions are then defined to correspond to the next three GPT partitions.),right?

Seems like there is no partition entry in my SSD MBR,clover boot "boot file" by sector address,right?Because I use iBored see MBR is same as clover boot0af.Seems like this is not Hybrid MBR because Hybrid MBR need partition entry in MBR,however I create Yosemite USB installer is Hybrid MBR

because I got this on USB Flash Drive

Disk: /dev/rdisk2 geometry: 3892/255/63 [62537728 sectors]

Signature: 0xAA55

         Starting       Ending

 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

------------------------------------------------------------------------

 1: EE 1023 254  63 - 1023 254  63 [         1 -     409639] <Unknown ID>

 2: AF 1023 254  63 - 1023 254  63 [    409640 -   11718752] HFS+        

 3: 0B 1023 254  63 - 1023 254  63 [  12390536 -   49885008] Win95 FAT-32

 

 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused 

This is SSD

Disk: /dev/rdisk0 geometry: 15566/255/63 [250069680 sectors]

Signature: 0xAA55

         Starting       Ending

 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]

------------------------------------------------------------------------

 1: EE 1023 254  63 - 1023 254  63 [         1 -  250069679] <Unknown ID>

 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused

 

this is beyond my knowledge,first time I know BIOS can use pure GPT.Seems I need confirm direct from developer said that clover doesn't create Hybrid MBR only Bootstrap code.

And I create USB Yosemite installer format GPT installed Clover,then I storage some Windows only file on it.but it cannot accessed by Windows 7 and Windows 8.1,but can accessed by OS X Yosemite,maybe Windows can't "see" Hybrid MBR this special GPT because it doesn't have partition entry,it pop up said USB Flash Drive need format,however SSD also installed clover doesn't pop up need format.

If this question cannot be answered,maybe I can iBored edit disk sectors in MBR to examine if SSD is hybrid MBR.

 

The hybrid MBR on the USB was not caused by installing Clover's boot files but by using OSX Disk Utility to add a FAT partition to the drive (Disk Utility automatically assumes you want a bootcamp partition to install legacy Windows ---> adds a hybrid MBR).  You can remove it and (restore the protective MBR) by using GDisk - see post#359.

 

The issue with Windows not seeing more than one partition on the USB is because your USB needs to have its "removable bit flipped" in order to be treated as a "fixed disk" - see this post.  Other OS's like OSX and Linux don't have this limitation so you can multi-partition the USB and the OS will see all partitions.

Share this post


Link to post
Share on other sites

U great ..very cool ...crazy friend..how are u?

Thanks !

Good !  You my friend ?  :D are you doing ?

Share this post


Link to post
Share on other sites

apianti has not attempted to get in touch for like 2 and a half months. Last I heard was he had the core libraries pretty much done and was refining them.

I suppose there would be more to share if someone would get his head into IRC...

Share this post


Link to post
Share on other sites

Hi all,

I experienced random kernel panic and page faults after wake from sleep for a long time, 

This computer worked well with mavericks installed, so i thought it might be hardware compatible problem of the new power supply,

I replaced the old one but problem still existed in yosemite,

In normally use, the system is very stable,  

Wake from hibernation is ok,

Wake from sleep, system might encounter kernel panic or a application crash immediately or after a while, 

the system may be still running, and can open a new app, but crashed apps due to page faults can not be opened again,

it seems there are memory corruption after sleep.

 

I searched yosemite post-installation sub-forum, found a lot of similar posts, it seems lots of 8/9 series gigabyte mbs are affected,

I use a gigabyte B85 mainboard and a i5-4570s haswell cpu too,

related posts:

http://www.insanelymac.com/forum/topic/306073-random-kernal-panics-any-advice-details-enclosed/

http://www.insanelymac.com/forum/topic/305809-wakeup-issues/

http://www.insanelymac.com/forum/topic/303388-reset-when-waking-from-sleep/

http://www.insanelymac.com/forum/topic/304336-kernel-panic-10102-when-screen-zooming-after-sleep/

 

I also found a useful post which solved this problem by deleting IOPlatformSystemSleepPolicy from X86Platformplugin.kext

http://www.insanelymac.com/forum/topic/305457-haswell-memory-corruption-after-sleep-kernel-panic/

 

I hope somebody will find the root cause and patch it through clover.

Share this post


Link to post
Share on other sites

I wonder how do you make font for Clover? Is there specific tool we can use?

I have a script I made last year which uses ImageMagick to create font .png files for both Clover and Chameleon. I'll post it when I get time.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By miliuco
      Install macOS 10.15 Catalina on Gigabyte P55-USB3 with Radeon RX 580 graphics card using a USB device created with the createinstallmedia command and Clover as bootloader. Instructions to install macOS 10.14 Mojave on this computer are almost identical, replacing Catalina app with Mojave, so this article is suitable for both versions of macOS. The Gigabyte P55-USB3 motherboard (and some others from the same brand with the P55 / H55 chipset) have made it easy to build a hackintosh and install macOS since 10 years ago. Although it is an old motherboard, the behavior with Mojave or Catalina is very good after changing the classic hard drive (HDD) for a solid state drive (SSD).

      Components of the hackintosh
      Gigabyte GA-P55-USB3 motherboard: P55 chipset, 1156 socket, ALC892 audio, Gigabit RTL8111D network, DDR3 RAM Intel Core i5-750 processor for socket 1156: 4 cores, 8MB cache, clock rate 2.66 GHz Fenvi FV-T919 wireless + Bluetooth card: PCI-Express, wifi is ac type, detected by macOS as Airport and Apple Bluetooth Radeon RX 580 8 GB graphics card: works OOB but with a few details to be considered, it has its own article.  
      Previous requirements
      Install macOS Catalina app in /Applications folder USB flash drive with at least 16GB prepared from Disk Utility with MBR partition scheme and formatted as Mac Os Plus (on older Gigabyte boards like mine, USB sticks partitioned with GUID scheme instead of MBR usually hang the system when booting) Recent version of Clover (I have used r5117) Recent versions of Lilu (at least 1.4.4) and WhateverGreen (at least 1.3.9) to fine-tune the behavior of the graphics card Recent version of RealtekRTL8111 (I have used 2.2.2) FaceSMC version 6.26-322 (newer versions disable automatic mounting of USB devices on my system).  
      Create install USB
      Run this command from Terminal (assuming the target device is called USB):
      Bash: sudo /Applications/Install\ macOS\ Catalina.app/Contents/Resources/createinstallmedia --volume /Volumes/USB /Applications/Install\ macOS\ Catalina.app
      Clover must be installed on the USB memory, I choose the following options:
      Bootloader > Install boot0af on the MBR CloverEFi > CloverEFI 64-bit SATA BIOS Drivers, 64 bit > Recommended drivers > FSInject + SMCHelper + XhciDxe BIOS Drivers, 64 bit > File System drivers > ApfsDriverLoader Install RC scripts on selected volume Optional RC scripts > Disable sleep proxy client.  
      You have to copy 4 kexts to the EFI/CLOVER/kexts/Other folder of the USB device: FaceSMC 6.26-322, Lilu 1.4.4, WhateverGreen 1.3.9 and RealtekRTL8111 2.2.2. Regarding the config.plist file, the most significant is:
      Boot > kext-dev-mode = 1 in Boot arguments GUI > Theme embedded, EmbeddedThemeType Dark, Screen Resolution 1920x1080, Preboot in Hide Volume Graphics > blank, nothing is checked except if foxbox solution is used to have more than 2 connectors enabled RT Variables > 0x28 in BooterConfig and 0x67 in CsrActiveConfig SMBios > iMac14,2 Sytem Parameters> Yes in Inject Kexts and check Inject System ID.  
      Install macOS Catalina

      Boot from the USB device and choose Install macOS from Install macOS Catalina. The installation program runs until the PC restarts. Here choose Install macOS from HDD (the name of the volume you are installing macOS on). With RX 580 graphics card, the screen goes black in this second phase of the installation, it is a phase in which the user has nothing to do until the PC is restarted so you can let it work until the Clover menu again. You have to choose Boot macOS from HDDto boot the installed system from the hard disk, the screen is recovered and you can configure the account and the initial options. From this moment the screen works fine.

      In summary:
      Boot from USB > Clover menu > Install macOS from Install macOS Catalina > screen works fine Boot from USB > Clover menu > Install macOS from HDD > black screen Boot from USB > Clover menu > Boot macOS from HDD > screen works fine.  
      Install Clover and kexts on the hard drive

      Clover needs to be installed on the disk where we just installed macOS. Options are the same as when installing it on the USB memory. You also have to copy the 4 kexts (FaceSMC 6.26-322, Lilu 1.4.4, WhateverGreen 1.3.9 and RealtekRTL8111 2.2.2) into the EFI/CLOVER/kexts/Other folder on the EFI partition of the disk. And review the config.plist file remembering the comments for the USB.

      If everything goes well, the computer starts from the hard disk with a running copy of macOS Catalina.
       
       

    • By miliuco
      Radeon RX 580 8 GB graphics card on macOS High Sierra (as of 10.13.6), Mojave and Catalina on the P55-USB3 board: excellent performance with acceleration (Metal) OOB, no need for drivers (kexts), with 3 drawbacks, one has to do with the boot of the operating system (a solution is proposed), another with the number of rear connectors enabled (a solution is proposed) and another that only affects to one phase of the Mojave or Catalina installation (without clear solution for now).

      I have placed the XFX AMD Radeon RX-580 P8DFD6 8GB Triple X Edition GDDR5, 256BIT, DVI + HDMI + 3DP graphics card on a 10 year old motherboard (Gigabyte P55-USB3) in order to update the hackintosh to 10.14 Mojave and 10.15 Catalina because the card that I have used in past years, Nvidia Geforce GTX 750 1GB, has stopped working after 10.13.6 High Sierra since this was the last version for which Nvidia published the alternate web drivers that were necessary for the card to work well with graphic acceleration.

      The new RX 580 card needs considerably more space than the old one although it fits perfectly in an ATX case, and requires an additional power connector. It has 2 big fans that most of the time are stopped, at least in my case. In macOS it works perfectly, even with Metal acceleration, without additional drivers and without extra settings in Clover. But it has drawbacks that I comment below.

      Alterations during startup

      During the boot of the operating system, when the screen goes from the basic driver to the AMD driver, 2 artifacts appear randomly, they are very short in duration (from one to a few seconds):
      Very short flashing white screen that may or may not be accompanied by purple lines The fans runs for a few seconds (the noise is clearly audible). This behavior is solved with the installation of 2 kexts, Lilu and WhateverGreen. Lilu is an extension created by acidantheraand vit9696 among others whose function is to help to patch kexts, processes and libraries during macOS boot. It is accompanied by specific plugins for the task required, for example WhateverGreen that injects necessary patches for certain AMD, Intel and Nvidia graphics cards. It is mandatory to have both extensions together, one of them separately does not correct the problem.
      I have installed Lilu 1.4.4 and WhateverGreen 1.3.9 in the EFI/CLOVER/kexts/Other folder of the EFI partition and artifacts have disappeared. Remember that these 2 extensions are not necessary for the card to work properly, if you tolerate those very brief distortions of the screen or the noise of the fans running for a few seconds, you can live without Lilu and WhateverGreen.

      Note: authors recommend that when using Lilu and WhateverGreen with Radeon cards, NO graphic settings have to be added to Clover (Inject ATI, etc.).

      Note: these alterations, especially the brief white screen and less frequently purple lines and fan noise, are also seen in Windows and some real Macs with the same card.

      Alteration during macOS installation

      Boot from USB > Clover menu > Install macOS from Install macOS Catalina > screen works fine
      Boot from USB > Clover menu > Install macOS from MacintoshHD > black screen
      Booting from USB > Clover menu > Boot macOS from MacintoshHD > screen works fine.

      In the first and third stages, screen works fine. In the second stage the screen goes black although the installation continues. The user has nothing to do at this moment so you can leave the PC working until the Clover menu is shown again, the screen is recovered, the initial account options can be configured and you can enter into the newly installed system with correct resolution and acceleration.
      This behavior is not corrected even by placing Lilu and WhateverGreen into the USB device. At least in my case I have not found a solution for it. Yo can install macOS perfectly with that drawback of not seeing how it progresses during the second phase of the installation.

      Only 2 connectors of the 5 available work

      This card has 3 Display Port (DP) ports, 1 HDMI port and 1 DVI port. In my case, only 2 DP work, those that are further from the HDMI connector. It is enough if you use a single monitor or 2 monitors that can be connected by DP. But if you want to have 3 or more connected devices or some of them only have HDMI, it is necessary to enable the 5 connectors or at least 4 of them since the DVI is obsolete and does not allow resolutions as high as DP and HDMI.
      User foxbox has proposed a solution in a thread titled [Solved] Sapphire RX 580 Nitro + SE | black screen on HDMI and DVI. Must inject from Clover a modification to the Orinoco framebuffer (which is used in the RX 580 card) so that the 5 connectors lack a fixedly assigned address and, instead, receive it dynamically. This change is made from the KextsToPatch section of Clover. Read the post from foxbox.
      This has to be accompanied by 3 changes in the Graphics section of Clover: Orinoco in FB Name / Inject ATI / 5 in Video Ports. I have tested this solution in macOS Catalina and it effectively enables the 5 ports of the card but, since I only use 1 monitor, I have removed it and I am with Lilu and WhateverGreen.
       

    • By zazman
      Bonjour,
       
      Je rencontre un souci depuis la dernière maj supplémentaire catalina 10.15.4, même chose pour la 10.15.5 aujourd'hui : après le début de l'update, lorsque le pc redémarre, je ne vois pas le volume d'installation dans les volumes de l'écran de boot clover (v5118). j'ai juste Preboot dans les volumes cachés au démarrage, et j'ai essayé de les afficher, le préboot de l'install apparait bien mais le boot n'aboutit jamais par ce biais. du coup, je suis bloqué en 10.15.4. Auriez-vous une idée du problème ?
    • By y010204025
      Perhaps it was the first NEC (Lenovo) Lavie Z HZ550 to install hackintosh. I hope more people who like Lavie Z series can experience Hackintosh at HZ550. She is really great.
       
      I found HZ550 & HZ750 on the Chinese website, which is amazing. It weighs only 790g, 13.3 inches, and the standard 2k screen, which is too attractive to me. I am a Hackintosh enthusiast. I think HZ550 or HZ750 with MacOS is the best Unfortunately, the Lavie Z series is not listed in China, only exists in the Japanese and American markets, and in the Japanese market is the NEC brand, while the American market uses the Lenovo logo.
       
      Fortunately, I got an HZ550 from Taobao. Yes, not HZ750. In comparison, HZ750 has more touch screens and 360 ° flip. These are hard to attract me. More importantly, HZ750 is about 200g heavier than HZ550 That's why I chose HZ550. Well, because he is only 2,000 RMB.
       
      The specific introduction can refer to NEC Japan official website:http://nec-lavie.jp/products/hz13b/
       
      The HZ550 hardware list I obtained:
                                    
                       -/+:.          ningnan@ningnandeMacBook-Air
                      :++++.          OS: 64bit Mac OS X 10.15.5 19F96
                     /+++/.           Kernel: x86_64 Darwin 19.5.0
             .:-::- .+/:-``.::-       Uptime: 19m
          .:/++++++/::::/++++++/:`    Packages: 1
        .:///////////////////////:`   Shell: zsh 5.7.1
        ////////////////////////`     Resolution: 3840x2160
       -+++++++++++++++++++++++`      DE: Aqua
       /++++++++++++++++++++++/       WM: Quartz Compositor
       /sssssssssssssssssssssss.      WM Theme: Blue (Dark)
       :ssssssssssssssssssssssss-     Disk: 11G / 108G (12%)
        osssssssssssssssssssssssso/`  CPU: Intel Core i7-5500U @ 2.40GHz
        `syyyyyyyyyyyyyyyyyyyyyyyy+`  GPU: Intel Iris Graphics 6100
         `ossssssssssssssssssssss/    RAM: 4376MiB / 8192MiB
           :ooooooooooooooooooo+.    
            `:+oo+/:-..-:/+o+/-     
       
       
      Advantages: small size, light weight, 2K screen, 8G memory, 512g SSD, keyboard feels good, and wireless network card can be replaced, which is unimaginable in today's thin and light books.
      Disadvantages: The sound is small, almost the same as the mosquitoes.
       
      Ok, bragging is over!
      In order to use the wireless network, I changed the wireless network card from inter 7265 to BCM94352ZAE. Some people called it DW1560. It is uncomfortable that in China, this card and his elder brother DW1830 were hyped to a high price of 480RMB. of. Fortunately, I bought it early, and this card is also very stable under win10, and there is no high delay and outage. The hard disk should be PM951 of Samsung, not PM981, which is lucky.   Before installing Hackintosh: You need to prepare a 16G U disk, SanDisk is not a rough choice for making MacOS installation disk, I used the latest MacOS Catalina 10.15.5, got config.plist from Rehabman, and put together an EFI, the latest version of clover and kext drivers. Thanks to Rehabman and the developers of the Black Apple community. I do n’t like that OC team very much.
      Make an installation disk: If you have a computer running MacOS, you can use the command line to make it, if you do n’t have a computer running MacOS, you can try VMware, I know that the insanelymac forum allows discussion, or use ether to write the image to U disk, use the EFI I provided to boot into the installation process.   BIOS setting: Press F12 at boot to enter the BIOS settings, Tab switches to "Security-Secure boot", set to "DISable", this is what we need, and switch to "Boot -Boot devices", set the U disk as the first boot item You can directly enter the clover guide interface, please follow it for google it.
      It is worth noting that the remaining space of your EFI partition needs to be greater than 200M, otherwise, the disk format will be wrong. In addition, the format partition format is APFS, do not choose to encrypt, your data is not valuable, at least you must have this awareness of Hackintosh, the file safe is also the same, do not enable, do not use to find your mac, otherwise, change the machine, OK .   Fortunately, no additional ssdt patch is required. All the patch functions are implemented through clover. The flat Apple is turned on. This is to solve the problem of the flower screen. You can find a solution yourself.
      Experience your black apple, this will bring a better experience than MacBook Pro. EFI_HZ550.zip
    • By cvad
      View File Bootdisk Utility
      Make bootable USB Flash Disk for MAC OS X with Latest Clover bootloader revision fast and easy by one click! under OS Windows.
      Special utility from cvad & russian MAC community for new hackintosh users.
       
      Enjoy...
       
      For more information and complete instructions please see this topic.
       
      Anyone who likes the program, please support its Community Score.
       
       
      Feel free to "Rate File"
      Submitter cvad Submitted 04/28/2013 Category Bootloaders  
×