Jump to content
ErmaC

Clover General discussion

20,947 posts in this topic

Recommended Posts

Slice is glad to present a new EFI bootloader.
CLOVER
Now version 2 rEFIt based.


It is open source based on different projects: Chameleon, rEFIt, XNU, VirtualBox. The main is EDK2 latest revision.
I also want to thank all who help Slice with the development. Credits and copyrights remain in the sources.
http://cloverefiboot.sourceforge.net/

Main features:

 

  • Boot into 10.4 - 10.8 OSX, Windows EFI and Linux EFI
  • Boot into LegacyOS (WindowsXP, Linux, DOS) by their bootsectors
  • This is EFI bootloader so it provides RuntimeServices for OS that impossible for Legacy Bootloaders
  • Mostly Clover do automatic detection of hardware and set all properties by default. But user can change them by config.plist
  • with Clover you may restart into other OS from Startup Disk prefPane
  • Config autodetect by OEM product name
  • UUID written into config.plist will be the same as in OS
  • Autopatch OemDSDT for working OSX
  • SMBIOS will be corrected to standard 2.6
  • ACPI will be corrected to standard 4.0. Custom DSDT will be loaded from booted partition or from EFI folder
  • MADT table may be corrected to resolve problem with NMI on some hardware
  • ACPI tables loading (SSDT-xx, APIC, BOOT, SLIC, SLIT, SRAT, UEFI...)
  • Correctly set PowerProfile for laptops (notebooks), desktops, workstations
  • Customizable RestartFix
  • sleep/wake fixes
  • PCIRootUID value (0,1) for device-injection for those who can't edit DSDT
  • Graphics Properties Injector for ATI, NVidia and Intel for wide range of supported cards. Also customizable.
  • Custom EDID for non-DDC monitors
  • USB fix (LegacyOff, Ownership, Builtin, clock-id) up to USB 3.0
  • HDA injector, HDMI fix.
  • Ethernet builtin injector
  • CPU turbo
  • P- and C-states generator
  • PLimitDict and UnderVoltage for CPU Speedstep
  • patch kernel on the fly for unsupported CPU like Atom and Ivy Bridge
  • patch kexts inside kernelcache for unsupported hardware
  • Extra kexts loading
  • Security mode for FireWire
  • Default boot after timeout
  • Customizable GUI: themes support, own icons, fonts.
  • There is a possibility to implement national languages and fonts. F1 - multilingual help
  • Saving boot.log in OS and preboot.log from GUI by typing F2
  • Save original (OEM) ACPI tables by pressing F4
  • Test DSDT patching with F5
  • Save videoBIOS into EFI/misc by pressing F6
  • Saving screenshots from GUI typing F10
  • CD/DVD eject by F12 and refresh menu after CD insertion

 



If you have a question please provide outputs from DarwinDumper (formed from Trauma tool). Thanks Trauma!
Continued by blackosx and STLVNUB.

-----------------

Edited by Slice
new update / references added

Share this post


Link to post
Share on other sites
Advertisement

To begin with, congratulations to all of you, this project is fantastic!!!!!

 

Last night I tried the installer on my Lappy, but I can only see at boot "GPT, boot0, boot0, DONE", or something like that.

 

For those who have already installed the bootloader (Chameleon) there are specific warnings?

 

My partions on GPT disk:

 

Efi

osx 10.8.1

osx 10.8.0

 

 

Another curiosity, we can change now the APIC.aml table, for override the original, to surpass the Local Apic error for Insyde BIOSes? Is possible with this bootloader?

 

 

As soon as I can, experiment on USB key, and report results!

Share this post


Link to post
Share on other sites

Excellent job on the setting up this topic Fabio & Slice.

 

Clover has grown and expanded incredibly this year and it now supports a wealth of options, many of which I don't use either because my hardware doesn't require them, or my setup already had the required patches applied. Because of that, and also the pace of development, I've missed out on the learning, experimenting and understanding of some of Clovers options and with the previous available documentation being either the Russian PDF at AppleLife, or one of the hundreds of posts at projectosx your opening posts here make a welcome resource.

 

Keep up the great work :)

Share this post


Link to post
Share on other sites

Hi people, and thank you for your efforts !

I followed this tutorial :

How to install InstallESD.dmg to GPT. since r480.

 

First, you need to Restore InstallESD.dmg to disk by using Disk Utility.

Then, follow the stage 1 and stage 2 to install 10.7.x or 10.8.x to GPT, and auto-create the Recovery HD used for iCloud.

 

Stage 1

 

1.Remove kernelcache in InstallESD.dmg/Library/Preferences/SystemConfiguration/com.apple.Boot.plist.

<key>Kernel Cache</key> remove this line.

<string>xxxxxxxxxxxxx</string> remove this line.

2.Copy BaseSystem.dmg/System/Library/Extensions to partition of InstallESD.dmg and add other kexts (FakeSMC.kext).

3.Clover select to "Boot Mac OS X with extra kexts (skips cache)", and follow the installation with restart first time.

 

Stage 2

 

1.Remove kernelcache in target partition's /OS X Install Data/com.apple.Boot.plist.

<key>Kernel Cache</key> remove this line.

<string>xxxxxxxxxxxxx</string> remove this line.

( 10.7.x is /Mac OS X Install Data/com.apple.Boot.plist )

2.Copy InstallESD.dmg/System/Library/CoreServices and /mach_kernel to target partition's / .

3.Copy BaseSystem.dmg/System/Library/Extensions to target partition's / and add other kexts (FakeSMC.kext).

4.Boot to "OS X Install" with "Boot Mac OS X with extra kexts (skips cache)" and finish the installation.

(10.7.x is "Mac OS X Install")

 

I completed stage 1 (the installation), after restart i can't seem to detect my HFS+ drive on clover unless i change AHCI to IDE in my bios sata configuration. Once it is detected, it is stuck at [PCI Configuration Begin].

Tried FixDsdtMask = 0x0000 = Fail

npci=0x3000 PCIRootUID=0 GraphicsEnabler=Yes = fail

I did not change the smbios or anything else except doing a clean installation and following the above steps. So for stage 2, do i perform all these steps from the shell or any other way (like from windows partition for instance)?

I have an Asus G53JW-A1 with nvidia 460m GTX 1.5 Gb memory, and its working pretty well with Chameleon, but was just hoping to get something more Vanilla with your masterpiece and achieve better ACPI integration (Battery, Brightness control,...).

Please let me know .

Share this post


Link to post
Share on other sites

@slayer2333 see at post #9, under AHCI timeout by bcc9,

 

kext editing (or use an injector), not dsdt fix

 

 

EDIT

 

or something like this?

 

<key>0</key>
  <dict>
    <key>Name</key>
    <string>IOAHCIBlockStorage</string>
    <key>Find</key>
    <string>example in bcc9 script</string>
    <key>Replace</key>
    <string>example in bcc9 script</string>
  </dict>

 

???? :|

Share this post


Link to post
Share on other sites

Hi Slice.

I have absolutely no experience with ATI card (I don't have one).

 

One question related to Ati injector...

I see in the source only the "generic" Device ID like this:

{ 0x688D, 0x00000000, CHIP_FAMILY_CYPRESS,"AMD FireStream 9350",kZonalis},

 

Any reason for not add the specific SubId?

I have a lot of it... if you wont also add it...

 

Fabio

Share this post


Link to post
Share on other sites

I tried the last versione of Clover and i found this problem.

 

Boot Clover .

Press "O" .

Enable "Turbo" .

 

When i want to exit from menu and try to boot Clover Freeze. I'm alone?

Share this post


Link to post
Share on other sites

Hi Fabio,

It works without any knowledge about specific SubsystemID.

Dunno about NVidia but sure about ATI algorithm. It works also for Mobile Radeons.

 

I tried the last versione of Clover and i found this problem.

 

 

 

When i want to exit from menu and try to boot Clover Freeze. I'm alone?

I think the "Turbo" is a dangerous characteristic but I can't make a proof if it is allowed.

Share this post


Link to post
Share on other sites

hello

 

@slice

 

the customedid key for me don't work, clover loads the key, but result in nothing if don't apply the fix in file

 

/System/Library/Displays/Overrides/DisplayVendorID-756e6b6e/DisplayProductID-717

 

i don't have graphics at all, only black screen.

 

good hack

Share this post


Link to post
Share on other sites

hello

 

@slice

 

the customedid key for me don't work, clover loads the key, but result in nothing if don't apply the fix in file

 

/System/Library/Displays/Overrides/DisplayVendorID-756e6b6e/DisplayProductID-717

 

i don't have graphics at all, only black screen.

 

good hack

This is something that I don't know.

Share this post


Link to post
Share on other sites

Slice, I've set SMBios to Mac Pro 5,1, but after booting from Clover, it is always become iMac12,1.

What can I do if I want to force it to identify the system as MacPro5,1?

 

This is the config.plist which I'm using now.

 

.
.
<key>SMBIOS </key>
<dict>
<key>BiosReleaseDate</key>
<string>03/21/12</string>
<key>BiosVendor</key>
.
.

 

-Problem Solved-

Share this post


Link to post
Share on other sites

See if removing that space after SMBIOS helps.

 

<key>SMBIOS </key>

Thank you very much. Problem solved... :)

 

It's hard to notice the space in Xcode....

Share this post


Link to post
Share on other sites

Can anyone give me an example about how to hide partition in Clover?

I don't understand what the introduction means.

 

What should I key for "VolumeString" and "String or it's part from boot.log?"

 

Is VolumeString the name of partition or something like disk2s1 or the UUID of the partition?

Share this post


Link to post
Share on other sites

hello

 

@slice

 

the customedid key for me don't work, clover loads the key, but result in nothing if don't apply the fix in file

 

/System/Library/Displays/Overrides/DisplayVendorID-756e6b6e/DisplayProductID-717

 

i don't have graphics at all, only black screen.

 

good hack

if you have a Laptop must work, but I doubt if you are using an external monitor, their EDID are published by their EEPROM, so, attention if your Display product/vendor ID already exists in your Overrides folder.

ProductID-717 indicate a generic files generated by Osx visible in ioreg (not a real product ID), and video acceleration is really required for override the EDID, your display must be attached to the framebuffer, without, injection does not work!

 

 

search mmod, for real Product/Vendor ID

myedid.png

 

Micky

Share this post


Link to post
Share on other sites

Hi all, this is a very great job , but i dont unterstound , i have two answer , wich is config.plist of edited?

http://www.mediafire...4jiib4fupsd4n3d

 

The first or second in OEM folder

 

and why is slow between the boot done to get to the screen shots of the theme?

the first from the left work!

 

/EFI/config.plist

Share this post


Link to post
Share on other sites

Can anyone give me an example about how to hide partition in Clover?

I use the volume GUID. So for example, here's mine:

<key>Volumes</key>
<dict>
<key>HideAllLegacy</key>
<string>Yes</string>
<key>HideVolumes</key>
<dict>
<key>0</key>
<dict>
<key>VolumeString</key>
<string>F55D9AC4-08A8-4269-9A8E-396DBE7C7943</string>
</dict>
<key>1</key>
<dict>
<key>VolumeString</key>
<string>43EB9A16-6572-4B7F-A537-6303895DAE0A</string>
</dict>
</dict>
</dict>

You can get the GUID of each volume by checking your Clover bootlog.

Or easier still, run DarwinDumper and select the Disk Volume UUID & GUID option.

Share this post


Link to post
Share on other sites

if you have a Laptop must work, but I doubt if you are using an external monitor, their EDID are published by their EEPROM, so, attention if your Display product/vendor ID already exists in your Overrides folder.

ProductID-717 indicate a generic files generated by Osx visible in ioreg (not a real product ID), and video acceleration is really required for override the EDID, your display must be attached to the framebuffer, without, injection does not work!

 

 

hello

 

i use the lcd note

 

and the customedid is loaded by the key and string, is show in boot.log

 

but no works

 

only work with the edid in file

 

Captura de ecrã 2012-09-23, Ã s 22.02.28.png

 

good hack

Share this post


Link to post
Share on other sites

oh sorry, you said:

"i don't have graphics at all" and I thought this appen with Clover (no QE/CI

at all), .......perhaps I misunderstood.

 

only 2 thing, the string in the config.plist is property converted to BASE64, and maybe you have to remove your custom override file in S/L/D/O, using the Clover injection?

 

bye

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Similar Content

    • By kingoffright
      Dear all,
       
      I have a external harddisk about 500GB, I installed the clover into it and the harddisk is GPT format, below is the 3 partitions details:
      FS01: EFI - disk0s1 - fat32
      FS02: install mac  image - disk0s2 -  hfs+
      FS03: install windows 10 - disk0s3 - fat32
       
      I can use this external harddisk to install Mac without issue, I use below steps to install windows 10
      enter the FS03:
      cd to efi/boot/ and excuete bootx64.efi
      after pop up the windows install screen, i click next and it shows error 'A media driver your computer needs is missing...' and the installation can not go any further.
      Firstly I use ultraiso to write the windows 10 image to a flash disk and no issue to start install window 10 so the image is working fine. Since I dont know how to write
      a wiindow installation image into harddisk partition, I used winrar extra all the files into disk0s3, am I missing some steps or actually clover not support to install windows
      by partitions, apprecating any helps.
       
    • By kushwavez
      Acer Aspire V15 V5-591G - Catalina 10.15.1
      This post will no longer updated, go for the osxlatitude link for further updates
      Original and updated link:
      https://osxlatitude.com/forums/topic/11355-acer-aspire-v-15-v5-591g-catalina-windows-10/
      (Note: mine is 55TU version, but the bootpack will work fine with another versions of 591G, for example: V5-591G-71K2, -764Z, -59PU, etc.)
      Specifications:
      - Motherboard: USOPP_SLS (Skylake-H PCH)
      - BIOS: Insyde Corp. v 1.15
      - CPU: Intel Core i5-6300HQ 2.3 GHz (Skylake)
      - GPU: NVIDIA GeForce GTX 950M 2 GB (Optimus) & Intel HD Graphics 530
      - RAM: SK hynix 4 GB DDR4 (Later I bought + KINGSTON 4 GB) 2133 MHz
      - WiFi + Bluetooth: Qualcomm Atheros QCNFA344A 5 GHz (Later -> Broadcom BRCM94352Z M.2 5 GHz WiFi + 4.0 Bluetooth)
      - Audio: Realtek HD Audio: ALC 255 
      - Ethernet: Realtek RTL8168/8111
      - Card Reader: Realtek USB 2.0 Card Reader (USB2.0-CRW)
      - Webcam: HD Webcam
      - HDD: TOSHIBA MQ01ACF032 320 GB HDD
      - SSD: SPCC M.2 230 GB SSD
      - Display: 1366x768 (15.6", Matte)
      - Battery: 6 cell 56Wh / 5040mAh
      - Connectors: 
      1x SD Card Reader 2x USB 3.0 (1x USB Charging), 1x USB 2.0 1x VGA 1x HDMI 1x 3.5mm microphone/audio combined jack connector 1x Ethernet (Rj-45) - Keyboard & Touchpad: Multi-Touch & Multi-gestures ELAN 501 Touchpad, Backlight Keyboard.
      Working:  
      - Wi-Fi (with BCM94352Z)
      - Bluetooth hand-off (With BCM94352Z)
      - Full Graphics enabled on HD 530: ig-platform-id: 0x191b0000 (HD 530 Mobile)
      - Display: if default colour profile is corrupted (blue is not actual blue but purplish) Use "Rec. ITU-R BT. 709-5" Color Profile (System Pref. -> Displays -> Color)
      - HDMI & VGA Outputs: AppleGraphicsDevicePolicy.kext Clover patch
      - Audio (ALC 255): (Internal Speakers, Internal Microphone, Headphone jack with AppleALC, ALCPlugFix -> layout-id=17)
      - Ethernet Realtek 8168/8111: RealtekRTL8111.kext
      - App Store, Messages, FaceTime, Siri, iCloud (native)
      - Integrated webcam (native)
      - 3.0 USB (native)
      - Touchpad and Keyboard (ELAN501): Fn keys are good, the weird thing is the Brightness key. On my keyboard it's Pause Break:Br-up, Fn+F12:Br-dwn-> To fix this try Karabiner (VoodoPS2Controller.kext), - for gestures try SmartTouchpad drivers
      - Battery info: Install ACPIBatteryManager.kext with Kext Utility or other installer.
      - Sleep Mode
      - SSD with TRIM enabled (to enable trim, open Terminal and write "sudo trimforce enable")
      Not working:
      - Original Wi-Fi (Qualcomm Atheros QCNFA344A):  unsupported, you need switch to BCM94352Z or just use a mini usb wifi dongle.
      - NVIDIA GeForce GTX 950M: Optimus not supported.
      - Card Reader: Unsupported -> Can't really fix because I don't have any SD Card at the moment, maybe can be fixed by adding Prod & Ven IDs to AppleStorageDevices.kext, I never used it anyway. name: "USB2.0-CRW" Prod ID: "0x0129" Ven ID: "0x0bda  (Realtek Semiconductor Corp.)"
      For Wi-Fi:
      - 1st method: You can choose an external USB wifi dongle (I used TP-Link Archer T1U (5GHz support), TP-Link has official macOS drivers, you just need to install it
      - 2nd and I think the best method: Replace your M.2 Qualcomm Card with a compatible BCM94352Z card (you will have hand-off Bluetooth too), just install the kexts (enabled with BrcmFirmwareRepo.kext, BrcmPatchRAM2.kext, FakePCIID.kext, FakePCIID_Broadcom_WiFi.kext, they're all in my attached zip). You could buy this card from ebay, aliexpress, or amazon
       
      Issues:
      - None
      BIOS Settings:
      - BIOS version 1.15 (irrelevant)
      - Secure Boot: Disabled
      - Touchpad: Advanced
      - Boot mode: UEFI
      Getting ready for Installation:
      - Download the Catalina install zip (bootpack & postinstall): acer_aspire_V591G-55TU_cata.zip
      Installation:
      - Create an installer with any method you know (- Mac: createinstallmedia - Windows: Transmac, Vmware, Win32diskimager)
      - Copy my Clover folder to the USB's EFI folder
      - Boot with the Installer USB
      - If you stuck in boot, reboot and in the Clover bootloader select "config_debug.cfg" -> you'll have more informations about the freeze
       
      Please open the README.rtf in my install zip for more informations about the USB Installer & Post installation!
      On Catalina the System folder is read-only, so you need to remount in rw to modify System/Library. 
      If you have a single RAM and getting panic at boot, then you need to edit the "config.plist" with these (SMBIOS->after "Version 1.0"):
      ->Edit "Frequency" and "Size" to match your RAM values
      <key>Version</key> <string>1.0</string> <key>Memory</key> <dict> <key>Channels</key> <integer>1</integer> <key>SlotCount</key> <integer>1</integer> <key>Modules</key> <array> <dict> <key>Slot</key> <integer>0</integer> <key>Size</key> <integer>8192</integer> <key>Frequency</key> <integer>2133</integer> <key>Type</key> <string>DDR4</string> </dict> </array> </dict> </dict>  
      PowerManagement  fix:
      Set HWPEnable=YES in Clover (already set), CPUFloor to "700", Frequency to "2300" and "3200"(Normal and Turbo, if you have i7-6700HQ version then it should be "2600", "3500") and "FrequencyVectors" from "0x0d000000" to "0x07000000" in "S/L/E/IOPlatformPluginFamily.kext/Contents/PlugIns/X86PlatformPlugin.kext/Contents/Resources/Mac-A5C67F76ED83108C.plist", MSR _xcpm_idle Patch to KernelToPatch in Clover (If you have High Sierra, change "MatchOS" to 10.13):

      <key>KernelToPatch</key> <array> <dict> <key>Comment</key> <string>MSR 0xE2 _xcpm_idle instant reboot(c) Pike R. Alpha</string> <key>Disabled</key> <false/> <key>Find</key> <data> ILniAAAADzA= </data> <key>MatchOS</key> <string>10.14</string> <key>Replace</key> <data> ILniAAAAkJA= </data> </dict> </array> Reboot, and it's 800MHz in idle state, same on Windows.
       

      Elan SmartTouchpad
      I only use scrolling, one-, double- & tripletap
      If you want to try other gestures go to this link for more informations, options (v4.6.5) ->  DETAILS ABOUT THE SMART TOUCHPAD DRIVER FEATURES
      Fn Brightness keys not working with this, tried several things without success. With VoodoPS2Controller it's working, but you'll have no gestures (neither scrolling).
       
       
      Before updating to a new version of Catalina please update kexts (and clover if necessary) to newer versions to avoid kernel panics.
      Generate a serial number with Clover Configurator.app (open up your config.plist with CC then -> SMBIOS -> Serial Number -> Generate New)
       
      Catalina & Windows 10 Dual-Boot:
      Dual-boot clean install (on one drive), UEFI Only:
       
       Boot into your Mac installer, Create 2 partitions in GUID table (1 for Win (I used FAT32 but I think it doesn't matter what you choose), 1 for Mac),   Install Mac, boot with your USB, mount your EFI partition (use terminal or an EFI mounter app), create an EFI folder (if there is no folder), copy the CLOVER folder I attached to the EFI folder, restart,  Boot into your Win installer, Format the partition you created for Win, install.   Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       5.  You're done! It will booting into Clover when you start the system, and you can select Win or Mac (or another OS if installed on a 3rd partition).
       
      Dual-boot with Windows installed first (on one drive), UEFI Only:
      If you already have Windows and you don't want to lose all your data there is a hope:
      I created a video from this restore method: [Hackintosh] Dual-Boot High Sierra & Windows - when Windows already installed - no data waste - UEFI
      You need bootable Mac Installer and a full system restore image (link is in my video's description).
      (You may see errors if your EFI partition is not 200 MB)
       Boot into your Windows, resize your partition or create one for Mac.  Boot into your Mac installer and in Disk Utility format the partition you created.  Restore from image: select your full system restore image.  When it's finished restoring you just need to restart, then boot to the system with your usb.  When you successfully booted to Mac desktop, mount your EFI partition (use terminal or an EFI mounter app), open EFI, you will see there is a Microsoft folder already (don't touch that!). Copy my CLOVER folder to the EFI folder then Restart.  Now, it's automatically booting into Windows. To use Clover open cmd in administrator, type:  bcdedit /set {bootmgr} path \EFI\CLOVER\CLOVERX64.efi       7.  You're done! You can select your old Windows and your new macOS!
      (Only tried with Windows 8/8.1/10. I don't know Windows 7,etc.)
       
      IF YOU GETTING ERRORS DURING MAC RESTORE:
      - Make sure you have partitions in GPT
      - Windows using 100 MB EFI and will annoy the Mac restore. Don't worry, just ignore the errors.
       
      IF YOU GETTING ERRORS DURING WINDOWS INSTALLATION (could not be formatted, etc):
      - Make sure you have GPT partitions, and GPT (UEFI) installer, also disconnect all external storage drives (except the installer USB)
       
      IF YOU USED RESTORE METHOD THEN CAN'T MOUNT YOUR EFI PARTITION (No EFI partition found):
      - It's because your EFI is not 200 MB or not an "Apple" original EFI,  but do not worry, try another EFI mounter, or mount from terminal (I used EFI mounter v3: Getting errors, but you can mount and use without problem)
      - You also could "mount" the EFI from Windows:
      1st method: open cmd in administrator mode and type:
      diskpart list vol (Now select the "System" volume,(FAT 32) For example I select 4) sel vol 4 list part (Select System type partition, for example 2) sel part 2 assign letter=b (This will "mount" your EFI partition) Open Explorer++ or TotalCommander in administrator mode to manage EFI remove letter=b (This will "unmount" your EFI) 2nd method: open cmd in administrator mode and type:
      mountvol b: /s (This will mount your EFI) Open Explorer++ or TotalCommander in administrator mode to manage EFI mountvol b: /d (This will unmount your EFI) Thanks to all OSXLatitude members for helping me out! (Jake Lo, Hervé, Bronxteck, black.dragon74)!
      Notes:
      2019.11.03: Enabled SIP caused a lots of issues so now it's disabled -> updated bootpack
      2019.11.02: Updated to 10.15.1 -> no problem when/after installing
      2019.10.09: Installed macOS Catalina 10.15 -> Updated Clover, kexts & config.plist -> no problem so far
      2019.08.18: Updated to 10.14.6 -> no problem when/after installing
      2019.06.01: Updated to 10.14.5 -> no problem when/after installing
      2019.04.25: Optimized touchpad scrolling -> updated install files
      2019.03.30: Fixed USB 3.0 ports, fixed Bluetooth crashes after sleep -> updated bootpack
      2019.03.28: Updated to 10.14.4. Unexpected crashes while updating to 10.14.4 -> fixed by updating Clover to the latest (v4910) version. Bluetooth crashes appeared -> fixed by downgraded Brcm*.kexts. Updated bootpack.
      2019.02.24: Bluetooth crashes after sleep -> fixed, updated bootpack. 
      2019.02.22: Updated to 10.14.3. Fixed HDMI Audio by installing "FakePCIID_Intel_HDMI_Audio.kext" -> fixed freezing during boot. Fixed brightness levels by installing "AppleBacklightFixup.kext". Also updated bootpack & postinstall zip down in attachments.
      2019.01.21: Removed FakeSMC.kext, SMCHelper-64.efi, replaced by VirtualSMC.kext, VirtualSMC.efi because I got random freezes when booting system (kextd stall[0], (120s): 'AppleACPICPU' -> CPU is at 100%, fans are spinning fast), also updated bootpack in the attachments "acer_aspire_v591g-55tu_clover.zip" -> Freeze continued, brought back FakeSMC, deleted VirtualSMC (caused BT crashes).
      2019.01.18: HDMI Audio is fixed, I didn't do anything HDMI Audio is not fixed, sometimes it worked but most likely not. (no idea why)
      2018.12.09: Updated to 10.14.2 -> did without any complication
      2018.11.28: Fixed combo-jack garbage sound output by installing ALCPlugFix and CodecCommander.kext
      2018.11.01: Updated to 10.14.1 -> HDMI & VGA ports are gone again. -> Fixed by "AppleIntelSKLGraphicsFramebuffer.kext" rollback from 10.14.
      2018.09.28: Updated to Mojave 10.14 -> Fixed HDMI & VGA Outputs by adding "AppleGraphicsDevicePolicy.kext" patches to config.plist, HDMI audio not working
    • By Cwtf
      I just made a clean install of High Sierra on a 1TB crucial ssd. Installed clover Clover_v2.5k_r5070 into the EFI of this ssd, but when I tried to make it my default boot drive, the clover screen wouldn't come up, and left a black screen.
      I tried using the Olarilia usb drive and clover did the same thing.  The only way I can currently boot is to use my old drive with clover v2.4k_4945 then select  my new drive from the clover menu.   
       
      Do I need to install v2.4k on my new drive or is there a way I can get v2.5k working?
       
      I have a GA-x79-ud5 motherboard, AMD  rx580 graphics card and use a Sony 4k tv as my monitor.
    • By kylon
      Cloud Clover Editor is an open source application that allows you to manage the configuration of various Hackintosh Bootloaders.

      Open Cloud Clover Editor
       
      Cloud Clover Editor Wiki
      Cloud Clover Editor Sources
       
       
      Features
      Supports Clover EFI, Ozmosis, Chameleon, OpenCore GUI and Text Editor Mode CCE Bank Mobile friendly and more...  
      Officially supported browsers
      Chrome 42+ Microsoft Edge 14+ Firefox 39+ Safari 10+ Opera 29+ Opera Mobile 12+ Chrome for Android 75+ Firefox for Android 67+  
       
      Credits
      mackie100 - took some ideas from his app Clover EFI dev team Eric Slivka - new serial number Virtual1 - new serial number cecekpawon - PHP 5.3.3 patch, , help with the ACPI Loader Mode flag and more Micky1979 - Clover flying editor  (Discontinued) crusher. - Help with the ACPI Loader Mode flag Download-Fritz - Help with the ACPI Loader Mode flag Pavo - Ozmosis fields and values stehor - Ozmosis fields and values Sherlocks - General help and support gujiangjiang - General help and support  
      Please let me know if i forgot you!
×