Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


[Solved] kernel panic after the combo update 10.7.5 when plug USB

4 posts in this topic

Recommended Posts

I install a combo update of lion 10.7.5 in my running 10.7.3

after the installation before reboot the system i ran a script from this site http://www.souldevte...n-a-hackintosh/


my machine reboot successfully but when i plug my phone using USB cable suddenly kernel panic appear .so how to solve this issue.


I need your help ,its very urgent


Please help me

Share this post

Link to post
Share on other sites

I see you read this already http://www.insanelymac.com/forum/topic/284139-kernel-panic-when-inserting-usb-flash-drive-after-1075-update/ but am not sure what part you don't understand?


Depending on what additional extensions you had to install/modify when first installing OSX, you should be able to just copy your appleHDA.kext to the desktop, re-run the combo update and don't use any silly script, and reinstall your appleHDA.kext using kext wizard or similar when your done.


or: use Pacafist which you can download for free and use it to open the combo update, it will list all the files included in the update, go to IOStorageFamily.kext and click extract, when it asks if you want to extract with admin privileges say yes and enter user name and password

Share this post

Link to post
Share on other sites

Thanks eep357(Moderator)

I figure out the solution.

i unpack the combo update of 10.7.5 using upak application and copy the IOStorageFamily.kext in to desktop and install it using Kext installer

After restarting my mac the probleam was fix. Now i can plug USB Devices.


Thanks for your support

Share this post

Link to post
Share on other sites

Hello guys, @nithin121 i had the same problem, can you give me these IOStorageFamily.kext,please?


Other question.. when it starts without USB devices,the system hangs-up (NVEnabler..probe fail). I have got Nvidia 9200 M-GS. In Lion 10.7.2-10.7.4 it works. ON Lion 10.7.5 no, are there any solutions? thanks!

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.