Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 

Waiting For Root Device, unexpected error

2 posts in this topic

Recommended Posts



I'm not a noob to Hackintosh's, but I'm confused by why this is happening. I've setup a fool proof guide on how to setup Leopard/Snow Leopard (and have success with Lion/ML, but this is unpublished for the meantime) on my VAIO (http://www.javakrypt.com/mac).


I had a failing 320GB hard drive, so I backed up what I could and tried using a Samsung 320GB drive that I used for previous backup purposes. I know this drive was working, I'd be using it for months without problems. Whenever I installed Leopard, it worked, installed Snow, I got the Waiting For Root Device error. So I decided to buy a new hard drive thinking that too was breaking. I bought a 320GB Toshiba drive, tried to use it the first day, got the same outcome. Boots with Leopard, Root Device error with Snow. I'm actually using Leopard which is on the new Toshiba 320GB drive right now to type this.


Now here's the more confusing part, following my own guide, as I have done using my other drives, I can install Snow and Leopard, and get them to boot, using a very old 80GB drive that originally came with this laptop (it's nearing 6 years old.) So I know it's not the guide, or the kext downloads on my server. If I -v I see lots of errors about not being able to allocate or load certain kexts (most to do with SMBIOSEFI, AppleIntelPIIXATA.kext etc.)


I've tried using other boot flags to no avail. But I shouldn't HAVE to use those.


Anyone have any idea why this happens?

Share this post

Link to post
Share on other sites

No body had any clue why this still happensI don't want to risk buying another drive for it to still happen.




Using arch=i386 boot flag makes it with weirdly. Never had to use it.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.