Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
others111

Acer v3-771g Mountain Lion

193 posts in this topic

Recommended Posts

I switched to Windows 8, and with it, UEFI instead of legacy BIOS. Is it possible to install on UEFI? If so, what are the tricks? I have a sneaking suspicion that it would actually work better, but that doesn't say much, since I have no reasonable idea how the EFI systems work. I'd like to keep my Windows 8, since the tiles and full-screen apps really have me addicted.

Well,

 

I switched to Windows 8 and 8.1 without UEFI...

Hmm, but why should a UniversalEFI BIOS work better with an EFI BIOS & Partition for Mavericks, as long as it is meant for Win...

My Tip would be, that you use Clover, because it does not "interfer" that much with your EFI (Well, since Chameleon couldn't even boot a EFI Recovery Partition, which is possible in Clover)

 

But I think that this guide might help: http://www.insanelymac.com/forum/topic/293574-beginners-guide-to-uefi-tripledual-boot-os-x-windows-and-linux-kali-on-an-single-true-gpt-ssd/

Share this post


Link to post
Share on other sites

Hi there,

 

I found an interesting article in this post: http://www.osxlatitude.com/tuning-performance-with-fakesmc-smbios-plist/

 

It claims that the performance of the internal CPU fan could be influenced by changing the SMC-Vervion in FakeSMC.

By default it loads version 1.30fxx which some kind of generic (even suitable for old systems).

 

My fan comes up quite fast and loud when load is on the system.

Using my SMBIOS version MBP10,1, which comes closest to my system, I changed the version of the SMC to 2.3fxx.

This is the apporpiate version corresponding to the Apple table (see PDF).

 

My fans come in slow and later. the system heats up a bit more (about 10 degrees celsius), but it is really smoother and not so loud. I personally think that the battery might last longer, when the fans do not turn at such high speeds all the time.

 

So test it, if you want:

- open the FakeSMC.kext in S/L/E,

- choose the correct version from the PDF from Apple,

- backup the kext,

- edit the Info.plist (look at JPG and Info.plist.txt, which I had to rename in order to upload it here) inside FakeSMC.kext,

- install it back with KextWizard and... voila!

 

Happy New Year :-)

FakeSMC SMC-Firmware-Updates für Intel-basierte Macs.pdf

Info.plist.txt

post-804732-0-21836100-1388523090_thumb.jpg

Share this post


Link to post
Share on other sites

the fans in my v3-771g run at medium speed always and when I run a program they go high speed and then back to medium.It`s not ok,does anyone have the same issue?

Share this post


Link to post
Share on other sites

VGA preferably

Hi,

 

tested 4 weeks ago with "standard" Intel driver (non-patched) to get dual link. Well, it functioned, but I hadn't a full-HD monitor. Installed SwitchRes for a help...

Will try with patched driver and VGA-cable on my TV (damn, where is the cable...)

 

@iClock:

No. Got this with one time after updating FakeSMC. Solved by reinstalling, repairing permissions and kernel cache and using "-f" (or UseKernelCache=No in Chameleon), allthough I did not change that before.

Right now the fans are working... (kernel[0]: AICPUPMI: CPU P-States [ 12 22 23 29 30 31 32 33 ]) using FakeSMC 6.0.1115.

 

Share this post


Link to post
Share on other sites

My laptop runs hot that is the reason why my fans are running constanty at the same speed.Average CPU temp is 64.9 Celcius using Intel Power Gadget  to monitor temperature of CPU.This app also shows me the speed of the cpu which goes from 1,2ghz to 2,5 ghz depending on the what the user does,the power used is usually 6.54 W.How can I lower my CPU Temp ?switching system definitions does not work ,currently I have MacBook Pro(9.2).

 

Here is a screen shot in order to show my cpu temp using the Intel Power Gadget app.Temp too high for just surfing the web.

 

https://www.dropbox.com/s/8pqompmlbjumsaz/Screen%20Shot%202014-02-22%20at%2013.53.06.png


After using Intel Power Gadget it seems that the cpu average speed is 1.59 ghz when actually idle,however sometimes it goes to 1.2.

Share this post


Link to post
Share on other sites

ok so I managed to get SpeedStep working using SSDT and I have [12 17 25 28 29 31] on i5-3210m Ivy Bridge.The system seems to run cooler but it is not enough the difference is just 2 degrees from what it was like when I had just 2 steps like 12 and 28.I heard that this is because of the Optimus issue and Nvidia card which is powered on but not used.Did anyone manage to turn it off?Is anyone still following this topic or is it dead?

Share this post


Link to post
Share on other sites

Hi,

 

well, using SSDT should be standard on our system... Using an patched AppleIntelCPUPowermenagement is also a good idea (although practically it is not used any longer).

Did you generate SSDT using Piker-Alphas latest script (v12.3, I think)? - You can enable XCPM of the kernel, which might help a bit.

Oh, did you patch AppleIntelGraphicsPowermanagement? - Might be a good idea, because the IGPU might work better in Powermanagement, but I think that is not mandatory.

 

 

For the Nvidia: Nonsense. I've still got it on and had never temperature issues due to it. System Temp usually is between 35-42 degrees Celsius and on max load up to 60 degrees.

The only "good" way to disable the nvidia is by deactivating it in BIOS. So I think you will need a patched version for that (if you really want it).

 

Disabling the Nvidia has two reasons:

 

1) Notebook power lasts longer, because the Nvidia FSN does not drain the battery. But this really can't be notable.

2) Well, since Optimus switching will never work, the Nvidia is just useless on MacOSX.

 

Latest thought: Which version of HWSensors/FakeSMC is installed on your system?

 

Take care... :-)

 

(Yes, I am still following this topic - as you can see)

the_temps.tiff

Share this post


Link to post
Share on other sites

WOW,you get 42 degrees and 60 on load?!how can this be possible?I don't even get these values in Windows.I patched AppleIntelCPUPowermenagement with myHACK then with [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] but they don't work.I used a script for SSDT but I don't know the name of it because my laptop is bricked after changing some bios settings and I had to send it into service to have the bios chip removed from the motherboard so that it can be rewritten,still waiting for it to be fixed.What I did was to change the primarily graphics in bios(unlocked version) so that the first to be NVIDIA but the laptop showed black screen on boot and a bios recovery using FN+esc was not possible also the laptop froze after these custom configurations ,it didn't boot just black screen.So dont disable the intel graphics cause nvidia uses it no matter what.Pressing f2 then f9(load default settings) then f10(save settings) on black screen didnt help either,worked when intel was enabled but when primarily graphics was set to pci also showed black screen but at least it did not froze and I could load default settings on bios when it was black screen and fix it.

 

So Im still amazed about your cpu temp values!i thought that nvidia was causing my temp to get so high.Never heard about xcpm, will try it.The problem is the fan which gets very loud ,average temp is 70 C when using xcode and goes up to 80+ when I am watching youtube.In windows, temps are low as 50C and 72 on load but cools down fast.I used the latest myHack to install Mavericks.

 

FakeSMC.kext is 4.2

Share this post


Link to post
Share on other sites

Oh man,

 

I think you are making may mistakes ... I thought I warned everybody in this forum about that.

 

Again (in short) & just for you:

 

For the SSDT-part:

1. extract ALL SSDTs with AIDA64 on win or MacIASL and compile them. Copy ALL in the Extra directory of chameleon (suppose you are using chameleon and not Clover) and rename them SSDT-1.aml, etc. Leave out the SSDT for the processor.

2. Go here: https://github.com/Piker-Alpha/ssdtPRGen.sh/  and download the script.

Script instructions: ssdtPRGen.sh

Usage: ./ssdtPRGen.sh [-abcdfhlmptwx]

    -acpi Processor name (example: CPU0 or C000)
    -board-id (example: Mac-F60DEB81FF30ACF6)
    -cpu type [0/1/2/3]
        0 = Sandy Bridge
        1 = Ivy Bridge
        2 = Haswell
        3 = Broadwell
    -debug output [0/1/3]
        0 = no debug injection/debug output
        1 = inject debug statements in: ssdt_pr.dsl
        2 = show debug output
        3 = both
    -frequency (maximum turbo frequency)
    -help info (this)
    -list (example: Sandy Bridge, Ivy Bridge, Haswell or Broadwell)
    -model (example: MacPro6,1)
    -processor model (example: 'E3-1285L v3')
    -tdp [11.5 - 150]
    -workarounds for Ivy Bridge [0/1/2/3]
        0 = no workarounds
        1 = inject extra (turbo) P-State at he top with maximum (turbo) frequency + 1 MHz
        2 = inject extra P-States at the bottom
        3 = both
    -xcpm mode [0/1]
        0 = XCPM mode disabled
        1 = XCPM mode enabled

 

make the script executional with chmod u+x ssdt...sh and execute. You will get SSDT-pr.aml + .dsl on desktop and will be asked, if the scipt should copy it for you. rename it to SSDT.aml and copy it to the rest in Extra. repair permission, rebuild cache.

3. DISABLE all Chameleon options like C-States, P-states, etc. Just leave "drop SSDT" on.

As long as you did that, everything so far is good.

P.S.: Piker-Alpha also maintains the AppleIntelCPUPowermanagementInfo.kext...

 

For the cracked BIOS:

I already went through all of this and made the mistakes myself.

Well, the Intel AND the nvidia share the same framebuffer (memory) during boot. the intel is always initialized FIRST for boot display. The Nvidia switches over shortly after boot. Chameleon cannot handle the switch so the best thing to get is a display on the external VGA-Port and.... you guessed it ... a blank LVDS. MacOS X initializes the LVDS first and hands it over to the intel. Thus the nvidia cannot catch the LVDS anymore and "says" Ports unavailable. The Optimus switching does not happen on MacOS X because Apple handles it through their own kernel extension and their own VBIOS.

Consequence is IT WON'T WORK. Believe me.

I had to sent my Acer to the service 10 month ago, because of that...

 

For FakeSMC:

I am using FakeSMC 6.0.1123 here. If you installed with some MyHack or the other thingy, GET A NEW VERSION. AND REMOVE THE MYHACK KERNEL EXTENSION INCLUDING NULLCPUPOWERMANAGEMENT.KEXT & EVERYTHING IN EXTRA/EXTENSIONS! (the MyHack.extension has some extensions in it's plugin directory inside the kext. You can copy things like the Voodoo*.kext from there to the normal extensions folder)

Get a new version here: http://www.hwsensors.com/

Install it and install ALL extensions with it (has to be done manually in the installer...).

 

These are the first steps... more to follow (VoodooHDA, correct Trackpad/mouse extensions, ACPIBatteryManager, etc.)

 

At last: Remember that I've got an i7 and not an i5, but I think that this does not really matter...

 

For the records: currently CPU Temp is 30 to 34 degrees celsius at 1.19 Ghz and fans are OFF (!), CPU P-States [ (12) 22 23 26 29 30 31 32 ], current system is 10.9.2

Share this post


Link to post
Share on other sites

OMG! 34 Celsius?!!!?what is your room temperature?I have never seen a laptop running so cool and I saw many and most of them run at 40 in idle ! Jessus!

Are you sure you have Acer ?:)))

Probably i7 is cooler than i5.

 

I'll try what you wrote above when I'll receive my laptop,can't wait .

 

Thank you

Share this post


Link to post
Share on other sites

My laptop was 3 weeks in service but they we`re unable to rewrite the bios and make it work again.I backed up my bios with Universal Bios Backup but even with that backup it didn`t work.Hackintoshing is pain.Does anyone know how to fix this bios issue?My laptop is bricked

Share this post


Link to post
Share on other sites

I fixed it myself using the Crisis Bios Recovery option from the Service Manual.Can not believe it...but actually one can recover bios on Acer V3-771g if it is Bricked !!!

Share this post


Link to post
Share on other sites

EDITO: He realizado algunos cambios en el mensaje. Mi cobaya (roedor) ha meado en mi portátil. Tenía intenciones de subir una versión clover preconfigurada con un tema de bootcamp, haciendo el arranque y la instalación de OS X todavía más perfecta y nativa. También iba a incluir una ROM uEFI sin el logo de Acer (reemplazado por un fondo uniforme #bfbfbf), haciendo el arranque sin esperas idéntico a un Mac real (¡A excepción del sonido!). Junto a esto, añadía también una solución para la memoria NVRAM, permitiendo el uso de iCloud e iMessages. También ".kext" para la actualización 10.9.5... Siento mucho decir esto, pero lo he perdido. El disco duro, increíblemente, también se ha visto afectado. No he podido actualizar la traducción al Inglés debido a problemas con la función copiar y pegar (no puedo pegar texto aquí).

 

-----------------------------------------------------------------------------------------------------------------

 

¡Hola! ¡Hay que actualizarse a Mavericks!


Aquí dejo un repack con todo lo necesario para actualizar a Mavericks 10.9.2 en el modelo Acer Aspire V3-771G-53234G50Maii:
MavericksV3-771G-53234G50Maii.zip 60,6Mb

Incluye:
· Ethernet, gráficos QE/CI con HDMI (Incluye AppleIntelFramebufferCapri que habilita el HDMI; sólo el vídeo funciona. Para evitar fallos visuales al usar la conexión HDMI, debes asignar >=64Mb de VRAM para la IGP mediante una imagen ROM BIOS/uEFI parcheada. NO hay sonido por HDMI. Tampoco funciona el puerto VGA. El "AAPL,ig-platform-id" está inyectado en DSDT.aml), trackpad (ALPS - VoodooPS2Controller: no funcionan los gestos multitáctiles), teclado (AppleACPIPS2Nub), batería (AppleSmartBatteryManager), USB 3.0 (GenericUSBXHCI: recomiendo eliminar AppleUSBXHCI, para evitar conflictos), y audio (AppleHDA).
· OPCIONAL: IOath3kfrmwr y IO80211Family, para Atheros ARB595. Perdón por escribir incorrectamente el modelo dentro del archivo ".zip". Creo que esta tarjeta (combo BT&WiFi) es la mejor alternativa.
· Tablas SSDT.aml (con ssdtPRGen.sh) y DSDT.aml (del mensaje del usuario Styrian con ligeras modificaciones en la sección "HDEF" y otras más como la inyección del AAPL,ig-platform-id 01660003). Ahora es innecesaria la cadena "device-properties" en chameleon (para la Intel HD4000).
· AppleIntelCPUPowerManagement parcheado con AICPMPatch.
· Carpeta "Extra" preconfigurada; versión instalador USB-DVD, y versión post-instalación. Incluye un tema muy aproximado al bootcamp/EFI de un Mac real. Adaptado a 1080p). Incluye copia de seguridad de los archivos ".kext" de nVidia y IOUSBFamily. Incluye un instalador de Chameleon 2.2 (Enoch Rev 2377).
· Perfil ColorSync en caso de tener problemas de imagen como brillo excesivo (no se refiere a la retroiluminación), y colores quemados (en algunas pantallas). No todas las pantallas 1080p son del mismo fabricante. Úsalo única y exclusivamente si se manifiestan dichos problemas.

 

P.D: No se manifiesta ningún problema de consumo excesivo de batería (no he hecho pruebas sin el dsdt.aml). Mi consumo actual creo que es bastante bajo; Safari (sin plug-ins), retroiluminación mínima, y 2 discos duros (500Gb (seagate OEM) + 500Gb (hitachi, OEM de PS3 SuperSlim CECH-400x). Para medir el consumo, he usado la aplicación "CoconutBattery": http://prntscr.com/3700h9
P.D 2: El multiplicador del CPU llega a x32 (3,20Ghz); el TurboBoost funciona correctamente. Estas son las 2 cosas que no he podido hacer funcionales: audio vía HDMI, y el lector de tarjetas.

 

 

 

*** Para TODO modelo v3-771G con uEFI 2.xx ***: ¡uEFI 2.23 con el menú "Advanced" desbloqueado!
V3-771_VAG70X64_MENUS_GENERAL.zip 1,9 Mb comprimido. Instrucciones para flasheo dentro. GRACIAS A felipejfc DEL FORO BIOS-MOD.
¿Sabíais que los 2 puertos USB de la derecha en realidad son 3.0, pero están limitados a 2.0 por retrocompatibilidad? ¡Podéis cambiarlo en el bios!
No tratéis de desactivar los gráficos integrados. No se puede. La nVidia NO tiene salidas al HDMI, LVDS, y / o VGA. El único método para dar video que la nVidia tiene, es "empujar/escribir/inyectar" vídeo en el Framebuffer de la Intel HD4000. Si la GPU Intel es desactivada, tendréis que hacer un CLEAR CMOS haciendo un pequeño cortocircuíto entre 2 puntos de estaño ocultos en la placa base bajo una de las memorias RAM para "resucitar" el portátil.




*** Para TODO modelo del V3-771G y cualquier BIOS (1.xx & 2.xx) ***

Podéis reutilizar del repack:
· El DSDT*, AppleHDA-IOAudioFamily y/o AppleIntelFramebufferCapri (¡Sólo si tu Intel HD4000 usa el AAPL,ig-platform-id 01660003/4! ¡Para que el HDMI funciona tendrás que forzar el 01660003!

*Atención: este DSDT.aml está configurado para forzar el AAPL,ig-platform-id 01660003. Si tu Intel HD4000 usa otro AAPL-ig-platform-id, debes reemplazar el número marcado en rojo de este fragmento del archivo "DSDT.aml", por el último número de vuestro AAPL,ig-platform-id. Por ejemplo, si vuestro id es 01660002, en el DSDT el número 3 que está marcado en rojo debería reemplazarse por un 2. etc...

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x0E)
{
"AAPL,ig-platform-id",
Buffer (0x04)
{
0x03, 0x00, 0x66, 0x01

},

· El AppleIntelCPUPowerManagement ya parcheado.
· El AppleSmartBatteryManager.
· El GenericUSBXHCI.kext
· El tema de bootcamp (bajo previa edición del archivo Theme.plist para alinear correctamente el tema en pantallas no 1080p).


¡Un saludo, y siento si incumplo alguna norma!
He estado buscando el post de las reglas, pero no lo he encontrado... ¡Si alguien me lo puede pasar por MP, lo agradecería!

 



Hello! You have to upgrade to Mavericks !


Here I leave a repack with everything you need to upgrade to 10.9.2 Mavericks in the model Acer Aspire V3- 771G - 53234G50Maii :
MavericksV3 - 771G - 53234G50Maii.zip 60.6 Mb

Includes:
· Ethernet, graphics QE / CI (Intel HD4000 , ID injected into DSDT.aml ) , trackpad (ALPS ) and keyboard, battery , USB 3.0 , audio ( AppleHDA - IOAudioFamily ) .
· IOath3kfrmwr and IO80211Family for Atheros ARB595 (sorry for misspelling the model within the folder . Zip .Incredible mess of numbers! ) . In my opinion the best and most economical alternative to replace the WiFi card + Bt
· SSDT.aml ( with ssdtPRGen.sh ) and Message User DSDT.aml Styrian HDEF slightly modified and injected in the AAPL , ig -platform- id 01,660,003 ( the "device -properties " is no longer required in org.chameleon . Boot.plist ) .
· To others, AppleIntelFramebufferCapri I patched using the tutorials available to enable the HDMI port ( VGA port does not work ) .
· AppleIntelCPUPowerManagement AICPMPatch patched .
· Folder " Extra" preset ( USB- Installer Version DVD Version and post- installation. As an added detail, a subject as close to bootcamp / EFI a real Mac 1080p ) . Also included in the version for the hard post-instalación/disco back extensions and IOUSBFamily nVidia ( I recommend removing AppleUSBXHCI plugin. Might cause conflicts with GenericUSBHXCI ) and Chameleon 2.2 installer ( Rev Enoch 2377 ) .
· ColorSync Profile if you have image problems as excessive brightness ( no backlight ) , and on some screens burnt colors. Apparently all 1080p panels are not manufactured by the same manufacturer.

PS: The nVidia Optimus manifests no problem battery consumption (I have not done tests without DSDT.aml ) . My current consumption I think is pretty good at idle / safari ( without plugins) with minimum brightness and 2 hard drives (App CoconutBattery ) http://prntscr.com/3700h9

PS 2 : I've also come to see the multiplier to x32 (3.20 Ghz) . The TurboBoost working properly. The only thing I could do is run the card reader , and HDMI audio . :/


And one last detail to users of any v3- 771G model with uEFI 2.xx :uEFI 2.23 with the " Advanced" menu unlocked !
V3- 771_VAG70X64_MENUS_GENERAL.zip 1.9 Mb compressed . Click for flash inside. THANKS TO THE felipejfc BIOS -MOD FORUM .
Did you know that the 2 USB ports on the right you are actually 3.0, but are limited to 2.0 backward compatibility ? Can you change it in the bios !

Do not try to disable integrated graphics . You can not . The nVidia NO has outputs to HDMI, LVDS, and / or VGA . The only method to have nVidia video that is "push / write / inject" Framebuffer video on Intel HD4000 . If the Intel GPU is disabled , you have to make a CLEAR CMOS making a small short circuit between 2 points of tin hidden under the motherboard RAM memories to " resurrect " the laptop.



*** For ANY V3-771G model and any BIOS (1.xx & 2.xx) ***

You can reuse the repack:
· The DSDT, AppleHDA-IOAudioFamily and AppleIntelFramebufferCapri whole (to enable HDMI Audio and Realtek ALC269 chipset in).


If for some reason you have a AAPL, ig-platform-id 01660003 ~ 01660004 different, only you would have to discard and replace AppleIntelFramebufferCapri the next number in red in the following fragment DSDT.aml, by the number in which AAPL this end, ig-platform-id. 01660002 If your outside, that digit in the DSDT should be replaced by 2.

Method (_DSM, 4, NotSerialized)
{
Store (Package (0x0E)
{
"AAPL,ig-platform-id",
Buffer (0x04)
{
0x03, 0x00, 0x66, 0x01

},



· The AppleIntelCPUPowerManagement already patched.
· The AppleSmartBatteryManager.
· The GenericUSBXHCI.kext
· The issue of bootcamp (on previous edition Theme.plist file to correctly align the subject on screens not 1080p).


Regards, and sorry if I break any rules!
I've been looking for the post of the rules, but I have not found ... If someone can pass me by MP, would appreciate it!

Edited by JadaOnyx

Share this post


Link to post
Share on other sites

Breaking the rules? - Aren't we doing it all the time?  :angel_not:

 

Anyway... good post. Combines the work of all of us (well, at least for his machine).

Share this post


Link to post
Share on other sites

Hi there.

 

Well, after updating to 10.9.3 I kinf of lost my Audio Output support for the headphones jack and internal microphone via AppleHDA (It never worked with VoodooHDA either).

 

Anybody out there got it working or must i boot into linux, get the codec and patch myself?

 

(Oh, I should mention: I am using Chameleon HDAEnabler, a patched DSDT and a patched AppleHDA. Audio Codec is - as ever - ALC269).

 

Can anyone help?

Share this post


Link to post
Share on other sites

Try this one from me i patched it myself, maybe it works for you too.

 

 

Have someone sucsessfuly disabled the nvidia by dsdt+ssdt to make the batterie last longer ? I would appreciate any help by deaktivating the gt650

Share this post


Link to post
Share on other sites

Thanxs.

 

Oh no, not this disabling thing again. How long dows your Battery last with the Nvidia "on"? - I tested it on my machine with a patched BIOS to fully disable the Nvidia and it gave me max. 17 Minutes more... So I left it the way it was originally.

Share this post


Link to post
Share on other sites

:D for me its not only for battery but for graphics glitches on some programms that accour when the nvidia is on.

Share this post


Link to post
Share on other sites

:D for me its not only for battery but for graphics glitches on some programms that accour when the nvidia is on.

.. when using external Monitors?

Share this post


Link to post
Share on other sites

Try this one from me i patched it myself, maybe it works for you too.

 

 

Have someone sucsessfuly disabled the nvidia by dsdt+ssdt to make the batterie last longer ? I would appreciate any help by deaktivating the gt650

Ups, almost forgot. Thank you, everything is working again. My fault, because I found my AppleHDA Backup extensions on my SSD ;-)

Hmm, I should have looked in my own folders like "Rollback". There it was.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×