Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
nekomata

HP dv6-7029wm/7010us wireless? (AR9485)

5 posts in this topic

Recommended Posts

I can't find any information on getting my laptop's internal wireless to work. It is an Atheros AR9485 (thats what Windows says) with the HW ID as: PCI\VEN_168C&DEV_0032&SUBSYS_1838103C&REV_01

Other people said to buy a new card but I can't afford a new wireless card as I spent all my money on the Mountain Lion DVD :( Any ways to get my wireless to work and I would be so happy. I couldn't have gotten a different computer because this one was a present from some friends in the US (but i dont like windows so there). thx in advance guys and please help.

 

PS also if you know how to get AMD Radeon 7640G to work.

Share this post


Link to post
Share on other sites

if u fake device id 30 instead of 32 it might work. cant guarantee anything.. look at the ar9285 fix in dsdt and modify it.

 

im pretty sure if u change the card it will deny boot with error of unsuported wireless card (whitelist) and i dont know if there is a bios mod with NO Whitelist for sp57048.exe or sp58982.exe bios

Share this post


Link to post
Share on other sites

if u fake device id 30 instead of 32 it might work. cant guarantee anything.. look at the ar9285 fix in dsdt and modify it.

 

im pretty sure if u change the card it will deny boot with error of unsuported wireless card (whitelist) and i dont know if there is a bios mod with NO Whitelist for sp57048.exe or sp58982.exe bios

 

How do I do this? I found a patch file for ar9285 fix on olarila.com how do I modify it?

 

into device name_adr 0x00 parent_adr 0x001C0001 insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
   Store (Package (0x0C)\n
    {\n
	    "AAPL,slot-name", \n
	    Buffer (0x08)\n
	    {\n
		    "AirPort"\n
	    }, \n
	    "device-id", \n
	    Unicode ("*"), \n
	    "device_type", \n
	    Buffer (0x08)\n
	    {\n
		    "AirPort"\n
	    }, \n
	    "model", \n
	    Buffer (0x34)\n
	    {\n
		    "Atheros 9285 8802.11 b/g/n Wireless Network Adapter"\n
	    }, \n
	    "subsystem-id", \n
	    Buffer (0x04)\n
	    {\n
		    0x8F, 0x00, 0x00, 0x00\n
	    }, \n
	    "subsystem-vendor-id", \n
	    Buffer (0x04)\n
	    {\n
		    0x6B, 0x10, 0x00, 0x00\n
	    }\n
    }, Local0)\n
   DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
   Return (Local0)\n
}
end

Share this post


Link to post
Share on other sites

into device name_adr 0x00 parent_adr 0x001C0001 insert
begin
Method (_DSM, 4, NotSerialized)\n
{\n
 Store (Package (0x0C)\n
		 {\n
				 "AAPL,slot-name", \n
				 Buffer (0x08)\n
				 {\n
						 "AirPort"\n
				 }, \n
				 "device-id", \n
				 Buffer (0x04)\n
				 {\n
						 0x30, 0x00, 0x00, 0x00\n
				 }, \n
				 "device_type", \n
				 Buffer (0x08)\n
				 {\n
						 "AirPort"\n
				 }, \n
				 "model", \n
				 Buffer (0x34)\n
				 {\n
						 "Atheros 9485 802.11 b/g/n Wireless Network Adapter"\n
				 }, \n
				 "subsystem-vendor-id", \n
				 Buffer (0x04)\n
				 {\n
						 0x6B, 0x10, 0x00, 0x00\n
				 }\n
		 }, Local0)\n
 DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))\n
 Return (Local0)\n
}
end

however the subsystem id of the device id 30 is not 8F

 

look in ioregistry explorer to see if the card is at 0x001C0001

Share this post


Link to post
Share on other sites

Well my computer crashed and now I can't load OSX SL on it any more for some reason, it panics on the install disc boot with ahci apple something :( do you know how to fix? I can't do IDE mode in the BIOS cause its locked.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×