Jump to content
InsanelyMac Forum
Fra_gt

[AIUTO] Installazione ML

Recommended Posts

Ciao a tutti,

 

ho un pc desktop con W7 e Mac SL 10.6.6, diviso in 3 partizioni su 2 HDD, win, mac e dati.

Volevo in questi giorni mettere W8 invece di 7, e pensavo magari di mettere ML invece di SL.

Il pc in questione è quello in firma:

 

-vga: ATI 5770

-pcu: Intel core 2 quad Q9550

-ram: 4 GB ddr2 800

-mb: Asus P5Q pro turbo

 

Volevo sapere:

 

-Installo prima mac giusto?

-I componenti sono compatibili (ci sono i kext giusti) ?

-Quale versione di ML mi consigliate?

-Ci sono accorgimenti particolari?

 

Grazie :)

Share this post


Link to post
Share on other sites
Advertisement

Grazie mille, allora ci provo e poi vi faccio sapere :)

 

FAcendo delle ricerche ho letto che non basta un dvd, giusto? :(

Share this post


Link to post
Share on other sites

Ciao,

Generalmente si crea una pendrive di installazione, la puoi fare direttamente da Snow seguendo una guida del forum, ricorda che la pendrive deve avere una dimensione di 8 giga.

Share this post


Link to post
Share on other sites

Grazie della risposta,

 

lo so anch' io del poter installare da chiavetta, ma la dovrei comprare da 8 gb, vedo se prendere un dvd dl per ora, dovrebbe funzionare lo stesso penso...

 

Piuttosto ho scaricato la retail di ML, o almeno così era scritto, ove aprendo il .dmg con 7zip mi trovo questi file:

 

----

InstallMacOSX.pkg

Resources

Distribution

[TOC].xml

----

 

 

Dove detro InstallMacOSX.pkg si trova

----

Bom

Payload

Scripts

PackageInfo

InstallESD.dmg

----

 

Mi serve sapere se devo masterizzare/mettere su chiavetta TUTTO oppure SOLO InstallESD.dmg

Share this post


Link to post
Share on other sites

Grazie per la risposta, ho visto la guida (non penso differisca Lion da ML), ma non posso eseguirla poichè SL non mi legge il masterizzatore...

 

Pensavo potessi masterizzare da windows con ultraiso (o transmac) come avevo fatto per le versioni hazard e itaskos di SL e Lion...

 

Ora,

posso masterizzare un disco (dvd o dvd dl) funzionante con windows o serve necessariamente la chiavetta da ripristinare su mac?

(massimo la compro...)

Se si serve SOLO l' InstallESD.dmg o tutto il pacchetto con i file riportati sopra, masterizzato con ultraiso o qualche altro programma?

Share this post


Link to post
Share on other sites

A questo punto ti conviene trovare la iAtkos ML DVD, è una .iso e puoi usare win7 ma devi masterizzarla su un dual layer (supera i 5 giga).

SL non ti vede il masterizzatore... immagino sia perché il masterizzatore è IDE, hai provato con dei kext adatti?

Allego jmicronATA

JMicron36xATA.kext.zip

Share this post


Link to post
Share on other sites

Grazie per le risposte,

 

A questo punto dovrei comprare la chiavetta (a minuti penso, e quelle mac le legge), quindi farei la procedura su mac e non più su windows, che mi sembra enormemente più facile.

 

I file chi vi ho mostrato sopra (che ho scaricato) io non ho ancora capito se vanno bene, se ci vogliono TUTTI o solo l' installaESD.dmg...

 

 

EDIT:

 

-ho comprato la chiavetta da 8GB

-ho cercato una guida e ho provato a inizializzare ML:

Quì l' immagine:

 

http://i50.tinypic.com/2icb8ll.jpg

 

-ho aperto il file;

-ho inizializzato la chiavetta con esteso-journaled;

-ho fatto inizializzato trascinando come sorgente l' immagine che avevo sul desktop e come destinazione la chiavetta.

Share this post


Link to post
Share on other sites

Perdonatemi il doppio post ma sono bloccato:

 

-Fatto quanto indicato sopra ho provato a bootare da chameleon che avevo già installato e che mi faceva partire windows oppure SL al boot...

-Riavvio immediato...

-Ho cercato nelle FAQ, quindi ho provato ad avviare con -v -f -s busratio=20 e cpus=1\2\4 ma niente...

-Ho provato a rifare la stessa cosa con due bootcd che avevo:

-bootcd 132

-bootcd 132 radeon

 

Ma niente, 10 righe di scritte e si riavvia subito, forse sono dei bootcd che non supportano ML oppure ho sbagliato a ripristinare la chiavetta?

Qualche dritta?

Share this post


Link to post
Share on other sites

Chameleon deve essere aggiornato, le versioni dei tempi di SL non sono compatibili con ML.

Puoi aggiornare quello preesistente, oppure installarlo sulla chiavetta, l'importante è dare le giuste impostazioni all'avvio

Share this post


Link to post
Share on other sites

Grazie per la risposta, ma non funziona, o meglio:

 

-ho trovato chameleon 2.1 aggiornato al 3/10/2012 (c' è scritto l' ultimo sul sito, penso vada bene)

-scaricato, installato il .pkg riavvio

-al boot non sembra cambiato niente però c' è scritto sopra v 2.1 e qualcosa, dovrebbe averlo installato correttamente penso (anche se in preferenze\chameleon\info c ' è sempre scritto 2,0,0 rc4)

-provo quindi a riavviare mettendo la chiavetta, la vede, provo il boot...

 

Praticamente non succede niente, ovvero quando faccio partire il boot sia con -v che senza, con busratio=20 o senza, sembra caricare per 2 secondi netti e poi (senza ne errori ne riavvio o altro) torna subito alla schermata di boot con le varie opzioni...

 

Cos' è che non va?

Share this post


Link to post
Share on other sites

@ Fra_gt

 

Ciao poco tempo fa a un mio amico ho installato ML, la configurazione e' uguale alla tua tranne la scheda video.

Ho visto che hai come scheda Ati 5770 ma e' compatibile.

Dai un occhiata alla mia guida : http://www.insanelymac.com/forum/topic/282652-guida-installare-os-x-mountain-lion-108-rtm-su-asus-p5q-deluxe/ per la preparazione della USB e guarda le impostazioni bios.

Come scheda madre non e' uguale pero' ti puoi fare un idea.

Per altro chiedi pure.

 

Fabio

Share this post


Link to post
Share on other sites

Ciao Fra_Gt, ti posso dare una mano per installare ML sulla tua scheda madre, la mia configurazione è identica alla tua trane che per la cpu, ti posso passare i kext che utilizzo per far funzionare tutto, comunque ti consiglio l'installazione da penna usb è più veloce ed è più facile modificare alcuni kext. Per prima cosa per installare ML utilizza la versione 10.8.0 e segui la guida per creare la penna usb di lion, inoltre nella cartella extra inserisci il nulpowercpumanagment, e IOACHIstoreinjector.kext, infine segui la mia guida per installare lion per quel che riguarda la configurazione del bios http://www.insanelymac.com/forum/topic/264330-guida-installare-lion-su-asus-p5q-pro-turbo/.

Ps: la guida è identica a quella che ho utilizzato per montare ML, oggi però ti passo i kext per Mountain Lion.

Share this post


Link to post
Share on other sites

Ciao fra_gt come promesso questo è il link da dove puoi scaricare i kexts per l'installazione di mountain lion, all'interno troverai anche una guida su come creare una penna usb (se hai già un sistema osx funzionante) oltre alle procedure per l'installazione di mountain lion su questa scheda madre. La guida la posterò a breve sul forum.

Ps: nella cartella extra che copierai sull'hard disk dove hai installato mountain lion, all'interno troverai anche il file DSDT.AML che è per bios versione 0602, quindi se hai un bios diverso devi eliminarlo il file dsdt.aml ed utilizzare il nullpowercpumanagment.kext oppure fai il flash del bios scaricandolo dal sito asus ed utilizzando l'utility EZ flash presente nel bios della tua scheda madre.

 

Questo è il link da cui scaricare: http://depositfiles.com/files/2gkhuwij8

Share this post


Link to post
Share on other sites

Grazie mille a tutti per le risposte!

 

Non capisco cosa sbaglio... non vuol partire al boot!

 

Allora, ho riformattato la chiavetta e ho seguito la guida di fabio per la nuova preparazione, ossia:

-aprire il basesystem.dmg

-ripristinare la chiavetta

-copiare i packages

-copiare il mach_kernel

-installato chameleon*

-installato fakesmc e riparato cache e permessi

-ho quindi settato il bios come nella guida di pianman (http://www.insanelym...-p5q-pro-turbo/)

-ho riavviato ma parte solo il chameleon di SL, e da quel chameleon si vede base system ecc. (la chiavetta) ma non parte (ne dal chameleon sul disco di SL ne da sola disattivando tutte le periferiche bootaili)

 

 

 

 

* -installare il chameleon (forse ho sbagliato qui?! ho scaricato chameleon 2.1 latest version (invece del wizard, questo era più aggiornato sembrava) del sito "chameleon.osx86.hu", ho aperto l' iso, sono andato nel package dell' installer e l' ho aperto, ho fatto installa e ho selezionato la usb, ma ora ho provato a disattivare da bios tutti i boot possibili tranne le removible dev. e mi dice "Reboo and select proper boot device ecc. ecc.", quindi sembra non sia bootable!)

 

 

Devo cambiare chameleon sulla chiavetta?

Share this post


Link to post
Share on other sites

Grazie mille a tutti per le risposte!

 

Non capisco cosa sbaglio... non vuol partire al boot!

 

Allora, ho riformattato la chiavetta e ho seguito la guida di fabio per la nuova preparazione, ossia:

-aprire il basesystem.dmg

-ripristinare la chiavetta

-copiare i packages

-copiare il mach_kernel

-installato chameleon*

-installato fakesmc e riparato cache e permessi

-ho quindi settato il bios come nella guida di pianman (http://www.insanelym...-p5q-pro-turbo/)

-ho riavviato ma parte solo il chameleon di SL, e da quel chameleon si vede base system ecc. (la chiavetta) ma non parte (ne dal chameleon sul disco di SL ne da sola disattivando tutte le periferiche bootaili)

 

 

 

 

* -installare il chameleon (forse ho sbagliato qui?! ho scaricato chameleon 2.1 latest version (invece del wizard, questo era più aggiornato sembrava) del sito "chameleon.osx86.hu", ho aperto l' iso, sono andato nel package dell' installer e l' ho aperto, ho fatto installa e ho selezionato la usb, ma ora ho provato a disattivare da bios tutti i boot possibili tranne le removible dev. e mi dice "Reboo and select proper boot device ecc. ecc.", quindi sembra non sia bootable!)

 

 

Devo cambiare chameleon sulla chiavetta?

 

Lo chameleon di snow leopard non è compatibile con mountain lion per questo non parte, devi utilizzare quello presente nei miei file che ti ho postato che anche quello presente qui sul forum internazionale. Per la chiavetta il procedimento è lo stesso che si utilizza per lion quindi hai fatto bene la procedura, io ti consiglio una volta preparata la chiavetta installa lo chamaleon che ti ho dato sulla usb, copia la cartella extra che trovi nella cartella extra usb e sostituisci smbios.plist che ci trovi con quello che utilizzi per snow leopard (attenzione che l'smbios.plist deve essere di un imac superiore o ugale ad un imac 10.1 poiche mountain lion altrimenti non si installa su pc più vecchi) poi con kext wizard ripari i permessi e ricostruisci la cache, mi raccomando a selezionare la penna usb, ed infine riavvii da usb al prompt avvia con -v ce così se ci sono errori possiamo vedere da cosa sono causati.

Segui la guida che ti ho postato io con la mia configurazione ci ho impiegato circa 20 minuti per l'installazione.

PS: Mi raccomando non eseguire guide che prevedono la creazione automatica della penna (es: Lionize per mountain lion) poichè le ho provate e si bloccava l'installazione.

Share this post


Link to post
Share on other sites

Grazie per la risposta, allora:

-ho scaricato i tuoi file;

-ho installato il chameleon (senza cambiare nessuna impostazione) sulla chiavetta (ho notato che durante il processo l' icona della chiavetta è diventata quella di un HDD e poi è tornata normale)

-ho copiato la extra (in extra usb) nella root principale della chiavetta

-sono andato nella root principale di SL, in extra e ho sostituito il smbios.plist sulla chiavetta con una copia di quelle su SL (mac pro 3.1)

-ho riparato permessi e cache con kext wizard

 

***

AGGIORNO

***

 

Aggiornamento:

 

Dopo il riavvio ho notato che:

 

-se disattivo tutti i device di boot tranne i removible dev mi dece sempre "reboot or choose proper ecc. ecc."

-se avvio normalmente parte il chameleon che avevo installato sul disco di SL (2.1 r2069), il quale vede la chiavetta, fa il boot ma si pianta quì:

 

http://i45.tinypic.com/2w6wbrm.jpg

 

ossia, arrivato lì la chiavetta lampeggia ancora per un po' dopo si ferma

 

Cosa devo cambiare?

Share this post


Link to post
Share on other sites

DSMOS has arrived e poi si ferma lì: il problema potrebbe essere dovuto al FakeSMC.kext (provane un altro) oppure all' SMbios, ma se è Mac Pro 3.1 direi che va bene.

Se non risolvi con FakeSMC tenta l'avvio con -f o GraphicsEnabler=No

Share this post


Link to post
Share on other sites

Grazie per la risposta

 

il fakesmc l' avevo installato sulla chiavetta con kext wizard dalla guida di fabio, per quando riguarda l' smbios aprendolo c' è scritto mac pro 3.1...

 

I fakesmc non sono uguali? Quale potrei installare (se lo installo quello "vecchio" lo elimina da solo?) ?

 

Devo anche dire anche che ho provato a lasciarlo andare per 1 ora e un quarto (magari doveva caricare qualcosa boh...) quindi ho schiacciato le 4 frecce direzionali, enter e poi esc tanto per provare qualcosa, non so se è normale ma mi sono uscite un paginata di scritte veloci (illeggibili) e si è riavviato da solo...

 

Forse ho sbagliato a copiare la cartella, ho copiato la cartella "extra" presa dai file di pianman nelle root principale della chiavetta, è corretto o va in qualche sottocartella?

 

***

AGGIORNAMENTO

***

 

Dato che ancora non so quali kext cambiare (e se cambiarli) nella usb, ho provato come mi ha detto carbo, ossia con -f e graphicsenabler=no.

Così è partita l' installazione, ma mi dice impossibile installare su questo computer, è il smbios vero?

 

Devo cambiare qualche kext?

Devo modificare il smbios?

 

Questo è il mio:

 

http://i48.tinypic.com/1ysmz7.jpg

Share this post


Link to post
Share on other sites

Nessuno?

 

Ho provato a informarmi sul smbios.plist dato che penso ora sia quello che blocca (chiedo conferma).

 

Ho letto questa "guida":

 

http://notes.quaestor.us/smbios-plist-values/

 

E ho preso i valori del mio processore:

 

http://ark.intel.com/products/33924/Intel-Core2-Quad-Processor-Q9550-12M-Cache-2_83-GHz-1333-MHz-FSB#infosectionmemoryspecifications

 

Ho provato a modificare da me il smbios nei fila di pianman:

 

Da: http://i49.tinypic.com/dqi4xc.jpg

 

A: http://i47.tinypic.com/29xykhl.jpg

 

Quindi chiedo:

 

-E' corretto?

-Posso cambiarlo nella chiavetta?

-Non devo cambiare nessun kext?

-E' giusta la posizione della cartella extra che ho copiato nella root PRINCIPALE della chiavetta?

Share this post


Link to post
Share on other sites

Nessuno?

 

Ho provato a informarmi sul smbios.plist dato che penso ora sia quello che blocca (chiedo conferma).

 

Ho letto questa "guida":

 

http://notes.quaesto...s-plist-values/

 

E ho preso i valori del mio processore:

 

http://ark.intel.com...yspecifications

 

Ho provato a modificare da me il smbios nei fila di pianman:

 

Da: http://i49.tinypic.com/dqi4xc.jpg

 

A: http://i47.tinypic.com/29xykhl.jpg

 

Quindi chiedo:

 

-E' corretto?

-Posso cambiarlo nella chiavetta?

-Non devo cambiare nessun kext?

-E' giusta la posizione della cartella extra che ho copiato nella root PRINCIPALE della chiavetta?

 

Guarda è capitato anche a che dice impossibile installare su questo computer, ed ho scoperto che era l'immagine di mountain lion che non era buona, infatti era una versione rilasciata per essere installata solo un macbook, quindi ho trovato un'altra dgm e tutto è andato a buon fine. Il tuo smbios lo puoi editare anche con chamaleon wizard sotto SL, ci sono già degli smbios con i seriali funzionanti, quindi ti conviene editarlo con chamaleon wizard. Il fakesmc che trovi in extra usb è perfettamente funzionante, è quello con cui ho installato ML su questa scheda madre, fallo partire solo con graphicsenabler=no e facci sapere.

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.

×