Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Ashikaa

[HELP] Sound works but headphone jack does not

14 posts in this topic

Recommended Posts

Hi,

 

I managed to installed 10.8.2 on my laptop ASUS K42JA. The sound is working but the headphone jack does not. In System / Sound / Output it always shows up Internal Speakers whenever I plug in headphone.

 

Is there any way to fix this problem?

 

The following is the screenshot about sound driver in Window

95ebc7fc5cdd77cbb488667800869cab_50757888.untitled.png

Thanks

Share this post


Link to post
Share on other sites

Cleaned up the DSDT you had and added you GPU into it and HDMI audio. You should no longer need GraphicsEnabler=Yes with this DSDT.

 

As for onboard audio there is a pin layout issue with the kext. Attached is another AppleHDA for ALC269 of which you have so try the new kext.

Files.zip

Share this post


Link to post
Share on other sites

Cleaned up the DSDT you had and added you GPU into it and HDMI audio. You should no longer need GraphicsEnabler=Yes with this DSDT.

 

As for onboard audio there is a pin layout issue with the kext. Attached is another AppleHDA for ALC269 of which you have so try the new kext.

 

I am kind of confusing. What you mean is just replacing my current DSDT and AppleHDA by your attached files?

Share this post


Link to post
Share on other sites

I am kind of confusing. What you mean is just replacing my current DSDT and AppleHDA by your attached files?

 

Place the DSDT i posted in your Extra folder. Then install the AppleHDA I posted using a app of your choice.

Share this post


Link to post
Share on other sites

Place the DSDT i posted in your Extra folder. Then install the AppleHDA I posted using a app of your choice.

 

Do I need to edit anything your DSDT ?

Thanks

Share this post


Link to post
Share on other sites

No I already did.

 

I delete DSDT file in Extra folder and place yours in. I also install AppleHDA by using Kext Wizard. But after I restart it the sound doesn't work anymore.

Share this post


Link to post
Share on other sites

Looking at the IOregs my DSDT is not installed...

 

There are some IOregs files.

 

your DSDT & HDA.zip : your 2 files

your DSDT & my HDA.zip : your DSDT with my old AppleHDA

 

Please let me know if they are wrong.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×