Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
lithiumion

VAIO PCG-11211L Black Screen (Geforce 310m) ML 10.8.2

5 posts in this topic

Recommended Posts

Hello,

 

I got this nice machine from a friend. After trying to install ML on it for a whole day with no success I decided to clone my already working 10.8.2 installation running on a GA-Z77X-UD5H onto a disk and plug it into the Vaio.

 

It boots without a kernel panic but to a black screen. If I boot verbose I can see the text freeze after the [PCI configuration begin]

 

I know the machine is up and running cause there is disk activity and it responds to keyboard strokes. I booted it into SUM and although the text was frozen on the screen it rebooted when I typed "reboot" and hit Enter.

 

So, I'm pretty sure this is a GPU detection issue.

 

It has an i5 CPU, Geforce 310m (ID=0x10DE0A75), Atheros Wifi, Realtek Audio, and a touch screen.

 

So far I have tried multiple boot variables such as PCIRootUID=0/1, npci=0x2000/3000, GraphicsEnabler=Yes/No, UseKernelCache=Yes/No both with and without -v/-f/-x/-r . But the result is always a black screen right after the [PCI configuration begin]

 

I have tried one NVEnabler.kext and it gives me some scrambling colours on the screen. This is the only way I'm able to see anything on that machine's screen.

 

I have also tried adding the device ID "0x0A7510de&0xffe0ffff" to both NVDAGF100Hal.kext and NVDANV50Hal.kext to no avail.

 

Any ideas?

 

Help is really appreciated.

 

Thanks

Share this post


Link to post
Share on other sites

I`ve the same problem in my Samsung R480 with 310m and for my works, write in chimera BootLoader PCIRootUID=0, after you boot go to /Extra folder and open the file org.chameleon.Boot.plist and put:

 

<key>PCIRootUID</key>

<string>0</string>

This its for every time you boot don`t have to write again PCIRootUID=0.

I hope this works for you, sorry for my english lol.

Share this post


Link to post
Share on other sites

So couple of days ago I gave it another shot with a 10.9 myHack USB stick and it worked!

 

All I had to do is to boot with PCIRootUID=1. Same flag was useless with 10.6, 10.7, and 10.8 installations. 

 

The machine booted and OS X installed just fine. Except for CI/QE which don't work still. No graphic acceleration.

 

The GPU is nVidia GeForce 310m with 512MB of VRAM

 

Any clues on how to get CI/QE work ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×