Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Znaxcy

Video editing: MacBook Pro or Hackintosh?

2 posts in this topic

Recommended Posts

I am a filmmaker and recording artist. I use most professional video and audio editing software.

Here's the deal:

I will be using the Nikon D600 to stream uncompressed 1080p video to SSD via a Blackmagic Hyperdeck Shuttle. I will then need to plug these SSDs into my machine and back them up. I want to be able to then edit, render and compress the video. I want to be able to process the video with as little as quality loss as possible, so everything needs to run smoothly. No jerry rigging connections.

I've read that the Nikon D600 and D800 stream uncompressed to SSD at up to 12GB per minute, so this is gonna be a pretty heavy workload.

I currently have a 15in MacBook pro from early 2011 with a 2.2 GHz Intel i7 quad-core processor. I have 16GB of RAM.

If I were to get a Promise Pegasus R4 (or something else: I'm open to suggestions) and load it up with SSDs, do you think I'd be able to handle what I'm planning on doing with just the laptop and an external monitor?

OR should I build a hackintosh that can adequately do ALL of this? If so, what build should I go with?

OR should I build a hackintosh for support via render-farm, allowing me to build a barebones hackintosh and spend the big bucks on extra SSDs.

Thank you for taking the time to answer.

Oh, and I'm not incredibly rich, so if you do think a hackintosh is a better idea, it's gonna need to not be more than $2500. (If that's possible. If not, still post what you can come up with.)

Share this post


Link to post
Share on other sites

Go to the wiki to see a list of compatible components, pick what you want and build it.

 

If you want VFM build a hackintosh, if you want it to look pretty / professional buy a mac.

 

Your laptop should be capable of the task but probably a bit slow due to the mobile processor. Personally I'd build a xeon-based hackintosh and you'll never have to worry about power...

 

12GB/min is about 200MB/second (or 1.6Gbit) so make sure if you use an external enclosure its thunderbolt and the only way you'll hit those speeds is with high-end ssd's or raid hdds.

Actually surely a raid array is a better idea than SSDs? Or your gonna be spending more on the ssd's than the rest of your rig...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • What did you add exactly, i did inject the unsupported 100 series kext and did see my macOS partition. I couldn't boot at all. I still get an error from VoodooPS2Mouse i think here is an image: https://drive.google.com/open?id=1dkcoWh2ZXj56ketONkrV8x9TNOVJdXkf
    • @Slice what's te correct russian translation for "copy to clip board"?   .. I need also a translation for "log copied to clip board!"
    • Hello MaLd0n,   Could you please make DSDT edits for my new Skylake desktop Lenovo M910t    RunMe files: https://www96.zippyshare.com/v/5bgqAiga/file.html
        Thank you very much in advance!
    • Have you tried adjusting the Khz in midi pref pane or editing the info plist to suit your needs. that sometimes corrects weird noise behavior.
    • Hello Mald0n:

      Nice to meet you, I have created a post about my problem on High Sierra before and I was redirected to this guide by Allan.

      As mentioned in the post, I was not able to get pass the login screen at initial boot and the system could not shutdown occasionally.

      However I solve the high temperature problem when I replace the clover folder you provide on first post, currently the cpu temperature is around 5x-6x'c after 10 mins up time.

      Attached is the clover folder, ioreg as well as the send me app, thanks for your help!

      p.s. I notice that your clover boot efi is a old traditional grey apple boot logo, Is there a version of modern dark and white logo one that I could replace with? Thank you!

      https://www.insanelymac.com/forum/topic/333867-cant-get-pass-2nd-stage-boot-logo-on-initial-boot-and-high-temperature/   My system:
      Gigabyte GA-X48-DQ6
      Core 2 Extreme QX9650 C0
      4 x Kingston DDR2 800ghz Ram
      Galaxy GTX460 1GB
      120GB SSD Leven JS500120C, high Sierra installed
      250GB seagate ST3250310AS
      250GB WDC WD2500JS-08NCB1
      File: https://drive.google.com/file/d/1_k3_jxvzGaLfDzin0zSAUT5ml16Hq15c/view?usp=sharing      


×