Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Some issues with 10.6.8 and ThinkPad T60

6 posts in this topic

Recommended Posts


There's no general lag now and the wifi works again :)

But i have some other issues like flash video lagging (videos from disk play smooth) and sleep not working properly, the computer goes to and back from sleep only the LCD backlight doesn't turn on after sleep so i get a black screen (though it is turned on and showing barely visible graphics).


I've done some lurking and found that if your GPU works OOB or you have a kext for it then you should settle for one method. Either GraphicsEnabler, or EFI string or Kext but not all of them, so i've disabled GraphicsEnabler. But the flash lag persists..





- - - (the stuff below this text is now solved thanks to fantomas1) - - -

Just recently i changed the internal wifi on my T60 thinkpad to a broadcom bcm94311mcg which worked oob. Then, yesterday i updated to 10.6.8 and it broke the wifi (shown as turned off in settings) and every app including the os itself lags when ever i open a new finder window, a menu, or an app.

Do you guys know what is causing this?

Share this post

Link to post
Share on other sites



at first :


Please remember that you are in a public forum, a bit of courtesy is always welcome. It's always nice to start by saying "Hi" or "Hello" before asking a question or seeking help.


and then:


If you have a question please do your best to use the search feature and search the forum before creating a new topic.


see here:





Good luck




Share this post

Link to post
Share on other sites

According to Himlaklar in this thread turning off hardware acceleration in the settings of flash player should fix the lag. So far it seems like it's working. I'll report after more comprehensive testing.


It turns out it didn't work. Still got lag with all flash videos..

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By jojo2203
      habe versucht nach der Anleitung von http://x220.mcdonnelltech.com/  auf einen X220 i7 zu installieren, bisher leider erfolglos. kann mir jemand die angehangenen Log Meldungen interpretieren und einen Tip geben an welcher Stelle ich weiter probieren muss. Habe es schon mit den folgenden Bootparametern probiert
      -v -x -s -f cpus=1 maxmem=4096 GraphicsEnabler=No -no-zp
      Es war ein 8 GB Speicherriegel gesteckt und die "neue" WLAN Karte, außerdem ist zusätzlich zur MSATA eine weitere HDD installiert.

    • By bepferr
      Ciao a tutti! Ho un Lenovo y50-70 con schermo UHD e Intel hd4600.. vorrei installare High Sierra, ho letto che questo laptop è una delle configurazioni più compatibili in assoluto.. Solo che non ne ho le capacità Qualcuno sarebbe in grado di darmi una mano?
      grazie mille!
    • By bepferr
      Hello everyone! I installed OS Sierra 10.12.6  on a Lenovo y50-70 with 4k monitor following the tonymacx86 guide (this: https://www.tonymacx86.com/threads/guide-lenovo-y50-uhd-or-1080p-using-clover-uefi.232960/ ). All is OK (except the bluetooth but I consider that a secondary problem) except that I can not absolutely activate the monitor! For example, I can connect an external monitor via HDMI and so doing everything OK. I would like to understand how to do it, does anyone have any idea? I have already set up the DVMT prealloc to 128mb with modified bios and installed coredisplayfixup in L / E but nothing. If I boot up setting clover id-ig 0x12345678 the monitor works but the graphics card is recognized only as 31mb and everything is slow, the web pages for example are unusable. I have an integrated intel hd4600 card. I hope you can help me, thank you so much in advance!
    • By tluck
      Lenovo T460 macOS with Clover Guide
      Release v2018.01.28 on GitHub Updated to Clover r4394 Updated apfs.efi to patched 10.13.3 version Updated Lilu and AppleALC kexts to v1.2.3 (supports both Sierra and High Sierra) Revised misc kexts (FakeSMC)  ​Various Tweaks over Last months
      The zip file is a complete Clover ESP (/EFI) bundle and kext pack for the Lenovo T460. The current file bundle is tested on Sierra. 
      Note: I never got the GFX fully working on El Capitan. 
      Full Clover file set - config.plist etc. Includes all custom kexts Includes custom DSDT/SSDT scripts and patches Utility scripts The zip bundles are posted to GitHub: https://github.com/tluck/Lenovo-T460-Clover/releases
      Caveat: My system is a T460 with i5-6300U, Intel HD Graphics 520, 1920x1080 touch screen. If you have a different system model, then extract the ACPI files and use the included scripts to create a set of files consistent with your system type and BIOS version. See below for details.
      Credits: RehabMan, Shmilee, vusun123, TimeWalker, Mieze from which, much of their work and help is/was was used to get the T460 to this point.
      Devices and aspects working:
      Ethernet -  Intel I219LM is enabled via IntelMausiEthernext.kext WiFi/BT - substitute the Intel WiFi/BT with a compatible Broadcom or Atheros chip Audio - ALC293 codec implemented via AppleALC.kext (old AppleHDA_ALC293 and CodecCommander kexts are not needed) PS2 - ClickPad + TrackPoint + all 3 buttons - using a modified VoodooPS2Controller to support new layouts - and added some custom Fn key maps based on 440/450 dsdt USB - implemented via custom SSDT + USBInjectAll kext. All USB3/USB2 ports are intel-based and work -  3 external USB and internal Camera, BT, etc  Sleep/Wake - the sleepwatcher package and custom sleep/wake scripts are used to help with sleep/wake for BT and PS2 devices. Note: have not tried to implement the SD card reader - no driver found.
      ACPI Files

      New Installation - Steps and Details
      Part 1 - OS Installation
      Part 2- Post OS Installation and Setup

      Notes on Custom Kexts
    • By ALManimation
      Fala Pessoal!
      Comprei um notebook Lenovo Legion Y720, anteriormente usava um Dell L502X que se deu muito bem com o Mac OS, mas esse Y720 não achei ninguém que tenha conseguido fazer ele ao menos bootar...
      Procurei vários tópicos de modelos parecidos e juntando todas as informações consegui instalar o Mac OS High Sierra nele (créditos ao rehabman pelo config da intel 630 e a toda a comunidade, só testei vários kexts e configurações, não criei nada), incrivelmente ele está bem estável, só que precisa otimizações e eu sinceramente não sei se sou capaz de realizar todas elas.
      Então estou postando a minha pasta EFI que uso pra botar nele afim de que mais pessoas possam usar o Mac OS no Legion e podermos otimizar ele o máximo possível.
      Metodo de instalação utilizado:
      1 - Baixar o instalador oficial pela própria Mac App Store (ou algum método alternativo)
      2 - Criar um pendrive de instalação com a linha de comando no terminal:
      sudo /Applications/Install\ macOS\ High\ Sierra.app/Contents/Resources/createinstallmedia --volume /Volumes/NomeDoPenDrive --applicationpath /Applications/Install\ macOS\ High\ Sierra.app --nointeraction 3 - Montar a partição EFI e copiar a pasta efi desse post dentro dela.
      (Usei o clover configurator pra montar a partição efi)
      4 - Pressionar F12 na inicialização do Notebook pra escolher o pendrive como disco de boot
      5 - Bootar o instalador e instalar normalmente, não precisa de mais nada! (pode ser que a instalação demore horas, parece que é um problema do USB3.0, aguarde com paciência)
      O que funciona?
      Portas USB 3.0
      Audio (voodoo)
      Intel HD Graphics 630
      O que não funciona?
      thunderbolt (ainda não testei mas nem reconhece)
      Mini display port 
      Nvidia gtx 1060
      Controle de brilho
      Provável que a gtx 1060 não será reconhecida, tenho esperança de que seja pelo menos em uma HDMI e que possa usar os CUDA cores dela, mas é sonho, já reconheço!
      Toda a ajuda é muito bem vinda,agradeço desde já a todos que puderem ajudar, grande abraço a todos!
      Pasta EFI do Legion Y720
      Legion Y720 ACPI Clover Dump.zip
      DSDT nativo extraído pelo clover

      Screenshot de tudo que é reconhecido no DPCIManager 
  • Recent Status Updates

    • Bios-PC  »  MaLd0n

      Hi MaLd0n
      you helped me with dsdt and everything working fine .
      I fix the audio issue.
      I need to add wifi bcm4360 original apple to dsdt to be  en0 all the time 
      also to add it to pci list.
      and I change from gtx970 to AMD radeon pro rx580 and I have issue with vtencoderxpcservice that make my cpu 300% and high temperature . with Nvidia it doesn't happen.
      I search the internet days and night and try to fix this issue no luck.
      best regards
      · 0 replies
    • DynaFEX  »  MaLd0n

      Hi MaLd0n!!
      I just don't know what the hell to do with this issue and I was wondering if you might please have any ideas??
      Sorry to bother you and thanks for all your help!
      · 0 replies
    • mrjayviper  »  e97

      hello. Can you please share instructions and files to get OSX working on a dual 2011 setup? you included a link to sixflow but it's not loading anymore. Thanks
      · 0 replies
    • adamfox

      I added a video to a @YouTube playlist https://t.co/EXJucl9T8B Go the distance sung by Adam Fox karaoke cover Disney Hurculese
      · 0 replies
    • Mr. Xtreme

      Hey, I'm not dead, I've moved over to using the nickname "Mr. Xtreme", and mostly use Linux distros/Windows 10, though it seems I'm gonna have to hackintosh again, so, hey everyone who remembers me! :wave:
      · 0 replies