Jump to content

ML on my DV6661 laptop - Migration Problem

dimitris d

3 posts in this topic

Recommended Posts

I have the HP DV6661 laptop (core2 duo T7250, NV 8400M GS). Since now I had the Snow Leopard IATKOS updated succesfully up to 10.6.8 with minor problems (intel 3945 wifi doesnt work - probably will never do, firewire RICOH OHCI worked in 10.6.5 didnt work in 10.6.7, worked again in 10.6.8 - weird!!).


I purchased ML, made a bootable clone of my SL partition with SuperDuper!, and tried installing (clean install - ######+###### method) ML first in an external HD and after success in my specific internal HD partition. In the proccess I found out what kexts I need, what boot flags to use etc.


( EvoReboot, FakeSMC, NullCPUPowerManagement, ElliotForceLegacyRTC, AppleRTC patched, org.chameleon.boot.plist with EthernetBuiltin=Yes, GraphicsEnabler=Yes, smbios.plist and chimera bootloader, + Voodoo 0.2.1 (stable) + Ethernet Gigabit +PS2 keyboard/mouse)


Since I have a lot of work/accounts/keychains/developer stuff in my SL installation, the 1st time I boot into ML I tried to migrate from my external HDD copy of SL. The procedure ended with KP, and as I discovered the old (SL) kexts were copied also. Deleted them, repaired permissions but ended up stuck at [pci configuration begin]. If I boot with npci=xXXXX I get stuck a bit later. PCIRootUID=x, -x, -f, changhes nothing


Made a copy of the copy of SL where I removed all the kexts in S/L/E , all the contents of Extra, all the caches in Library and System/Library as well as the old com.apple.boot.plist. Reinstalled (same method) ML and tried to migrate from the new copy but had the same problem.


Tried to install ML over the previously mentioned copy of SL with the same results.


I would be gratefull for any ideas.


What else could I remove from the SL IATKOS installation so that migration or update works well?

Is there another way (manual or sth else) to get all my data, apps, prefs, keychains, accounts from the SL to ML without messing up the system?


Many thanks in advance for any thoughts.

Link to comment
Share on other sites

Migration is basically broken, it's not a hackintosh problem. It copies malformed preference files, obsolete kexts, and completely screws up file permissions on your user folder. I would only migrate your user folder and leave the other options unchecked. Before doing that, make note of the proper file permissions for your user library or read on for better solution. After migrating, you can boot back into the ML installer, open terminal and type resetpassword which will launch the password reset utility, you can use this to clear acl's on your home folder and get half the work done. There will still be a few stragglers though. I recommend getting the "fish" terminal shell, when you use it and list a folder's content's and permissions, i.e.:

ls -l ~/Library/Preferences

it will color code the list showing files with incorrect permission is red text, files with correct permissions will be in green text, or blue for folders, makes it fairly easy to spot the ones you need to chmod manually.

Link to comment
Share on other sites


  • Create New...