Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
artur_pt

"boot0: error" em HDs com setores de 4 K

7 posts in this topic

Recommended Posts

Se o seu HD tem setores de 4 K você poderá ter este erro ao instalar o Chameleon e fazer boot pelo HD

boot0: test
boot0: test
boot0: test
boot0: error

http://forge.voodooprojects.org/p/chameleon/issues/129/

 

A solução é gravar o boot1h (obtido nos binários do Chameleon) com a partição desmontada. Para tanto você precisa rodar o comando a partir de outra partição, seja com Mac OS, Windows ou Linux. No caso do Windows você precisa instalar o comando dd que não faz parte do sistema

http://www.chrysocome.net/dd

 

Os comandos devem ser executados como root (no Windows execute o prompt de comando como administrador)

sudo -s

 

Navegue para a pasta onde se encontra o boot1h, por exemplo

cd ~/Downloads/i386

 

Mac OS

dd if=boot1h of=/dev/diskXsY bs=4096

 

Linux

dd if=boot1h of=/dev/sdXY bs=4096

 

Windows

dd.exe bs=4k if=boot1h of=\\.\X:

 

Se você particionou o HD em GUID, pode instalar na partição "EFI" (disk0s1)

 

Para ter a partição EFI sempre montada

diskutil eraseVolume "HFS+" "EFI" /dev/disk0s1

 

Para montar a partição manualmente quando necessário

mkdir /Volumes/EFI
newfs_hfs -v EFI /dev/disk0s1
mount_hfs /dev/disk0s1 /Volumes/EFI

 

Antes de rodar o comando dd, desmonte a partição

diskutil unmount disk0s1

ou

umount /Volumes/EFI

 

Os demais comandos são os mesmos deste tópico (instalação manual) http://olarila.com/forum/viewtopic.php?f=3&t=23

 

Dicas de utilização do Terminal http://olarila.com/forum/viewtopic.php?f=3&t=24

 

Outro método para quem instala por USB http://olarila.com/forum/viewtopic.php?f=8&t=1198

Share this post


Link to post
Share on other sites




  

Verificando, aguarde...

Olá!

Instalei o Snow Leopard Retail (Pelo DVD) no PC de um amigo meu com configuração: Processador Intel Celeron Dual Core, 4GB Memória, Mobo PCWare e HD de 500GB. Depois de todos os procedimentos de configuração e tudo mais, logo depois de instalado as outras kexts necessárias para o sistema subir, depois de reiniciar o PC, ocorreu o erro: "boot0: error"; reiniciei novamente o PC com o cd de Boot , e o sistema funcionou normal. Qual seria a explicação? Sendo que sem o cd de Boot, continua dando o erro de boot:0...

  
Verificando, aguarde...

Share this post


Link to post
Share on other sites

Olá

 

Ou deve estar com problema de falta de bootloader...

 

Já instalou o Chameleon? Pois esse erro também é comum quando não se tem bootloader instalado no HD, um hack não é só feito de kext.

 

Faz aqui o donwload: http://www.insanelymac.com/forum/files/download/59-chameleon-22-svn/

pkg ou binários, eu prefiro pkg.

Share this post


Link to post
Share on other sites
  
Verificando, aguarde...

Sim, o controlador é SATA, tem AHCI e inclusive UEFI também. Usei o Bootloader Chimera e instalei as outras kexts necessárias tbm... por isso não entendi porque o sistema não subiu sem o cd de Boot...

Share this post


Link to post
Share on other sites

Olá

Para UEFI não se costuma usar Chameleon, mas se usa Clover.

Leia sobre ele aqui: http://www.insanelymac.com/forum/topic/282787-clover-v2-instructions/

Ainda não usei, mas não é tão difícil assim de usa-lo e quase igual Chameleon, mas tem alguns procedimentos extras, leia bastante na área para boot em UEFI.

 

Esqueça Chimera(é uma imitação barata do Chameleon).

Share this post


Link to post
Share on other sites

 

  
Verificando, aguarde...

Sim, o controlador é SATA, tem AHCI e inclusive UEFI também. Usei o Bootloader Chimera e instalei as outras kexts necessárias tbm... por isso não entendi porque o sistema não subiu sem o cd de Boot...

 

Tem AHCI mas esta em AHCI? Olhe bem para as configurações da Bios, conferi se esta tudo certo.

Segue o procedimento postado pelo artur-pt.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×