Jump to content
23 posts in this topic

Recommended Posts

Hi all,

yesterday i bought an HP 2510P:


12" 1280x800

Core2Duo U7600 1.2ghz

Intel X3100


DVD-R combo drive

60gb 1.8" harddrive


I installed successfully Mac Os X Lion 10.7.

Here some information:

Created a USB Disk with MyHack with my own Extra folder (you'll find at the and of post)

Everything is working really well, except for WiFi Intel that does not work. I'm thinking to buy a BCM4321MCP2 that seems to be the only compatible with this notebook (i already have a BCM4322, Dell 1530 and two mini-pci-e Atheros and Broadcom got from MacBookPro, but anything seems to be accepted by this hardware... it's a bios/hardware limit, pay attention!)



The method i used is to set on smbios "MacBook 3,1" and GraphicsEnabler=no (obviously, arch=i386 is necessary!). This is the only one method that permits system to boot in 1280x800 with QE/CI enabled and full resolutions.

After that, you have only to install VoodooHDA to get sound.


What does not work?


- Wireless does not work at all

- Touchpad is working only with ApplePS2Mouse (no scroll), because i was not able to make ApplePS2TrackPad to work. If anyone knows a method to get it working better, please let me know.


What does work?


- Volume Buttons works perfect

- Sound is working perfect, even the integrated microphone

- USB both working

- Graphic Card is perfectly identified



I was not able to set Power Management for sleep, because i was not able to generate a DSDT.aml for this machine (there is no patch) and i don't have information to make it works (need help to understand what to make)


Anyway, i'm happy because the system is good and with an external Asus WL167G i'm able to use network


Please, let me know if you are able to explain me how to make PM works.






  • 2 weeks later...

I successfully update to 10.7.5 using a script to "clean" /S/L/E.


No way to find a way to use a DSDT.aml

If anyone knows how to build one without having a patch, please let me know

  • 1 month later...

First, I would like to thank the original poster (Iceman) for sharing his knowdlege. This original post (on top of this thread) inspired me to try installing OSX on my HP 2510p.


I am a newbie when it comes to Hackintosh but I will share my experience thus far.


I used MyHack 3.2.1 (http://myhack.sojugarden.com) to create a USB image of the retail version of OSX Lion 10.7.2 (the torrent equivalent which should substitute for the retail copy, if you do not have an Apple store in your country and you want to walk on the grey side, is "Mac.OSX.Lion.10.7.2-Addict").


Using MyHack and Iceman's graciously provided "Extras" file (included in his original post) I was able to install OSX Lion 10.7.2 on my HP 2510p (I have 2 GB of RAM, considering upgrading it to 4 GB if I can stabilize OSX). The display came up perfect, the resolution was excellent, and it even looked clearer (to me) on the 2510p than Linux Ubuntu or Windows XP.


During the install I was able to use the 2510p's built-in keyboard and touchpad... however after the first boot when I needed to configure the timezone and such the keyboard was not responding (the trackpad still was). As you may know, OSX will not let you install unless it detects a keyboard present, so the install just sat there until I plugged in a USB keyboard into the USB port on the left side of the 2510p (the USB port on the right side did not seem to work) which it detected and let me proceed with the installation. After the initial installation OSX was once again able to recognize the laptop's built-in keyboard and I did not need the external USB keyboard anymore.


When the machine booted up I still was not able to get OSX to recognize the right side USB port, but I was able to use a USB 2.0 hub (multiplier) in order to hook up both an external keyboard and mouse to the 2510p and had them both working (in addition to the 2510p's built in keyboard and mouse). Thus, we need to figure out why the right side USB port is not working (it works in Ubuntu Linux and Windows XP, so it must be a software issue).


During the first boot the fans of this mini laptop were running at full speed and it was VERY LOUD (even after the installation, when the machine was idle). Luckily, during the subsequent boots the 2510p's fans were quiet and normal (almost making no sound, which is excellent).


The next thing I tried was to plug in an external monitor via the VGA port. The 2510p has a Function (Fn) keyboard combination whichi turns on the external display. This is a bit flaky but when I close the 2510p's lid I can view the screen on the external monitor at excellent resolution. For a while I was able to do a dual screen setup (where I could seemingly drag applications from one screen to the other with the display showing on both screens), but I haven't extensively experimented with this yet.


Here are the current problems I'm trying to address:


After the install the on-board wired (copper) NIC card is not working. The NIC appears to be the Intel 82566MM Gigabit Network Card. It seems we need the correct driver for OSX 10.7.2 for this NIC to work. Doing some web searches, I found found the following sites which talk about various versions of the Intel 82566MM driver but seemingly for different versions of OSX (one of the links talks about the correct driver for 10.7.2 but the 64 bit version... for the 2510p we need the 32 bit version, I believe).






If anyone can point me toward the compiled version of the Intel 82566MM driver for OSX 10.7.2 the 32 bit version I would appreciate it.


Next, it does not appear the Bluetooth is working out of the box. Further research needs to be done to understand the bluetooth aspect. If we can get Bluetooth working then the next goal would be to get the Apple Magic Trackpad working (I'm not sure if that's possible, but it's an idea I've seen others on this forum make work).


I understand the internal WiFi (wireless) is not an option, so I will have to look at the USB WiFi adapter approach (my priority for now is getting the hardwired NIC card working, but the Wi-Fi is a "nice to have"). Another idea would be to use the PCMCIA slot wireless adapter, but it doesn't seem OSX is recognizing that either so I'm not sure how to proceed with that.


I am also looking to understand if I can use a docking station (port replicator) with OSX on the 2510p. I don't have a docking station to test with but I am wondering how OSX would react if I tried to use one). More research needs to be done on this front.


I will have to get the sound working per Iceman's posting ("VoodooHDA" is involved, further research is necessary).


Interestingly, when I abrupty pull the power cable from the laptop it immediately either goes to sleep or freezes (not sure which one yet). It should run on battery when the cable is pulled, maybe this is just a power management setting, further research is necessary.


Please respond to this message if anyone has any tips or tricks relating to OSX on the 2510p as it would make for a wonderful Apple replacement.


Muchas Gracias!



I got the internal NIC (network card) working by installing the seemingly "Intel-universal" AppleIntelE1000e.kext file. The discussion about this file is here:




And the file is available here (find it in the list at the below URL):




Important note - Use a USB drive to move the file to the new Hackintosh box (since you won't have ethernet access yet). I ran into an issue by trying to use a Windows 7 box to download and copy the file (OSX kept giving me permissions errors on kext installation). Then I got a hold of a friend's real Mac and used the "Disk Utility" to format the USB drive with the "Mac OS Extended Journaled partition". After this, I downloaded the kext file to this USB drive and took the drive to my Hackintosh, at which point it installed with no problem! The permissions issue must have had something to do with the fact I was trying to use a Windows 7 box on an FAT32 formatted USB drive.


I was able to install it using the below instructions from user "hnak" on this forum:


Open terminal.app and go to the directory and execute the following commands:


If you have an old one in /System/Library/Extensions :


sudo kextunload /System/Library/Extensions/AppleIntelE1000e.kext

sudo rm -rf /System/Library/Extensions/AppleIntelE1000e.kext


Then install a new one:


cd into the directory where AppleIntelE1000e.kext exists

sudo chown -R root:wheel AppleIntelE1000e.kext

sudo mv AppleIntelE1000e.kext /System/Library/Extensions/


The next command loads the kext immediately.


1. sudo kextload /System/Library/Extensions/AppleIntelE1000e.kext


I understand this generic "AppleIntelE1000e.kext" may be missing the ability to put the ethernet card into promisc or monitor mode (and may effect VMware and such), but I'll handle that hurdle later.

Another update:


Per Iceman's advice above, I was able to get the audio (sound) working by installing the "VoodooHDA".kext using the Kext Utility 2.5.1 from cVAD.


My version of the 2510p has bluetooth built in, but since I have a Kingston 33348 USB 2.0 bluetooth dongle I decided to use that instead. It was simply Plug and Play.... I plugged it in, OSX 10.7.2 immediate recogonized it, and Bluetooth showed up in System Preferances under "Internet & Wireless". I had not tried to configre the built-in bluetooth.


I was able to connect the Apple Magic Trackpad to the bluetooth... it works FLAWLESSLY. All the multi-touch functions work very good. All plug and play.


I also connected a wired USB Apple Keyboard and that works well too, all the custom Apple keyboard shortcuts seem to work well.


An issue I ran into is that whenever I unplug the AC adapter the machine either locks up or goes into a reboot loop. This means that unless the problem can be fixed, it can only be used as a desktop machine always plugged into AC power.


More updates to follow...

Just to let you know two more things:


1° I was able to make right USB port working after remove a kext. If i remember right, it's AppleHPET.kext (try yourself and confirm it's that... try moving out from folder before to remove)

2° I was able to make Sleep working!! (this is amazing!). I used SleepEnabler! Really nice!


The only problem still remains the touchpad really to quick... have to found a solution for that....

Thanks for your guide, as an owner of this fine piece of Hardware 2510p I would really love to see MacOS running on it. But before I'm going to try it, I have one question. Do you think it would be possible with Mountain Lion, too? I would really prefer 10.8 because it's also running on my iMac.

If not I'll have to get Lion out of the rescue partition of my iMac and follow your Guide ;)


Thanks in advance!

Iceman, thanks for following up on this thread! I'm glad to hear that the right side USB port can be enabled by removing the AppleHPET.kext (I hope that's the right one... just in case I will image my fairly stable drive before attempting any changes so I can roll back if needed... as soon as I figure out the best way of doing that :) ).


In terms of getting Sleept to work, I assume you used the below Sleep Enabler. I'll definately give that a shot too.




About the touchpad being too jittery and too quick you're right, I only use an external USB mouse and now the Apple Magic Trackpad for my mouse. The built-in touchpad can really only be used in an emergency, not for normal use. This delegates this laptop as mostly a desktop now, which works perfecetly for me.


The biggest problem I have come across so far is that whenver the machine is on AC power and the power cable gets disconnected the machine locks up or reboots and goes into a reboot loop (if the lid is closed and an external monitor is used). This is troublesome because the power cord can be easily kicked out by accident, causign the box to lock up and/or reboot and loose work.


If you have a moment, please let me know if you have experienced a similiar issue.


Thanks again, Iceman!


Just to let you know two more things:


1° I was able to make right USB port working after remove a kext. If i remember right, it's AppleHPET.kext (try yourself and confirm it's that... try moving out from folder before to remove)

2° I was able to make Sleep working!! (this is amazing!). I used SleepEnabler! Really nice!


The only problem still remains the touchpad really to quick... have to found a solution for that....

I don't experience reboot on power cable unplug...

Moving out AppleHPET don't hang your machine... you can always boot into single user (-s)

SleepEnabler can give you hang on boot if you do not choose the right one (i don't have it now, but i can upload it if you need), but you can always boot the installer by you install Lion and remove kext by hand...

As i know, it's not possible to install ML



The reboot on power cable unplug issue must be unique to my setup, I'll have to look into it further. Glad to hear you're not having this issue, which means it's theoretically fixable! :)


If you could please share the exact SleepEnabler you used I would very much appreciate it (perhaps you could upload it to this thread whenever you get a chance).


I'm not super interested in trying to install Mountain Lion since Lion is stable and is still fairly new (a Macbook I bought one year ago came with 10.7.2, the same version our 2510p runs stable, so it's not old yet).


By the way, did you end up upgrading all the way to 10.7.5, or did you stay at an earlier release? This will be my next project, to upgrade to 10.7.5 without "bricking" the 2510p :)


Thank you!



Per Iceman's advice above:


" I was able to make right USB port working after remove a kext. If i remember right, it's AppleHPET.kext"


I moved the AppleHPET.kext into my Documents directory, rebooted the machine, and both USB ports magically started working! Thanks for the advice, Iceman.


I also did a complete rebuild of the machine in the process (just to keep it fresh) and noticed that right after I installed the VooDooHDA.kext using the Kext Utility at the next reboot the machine crashed with a VooDoo error saying "you must now reboot". At the next reboot, everything booted normally and my sound started working. Not sure what caused that initial boot crash.


Another interesting note, if the laptop is booted from the off state (when the laptop is turned off), the fans turn on for about 20 seconds and then turn off, which means the machine overall quiet. However, if I reboot the machine from within OSX then the fans stay on constantly and seem to never turn off, which makes it loud. Basically, this means that whenever I need to reboot I shut down first and then manually press the power button to start the laptop.


Also, I upgraded from 2 GB of RAM to 4 GB of RAM with no issues.



I have been trying to use the 2510p with OSX 10.7.2 as my "production" computer for the last few weeks. I keep the lid closed and have it connected to an external monitor (23", set the resolution at 1920x1080 within OSX).


I find that every 4 - 6 hours of use I get a kernel panic. In order to diagnose, I boot with the "debug=0x100" boot flag. Every time I get a kernel panic I can now see the the details, which read "AppleIntelGMAX3100FB GPU Parser Error EIR 0x10 ESR page table error".


The kernel extensions in the backtrace are "com.apple.driver.AppleIntelGMAX3100FB 7.0". The GPU in this laptop is the X3100 (Intel 965GM). In doing research on the web I stumbled across a foreign language discussion of this problem at




Use Google Translate fort he above site. It talks about using a specific set of kexts for the X3100 in OSX Lion (10.7.x)




I installed them using Kext Utility and giving them a shot now. I think some of them are earlier drivers (based on version numbers), maybe they will stop the kernel panic. I will report back.


Attached is the file I referenced above. Just in case it disappears from the file hosting site.

Set X3100 LION.zip



After installing the video (GPU) kexts mentioned above and rebooting, the machine ran flawlessly for 26 hours. At around the 26 hour mark when the machine was under heavy load (many browsing tabs, etc), the machine locked up (no kernel panic message was displayed), the machine simply stopped responding.


A reboot of the machine had all the same browser tabs open again, and once again it locked up within a minute without any kernel panic message (even though I booted with the "boot=0x100" boot flag. I ended up rebooting again and forcing a fresh desktop (so all the old browser tabs wouldn't open) and it has been running fine since. I am hoping this was an isolated occurrence and not tied to the kernel panic video problem I had earlier.


Time will tell...

I will give it a try...

Let me know if you get other KPs...


Anyway, i was able to update to latest Lion (1.7.5) without anyproblem.

I installed combo update, no reboot and reapplied /Extra thru MyHack. Really easy



It seems that the screensaver MUST be disabled with these latest GPU kexts which I mentioned above (on my machine, at least). If I let the machine's screensaver kick in then the screen (and most likely the entirely machine) freezes. I have resolved this issue by simply having OSX put my display to sleep when it's idle, rather than turn on the screen saver, which works quite well.


Iceman, thanks for your input. Out of curiosity, have you also experienced the GPU-related kernel panic I mentioned above, or did you install some custom GPU video kexts right away? Also, are you using an external monitor? Please share any details you feel comfortable sharing about your 2510p setup, since I am trying to "stabilize" and "productionize" my Hackintosh.


My next plan is to figure out how to properly back up the entire machine and then try the Lion upgrade to 10.7.5. I'm hoping mine goes as smoothly as yours!


Iceman, which backup/image software do you use for your OSX image on your 2510p before you make major changes to it? Please let me know if you get a chance, thank you very much Iceman!



For over one week now I have been running the video kexts contained in "Set X3100 LION.zipz" (mentioned above) and have not had a single Kernel Panic yet. However, several times I did have the machine's screen simply freeze on me when under high load, however the mouse appeared to still be operational (since when moving the Magic Trackpad around I could see the bluetooth "activity" light flashing, corresponding to my movements of the trackpad).


At this point the machine is almost completely stable on 10.7.2, except for this above mentioned issue.

  • 1 month later...

Im so lucky to have found this topic.


I am one of the only few users of HP Compaq 2510p trying to install OSX Lion.

Great work by Iceman and qwerty99. I have gotten most of the stuffs working with the guides u guys provided except for the built-in keyboard.

Would appreciate if you guys comment on this or provide me with some directions.


Good luck!

  • 4 weeks later...



For over one week now I have been running the video kexts contained in "Set X3100 LION.zipz" (mentioned above) and have not had a single Kernel Panic yet. However, several times I did have the machine's screen simply freeze on me when under high load, however the mouse appeared to still be operational (since when moving the Magic Trackpad around I could see the bluetooth "activity" light flashing, corresponding to my movements of the trackpad).


At this point the machine is almost completely stable on 10.7.2, except for this above mentioned issue.



Did you find a solution to your video problems? I have a Lenovo T61 with x3100 graphics, and have recently been experiencing random KPs tracing back to the gmax3100fb.kext. I have tried a multitude of different kext packs, with no luck.


Interestingly, I never experienced these issues when I had a 1280x800 screen. Now that I'm using a higher resolution screen (1440x900), I get these KPs every day.

I have no problem with video. I have been able to Stop/resume with sleep.kext.

I have KP ONLY when not connected to power supply. And i was not able to use any kind of 3G USB pen... i got any time KP while to plug the pen... :(

  • 1 year later...

Hello all,

I've succesfully installed macos using Extra files attached by Iceman. Everything works great except two things.

1. Built-in keyboard works ok but touchpad doesn't. Neither during install, neither in installed system (keyboard and mouse connected to USB port works perfectly).

2. During boot cpu fan slows down (not stop at all) and stays at this speed independently of cpu temperature. After few hours when the cpu is too hot laptop turns off immediately.

Is there any possibility to resolve these problems? Especially mouse problem.

Thank You guys for help.

Best Regards, Arthur


  • 1 year later...
  • Create New...