Jump to content

Inspiron 1520 - Still waiting on root device / IOACPIFamily


18 posts in this topic

Recommended Posts

I was following this guide and I got through the first 17 steps, but I ran into a bit of a roadblock.


Here are the problems:

When I boot with no arguments: I get the prohibitory symbol (circle with line through it)

With arch=i386 -x -v (like the guide suggests): IOACPIFamily Kernel Panic (See photo below)

Without -x: Still waiting on root device



Dell Inspiron 1520

Intel Core 2 Duo T7500 2.4 GHz

nVidia NB8P-GS (Possibly GeForce 8600M)



Any ideas?


Link to comment
Share on other sites

OK, so problem with SATA controller (assuming it uses SATA, or is it IDE?) I'll try to find out


Are you using HD or USB to install?


if trying to use SATA HD, make sure SATA is set to AHCI in bios first, then if it is as still problem, injector includes your ICH8M-E device ID 2829, when set to IDE mode, the device ID changes to 2828, and injector won't work. Install into S/L/E, also if you need it, it maybe good idea to install ATA kext that was include in /Extra folder of your guide in S/L/E instead so it will be cached and hopefully load in safe boot. If not an edit to plist can change that if dependencies are met.


Link to comment
Share on other sites

2 things you can try:




When you are at chameleon boot menu, unplug and replug your usb, or move it to different usb port, wait a couple seconds and hit F5 to refresh, choose installer and continue booting

Link to comment
Share on other sites

Tried both. With the first option, I got still waiting on root device without -x, and the same HPET problem with -x. I tried with and without ForceHPET=Yes.


The second option just didn't work. As soon as I hit F10, it tried booting without flags.

Link to comment
Share on other sites

try different usb ports


dell usb ports are very flakey during boot


separate CD with bootloader part on it can help too


type tags first, then rescan for bootable media, there's 2 options F5 and F10, can't remember which is which, but one is for rescanning CD and the other is for everything else


The files your using along with Chameleon version quite old are best suited to Snow Leopard, and not Lion.


Delete Extensions.mkext from /Extra


new Chameleon version recommended, which will also require /Extra/com.apple.boot.plist be renamed to /Extra/org.chameleon.Boot.plist and extensions from /Extra/Extensions be instead installed to /System/Library/Extensions and delete /Extra/Extensions folder


check bios usb settings, usb3 disable, legacy mode, ehci handoff, etc. and try other ports


can also try selecting root manually, at boot prompt type rd=hd(0,2)

first number is the disk# and 2nd is partition#. It should be 0,2 but can try other disk #'s and partitions too

Link to comment
Share on other sites

Well, the only other thing I could suggest is either making a small 8gb partition on your internal HD and use it for the installer instead, or use a DVD. Every time I've worked on a Dell I've swore it would be the last time, there's always some weird thing to frustrate me. A friends Inspiron e1705 that I installed a few different versions of OSX on over the years always has problems with USB and DVD where it will read it, then for some reason stop reading it (blinking light stops blinking). A lot of trial and error and sequence of plugging/unplugging and/or ejecting and inserting DVD at just the right times, full cold boot power cycles, combined with a little luck, is always what it seems to take. Can't remember the exact song and dance though. One thing that comes to mind, the TSCsync extension you have, which will let you use both cpu cores without constant freezing and unfreezing every 5 seconds, during install I always had to disable one of the cores in bios, or if no option in bios using cpus=1. The freezing during boot could be enough to stop the usb from reading, or rolling back your USB kexts to these ones may help too. Make sure your properly installing kexts with proper permissions and not just drag and dropping. Either use a tool like kext wizard and if your terminal savy that will work too.


Link to comment
Share on other sites

Since I didn't have a bootable disc for Lion, I wound up installing Snow Leopard from a retail DVD. I ran the combo updater to 10.6.8 and applied 10.6.7 IOPCIFamily and IOACPIFamily kexts to fix the infamous [ PCI configuration begin ] lockup at boot.


Now I'm trying to install Lion, and it's just saying it requires a Core 2 Duo, Core i3, Core i5, or Core i7, then it refuses to continue. I have a Core 2 Duo, so I really don't know why it's doing that. Any idea?


EDIT: I should add that for the Snow Leopard install and subsequent boots, I've used the Nawcom Mod CD to boot.


EDIT 2: The installer recognizes my processor if I use ###### to boot. Unfortunately, I forgot to set my partition scheme to GUID, so I have to reinstall Snow Leopard now. Oh well.

Link to comment
Share on other sites


  • Create New...