Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Micky1979

Patched AppleHDA.kext for codecs IDT 92HD81B1X5, 92HD91BXX, 92HD87B1/3, 92HD87B2/4, 92HD87XX etc.

203 posts in this topic

Recommended Posts

Hello everyone

I tried to apply the guides for AppleHDA patch for my codec
(IDT 92HD99BXX - 0x111d76e5), but till now I only got the
codec show up in system preferences but no devices on input/output.

I use DSDT injection, but it seems that the codec is not
initialized - don't know if this is because of DSDT, MuteGPIO thing
or anything else.

I tried to follow the guide step by step and tried different
Nodes, LayoutIDs (12, 3) and other patches for this codec with no luck
(also AppleALC). The only semi-working thing is VoodooHDA.

I'm posting my DSDT, Clover config, linux dump and the patched files.
Can somebody have a quick look if can spot anything wrong?

Thank you very much!!
 

https://drive.google...UKi6sD9iQsRqkYI

post-1244116-0-61943300-1513006516_thumb.png

codec_dump.txt

layout3.xml

PathMaps.txt

Platforms.xml

verbitdebug.txt

verbs.txt

post-1244116-0-70410000-1513006557_thumb.png

Share this post


Link to post
Share on other sites

Did you try and check to see if the irq fix is applied to your dsdt? If it's not, try to apply it by using Rehabman's fork for MaciASL and apply the patch. Good luck.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • For F6 Bios, which DSDT is the one i should use? I´m a little confused in the Mass of DSDT here ;-).   Great Thread by the Way.   Another Question: I have 2 960Pro inside my Rig (one with OS X, one with Windows 10). When i try to mount my EFI on OS X NVMe the system freezes... :-(   DWhen i unplug the Windows NVMe everything is fine an it mounts the EFI.   Anybody an idea?   Tried the upper Port on the Board (OS X) & the middle / lower Port, in the Middle it mounts the EFI in the lower it freezes.   But i need the middle Port for an SATA M.2 SSD :-D... Even when i plug the Windows NVMe into an PCIe Adapter Card it freezes at the point i mount the EFI.   I´m mounting with Clover Configurator.     Thank You guys.
    •   Just add "ngfxsubmit=0" to config.plist to disable the fix within nvidiafixup
    • @MegaCookie   ok, I have no solution for that Trial 7 good for the release?
      Is this codec good enough for you?
    • @onejay09  - thanks again for your help and advice.  I tried various combinations of Info.plist mods (Adding a new Machine entry with my Board ID and GFX0, adding GFX0 to the MacBookPro6,1 Machine entry and adding a Vendor/Device entry to the Board ID and MacBookPro6,1 Machine entries. I thought these might make a difference, but after comparing GPU temps and frequencies to those reported in Windows 7, I'm not seeing any difference.  It appears as though AGPM is natively detecting and handling power management of the NVidia Quadro NVS 140m without any Info.plist mods.   Thanks again.
    • My rig is not booting without the "XCPM bootstrap patch" and "xcpm_program_msrs (c) Pike R. Alpha" patch. Already tested that.  Booting without the TSCAdjustReset.kex is working great and booth sleep and wake is working. The new bios 0603 has an updated microcode. That might be the reason  for the fact that everything is working as it should without the kext.


×