Jump to content

Looking to get help installing on a Dell Dimension 2400


7 posts in this topic

Recommended Posts


I'm trying to install OSX86 on my Dell Dimension 2400 which is running at stock spec for everything except the video card, audio card, and upgraded RAM.


The specs are as follows:

  • Processor: Pentium 4 HT 2.4GHZ
  • RAM: 1.5 GB
  • HDD: 80 GB IDE Drive
  • Video Card: Nvidia GeForce 8400GS
  • Sound Card: Sound Blaster Live! 5.1 Digital

Here's a link to the official Dell specs which may provide details that I have left out.


The installation method:

  • iDeneb Version 1.5.1 OSX86 version 10.5.7
  • Chameloan Bootloader.

The issue:

I'm able to get a successful install. Although when I try booting I get a Kernel Panic. Originally I was just getting a prohibitive sign at the loading screen although I found that was fixed with a reinstall and not selecting any Ethernet drivers. I'm going to attach a photograph I took of the final screen that is loaded in verbose (-v) mode. This should help prevent any misinformation due to typing errors.


The closing statments:

If I left out any information above do forgive me but this is my first time installing OSX86. I will gladly update any info that is needed, and would like to thank anyone who has taken the time to read this post. Also if the formatting seems weird feel free to let me know and i'll fix it. I just want it to be easy to read and non-cluttered :P Once again thanks!


Link to comment
Share on other sites

voodoo power kext is cause of your kernel panic. easiest would be just reinstall and not choose that one. You should only be selecting to install items you know you need, installing them because they are there=100% failure. Also in most categories, only one option can be chosen, or else 2 or more different kexts may conflict. Things can be added after install, like audio for example, so no need to have it during installation and maybe cause kernel panic. The less options you can choose and still install, the better.

Link to comment
Share on other sites

voodoo power kext is cause of your kernel panic. easiest would be just reinstall and not choose that one.

Awesome! this fixed my problem 100% I just reinstalled and did not choose any power management. I was able to install OSX86 successfully although now I'm having an issue with my display. When I try to preform a normal boot with no flags I get a the loading screen then a blank blue screen. I'm able to boot using safe mode with the -x flag, although this causes small bars to come up all over the active window and dock menu. I'll attach a pic that shows the issue I'm having. I was planning on uploading a screenshot although I can't connect to the network. I have a USB wifi dongle that I know I need to install a .kext for although I'm not sure what I need to do. Could someone help me with this here or should I move it to a different forum?


  • Like 1
Link to comment
Share on other sites

-x prevents video drivers from loading (among other things). Try booting with either GraphicsEnabler=Yes or GraphicsEnabler=No. If no luck with either of those options and -x is still needed, you'll probably need to add cards device ID to the nvidia kexts. A quick search should get you some directions on that

Link to comment
Share on other sites

Okay I'm currently stuck at the moment. I tried both of those options but neither seemed to work for me. The GraphicsEnabler=Yes/No produces a Kernel Panic which I've attached. The .kext that I found was nvdarwin.kext I believe which already had the device ID. The system seems to be recognizing the video card. I've copied and pasted the Video Card section from the System Profiler. I would greatly appreciate any help you can give me.


Edit: It looks like the PC may have been plugged into the onboard video card when I tried GraphicsEnabler and got the Kernel Panic. I will double check tomorrow to see what the outcome was when it's hooked-up to the video card, (I remember it didn't work I just don't remember the specific issue). I should also add that using the NVIDIA video card is not necessary as long as I can get the video card on the motherboard to work.


NVIDIA GeForce 8400 GS:


Chipset Model: NVIDIA GeForce 8400 GS

Type: Display

Bus: PCIe

PCIe Lane Width: x1

VRAM (Total): 512 MB

Vendor: NVIDIA (0x10de)

Device ID: 0x06e4

Revision ID: 0x00a1

ROM Revision: NVdarwin 1.2.5


Display Connector:

Status: No Display Connected


Resolution: 1280 x 800 @ 60 Hz

Depth: 32-Bit Color

Core Image: Software

Main Display: Yes

Mirror: Off

Online: Yes

Quartz Extreme: Not Supported


Link to comment
Share on other sites

NDVAResman is the one your referring to. Been a long time since I dealt with 10.5 and P4 stuff, so am a bit rusty and some of the older Chameleon options are different. I believe the onboard video should be disabled in bios and yes, monitor plugged into graphics card.

  • Like 1
Link to comment
Share on other sites

Okay I checked and I am plugged into the video card. I have tired both my VGA an DVI output (using a DVI to VGA converter on the DVI port) and that doesn't seem to make any difference. I have checked the kexts and they all seem to include my device ID. So or there any other options at this point?

Link to comment
Share on other sites


  • Create New...