Jump to content

Ati radeon 6370m not working qe/ci

16 posts in this topic

Recommended Posts

Hey, i stuck wich my hackintosh on graphics card. I tried http://www.insanelymac.com/forum/topic/282138-working-ati-radeon-hd6370m-on-mountain-lion-qeci/

and http://www.osx86.net/downloads.php?do=file&id=1442&page=6

and everytime shows up:

Framebuffer @0xc0000000 MMIO@0xD0200000 I/O Port ...

Ati card POSTed, reading VBIOS from legacy space

(Ati config) Framebuffer set to: Hoolock

Nr of ports set to framebuffer's default: 3

I habe problems with EDIT inf in 1st link, but something should shows on screen except this!

I tried PCIRootUID=1/0 npci=0x2000/0x3000 AtiConfig=Hoolock/Langur and all combinations of theese with -f, -v -x flags

Im tried to hack it witch niresch 10.8 ML with multiple bootloaders.

Desktop shows up only witch GraphicsEnabler=No, and -f (still waiting for root device stuck, i will do it later) but i want QE/CI!

My laptop is Lenovo g570, i5 2450m, chipset 6 series intel,

card Ati radeon 6370m PCI\VEN_1002&DEV_68E4&SUBSYS_397917AA&REV_00

wi-fi broadcom 4313(still not working)

Share this post

Link to post
Share on other sites

Add device ID 68E4 to ATI6000controller.kext, although I have feeling that for that card, may need to add it to ATI5000controller.kext instead


Or what arthur-pt said :)

Share this post

Link to post
Share on other sites

1. Your Wifi card will not work because its device ID is 4727 and it must be 4327. This means it has a different firmware and can not be changed.


2. Install this DSDT attached in your extra folder and then restart. Then post a new IOreg after restart.


Maybe i should try with 10.7 (via Iatkos L2) because people write here that this kext make this card working >




Share this post

Link to post
Share on other sites

I tried VoodooHDA and audio wasn't working properly because bass was distorted. Can you help me with Graphics? It is the most important for me.


I have never had my luck with moding kexts for mobile GPUS...

Share this post

Link to post
Share on other sites

I found working kexts on some chinese sites. I have an another problem. When I install graphics the battery indicator makes kernel panic. When i uinstall apple smart battery its ok. How to get batery level info?


This kext working with ATI Radeon 6370m Full QE/CI, EDID injection is needed AtiConfig=Langur




Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By olacombe
      Hello guys,
      I am trying to make work my ATI radeon 6370M 512mb on my Packard bell TK 85.
      I'm starting this topic cause i can't find anything at this moment to make that graphic card work properly on oSX 10.9.
      Sound is not working, my video card is well recognized but get lagging and only 4mb recognized on 512mb. Default framebuffer is Eulemur.
      I read a lot on how to edit framebuffer personality. My AMD5000controller.kext is already patched with what i think are the appropriate information of my videobios.
      I will share my results if i succeed in it. otherwise if anyone get the solution, i will be more than interesting
    • By kranjo
      I did clean install of iATKOS L2. After installation, graphic card works with native resolution (1600x900) but no QE/CI. When I try to make it work with this (http://www.osx86.net/view/3347-radeo...ull_qe-ci.html) method (extracted correct EDID and added it to DisplayProductID-717) the best i can get is the distorted image on internal display when started with -x argument and with GraphicsEnabler=No. I tried to to add correct resolution with resX using hdmi, but with no luck.
      When I try to boot with GraphicsEnabler=Yes option I get stuck on bootloader.
      When I boot with -v GraphicsEnabler=No, i get stuck on DSMOS has arrived.
      If anyone has any idea how to fix this, I would be grateful.