Jump to content
jimmyco2008

[GUIDE] HP Pavilion m6-1045dx (Mountain Lion)

41 posts in this topic

Recommended Posts

Oh you know what it probably is, our cards are slightly different I bet. Load up Ubuntu, open Terminal, type in LSPCI and copy the printout and paste it here, do the same with the readout of LSUSB.

 

I'm guessing the hardware IDs are slightly different, there are a few "versions" of this card, in general there are multiple versions of cards, but the kexts I used and uploaded were actually edited for my card's IDs. You might try the original set of kexts for WiFi, I believe it's on OSX86.net, Google a little bit it should be easy to find, but do that and try that out before going through all the Ubuntu stuff... Also, what about Bluetooth? Does that work in the Hackintosh? Keep in mind even though WiFi and Bluetooth are on the same AR5B195 card, WiFi operates on the PCI bus while Bluetooth uses the USB bus, at least on our laptop and probably all the similar HP laptops of 2012/2013 (so Bluetooth doesn't work after a sleep resume with the Hackintosh setup but WiFi does). I know I/we (eep357 has been helping a lot) had to edit the Bluetooth kexts, I think because of the USB bus thing, because the norm is for WiFi and Bluetooth to both run off of PCI, or at least that's how I understand it.

Share this post


Link to post
Share on other sites
Advertisement

I assume you're probably pulling the vendor and hardware ids with that command. I have a Dell model, Dell 1702 I think.

 

Ven 168C DEV 002B Subsys 02051028

 

there was a revision but I didn't copy that down. Give me a second and I'll post what Ubuntu states.

Share this post


Link to post
Share on other sites

Yep. We'll resume this tomorrow, but you don't have an HP m6-1045dx? You're using a Dell... I'm guessing with the same specs, Ivy Bridge i5 3210M, HD4000, HM77 chipset?

Share this post


Link to post
Share on other sites

M6-1045DX, bought a Dell 1702 because it's a AR5B195. Didn't realize that would be a big issue.

 

I downloaded a kext from osx86 for the AR5B195, added my 168c and 2b and restarted. Wifi works now! Thanks a lot for the help and suggestions. Time to start working on the other bugs.

Share this post


Link to post
Share on other sites

My battery monitor isn't working. I tried a couple kext's from google/osx86 and now I'm getting a KP stating I'm missing 2 files. I formatted my myHack flash drive for data transfers and don't have a mac nearby to create a new one. Is there any other repair methods? I have a .iso of ML, official disc of Snow Leopard, i_boot for 10.6 and i_boot for 10.8.

Share this post


Link to post
Share on other sites

I had to remake the myHack USB a few times... I have a few laptop hard drives and a few flash drives, so at one time I had a secondary hard drive with Windows and Mac OS X in a VM on it and two myHack USB drives. Without a Mac to use, you need a VM of OS X, and that can be done with Ubuntu or Windows.

 

I've never had any luck with disks, I have something like 10 different ones for Hackintoshing, bootloader disks, iAtkos disks, pure OS X disks... It's a mess.

Share this post


Link to post
Share on other sites

Yeah, finally after 3 or 4 myHack flash drives and a couple weird touchpad issues, I finally got Mac OS back on it. Time to do the kexts again. Thanks again btw for the pack.

Share this post


Link to post
Share on other sites

anyone have a minor link for the gatsby pack?

 

 

I second this. Haven't been in the Hackintosh game for a while, just came back to check in... The files should still be up, but it seems Google screwed up the goo.gl link so it doesn't know where to redirect to.... Nor do I, I think it's in a DropBox account I forgot I had, to be honest.

 

If anyone has it, I'd be much obliged if you sent it to me so I can update the link... Or if you want to host it, that's cool too.

Share this post


Link to post
Share on other sites

So I finally found the Gatsby Kext Pack:

 

http://goo.gl/oINTKU

 

And the Gatsby Everything Else Pack:

 

http://goo.gl/ZqvFHi

 

 

They may be older versions, but it's better than nothing, right?

I am happy to report that, I have Installed Mavericks on my 1045dx following your guide and the Kext Packs you provided. I will try installing Yosemite :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By shinho73
      I need a good vanilla guide for AMD A8 7600 with A58M-E FM2+ mother board and Palit GEforce GT 730. Any help will be greatly appreciated. Thank you.



    • By MaLd0n
      ---INSTALLATION TUTORIAL---
       
      ---Original Post---
      https://olarila.com/forum/viewtopic.php?f=45&t=9172
       
      ---USB---
      https://pikeralpha.wordpress.com/2016/07/13/simple-skylake-usb-fix-no-kexts-required/
       
      ---CLOVER FOLDER---
       
      CLOVER.zip
       
       
      --MOBO
      GigaByte Z390 M Gaming



      --PROCESSOR
      Intel Core i9-9900K


      --COOLER
      CoolerMaster MasterLiquid ML120R RGB


      --MEMORY
      Corsair Dominator Platinum 16GB (2 x 8GB)


      --GPU
      Sapphiretech Radeon RX 590 8 GB GDDR5


       
      --SSD
      Samsung 970 EVO NVMe M2 Flash Drive


      --POWER SUPPLY
      EVGA 750 N1, 750W


      --WIRELESS
      TP-Link Archer T9E


      --BLUETOOTH
      Orico BTA-403


      --CASE
      Thermaltake View 21 Tempered Glass Edition


      --DSDT Patches--
      -FIX ERRORS AND WARNINGS -FIX ACPI ERRORS -REMOVE UNUSED SCOPES / DEVICES -HIGH PRECISION EVENT TIMER -SATA SERIE 10 ID -DMAC -REMOVE 22K LINES, PROBLEMATIC and UNUSED -FIX K.P in REBOOT -NVRAM / REAL TIME CLOCK -SLPB -DARWIN / WINDOWS 2015 -XHCI -PLUGIN TYPE -HDAS to HDEF -HDEF -REAL TIME CLOCK -ARTC -IRQs -SBUS -MIKEY -BUS1 -MCHC -ALS0 -SHUTDOWN -UAR1 -LAN -FWHD -USBX -PMCR -PPMC -XSPI -GMM -IMEI -EC -PNLF -ARPT -GFX0 -NVME -DTGP -ACQUIRE MUT0 0XFFFF -OPERATION REGION GPIO -MUTEX MUT0 0x00 -EXTERNAL REFERENCES -UNKNOWNOBJ -HDMI / HDAU -FULL RENAMED DEVICES  
      --SCREENSHOTS--





























      --BruceX--
       
      --USB-C-- test with SanDisk Ultra USB-STICK 128gb


       
      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By dracoflar
      So you've been reading the forum on this brand new boot loader called OpenCore hoping to try it out but you take one look at the configurations PDF and take a step back in shock at the complexity! Well if you've been feeling a bit intimidated by the DOCS well you've come to the right place:
       
      OpenCore Vanilla Desktop Guide
       
      If you have any issues or suggestions please feel free to comment
       
      - Your local neighbourhood Hackintosh Slav
    • By JackBauer24
      Hello,
       
      I have installed OSx86 10.11 (El Capitan) on April 2016 on my Asus Z170 Deluxe system.
       
      For installation I used this Thread.
       
      I used it a lot and it worked well. Meanwhile I switched to Linux and I use Win10 time to time. So OSX was forgotten. Also it did not boot correctly anymore.
       
      Now I wanted to start with a fresh installation and use OSX more often again. I want to use OSX 10.13 High Sierra. Is it working on my Asus Z170 Deluxe? I have the same Hardware as of April 2016 only the graphics card was updated to a Nvidia GTX1080.
       
      My Hardware in detail: Asus Z-170-Deluxe (Bios 3801), i7-6700k, EVGA GeForce GTX 1080 SC GAMING ACX 3.0, Samsung 950 Pro/M2 NVME 512MB, HDD 4 TB)
      Can I use some of support files from the old thread for the installation (see attachment)? Can I still use  Clover 2.3k r3292 Special Edition v2 ? Or do I need a newer version?
       
      Has someone installed High Sierra successfully on the Asus Z170 Deluxe ?
       
      About some hints where to start I would be thankful.
       
      regards
      JackBauer24
       
      Z170DeluxeFiles.zip
    • By steamteam
      Hey everyone,
       
      after years I come back to Hackintosh. In the early days I played with ozmosis and my good old 4700k. Now I'm back and worked around a 100% working setup with enough power to get me through all my tasks like audio, video cut etc.
       
      In this short tutorial I will guide you through BIOS Settings and give you access to my EFI Folder. This I do because I haven't found anything on the web for my setup. Maybe it will help some of you. When you follow the steps you will have a perfect running Hackintosh  like I do have now  
       
      I've chosen the iMac 18,3 because of the easy integration of both Graphic Units and the support of HEVC. 
       
      Specs:
       
      CPU: Intel i7 9700k (Overclocked in Bios to 4,7 GHz)
      SMBIOS: iMac18,3 (Because of Dedicated Graphics and HEVC Intel Support)
      RAM: 32GB G.Skill Trident Z RGB DDR4-3200 DIMM CL16 (XMP Profile to 3200MHz)
      Motherboard: MSI MPG Z390 GAMING PRO CARBON (MS-7b17) <- It's the model without WLAN/Bluetooth
      Graphic Card: Sapphire RX580 Nitro+
      Bluetooth & WLAN: Broadcom Card in PCI Adapter
       
      What is working: 
       
      Almost everything! All USB Ports, Intel Power Management, Bluetooth, WLAN, LAN, Intel Graphics HEVC, Boot/Reboot, Sleep
       
      What is not working: 
       
      Facetime & iMessage (Don't need it but I will come back to this)
       
      Steps:
       
      1. Create Mojave 10.14.5 USB Drive | https://www.youtube.com/watch?v=9CZDXxKfodE&amp;t=95s | Us this tutorial or search the forum
      2. Load my EFI Folder: https://workupload.com/file/zkJ4zdQk
      3. Go into your bios and use my settings in the Screenshot I attached 
      4. Boot from USB Stick | Install Mojave | Boot into Mojave (Check other Tutorials if you don't know how)
      5. Generate Serials with Clover Configurator
      6. Happy Hackintosh Life! 
       
      Kext I use:
       
      AppleALC.kext | Needed for Sound
      BrcmFirmwareData.kext | Needed for my WLAN/Bluetooth Card 
      BrcmNonPatchRAM2.kext | Needed for my WLAN/Bluetooth Card 
      BrcmPatchRAM2.kext | Needed for my WLAN/Bluetooth Card 
      CodecCommander.kext | Fix Problems after Sleep
      CPUFriend.kext | Perfect Power Management for my CPU
      CPUFriendDataProvider.kext | Perfect Power Management for my CPU
      FakePCIID_Broadcom_WiFi.kext | Needed for my WLAN/Bluetooth Card 
      FakePCIID.kext | Needed for my WLAN/Bluetooth Card 
      FakeSMC.kext | Standard
      IntelMausiEthernet.kext | Ethernet
      Lilu.kext | Standard
      USBInjectAll.kext | To fix all USB Ports
      WhateverGreen.kext | Needed for graphics
       
       
      If you have success with my little tutorial and EFI Build let me know! Hope you reach the desktop and will be happy!
       






×