Jump to content

[GUIDE] HP Pavilion m6-1045dx (Mountain Lion)

41 posts in this topic

Recommended Posts

***See Second Post Below***



The latest! (01.14.13)

I'm going to start scheduled updates to the guide/Gatsby Pack. If I fix something, or someone else fixes something, I'll update everything here on the following Friday. So like this Friday I'll update the Gatsby m6-1045dx pack for three-finger swipe actions, and I can probably add the BIOS update, in case HP's website goes down or whatever.

Good News, Everyone (12.28.12)

USB 3.0 ports work, at least with the latest BIOS update, but they only work with 3.0 devices. I was only recently able to test this. Furthermore, a lot of 2.0 devices work with the 3.0 ports, like wireless mouse dongles. Things that don't work include flash drives, iPhones, Android phones, pretty much anything that transfers files.

Sound is now fully-functional (see the post in this thread about sound).

Still on Tap (to fix)

Intel Turbo/SpeedStep (I know it should be working, but I have a feeling it isn't)

USB 2.0 functionality in the 3.0 ports

Mapping for action keys with the latest VoodooPS2.kext that enabled three-finger swiping and brightness adjustment

Sound sometimes cuts out, like with YouTube videos and Spotify... I haven't had an issue since updating to 10.8.2, at least I don't think..so we'll see.

Sleep (supports the theory that SpeedStep and TurboBoost aren't working)

SD Card reader

I'm probably not going to bother with HDMI audio, VGA out, or getting ethernet to work post boot, they're nominal issues IMO.

Share this post

Link to post
Share on other sites

October 12th, 2014

Updated links:


Gatsby Kext Pack: http://goo.gl/oINTKU


Gatsby Everything Else Pack: http://goo.gl/ZqvFHi



They aren't the same as the 12/09/12 guide+file pack below, but they should provide some much-needed kext files and such for those out there who still need them. Apologies for the broken link, I really try not to let that happen. I'm not sure how Google (goo.gl) lost the link, and I've been unable to find where the goo.gl link went to (Dropbox, MX, Drive? I don't know, I have too many accounts, I'm afraid).








NEW: Download the updated (12.09.12) and easier guide and all the files you need here!

April 13th, 2013

I don't have the m6-1045dx anymore, but I hear that the modified AppleAHCIPort.kext does not work with 10.8.3... Anyone care to elaborate?

Updates for the downloadable guide above:

  • Don't install the two kexts for Bluetooth, especially if you're using the AR5B195- works out of box, may also fix Magic Mouse disconnect problem Actually that's a bad idea, I'm still working on the Bluetooth issue, but if you wait a minute after the Magic Mouse stops responding, it should start working again without a power cycle of the mouse.
  • Actually back in October, HP released a BIOS update (must be on Windows to flash) for Windows 8 prep that enables UEFI for the BIOS and gives us the option in BIOS to disable USB 3.0 for those three 3.0 ports we have...This kind of solves the problem where if you plug something into a 3.0 port OSX freezes until you unplug it- it does nothing now, no power to the ports, but no OSX freezing if you disable 3.0 in the BIOS. So I'll look into that more for a possible fix.

Also, if you don't have Dropbox, it'd be cool if you signed up with this link. No worries if you don't, but if I can get 500MB here or there, that'd be cool! It's my "Donate" button haha.

It doesn't include instructions for Ethernet, since I, like most people, don't use it, and it doesn't even fully-work really... If you need it, find the section in the guide below that covers it!


  • A half-height Mini PCIe WiFi/Bluetooth card that works with OSX ( I am using the AR5B195 with N WiFi and 3.0 Bluetooth - $10 on eBay) Don't worry, the m6-1045dx does NOT have a whitelist, any half-height mini PCIe card should do, again, as long as it works with OSX.
  • Access to a working Hackintosh, Mac/Macbook, or OSX in a VirtualBox VM (Google "Mountain Lion Virtualbox july 31" for guide)
  • A flash drive with at least 8GB of total space
  • Be ready to completely reformat your hard drive, back up the important stuff!

The Actual Guide Part!

  • Create a myHack bootable flash drive with a computer already running Mac OSX (remember the prerequisites!) and that retail copy of Mountain Lion that you "purchased".
  • Hold your horses, because goddamn HP doesn't let us change the SATA mode of our hard drive to AHCI, we must make due with the mode it comes in (RAID). Who the hell uses RAID, especially for one and only one hard drive... Whatever, anyway you need a modified version of the SATA controller kext in order for your hard drive to be detected by the OSX installer on myHack. Get it here.
  • When you download that kext, you need to replace it with the version of that kext that is already on the myHack flash drive, and it's located in Libraries/System/Extensions. You should be able to easily navigate the contents of the myHack drive, assuming you're in Linux (even in a Live Session) or OSX (even in a VM)
  • With your laptop off, insert the myHack flash drive into the only USB 2.0 port on our laptop (next to the AC plug on the right side)
  • Boot the laptop and immediately press F9 to get into the boot menu for the BIOS
  • Select the flash drive, which will be named based on the manufacturer (ie Lexar, SanDisk, HP, etc.)
  • Press any key to stop the boot process for OSX, where it should prompt you to enter boot flags
  • Type in, exactly as typed here (excluding quotes), "cpus=1" and press enter
  • You should now be at the install thing for OSX. Navigate through it, and you should see the laptop's internal hard drive, along with the myHack drive.
  • Open up Disk Utility and format the laptop's hard drive with Mac Extended (Journaled).
  • Close Disk Utility to return to the hard drive selection screen
  • Select the laptop's hard drive and click Install
  • Wait, if it takes more than 45 minutes, I think it's safe to say it's stuck, so keep that in mind
  • Finished? Huzzah. Remove the myHack flash drive and boot, if it isn't already doing so.
  • Make sure to press a key within 5 seconds to interrupt the boot process, even with OSX installed and myHack out of the picture, you still must enter the boot flag "cpus=1" to successfully boot into OSX. Failure to do so will result in a kernel panic. Every time.
  • So now you should be at the welcome setup thing for OSX. Go through all that, and you should end up on the Galaxy-backgrounded desktop.
  • Screw around with the dock and its magnification (enable magnification in Settings > Dock) for like 5 minutes
  • Now we need [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url]. Download it from some other device/computer, place it on a flash drive (not the myHack one...) and insert it into the USB 2.0 port on your laptop. Note: This is the only port that will work until the kext for the USB 3.0 ports is installed. That bootflag for USB fix might fix them, haven't tried yet.
  • Install/run [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] and use it to install really any of the VooDoo HD Sound kexts (NOT the Realtek one), as well as the Realtek Ethernet kext.
  • Reboot. Now you should have working Ethernet (must be plugged in before OSX boots, and cannot be unplugged and then plugged in again without rebooting, I'm working on that, too...) and sound. Note: volume cannot be adjusted/muted, so before you start playing certain songs or videos, lower the volume within Youtube/Spotify/iTunes/etc. Especially with headphones... Also note that notifications will be at full volume...
  • I'm working on the rest, including getting Bluetooth and WiFi working with my particular card, getting the other 3 threads working on our i5 APU, fixing sound adjustment, fixing the other USB ports, etc.

Keep in mind that you may need -f and -v boot flags in addition to cpus=1 in order to successfully boot. If you don't -f and -v and see a circle with a line through it on the Apple logo (which is on the splash screen for OSX), you DEFINITELY need -f and -v. At least for now.


  • Ethernet
  • Webcam (works out of box)
  • DVD Drive (works out of box too!)
  • The USB 2.0 port (works out of box)
  • WiFi
  • Sound, including volume adjustment and mute, as well as in-line mics that may be plugged in to the headphone jack, and I think the webcam mic works out of box, I mean it works.
  • Battery + Icon (shows in desktop now too!)
  • HD4000 Graphics
  • A second display (Multi-Monitors!)(HDMI only)
  • Bluetooth
  • Wireless Toggle button ( f12 key ) + Orange/White light change
  • FN action keys Previous, Play/Pause, Next, Volume Up, Volume Down, Mute, Wireless Toggle (pretty much all working out of box)
  • Sleep! (as of 11/20/12)

Not Working (yet?)

  • USB 3.0 ports (USB 3.0 kexts tend to {censored} up my hackintosh, so be careful! I'm on the hunt for a fix too)
  • SD Card reader (may be linked with Ethernet on PCI bus, so perhaps the key is getting Ethernet to work fully?)
  • FN action keys for brightness (DSDT edit required)
  • VGA out (might not even bother with this one, anyone even use VGA still?)
  • HDMI out sound

Definitely not happening

  • Validity Sensors Fingerprint Reader (138a:0018)
  • Our PS/2 touchpad being recognized as a Magic Trackpad (but that would be cool!)

Thanks to eep357 for all the help in getting everything working!

Post-Installation Setup

Firstly, do yourself a favor and show hidden files right now. In Terminal, type or paste in defaults write com.apple.Finder AppleShowAllFiles TRUE

And hit enter. Then type "killall Finder" (must be capital F) without parenthesis, and you're good to go!

For WiFi (AirPort), Bluetooth, Sound (no volume control, caution), Ethernet (must be plugged in before boot) and battery recognition (in lockscreen only atm):

  • Download the m6-1045dx Gatsby Kext Pack
  • Install all the kexts via Kext Wizard (included in Gatsby Kext Pack)
  • Reboot!
  • If Bluetooth or WiFi still do not work, try toggling f12, looking for a light change. Also try booting Linux from a live CD and enabling and connecting both WiFi and Bluetooth to at least one thing, then shut it down the proper way (don't hold power for 5 seconds). But you probably won't need this step! :)

For getting rid of the mandatory-or kernel-panic "cpus=1" boot flag (enabling all cores in your badass Ivy Bridge i5):

  • Replace mach_kernel in System with the one in Gatsby Everything-Else Pack (delete the old one from System first, then copy in the new one).
  • Fix permissions through Terminal (chown 0:0 /mach_kernel ENTER then type
    chmod 755 /mach_kernel ENTER)
  • Reboot!

For changing screen resolution to 1366x768

  • Open chameleon.boot.plist with text editor or whatever tickles your fancy...
  • Change the ONLY value that is "1024x768" to read "1366x768" (if you don't have the m6-1045dx, just replace with your native screen resolution)
  • Save changes (requires your password)
  • Reboot!

For sound (with working volume adjustment/mute via function keys as well as OSX applet):

  • Install the kext in the sound folder of Gatsby Kext Pack 2 (in other words, use the link in this thread's second post)
  • Reboot!

For making your system show up as a Macbook Pro and not an iMac:

  • Replace smbios in /Extra with the one in Gatsby Everything-Else Pack.
  • Reboot! (shouldn't need to fix permissions or what have you)

For HD4000 Graphics Acceleration (makes YouTube, Netflix, second display and Mission Control stuff run smoothly...obviously)

  • With Gatsby Everything-Else Pack open in Finder, browse to HD4000
  • Install legacyAGPM.kext
  • Open chameleon.boot.plist WITH TextWrangler (Google for that...) and at the end add this after the last </string> but before the last </dict>
  • Make sure that all lines up, <key> is lined up with the other rows of <key> and </dict> is on the next line, doesn't have to be flush with the rest of the rows.
  • <key>device-properties</key>
  • Restart!

Idiot- Proofing (Update-proofing...kind of) your Hackintosh (with special guest eep357)


This time around, to prevent your modified kernel from being over written, rename it to something different like ivy_kernel and then add instruction to load it in your org.chameleon.Boot.plist like this:

So then even though mach_kernel may get changed or overwritten it won't screw you up as long as the modified kernel is compatible with the updated version of OSX

Also along same type of thinking, I made this zip.gifAHCI_Multi_Injector.kext.zip(in Gatsby Everything Else pack) which will never be over written by OSX updates unless Apple decides they like my name and make one with the same title :) I made it using the ICH8M info for your laptop and also combined a number of other intel platoforms, Marvel, Jmicron and ASmedia that were scattered around in a few different injectors, to consolidate them all into one super injector. I tried it on mine and my Marvel and ASmedia sata controllers, which both work without doing anything but will show as generic device with orange drive icons if no injector is used, both show as internal with proper name in System Info, so should work for yours too, letting AppleAHCIPort.kext be left untouched and update proof.

Updates usually overwrite mach_kernel and sometimes AppleAHCIPort.kext (driver for your hard drive). As you can imagine, this could really {censored} your hackintosh. Above are preventative measures, thanks to eep357, that should help protect against the destruction caused by OSX updates. I cannot say for sure if after doing all this you can update OSX, do so at your discretion.

For sleep:

Alright I'll be honest...I'm not quite sure on this one. I *think* it only works when the laptop is NOT plugged in to AC power, because when it is, it usually just wakes up after like a second of sleep. Just this morning I literally just put it to sleep unplugged and it stayed asleep for once! So as far as that goes, maybe I should say Sleep mostly works.... Also bear with it, you'll see a black screen for up to like 20 seconds, maybe press a touchpad/mouse button or two if it takes longer than that.

Download (google > osX86.net) SleepEnabler.kext, the "Universal" version, install that with Kext Wizard, then search for NullCPUpowerManagement.kext, and delete it via Finder (search for it within your hard drive, only one should pop up).

NOTE: After waking from Sleep, Bluetooth does not work (methinks it's initialized with the boot process), I'll let you know if a fix comes into existence. WiFi DOES work, so I mean to some people that may not be a problem.

Share this post

Link to post
Share on other sites

what is the file that you are supposed to replace for the ahci? i managed to install but on first boot it went to still waiting for device.




Share this post

Link to post
Share on other sites

Oh, that's what I forgot. I'll upload it separately later tonight (October 23rd), apologies.


EDIT: yeah sorry about that, I had said "by 10/14" :/ well it's up now, have at it!

Share this post

Link to post
Share on other sites

I tried to use Tony's tool and ended up screwing the install with permission errors. Eventually I returned to this post and followed your updated guide. Here are the results....


The wifi light doesn't change (I bought the same chip as you), sleep doesn't work when you close the lid, and brightness is obviously not an option without DSDT. I dual boot with on the 750Gb hard drive which is formatted with the GPT partition scheme.


I have yet to try VoodooSDHC and I also had sleep working with SleepEnabler, but I don't quite remember how exactly....

Share this post

Link to post
Share on other sites

Apologies for the late reply... Try jumpstarting it with a Linux live CD of your choice. Literally enable WiFi and Bluetooth (if not already enabled) and connect to a WiFi network, that should be enough. Then try OSX again, but make sure you shut down the live session properly, don't just hold the power button and eject the disk.

Share this post

Link to post
Share on other sites

Hi, I\m interested in buying the m6-1125dx which seems to be the silver brother, otherwise the configuration is the same

I want to ask you several questions

Is the keyboard lit ok in Mountain Lion?

The battery life is the same as in windows (approximately) or significantly reduced?

Touchpad functions ok?

Thank you.

Share this post

Link to post
Share on other sites



The backlight for the keyboard is controlled by the BIOS, so it'll work with virtually any operating system that boots, including OSX- you're good.


Battery life... the m6-1045dx was supposed to get 7 hours, well BestBuy always lies about that {censored}, and {censored} them for it, I usually get 3-4 hours in Windows or Linux, same with OSX, maybe a little less but it's certainly usable.


Touchpad, like the backlight for the keyboard, pretty much works unconditionally too. myHack for example includes the universal kexts for PS/2 touchpads, which virtually all PC laptops use (PS/2).



Furthermore, I looked up the 1125dx, it's exactly the same as the 1045dx, like exactly, unless BestBuy has its facts wrong, but same processor, same amount of RAM, same HDD size, same screen size, same ports, so you should be good following this guide to a tee!

Share this post

Link to post
Share on other sites

Post for updating to 10.8.2 (Happy Holidays!)


1. Download the 10.8.2 version of our "ivy_kernel" here

2. Move it to the root of your Hackbook's hard drive with mach_kernel and ivy_kernel

3. Name it something other than ivy_kernel and mach_kernel. I called it "new_kernel" since it's new lol

4. Go to your Hackbook's Extra folder, edit Chameleon.boot.plist to boot from new_kernel by default

4b. Open Disk Utility and fix permissions OR don't bother if you boot with the -f flag (skips kernel cache).

5. Update OSX via App Store

6. Restart and tell it to install the update- it'll probably tell you the update failed, just ignore that and reboot anyway

7. Boot with -f, even if you fixed permissions, just to be safe!


8. Yeah so here's the thing, at least with me I had to reinstall the kexts for Bluetooth and WiFi. Actually I just selected all the kexts in the latest Gatsby m6-1045dx Pack (12.06.12) even though things like sound still worked. So do that with Kext wizard and reboot!


That should do it, let me know if it doesn't and I'll help to the best of my ability!




One other thing,

I used Chameleon Wizard to change the SMbios.plist from Macbook 9,2, to Macbook 5,1 to make the updates more relevant to our laptop. For example, now the App Store isn't trying to install a Thunderbolt Firmware update. This probably didn't affect my success with updating to 10.8.2, but if you're having issues this is something to try.

Share this post

Link to post
Share on other sites

Actually as far as battery life goes, I think Windows 8 does a better job, which makes sense since Windows has all the Intel chipset and CPU/GPU drivers and all that jazz.


OSX gives me about 2.5 hours on battery and Windows 8 is rating me at about 5 hours, so 100% improvement... I'm thinking maybe CPU frequency scaling isn't functioning properly on OSX, and since OSX is OSX there's really no way to tell what the frequency is at a given time, it just gives the stock 2.5Ghz. So there's no way to KNOW that that power management kext for Ivy Bridge is actually working, which sucks both ways because power drains faster if the CPU can't scale to 1.2Ghz or so, and when gaming or doing some intensive task there's no turbo to 3.1Ghz or whatever the max is for the 3210M.


Between that and the obvious lack of support for a lot of things on our m6-1045dx (including SD card reader, VGA out, sleep, USB 3.0 ports), it may be a good idea to just run OSX in a virtual machine, after all the m6-1045dx has 8GB of DDR3 RAM @ 1600Mhz, which is something else, like premium for virtualization.


This option is especially suiting if you just need OSX for Xcode (that's me!) or other small-but OSX-only applications. If you're feeling it, simply Google "July 31 Mountain Lion Virtual Machine", the July 31 narrows it down to the specific guide I reccommend. It's actually a pretty-simple guide and it links you to virtually all the files you need. I forget if the guide mentions this, but the Mountain Lion ISO I used for the install is called "Mountain Lion for Intel PCs DVD" (NOT USB) or something close to that, and it can be found at The Pirate Bay.


And I'm iffy on Guest Additions for things like shared clipboard between host and guest OSes, Virtualbox only officially supports OSX Server, but internet should work out of box... I forget, I think if you install OSX and Ubuntu is the host, you may have problems getting internet shared to OSX from host Ubuntu, though I *think* that was fixed in 12.04 and up.


Hap Holidays!

Share this post

Link to post
Share on other sites

Sound Fix


Set Chameleon to boot with "busratio=13", just found this fix on Google and it actually works, not sure why...



EDIT: That doesn't 100% do the trick, in fact I'm not sure it does the trick at all...


Here's the "real" fix:


Go to S/L/E and delete VoodooHDA.kext


Play it safe and in Utilities > MIDI Audio Setup change the frequency from 192000 Khz to 48000 Khz.


That should, at the very least, keep the sound from cutting out MOST of the time. I'll let you know in a few days if this turns out to fix it 100%.

Share this post

Link to post
Share on other sites

Good news, everyone! The following now work:



Brightness adjustment with F2 and F3 action keys

Three-finger gestures on the touchpad


Unfortunately the fix is in "beta", as the kext that gets you both of the above needs tweaking... For example, Fn is now required for the actions keys, so like Fn + F2 decreases brightness. I assume disabling Action Keys Mode in the BIOS will remedy this.


Also, F9, the volume down key, actually increases volume while F8 (skip forward) is volume down, so the kext needs slight tweaking for our particular keyboard layout, but that shouldn't be too hard. Three-finger swipe, well right now it just makes the notification sound for when you press an incorrect key or what have you, so we'll have to reassign the keyboard shortcuts. As per the kext, which I'll link shortly, it's something like three swipe left and right are " and ' ... oh that's not good. So I...or someone out there who wants to help out, will have to modify the kext in that regard as well. Because it beats {censored} with the DSDT IMO.


So yeah hopefully that brightened your day/night a little bit.


EDIT: You can fix three-finger scrolling, just go to the keyboard mapping settings and double click the command shortcuts to change them. When they are highlighted (prompting for new key combo) just three finger swipe instead of entering a key combo...If that makes sense. So like for "Move left a space", I just three finger swipe left to right, and it replaces the highlighted combo with whatever key combo it is that the VoodooPS2.kext has assigned to represent three finger swipe left, which looks like Option + [.


Anyway do that with the four three finger swipe directions, up, down, left and right. I think officially left and right should move between desktops and up should show desktop, down should show Mission Control. But make it whatever you want, that's the cool thing about OSX!

Share this post

Link to post
Share on other sites

THANKS A LOT man. I would like to confirm that this guide and the kexts work flawless with Hp Envy m6(1178sa). Can you please upload the kext for brightness and gestures?

Share this post

Link to post
Share on other sites



I'm godawful with maintaining this thread... Apologies, here's the link to that brightness and three-finger swipe kext pack.


Keep in mind it screws up the mapping for action keys- everything works without action keys mode, so F2 is brightness down as opposed to FN + F2. Also volume down is volume up, skip is volume down or something like that... It breaks more than it fixes really, but it's only a matter of editing the kext.


I no longer own the m6-1045dx, so I'm officially done working on it, but for {censored}'s sake, someone else take over, it's not too, too difficult.


I'd also like to thank those who helped me get this guide as far as it is today, and for letting me test drive OS X before committing to a Macbook Pro.


Good luck all!


This may help in remapping the action keys:


Share this post

Link to post
Share on other sites

I would like to comment, that I registered and completed both "quizzes" to give you my thanks, for this post and dropbox link for your used kexts. I own an M6-1045DX I picked up from best buy as an EOL piece post Win8 release, and was interested in putting OSx86 due to it's Intel base. I put Snow Leopard on my Asus G71GX-RX05 (best buy model) without major hitch, and ran into some incompatibility issues with Snow Leopard and my Ivy Bridge in my HP.


The only thing I've done was put a spare OCZ Agility 3 90GB ssd in my M6, everything else is stock. I'll report back when I convince my buddy to drive over with his macbook pro to make a myHack flash drive.


I would also like to mention you can invert the action keys. Under System Configuration, Action keys.


Disabled: Requires pressing Fn key + f1 through F12 to activate action keys

Enabled: Requires pressing only f1 through f12 to activate action keys


Not sure what this changes for the kext, but figured I'd make mention of it. I'm using bios rev 3.7 (not updating until I find out which one is ideal).

Share this post

Link to post
Share on other sites

Thanks for taking the time to reply!


Yes, by default the action keys work in OS X with Fn + F2 or whatever, but with these new kexts, it's just F2. So if Action Keys Mode is Enabled in the BIOS, then you must press Fn + F2 instead of just F2.

Share this post

Link to post
Share on other sites

I was succesfull for all steps, however did not update to 10.8.2, get a wifi card, test sleep mode or sound. I give you my thanks, and will post again if I make any progress with USB.

Share this post

Link to post
Share on other sites

Hm, having troubles getting Mac to recognize my wifi card. The light on F12 shows red, but when I boot a 11.04 Ubuntu CD the light is blue and I can connect to networks. I think the issue may stem from the OS not actually turning off when I hit Shut Down...


AR5B195 btw.

Share this post

Link to post
Share on other sites

99% of WiFi cards don't work with Hackintoshes... Come on man, read the guide, it clearly says several times that I'm using an AR5B195 WiFi/Bluetooth card. The card that comes with the m6-1045dx or really any HP laptop will not work... Of course it will in Ubuntu, that's not abnormal.

Share this post

Link to post
Share on other sites

I am using the AR5B195. I edited my post after the fact to mention it, you probably just didn't notice my edit.

Share this post

Link to post
Share on other sites

Just tried it again. I even tried a couple from google searches from osx86net. I have a older Ubuntu 11.04 Live CD, I get a weird error during startup, but I connect to WiFi fine (even after off/on switch). I would imagine it would "save" it's "on" state to the BIOS on power off, but it doesn't shut down properly. It will eject the drive and hang on the purple-ish rosey screen (sorry, colorblind.)


I've made a Ubuntu USB from 11.04 off of the usb-creator.exe located on the disc image, but that doesn't boot.

I also tried making a bootable USB with UNetBootin pulling the latest Ubuntu distro and it again has failed to boot.


I have the 750GB the HP came with, I guess I'll swap the HDD in place of my SSD just to get WiFi on and functioning, and then switch back to the SSD after a proper power off.


edit: grammar.


edit2: also, should I update my bios to latest supplied from HP while I'm at it? AKA, do you have it on and it's running properly?

Edited by Korpsicle

Share this post

Link to post
Share on other sites

No dice.

  • ssd to hdd with windows
  • installed drivers
  • turned them on and connected
  • updated bios
  • restarted
  • wifi was on already, connected
  • swapped hdd to ssd with mac
  • no wifi adapter in network utilities or ability to add as interface
  • F12 and FN+F12 make no change.


I'm stumped. How do I get this damn thing to turn on? lol.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By shinho73
      I need a good vanilla guide for AMD A8 7600 with A58M-E FM2+ mother board and Palit GEforce GT 730. Any help will be greatly appreciated. Thank you.

    • By MaLd0n
      ---Original Post---
      ---CLOVER FOLDER---
      GigaByte Z390 M Gaming

      Intel Core i9-9900K

      CoolerMaster MasterLiquid ML120R RGB

      Corsair Dominator Platinum 16GB (2 x 8GB)

      Sapphiretech Radeon RX 590 8 GB GDDR5

      Samsung 970 EVO NVMe M2 Flash Drive

      EVGA 750 N1, 750W

      TP-Link Archer T9E

      Orico BTA-403

      Thermaltake View 21 Tempered Glass Edition

      --DSDT Patches--

      --USB-C-- test with SanDisk Ultra USB-STICK 128gb

      -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!
      Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Apple, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad, Sampath007, onemanosx, erroruser, Jenny David, Olarila Facebook Community, Hackintosh Facebook Community and many others!
      We're all here to have fun and learn from each other!
    • By dracoflar
      So you've been reading the forum on this brand new boot loader called OpenCore hoping to try it out but you take one look at the configurations PDF and take a step back in shock at the complexity! Well if you've been feeling a bit intimidated by the DOCS well you've come to the right place:
      OpenCore Vanilla Desktop Guide
      If you have any issues or suggestions please feel free to comment
      - Your local neighbourhood Hackintosh Slav
    • By JackBauer24
      I have installed OSx86 10.11 (El Capitan) on April 2016 on my Asus Z170 Deluxe system.
      For installation I used this Thread.
      I used it a lot and it worked well. Meanwhile I switched to Linux and I use Win10 time to time. So OSX was forgotten. Also it did not boot correctly anymore.
      Now I wanted to start with a fresh installation and use OSX more often again. I want to use OSX 10.13 High Sierra. Is it working on my Asus Z170 Deluxe? I have the same Hardware as of April 2016 only the graphics card was updated to a Nvidia GTX1080.
      My Hardware in detail: Asus Z-170-Deluxe (Bios 3801), i7-6700k, EVGA GeForce GTX 1080 SC GAMING ACX 3.0, Samsung 950 Pro/M2 NVME 512MB, HDD 4 TB)
      Can I use some of support files from the old thread for the installation (see attachment)? Can I still use  Clover 2.3k r3292 Special Edition v2 ? Or do I need a newer version?
      Has someone installed High Sierra successfully on the Asus Z170 Deluxe ?
      About some hints where to start I would be thankful.
    • By steamteam
      Hey everyone,
      after years I come back to Hackintosh. In the early days I played with ozmosis and my good old 4700k. Now I'm back and worked around a 100% working setup with enough power to get me through all my tasks like audio, video cut etc.
      In this short tutorial I will guide you through BIOS Settings and give you access to my EFI Folder. This I do because I haven't found anything on the web for my setup. Maybe it will help some of you. When you follow the steps you will have a perfect running Hackintosh  like I do have now  
      I've chosen the iMac 18,3 because of the easy integration of both Graphic Units and the support of HEVC. 
      CPU: Intel i7 9700k (Overclocked in Bios to 4,7 GHz)
      SMBIOS: iMac18,3 (Because of Dedicated Graphics and HEVC Intel Support)
      RAM: 32GB G.Skill Trident Z RGB DDR4-3200 DIMM CL16 (XMP Profile to 3200MHz)
      Motherboard: MSI MPG Z390 GAMING PRO CARBON (MS-7b17) <- It's the model without WLAN/Bluetooth
      Graphic Card: Sapphire RX580 Nitro+
      Bluetooth & WLAN: Broadcom Card in PCI Adapter
      What is working: 
      Almost everything! All USB Ports, Intel Power Management, Bluetooth, WLAN, LAN, Intel Graphics HEVC, Boot/Reboot, Sleep
      What is not working: 
      Facetime & iMessage (Don't need it but I will come back to this)
      1. Create Mojave 10.14.5 USB Drive | https://www.youtube.com/watch?v=9CZDXxKfodE&amp;t=95s | Us this tutorial or search the forum
      2. Load my EFI Folder: https://workupload.com/file/zkJ4zdQk
      3. Go into your bios and use my settings in the Screenshot I attached 
      4. Boot from USB Stick | Install Mojave | Boot into Mojave (Check other Tutorials if you don't know how)
      5. Generate Serials with Clover Configurator
      6. Happy Hackintosh Life! 
      Kext I use:
      AppleALC.kext | Needed for Sound
      BrcmFirmwareData.kext | Needed for my WLAN/Bluetooth Card 
      BrcmNonPatchRAM2.kext | Needed for my WLAN/Bluetooth Card 
      BrcmPatchRAM2.kext | Needed for my WLAN/Bluetooth Card 
      CodecCommander.kext | Fix Problems after Sleep
      CPUFriend.kext | Perfect Power Management for my CPU
      CPUFriendDataProvider.kext | Perfect Power Management for my CPU
      FakePCIID_Broadcom_WiFi.kext | Needed for my WLAN/Bluetooth Card 
      FakePCIID.kext | Needed for my WLAN/Bluetooth Card 
      FakeSMC.kext | Standard
      IntelMausiEthernet.kext | Ethernet
      Lilu.kext | Standard
      USBInjectAll.kext | To fix all USB Ports
      WhateverGreen.kext | Needed for graphics
      If you have success with my little tutorial and EFI Build let me know! Hope you reach the desktop and will be happy!