Jump to content
pete.biggs

Frustrating lag/choppy graphics on Asus P5K Premium wi-fi / Asus 8800GT TOP / Q6600

7 posts in this topic

Recommended Posts

Hi all,

 

I've been successfully running Mac OS on my Asus P5K machine with an Intel Q6600 for quite a few years starting with Snow Leopard and was most recently on Lion 10.7.4 with everything working using:

  • spanakorizo's dsdt.aml from the thread http://www.insanelym...ack-pearl-only/
  • Chameleon (latest version)
  • fakesmc v3.1
  • VooDooHDA 2.7.2 for sound
  • evoreboot.kext to help with sleep/restart performance

I've hit a few problems along the way but I've always managed to work them out. However, in Mountain Lion I'm experiencing a strange UI lag/choppy graphics and videos getting the 'hiccups' or freezing up completely. Often when I type there is a delay between pressing the keys and the letters appearing on screen, scrolling is jerky and icons in the dock don't 'bounce' smoothly.

 

I've never had any graphics problems with the 8800GT before, it has always seemed very compatible.

 

To test I have created a new ML installation from scratch and installed Chameleon and fakesmc. I have been careful to take things one step at a time so I tried booting without the dsdt.aml and made an interesting discovery - I don't need the dsdt.aml after all!

 

It doesn't seem to make any difference either way, so I've removed it. I presume this is due to improvements over the years in Chameleon.

 

In ML I lost ethernet, so I installed the realtek drivers which fixed that. But I still have this frustrating lag!

 

So far I've tried:

  • installing the latest official nvidia drivers for Mac (which were released last week and list the 8800GT as supported) - this makes no difference at all.
  • Upgrading fakesmc to the latest version - this made no difference either.
  • Flagging GraphicsEnabler=0 on boot too, this just results in a black screen after boot (as I expected, as the 8800GT isn't a card with supports this AFAIK).

I'm not sure what to try next - Google suggests that choppy/laggy graphics can often be a problem in ML but there are more threads about real Macs than hacks, which in a way isn't reassuring!

 

Surely my 8800GT is powerful enough to deliver the graphics when ML is basically idling? It can't be new graphics card time already, can it?!

 

Can anyone help?

 

Thanks,

 

Pete.

Share this post


Link to post
Share on other sites
Advertisement

I think it's the other way around. It's time for your old DSDT to evolve so it can actually do more and enable more advanced native power management. Now that your booted without one, use Chameleon Wizard or DSDTSE to extract a new unmodified one from your bios. If using DSDTSE you can also extract your SSDT tables at the same time, which wouldn't be a bad idea. Next you'll want DSDT Editor available here or at Olarila.com and use it to apply the attached patch file, which is specific for your mobo, also courtesy of our friends at Olarila.com. Once patch is applied, compile it and save as DSDT.aml and place in /Extra. If you also extracted SSDT tables, rename them as SSDT.aml, SSDT-1.aml, SSDT-2.aml and so on, doesn't matter which ones are named what. Also place them in /Extra and remove nullcpupowermanagment.kext, then from org.chameleon.Boot.plist remove any generate P or C states and add:

<key>DropSSDT</key>
<string>Yes</string>

reboot

 

Also check that AppleGraphicsPowerManagement.kext is being loaded, along with AppleLPC.kext and that you have valid SMBIOS that matches your hardware as best as possible, likely MacPro 3,1. Someone correct me if AGPM doesn't load when using MacPro 3,1, can't remember for certain if it does for that model.

P5K Premium Wifi.txt

Share this post


Link to post
Share on other sites

Someone correct me if AGPM doesn't load when using MacPro 3,1, can't remember for certain if it does for that model.

...macpro3,1 doesn't invoke AGPM... :smoke:

Share this post


Link to post
Share on other sites

So that means 3.1 was the right choice for the smbios.plist? It seems to be anyway as I followed the instructions and wow - the lag is gone!

 

Thank you so much eep357. Everything is super smooth :)

 

The only problem I have now is that youtube/vimeo videos stop after exactly 11 seconds still. I've tried other sites and so far fine...

 

Is this likely to be related, or a different problem?

Share this post


Link to post
Share on other sites

Sweet, that's how we do it!! 11 seconds is odd and sounds like a different problem. Try chrome, firefox, etc. and see if any different

Share this post


Link to post
Share on other sites

Guys, 

 

I'm experiencing a similar experience to Pete's here ... though I'm using a GeForce 8800GTS 512, I managed to get my hackintosh to identify the video cards (i used to run two on SLI back on Windows), only that I get choppy performance & no video output on vlc / mplayerx.

 

I could try to remove the DSDT file I'm currently using, but need help with editing the patched file that eep357 kindly shared with Pete. 

 

Would appreciate your help in this.

 

Thanks in advance   :)

post-723059-0-07908500-1373380786_thumb.png

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×