Jump to content
  • ×   Pasted as rich text.   Paste as plain text instead

      Only 75 emoji are allowed.

    ×   Your link has been automatically embedded.   Display as a link instead

    ×   Your previous content has been restored.   Clear editor

    ×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By DiscoDancer
      Specs:-
      CPU: 9700k
      MOBO: MSI Z390 Gaming Pro Carbon AC
      GPU: Sapphire 5700XT Nitro

      The problem I am facing is with the way RGB is behaving in MacOS. I have couple of fans connected to the ARGB and RGB headers on my motherboard and the motherboard it self has some lights.
      The problem is that when I boot into MacOS the RGB freezes completely and doesn't recover even after rebooting into windows or shutting down the machine. I have to completely disconnect power and wait for 10-15 secs for the RGB to reset.
      At first I thought that it's a USB issue as there's an internal USB device present called 'Mystic Light' so I mapped it in the SSDT but that didn't fix the problem. Then I put in the limit patch and removed USB map to inject all ports that didn't fix the problem either. I also set up proper 'EC' device and still nothing.
      I have tried just about everything I could I even tried purposefully breaking nvram support then setting up RGB in windows and then booting back into MacOS. I am completely out of ideas and would be grateful if someone more knowledgeable than me would like to have a look.

      I had initially set up the machine with OpenCore but then I switched to Clover thinking OC might be the issue so I will attach both OC and Clover configuration. They are WIP as I am stuck on fixing this problem before jumping on other things.
      Clover.zip
      OC.zip
    • By MaLd0n
      Now have a Olarila app, just download app and clover folder for your Chipset! https://www.olarila.com/topic/5165-olarila-app-images-and-folders/   Nehalem, SandyBridge, IvyBridge, Haswell, Broadwell   https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Skylake, Kabylake and Coffeelake is here https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/   Install MacOS with Olarila Image, Step by Step, Install and Post Install
       
      https://www.olarila.com/topic/5794-guide-install-macos-with-olarila-image-step-by-step-install-and-post-install-windows-or-mac/
          First...   ***Update bios to last available version!***   If you need a full patched DSDT...  -Extract tables with F4 key in Clover boot screen! -Run it and send me files! RunMe.app   Installation   --Create a bootable copy of macOS Sierra / High Sierra / Mojave   https://github.com/chris1111/Create-Install-Media/releases   --Install Clover in USB stick   https://github.com/CloverHackyColor/CloverBootloader/releases   --Replace with my Clover folder https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Install Sierra/High Sierra and boot into system!   Post Installation --Install Clover and replace with my folder   https://www.olarila.com/topic/5676-clover-folder-for-all-chipsets/   --Reboot and activate video!   Bingo!   Now you need a fine tune! DSDT time!   --DSDT   Patches -FIX ERRORS AND WARNINGS -HPET -SATA -DMAC -SLPB -DARWIN -LPC -XHCI -PLUGIN TYPE -XXXX to HDEF -HDEF -RTC -IRQs -SBUS -BUS1 -MCHC -ALS0 -SHUTDOWN -LAN -USBX -PMCR -EC -PNLF -HDMI
       
      --Power Management
      - 1 Generation Intel Processors, use Generate P and C States in config.plist
      - 2 and 3 Generations Intel Processors, Generate SSDT with Piker script and drop CpuPm and Cpu0Ist SSDTs
      ssdtPRGen.command.zip
      Credits-https://github.com/Piker-Alpha/ssdtPRGen.sh
      - 4 Generation+ Intel Processors, use PluginType=1 in DSDT, SSDT or Clover config.plist
       
      for check Power, Frequency, Temperature and Utilization, use it
       
      Install Intel Power Gadget.pkg.zip
       
      --Brightness
      Install .app, select the required permission and reboot. Work in F1 / F2 keys!
      NativeDisplayBrightness.app.zip


      https://github.com/Bensge/NativeDisplayBrightness/releases
      *in some cases .app don't work, check patches in config.plist inside Clover folder Post Install
       
      --Clover
       
      https://sourceforge.net/projects/cloverefiboot/files/Installer/
       
      --AUDIO
       
      Use DSDT + AppleAlc
       
      --install Lan driver by Mieze
        -Atheros   http://www.insanelymac.com/forum/files/file/313-atherose2200ethernet/   -Intel   http://www.insanelymac.com/forum/files/file/396-intelmausiethernet/   -Realtek   http://www.insanelymac.com/forum/files/file/88-realtekrtl8111-binary/   --Links   -FakeSMC   https://bitbucket.org/RehabMan/os-x-fakesmc-kozlek   -Audio   https://github.com/vit9696/AppleALC http://www.insanelymac.com/forum/topic/314406-voodoohda-289/   -USB   https://bitbucket.org/RehabMan/os-x-usb-inject-all/downloads   It's time to Rock   -Credits and thanks to the old and new people in the community who developed patches, kexts and bootloaders!   Apple, Slice, Kabyl, usr-sse2, jadran, Blackosx, dmazar, STLVNUB, pcj, apianti, JrCs, pene, FrodoKenny, skoczy, ycr.ru, Oscar09, xsmile, SoThOr, RehabMan, Download-Fritz, Zenit432, cecekpawon, Intel, Oracle, Chameleon Team, crazybirdy, Mieze, Mirone, Oldnapalm, netkas, Elconiglio, artut-pt, ErmaC, Pavo, Toleda, Master Chief and family, bcc9, The King, PMheart, Sherlocks, Micky1979, vit9696, vandroiy2013, Voodoo Team, Pike R. Alpha, lvs1974, Austere.J, CVad and many, many, many others!   We're all here to have fun and learn from each other!  
    • By nukebuzag
      Hi, my name is Javier, i'm trying to install a Mojave Clean Installation, following the guide but allways is stopped with "alloc type 2". I've been searching the forums for 4 days, I've tried everything they say, but I can't fix the error. I'm trying to add the driver "OsxAptioFix2Drv-free2000.efi", "OsxAptioFixDrv-64.efi" and "OsxAptioFix3Drv.efi" but don't work... My current hardware is:

      Motherboard: MSI X299 GAMING PRO CARBON AC, bios.v-E7A95IMS.180
      CPU: Intel core i7-7820X
      HardDrive: Samsung 960EVO NVMe M.2 500Gb
      GPU: SAPPHIRE Radeon RX Vega64 8GB HBM2
      RAM: 32Gb - x4 8Gb - Corsair Vengeance RGB DDR4 3600

      Please can anybody help me? Thanks you very much
      EFI.zip
    • By steamteam
      Hey everyone,
       
      after years I come back to Hackintosh. In the early days I played with ozmosis and my good old 4700k. Now I'm back and worked around a 100% working setup with enough power to get me through all my tasks like audio, video cut etc.
       
      In this short tutorial I will guide you through BIOS Settings and give you access to my EFI Folder. This I do because I haven't found anything on the web for my setup. Maybe it will help some of you. When you follow the steps you will have a perfect running Hackintosh  like I do have now  
       
      I've chosen the iMac 18,3 because of the easy integration of both Graphic Units and the support of HEVC. 
       
      Specs:
       
      CPU: Intel i7 9700k (Overclocked in Bios to 4,7 GHz)
      SMBIOS: iMac18,3 (Because of Dedicated Graphics and HEVC Intel Support)
      RAM: 32GB G.Skill Trident Z RGB DDR4-3200 DIMM CL16 (XMP Profile to 3200MHz)
      Motherboard: MSI MPG Z390 GAMING PRO CARBON (MS-7b17) <- It's the model without WLAN/Bluetooth
      Graphic Card: Sapphire RX580 Nitro+
      Bluetooth & WLAN: Broadcom Card in PCI Adapter
       
      What is working: 
       
      Almost everything! All USB Ports, Intel Power Management, Bluetooth, WLAN, LAN, Intel Graphics HEVC, Boot/Reboot, Sleep
       
      What is not working: 
       
      Facetime & iMessage (Don't need it but I will come back to this)
       
      Steps:
       
      1. Create Mojave 10.14.5 USB Drive | https://www.youtube.com/watch?v=9CZDXxKfodE&amp;t=95s | Us this tutorial or search the forum
      2. Load my EFI Folder: https://workupload.com/file/zkJ4zdQk
      3. Go into your bios and use my settings in the Screenshot I attached 
      4. Boot from USB Stick | Install Mojave | Boot into Mojave (Check other Tutorials if you don't know how)
      5. Generate Serials with Clover Configurator
      6. Happy Hackintosh Life! 
       
      Kext I use:
       
      AppleALC.kext | Needed for Sound
      BrcmFirmwareData.kext | Needed for my WLAN/Bluetooth Card 
      BrcmNonPatchRAM2.kext | Needed for my WLAN/Bluetooth Card 
      BrcmPatchRAM2.kext | Needed for my WLAN/Bluetooth Card 
      CodecCommander.kext | Fix Problems after Sleep
      CPUFriend.kext | Perfect Power Management for my CPU
      CPUFriendDataProvider.kext | Perfect Power Management for my CPU
      FakePCIID_Broadcom_WiFi.kext | Needed for my WLAN/Bluetooth Card 
      FakePCIID.kext | Needed for my WLAN/Bluetooth Card 
      FakeSMC.kext | Standard
      IntelMausiEthernet.kext | Ethernet
      Lilu.kext | Standard
      USBInjectAll.kext | To fix all USB Ports
      WhateverGreen.kext | Needed for graphics
       
       
      If you have success with my little tutorial and EFI Build let me know! Hope you reach the desktop and will be happy!
       






    • By Gorec
      Hi.
      I apologize in advance if I didn't post in the right category and if my title and description aren't specific enough :c
       
      My config in a nutshell:
      CPU: i7 5820k GPU: MSI GTX 1060 3GB RAM: 16 GB MOBO: MSI X99 SLI PLUS I attached RunMe output with all the details of my built.
       
      Some background:
      I have my Hackintosh for about half a year. That time I managed to make it works and fix major issues, but some of them left unresolved since then and I ignored them until now.
      I use my Hackintosh for Adobe projects (PR, AE, PS, IL, AU and a lot more) - most of them connected with video editing of course browsing with Chrome and other small tasks.
       
      Problems:
      Random restarts - this is the biggest one. I'm starting to work on bigger and bigger projects and at this time I think I can't allow this to happen that often. In the past, they happened like once a day or a couple of times a week. However, now it's just frustrating when it happens even 5 or more times a day. I've tried to observe and find out what can be the cause but I haven't managed to find any connections. I thought it happens when Premiere or another app is using GPU, but I haven't seen increased usage when it restarts. I think that it can be connected with GPU, memory or PSU or... meh, anything else. I don't have resources to check if it'll work with other components. There should be some fix for this. I will really appreciate any help with this :c Restart instead of shutdown & sleep doesn't work. I've tried to look through some Google results for this and tried many solutions (as you can see in attached Clover folder), but I think the right one for many of these issues is to make my own DSDT. Glitches, freezes and other things while encoding a video. It happens very often when I try to do this. Maybe it is an issue with GPU or (hopefully) only with GPU drivers which can be fixed with some patch. Today my headphones stopped working. I have a multi-output device configured in the Audio MIDI Setup app which includes my headphones (HyperX Cloud via USB) and Soundflowerbed virtual audio device for capturing system audio. Today while I was trying (like 15 times) to encode a video in Media Encoder in the background and watch video on YouTube I stopped hearing anything from my system. Of course, it restarted a couple of times as always, but even this didn't solve this. If I plug them directly with mini jack (not via USB Soundcard which was in the box and which I always used) in the front IO or the back I only hear some loud noise It takes EX-Fat formatted volumes a few minutes to mount after each restart. I found a workaround to format it with NTFS since I have Tuxera installed and I will reformat these volumes when I will find time for this, but maybe there is some fix for this. GPU is a little bit hot. HW Monitor shows it is only 45-55 degrees, but for my hand is a little bit hot, idk. Also related to GPU - glitch after POST but before entering Clover boot menu. It is a black screen with little white squared glitches for a few seconds. Maybe it indicates the GPU drivers are loading, but maybe it shouldn't be like this. And if I can ask about that - I can't make all applications hide on startup. I, obviously, have "Hide" checkbox checked on every login item in settings, but it doesn't work, none of the apps is hidden in the dock. Is there a way to fix this? Also a small but annoying problem - I can't turn off permanently Mojave update notification (since I tried to install it, and I had to reverse to High Sierra because I had a black screen and I didn't have time for repairing all of them. Tags are not working in Finder - every time I tag a file or folder and make a change in it (for example save a text file) the tag disappears.  
      So, with knowing all of that, is there a way to make a proper DSDT file for my Hackintosh? I tried to look through some guides on how to make it but I think I reached my abilities to understand how Mac OS works and what all of these things are, so I'm asking you guys politely, would someone like to help me? At least with these random restarts? :/
      I really begin to think that I'm a newbie in configuring all of that Clover things - even after what I managed to do with my PC. Help me, pleease... :c
       
      If you have any questions post it below, I will really appreciate any help <3
      Send me MBP-Gorec.home.zip
×