Jump to content

eMachines W3502 / Intel D101GGC MB

3 posts in this topic

Recommended Posts

I had this PC for 5 years, and these were the specs out of the box:


CPU: 3200 MHz Intel Celeron D

HDD1: 80GB Western Digital UATA

RAM1: 512MB Samsung DDR

GPU: 128MB ATi Radeon X200

MB: Intel D101GGC



Today, I pitched in enough for upgrades, and this is what I got now:


CPU: Same

HDD1: 320GB Hitachi HDT725032VLA360 SATA

HDD2: 750GB Seagate ST9750422AS SATA (this used to be part of an external GoFlex drive until I broke apart the USB interface/outer shell and reveal the HDD itself)

RAM1: Same

RAM2: 1024MB "MemoryPower" DDR (I guess this is one of those aftermarket chips)

GPU: 256MB BFG nVidia GeForce 8600 GTS (overriding the on-board ATi)

MB: Same

PCI2: IOFlex 5-port USB controller


Based upon everything that was stock before, OSX installer would start up, however, it would not allow me to use the mouse or keyboard. I would even keep trying "USBBusFix" kernel flag and still no result. Today I just bought and installed the IOFlex USB controller today, and that was when I was able to use the mouse! The on-board USB ports continued to display "Unable to initialize UIM" messages on all of its outlets, however, this didn't seem to happen much with the USB outlets on my PCI card, so that is the only way to get something to work, at least the mouse.


So far, I have not yet installed OSX nor tested any other components/hardware on the MB. I can tell you right off the bat that on-board USB will not work. More to come later. :)

Link to comment
Share on other sites

  • 2 months later...

About a month ago, my Celeron D 351 chip stopped working. Luckily, I was able to order a replacement and an upgrade for under $30 - a 3.4GHz Pentium D 945! I also upgraded RAM to 2GB after purchasing a Mushkin 1GB PC3200 stick.


After I ran several distros, I am able to get Leopard 10.5.2 (Leo4All) working and a few other topics did have a kext or two for sound and network. I do have a Belkin F7D1101v1 and an old Linksys WUSB54G, both wireless adaptors, can't get either of them to work. Coming soon, I'll post a YouTube video showcasing first boot.


So far, no go on Snow Leopard 10.6, Lion 10.7, or later.

Link to comment
Share on other sites


  • Create New...