Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
am0nrahx

No DHCP with Netgear GA311

3 posts in this topic

Recommended Posts

I have a test machine running Mac OS X Leopard 10.5.7 and it sees that there is a NIC but it will not pull an address. I have tried setting the IP Address manually which results in no network connection.

 

Can someone give me some direction or point me in the direction to get this fixed?

Share this post


Link to post
Share on other sites

I have the exact same problem! I tried booting with linux just to make sure there was no issue with the card, and it works perfectly. Only in OSX does it give an issue. FYI, I believe I Had it working in Leopard, but it's been awhile since I used it. I can't get it to work with neither Lion, nor Mountain Lion as I tried both.

Share this post


Link to post
Share on other sites

Alright, I figured it out for me. The wrong kext was being loaded. How to figure out ... look at your system report (About This Mac | More Info ... | System Report ... | Ethernet Cards )

 

Mine was listed incorrectly as:

 

 

Kext name: RealtekR1000SL.kext

Location: /System/Library/Extensions/myHack.kext/Contents/PlugIns/RealtekR1000SL.kext

 

I moved that kext to /System/Library/Extensions/myHack.kext/Contents/PlugIns/RealtekR1000SL.kext.disabled and rebooted.

 

Now I get:

 

 

Kext name: AppleRTL8169Ethernet.kext

Location: /System/Library/Extensions/myHack.kext/Contents/PlugIns/AppleRTL8169Ethernet.kext

 

And everything works splendidly. (http://myhack.sojugarden.com/)

 

There's a native Apple one too, but because I'm using myHack, this is what it loaded.

 

I've shared the kext here for your convenience: http://ge.tt/91nFaBP/v/0

 

don't forget to rebuild your cache. I'd only try this one if you have the same problem as I did, and the system one does NOT work. (I'm not trying the system one since mine works)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×