Jump to content
Sign in to follow this  
Weishauptus

Strange Artifacts 10.8.2 Asus ENGT520 SILENT

2 posts in this topic

Recommended Posts

  • GA-EP45-DS3 (correct dsdt for bios)
  • SMBIOS Mac Pro 3,1
  • Asus ENGT520 SILENT
  • 10.8.2
  • latest Chimera

Experiencing some very odd artifacts that appear rather randomly.

3D/OpenGL stuff and Heaven Benchmark runs through continously and without errors, even with max AA and max AF turned on. I appear to have QE/CI working and dual Monitor too, the artifacts appear on both monitors and concentrate mainly on menu elements, icons and filenames.

 

The Graphics Adapter is brand new and does not appear to have any thermal issues under load (tested with my bare hands) and does not show any other abnormalities. After sleep, the artifacts tend to disappear for a while. After longer use (not neccessarily under load!) they reappear.

 

Currently I am using the stock NVDAGF100Hal.kext, patched with the correct device/vendor ID.

I installed the newest Chimera and deleted Appleupstreamuserclient.kext (if that is of any relevance).

Regardless of whether i boot with GraphicsEnabler enabled or disabled, I am seeing the same symptoms.

Also I am not using any special kexts other than HDAEnabler.kext and RTL-kext by lnx2mac.

 

Cinebench and Heaven results are what is to be expected of this card.

Since the System (GA-EP45-DS3, Q6600 on stock speed) is running vanilla and has been working with the proper DSDT for a couple of months now, and the only new component is the GPU, i guess that the card has faulty VRAM or something along those lines. But since stress tests do not make the system lock up or heat up for that matter, I was wondering whether someone else experienced similar issues. My searches in several forums did not bring up anything useful.

 

I have attached a couple of Screenshots (yep, the artifacts show up on screenshots).

Other than the artifacts the system is smooth and runs well.

 

Oh and I tried several options for the Gigabyte Robust Graphics Booster in the BIOS (AUTO/Fast/Turbo), but there does not really be a way to turn it off. However I cannot imagine that such a marginal overclock, if it even does anything at all, would cause such heavy artifacts.

 

- any ideas for a fix regarding the visual glitches?

- any way to do an artifact test under osx? i know of ways in windows, but the machine does not have a windows install available to test atm

- chances for this being a hardware defect? i am betting on corrupt vram or the likes

 

thanks in advance for any help offered :)

 

Guess this is a Fermi issue? The latest nvidia drivers do not show support for the GT520 though, should i try to install them?

post-491669-0-98117600-1348940132_thumb.png

post-491669-0-41120500-1348940150_thumb.png

post-491669-0-44041000-1348940151_thumb.png

Share this post


Link to post
Share on other sites
Advertisement

..maybe try the new drivers for 10.8.2... http://www.insanelymac.com/forum/topic/283299-nvidia-retail-drivers-for-1082-3040005f02/ ...not sure why you deleted Appleupstreamuserclient.kext....but if you can ...put it back...you will probably need the opencl fix as well... http://www.insanelymac.com/forum/topic/266318-opencl-fix-for-non-gf100gf110-cards-aka-ccsm-21/page__st__80#entry1852666 ...and i don't use GraphicsEnabler at all...it just works... :smoke:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By verymilan
      Hi, i recently set up High Sierra on my AMD computer with the help of the amdosx community (i actually used an installer just to confirm that something would work in the first place before i spend hours for nothing, i can and could have downloaded High Sierra the "legal" way).
      However the graphicscard is recognized properly, the 6gig are recognized and i have no artifacts and no screen tearing with the official nvidia webdriver,
      but unfortunally, dark colors have horizontal dark stripes in them and specific bright colors like on left bar of system windows such as settings do flicker like low fps.

      I only used the clover on the flash drive for now and i'd like if it's worth digging deeper of if i should just forget about it as it is a common nvidia problem on macOS.
      Would be amazing to know.
       
      Closer machine infos:
      * High Sierra (misses a recent minor patch as my network is veeeery slow and i got this nvidia issue anyway so i mainly jumped back to linux)
      * AMD fx8350
      * Asus Sabertooth 990fx Ref. 2.0
      * NVIDIA GeForce GTX 1060 6GB
       
    • By ammoune78
      Hey, i have problem of Freezes and Glitches with Intel HD 4400 in High Sierra 10.13.4. I have i5-4300U with the following edits:
       
      OperationRegion (GFXH, PCI_Config, Zero, 0x40) Field (GFXH, ByteAcc, NoLock, Preserve) { VID0, 16, DID0, 16 } Method (_DSM, 4, NotSerialized) // _DSM: Device-Specific Method { If (LEqual (Arg0, Buffer (0x10) { /* 0000 */ 0xC6, 0xB7, 0xB5, 0xA0, 0x18, 0x13, 0x1C, 0x44, /* 0008 */ 0xB0, 0xC9, 0xFE, 0x69, 0x5E, 0xAF, 0x94, 0x9B })) { If (LNotEqual (And (VID0, 0xFFFF), 0xFFFF)) { Store (Package (0x0E) { "AAPL,slot-name", "Built In", "name", "Intel Graphics Controller", "model", Buffer (0x0E) { "Intel HD 4400" }, "device_type", Buffer (0x14) { "Graphics Controller" }, "compatible", Buffer (0x0C) { "pci8086,412" }, "AAPL,ig-platform-id", Buffer (0x04) { 0x06, 0x00, 0x26, 0x0A }, "hda-gfx", Buffer (0x0A) { "onboard-1" } }, Local0) DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0)) Return (Local0) } } Return (0x80000002) } And using "0x04128086" as FakeID, injecting Intel enabled and using the "0x0A260006" in Clover config.plist.
      Please any suggestion to solve this issue?
      Thanks!
    • By coscos
      I recently set up my hackintosh. Everything else works fine, the only issue is my monitor cannot come back from sleep.
      Symptom: 
      If I click the "sleep" menu manually, the system goes to sleep fine. After the system sleeps for a while (more than a few mins, I guess it's called "deep sleep"), when I try to wake it up, the monitor wakes up but stays black screen. The machine is on. If I leave the system to time out and sleep by itself, only the monitor goes off; when I try to wake it up, same symptom as above.
      What I have tried (but none worked):
      additional boot flag: ngfxpatch=pikera additional boot flag: darkwake = 0 Customize EDID
      Specs:
      Motherboard: Gigabyte Z77x-UD5H BIOS: F16j CPU: Ivy Bridge i5-3570K CPU @ 3.40GHz (quad core) Graphics: Nvidia GTX 1050 Monitor: Dell P2715Q @ 4k / 60Hz, Display Port Wifi / Bluetooth: BCM94360CS with PCIE Onboard GPU: disabled OS: High Sierra 10.13.3
      Please see attached for following files:
      EFI zip file: https://www.dropbox.com/s/8nun37msu9b1bva/EFI.zip?dl=0 I generated my own SSDT.aml using ssdtPRGen.sh; Other SSDT patches are copied from this repository: https://github.com/VoiletDragon/Z77X-UD5H-Clover-Hotpatch-Patches ioreg dump: https://www.dropbox.com/s/5a10k82guczaaws/macchiato.ioreg.zip?dl=0 result from following command: https://www.dropbox.com/s/0b22qcw79ovnjdg/kext-touch.txt.zip?dl=0 kextstat|grep -y acpiplat kextstat|grep -y appleintelcpu kextstat|grep -y applelpc kextstat|grep -y applehda sudo touch /System/Library/Extensions && sudo kextcache -u /
      I am looking forward to your suggestions. Thanks.
    • By Oschly
      When I installed 10.13.4 I tried to boot macOS with iGPU enabled only in BIOS (without injecting and kexts, HD 4600) and my daily use dGPU (GTX 750 Ti, injected in config and web drivers enabled) and everything works fine, but it boots slower. There is a chance to make fully working dGPU and iGPU at one time? With kexts, injects, et cetera? Something like dGPU as eGPU and iGPU as main GPU? I don't want to break my build, so I am asking you before trying it.
      My computer:
      MOBO: Gigabyte P85-D3
      GPU: Gigabyte GTX 750 Ti Windforce (2GB VRAM)
      CPU: i5-4670
      RAM: 8GB DDR3 1600MHz
      Audio: ALC887
      Ethernet: Realtek RTL 8111
      Drives: SSD Goodram 240GB and HDD 1TB.
    • By zeg66
      Could you please help me enable the VGA port on the GT710 in 10.9.5 13F34 ? 
      It is currently booting fine through its HDMI port, web driver 334.0103f01 and config.plist arguments checked: Verbose (-v), npci=0x2000, dart=0, nvda_drv=1
      The nvidia GT710 works fine through its VGA port and web drivers on a friend's Mac Pro 3,1
      I must soon return this borrowed HDMI monitor, mine only has a VGA port so I'd appreciate your input.
×