Jump to content
cvad

Bootdisk Utility

211 posts in this topic

Recommended Posts

I'm unsure of what to do next with BDU. I checked the multi partition in options to format my USB to 1 64mb FAT 32 partition and the other into a larger FAT 16 partition. I have an install.dmg, I'm unsure of how to extract an hfs file from that. When I select the extract hfs partition from dmg file in the tools menu and select my .dmg file and a place to save it, nothing happens. 

 

I am also unsure how to make the second partition HFS insead of FAT through BDU. This second partition is invisible to everything but BDU. 

Share this post


Link to post
Share on other sites
Advertisement

dbraun31,

 

Read the previous posts please - link.

I have read the previous posts - let me rephrase my problem.

 

The first thing I do in BDU is configure the format options to install clover on a 64 mb partition of a USB drive. This creates a FAT32 64 mb partition that I can boot from and the clover GUI loads successfully.

 

However, the second partition becomes FAT16 which is invisible to explorer. Therefore, when I select Tools - Extract HFS+ partition from DMG image, after selecting my .dmg, I am unable to select the second, FAT16, partition on my USB drive. The menu just shows the 64 mb clover install.

 

I've tried formatting a separate USB to HFS+ with my .dmg image through Transmac. This leaves me with two separate USB drives (One for clover, one with the DMG image). I boot off the clover USB into the clover GUI, but clover does not show the USB with the OSX image as a boot option. - I know for this problem I will probably be referred to the Clover General Discussion where I have to pour through massive amounts of literature on the complex mechanics of the bootloader to find the answer to this seemingly simple problem.

 

In reference to the previous post, I'm assuming that refers to a command for command prompt? 

(run) 7z.exe (comand) -tXar -r (archive directory) InstallESD.dmg (output file name) InstallESD.dmg

When I do this it tells me it cannot open my .dmg as an archive. But when opening 7z.exe application and doing it through the GUI I can open it no problem.

 

All I'm hoping for is that you, in your infinite wisdom as a coder, can help me, an average user trying to install osx on his pc, or at least point me in the right direction.

Share this post


Link to post
Share on other sites

Can I get help?

 

I worked fine for me, my pen is prepared now, but when i start this mac os x set up...my system broke up @ "unable to open bootchache playlist.... No such file" What can I do?

Share this post


Link to post
Share on other sites

Thanks cVaD - after a few hours of trying, everything fell in the places.  Next step is to configure Clover to run with my new motherboard, which seems like the much bigger task.

 

This is what worked for me:

 

1. Download, unzip and run BootDiskUtility

2. Insert 8GB or larger USB drive

3. Click on Format Disk, you'll get a warning that all info will be destroyed, which is of course expected when formatting a drive

4. My guess is that this would be a good time to tweak the Clover config and maybe use the Tools->Clover FixDsdtMask Calculator (?)

5. Next run Tools->Extract HSF(HFS+) Partition from DMG-file.  This will convert your DMG file to HFS

6. Select Part2 and click on Restore Partition, then select the HFS file created above. This will transfer it to the second partition on your USB drive. This takes time...

7. Eject the drive and you're ready to run it on your hackintosh.  :thumbsup_anim:

Share this post


Link to post
Share on other sites

hello

Why bootloader is in english and when I select the OSX language is (maybe) russian because I dont undertand anything.

thanks

theDoor

Share this post


Link to post
Share on other sites

hello

Why bootloader is in english and when I select the OSX language is (maybe) russian because I dont undertand anything.

thanks

theDoor

Screenshot? Boot.log?

Share this post


Link to post
Share on other sites

BootDiskUtility.exe
v2.0.2014

rev.183b:
Latest Clover v2k r2652 & Chameleon r2377

Share this post


Link to post
Share on other sites

BootDiskUtility.exe
v2.0.2014

rev.184b:
Latest Clover v2k r2774

 

  • Removed Chameleon bootloader
  • Updated Fix Dsdt Mask Calculator
  • Updated internal Clover Bootloader rev.2774

 

Enjoy

 

Share this post


Link to post
Share on other sites

Thanks for the utility, very helpful. I have a question. Can i extract the HFS partition from ISO file? I got an OS X iso and i'm wordering if i can extract the OS X installer from it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By ajmcello
      The following files exist on the github:
       
      a) Clover.app-v1.11-5100.zip
      b) Clover_v2.5k_r5100.pkg
      c) CloverISO-5100.tar.lzma
      d) CloverV2-5100.zip
      e) CLOVERX64.efi.zip
       
       
      Is (a) for installing as an app on OSX? What is it for?
       
      What is (b) for, the .pkg? Not exactly familiar with .pkg. I've seen it used in UNIX, but I believe it's also a PKG format for installing packages on OSX. So, what is the difference between this (b), and (a)? (a) is labeled v1.11-5100, while (b) is labeled v2.5k_r5100.
      (c) contains only this file, Clover-v2.5k-5100-X64.iso, which I assume is a pre-bootloader.
      (d) looks like the NON ISO version, to build an ISO?
      (e) Contains CLOVERX64.efi, which is the same CloverX64.efi for Clover.app-v1.11-5100 and CloverV2-5100.zip
       
      Thanks for any explanations. 
       

       
       
       
       
    • By Dolamarv
      Hi all, I have been using an x240 thinkpad for more than 2 months as hackintosh and it is very stable. As of now I am in Catalina 10.15.1 and it’s running great until I updated it to the new clover build r5100. My laptop won’t automatically sleep when I close the lid down now. I reverted back to 5099 and close-lid automatic sleep works. I don’t know what caused the problem but I think 5100 fixed a dsdt patching of some sort that that conflicted with my config plist? Thanks in advance!
    • By Aldaro
      Gigabyte, in their infinite wisdom, decided to remove the option to disable serial ports, and not being able to do so has been causing me some problems. I know that I have to either use a patch in clover, or create a custom SSDT to disable super I/O, but I honestly do not know how to go about doing this. One of the weirder problems I'm experiencing is the inability to connect to Apple Music (error 11556) unless I go into my network settings, and delete my serial connection. If anyone could help me out with this, that'd be greatly appreciated; anyway, thank you for taking the time to read this.
       
      SPECS:
      Mobo GIGABYTE Z390 M GAMING (UEFI F8)
      CPU: i5 9600k
      RAM: 32GB DDR4 @ 2666 Mhz
      GPU: AMD Radeon RX 580 w/ 8GB of VRAM (MSI armor oc edition)
      Storage Samsung 970 evo 500GB
    • By e97
      HackPro X99 System
      Until Apple blesses us with the MacPro7,1 – this is for those that require tools to do their work.
      An appropriate bicycle for the mind.
       
       

       

       

       
      Specs:
       
      CPU: Intel Xeon E5-2678 v3 (12 core, 2.5 GHz / 3.3 GHz Boost)
      Motherboard: SZMZ X99-8D3
      RAM: 16GB DDR3-14900R 1866Mhz ECC RDIMM modules
      GPU: Radeon RX Vega 64 8GB
      Storage: Phison E12 m.2 NVMe PCI-E 3.0 x4 SSD
      Water blocks: BARROW CPU + GPU
      Radiator: 360mm x 25mm slim
      Pump: DDC
       
      Case dimensions: 431 mm x 342 mm x 177 mm
       
       
       
      XCPM OFF
       

       
      XCPM ON
       

       
      OpenCL
       

       
       
       
      iMacPro1,1
       

       
       

       
      OpenCL
       

       
       
      NVMe
       

       
       
      Win 10 x64 v1809
       
      AIDA64 - Cache & Memory
       

       
       
      Download:  https://github.com/xe97/X99-8D3-Clover
       
       
       
       
       
      Anyone else I forgot
       
       
    • By digivish
      Hi All - quick thing - I have a NUC 8i7BEH with 32GB RAM and 2 x 1TB SSD drives. Each drive has its own OS - Windows 10 and Catalina 10.15.
       
      Clover works well - Catalina Boots, so does Windows.
      Catalina - has sound over HDMI (to my monitor's speakers)
      Windows - no audio device found - It does show Realtek and Intel Display Drivers - but the speaker has a red"x" and in Devices, there is no entry for Microphone Array under Audio Input/Output. It does, however, show Intel display over the HDMI - but actually no sound.
       
      I have tried reinstalling Realtek drivers - now here's the thing...when it installs, it first uninstalls existing Realtek drivers - at this stage (and it's important) the sound starts working - as if uninstalling did the trick. As part of the installing, I have to reboot and upon reboot, it actually reinstalls the Realtek drivers. After that, I'm back to square 1. Unsure if it's the config.plist or boot args in clover. But something with Clover for sure.
       
      I have tested this by removing the Mac Drive with clover and just booting directly to Windows 10 bootloader and everything works as it should, I have sound over HDMI and the audio device shows. Just not when I boot with Clover.
       
      has anyone experienced this and have thoughts or pointers.
       
      Thanks a ton!
×