Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Kasi99

(Problem)Ati 5430 No resolution & QE/CI 10.8 HP g72

55 posts in this topic

Recommended Posts

Hello,

 

i have problem with ati 5430 and 10.8 No resolution & QE/CI 10.8 HP g72!

 

my english is bad, sry!

 

i have all kexte tried!

 

without success!

 

i have edit my chameleon boot plist! without success!

 

with GraphicsEnabler=yes have i Blackcsreen stuck after loding apple screen!

 

i have also my id´s ati5430 in the kext registered, without success!!

 

I need help!

 

best step by step instructions!

 

i would grateful!

 

mfg kasi

Share this post


Link to post
Share on other sites

hello artur-pt, thanks!

 

speak you german?

 

with instructions full working my ati 5430 on my laptop display ?

 

thanks!

 

gruss kasi

Share this post


Link to post
Share on other sites

Apologize for butting the post, if ATIRadeonX3000 (e.g.) is an accelerator so would it only accelerate HD 3000 cards or would also give acceleration to other cards with the correct kext and device ids ?

Share this post


Link to post
Share on other sites

hello eurofightertyhpoon!

 

i have devices id´s in the kext registered! nevertheless no QE/CI!

I look the week me the link of artur-pt on!

 

gruss kasi

Share this post


Link to post
Share on other sites

i have devices id´s in the kext registered! nevertheless no QE/CI!

I look the week me the link of artur-pt on!

 

 

 

Have you checked if the kexts are correct ? I am a similar problem with my HD 6750 but I am running Snow Leopard .

 

Check here olarila.com/kexts put in the device id and see what kexts it shows for ML.

Share this post


Link to post
Share on other sites

hello,

 

my id´s ati 5430, look screen short!

 

i have id´s in the kext registered (Apple Stock Kext ML 10.8)

 

i have edit plist

 

(AMDRadeonAccelerator):

 

 

<key>AMDBartsGraphicsAccelerator</key>

 

 

<key>IOPCIMatch</key>

<string>0x68e11002 0x67391002 0x67201002 0x67221002</string>

 

<key>AMDCaicosGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68e11002 0x67701002 0x67791002 0x67601002 0x67611002</string>

 

<key>AMDCaymanGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68e11002 0x67191002 0x67041002</string>

 

<key>AMDCedarGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68E11002</string>

 

<key>AMDCypressGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68e11002 0x68991002</string>

 

<key>AMDJuniperGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68E11002 0x68B01002 0x68B11002 0x68A01002 0x68A11002</string>

 

 

<key>AMDLombokGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68e11002 0x68411002</string>

 

 

<key>AMDRedwoodGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68E11002 0x68C01002 0x68C11002 0x68D91002</string>

 

 

<key>AMDTurksGraphicsAccelerator</key>

 

<key>IOPCIMatch</key>

<string>0x68e11002 0x67581002 0x67591002 0x67401002 0x67411002 0x67451002</string>

 

(ATI5000Controller):

 

<key>CFBundleIdentifier</key>

 

<key>IOPCIMatch</key>

<string>0x68E11002 0x68991002 0x68E01002 0x68E11002 0x68D81002 0x68C01002 0x68C11002 0x68D91002 0x68B81002 0x68B01002 0x68B11002 0x68A01002 0x68A11002 </string>

 

(ATISupport):

 

 

key>ATI Support</key>

<dict>

<key>CFBundleIdentifier</key>

 

<key>IOPCIMatch</key>

<string>0x68e11002&0x0000FFFF</string>

 

with GraphicsEnabler=Yes Mode, i have Blackscreen after loading screen AppleLOGO

 

please help my!

 

i find the error not :wallbash:

 

no QE/CI

 

mfg kasi

post-1056614-0-28968100-1348503354_thumb.jpg

Share this post


Link to post
Share on other sites

it is ML 10.8

 

please tell my, which kexts i edit must with my id´s??

 

i have

chameleon boot plist edit with GraphicsEnabler=Yes and AtiConfig Langur!

result boot loop !

Share this post


Link to post
Share on other sites

hello

 

what are u doing ?

 

u only edit 2 kext

 

ati5000controller

 

amdradeonacelerator in this kext u

 

must find u gpu family

 

and then insert there u dev id

 

not in all famiy of ati cards

 

man use google translator if u don't understand english

 

good hack

Share this post


Link to post
Share on other sites

i have only edit

ati5000controller &

amdradeonacelerator info plist in gpu family cedar!

 

i have bootloader

Chameleon-2.1svn-r2059 and edit

chameleon boot plist: GraphicsEnabler=YES AtiConfig

Langur!

 

 

result blackscreen after loading apple logo!

 

grafikcard 3mb look screen

 

 

no QE/CI no transparent bar

post-1056614-0-92164300-1348512569_thumb.jpg

Share this post


Link to post
Share on other sites

It could be that the kext is not loading, check in system profiler / Graphics it will show you "no kext loaded" that is only if its not loading. Keep GraphicsEnabler=No and try PCIRootUID=1 . Also please check Hardaware Compatibility List for ML at osx86project.org.

Share this post


Link to post
Share on other sites

...the "AtiConfig=Langur" could be your problem...most likely your default framebuffer would be Eulemur, if you use GraphicsEnabler=Yes

...and remember to repair permissions after doing any info.plist editing.... :smoke:

Share this post


Link to post
Share on other sites

hello,

 

i have it still managed :help:

booting with GraphicsEnabler Yes only PCI Root 1!

 

i have edit

ati5000controller &

amdradeonacelerator my id 0x68E11002 gpu family Cedar!

 

 

my boot flags in the plist:

 

 

<key>AtiConfig</key>

<string>Eulemur</string>

<key>GraphicsEnabler</key>

<string>Yes</string>

<key>PciRoot</key>

<string>1</string>

<key>RestartFix</key>

<string>No</string>

<key>UseAtiROM</key>

<string>Yes</string>

</dict>

 

terminal kextstat:

 

 

Index Refs Address Size Wired Name (Version) <Linked Against>

1 63 0xffffff8066c58000 0x686c 0x686c com.apple.kpi.bsd (12.0.0)

2 6 0xffffff8009d0c800 0x46c 0x46c com.apple.kpi.dsep (12.0.0)

3 78 0xffffff8066c5f000 0x1b7bc 0x1b7bc com.apple.kpi.iokit (12.0.0)

4 83 0xffffff8066c7b000 0x99f8 0x99f8 com.apple.kpi.libkern (12.0.0)

5 73 0xffffff8009d1b000 0x88c 0x88c com.apple.kpi.mach (12.0.0)

6 34 0xffffff8066c85000 0x5008 0x5008 com.apple.kpi.private (12.0.0)

7 53 0xffffff8066c4c000 0x2264 0x2264 com.apple.kpi.unsupported (12.0.0)

8 0 0xffffff7f8073e000 0x41000 0x41000 com.apple.kec.corecrypto (1.0) <7 6 5 4 3 1>

9 19 0xffffff7f8077f000 0x7000 0x7000 com.apple.iokit.IOACPIFamily (1.4) <7 6 4 3>

10 20 0xffffff7f80786000 0x1e000 0x1e000 com.apple.iokit.IOPCIFamily (2.7) <7 6 5 4 3>

11 2 0xffffff7f807a4000 0x57000 0x57000 com.apple.driver.AppleACPIPlatform (1.6) <10 9 7 6 5 4 3 1>

12 0 0xffffff7f807fb000 0x29000 0x29000 com.apple.driver.AppleIntelCPUPowerManagement (196.0.0) <7 6 5 4 3 1>

13 1 0xffffff7f80825000 0xc000 0xc000 com.apple.driver.AppleKeyStore (28.18) <7 6 5 4 3 1>

14 10 0xffffff7f80831000 0x25000 0x25000 com.apple.iokit.IOStorageFamily (1.8) <7 6 5 4 3 1>

15 0 0xffffff7f80856000 0x18000 0x18000 com.apple.driver.DiskImages (344) <14 7 6 5 4 3 1>

16 0 0xffffff7f8086e000 0x8000 0x8000 com.apple.nke.applicationfirewall (4.0.39) <7 6 5 4 3 1>

17 2 0xffffff7f80878000 0x4000 0x4000 com.apple.kext.AppleMatch (1.0.0d1) <4 1>

18 1 0xffffff7f8087c000 0x11000 0x11000 com.apple.security.sandbox (220) <17 7 6 5 4 3 2 1>

19 0 0xffffff7f8088d000 0x6000 0x6000 com.apple.security.quarantine (2) <18 17 7 6 5 4 2 1>

20 0 0xffffff7f80894000 0x3000 0x3000 com.apple.security.TMSafetyNet (7) <7 6 5 4 2 1>

21 0 0xffffff7f80897000 0x3000 0x3000 com.apple.driver.AppleIntelCPUPowerManagementClient (196.0.0) <7 6 5 4 3 1>

22 0 0xffffff7f8089b000 0x3000 0x3000 com.apple.driver.AppleAPIC (1.6) <4 3>

23 0 0xffffff7f8089f000 0x4000 0x4000 com.apple.driver.AppleSMBIOS (1.9) <7 4 3>

24 3 0xffffff7f808a4000 0x6c000 0x6c000 com.apple.iokit.IOHIDFamily (1.8.0) <13 7 6 5 4 3 2 1>

25 0 0xffffff7f80910000 0x4000 0x4000 com.apple.driver.AppleACPIButtons (1.6) <24 11 9 7 6 5 4 3 1>

26 7 0xffffff7f80916000 0x55000 0x55000 com.apple.iokit.IOUSBFamily (5.1.6) <10 7 5 4 3 1>

27 0 0xffffff7f8096b000 0x17000 0x17000 com.apple.driver.AppleUSBEHCI (5.1.5) <26 10 7 5 4 3 1>

28 0 0xffffff7f8098a000 0x3000 0x3000 com.yourcompany.driver.AppleACPIPS2Nub (1.0.0d1) <9 7 5 4 3 1>

29 2 0xffffff7f8098f000 0xf000 0xf000 org.voodoo.driver.PS2Controller (1.1.0) <9 7 5 4 3 1>

30 1 0xffffff7f8099e000 0x4000 0x4000 com.apple.driver.AppleEFIRuntime (1.6.1) <7 6 5 4 3>

31 0 0xffffff7f809a2000 0x7000 0x7000 org.netkas.FakeSMC (3.1.0) <9 7 5 4 3>

32 0 0xffffff7f809a9000 0x7000 0x7000 com.apple.driver.AppleEFINVRAM (1.6.1) <30 7 6 5 4 3>

33 0 0xffffff7f809b2000 0x3000 0x3000 com.apple.iokit.IOUSBUserClient (5.0.0) <26 7 5 4 3 1>

34 0 0xffffff7f809b5000 0x14000 0x14000 com.apple.driver.AppleUSBHub (5.1.6) <26 5 4 3 1>

35 3 0xffffff7f809cd000 0x15000 0x15000 com.apple.iokit.IOAHCIFamily (2.2.0) <5 4 3 1>

36 0 0xffffff7f809e2000 0x19000 0x19000 com.apple.driver.AppleAHCIPort (2.4.0) <35 10 5 4 3 1>

37 2 0xffffff7f80a02000 0x3000 0x3000 com.apple.iokit.IOSMBusFamily (1.1) <5 4 3>

38 0 0xffffff7f80a05000 0x7000 0x7000 com.apple.driver.AppleACPIEC (1.6) <37 11 9 5 4 3>

39 0 0xffffff7f80a0e000 0x3000 0x3000 com.apple.driver.AppleHPET (1.7) <9 7 5 4 3>

40 0 0xffffff7f80a12000 0x8000 0x8000 com.apple.driver.AppleRTC (1.5) <9 5 4 3 1>

41 0 0xffffff7f80a1c000 0x3000 0x3000 org.voodoo.driver.PS2Keyboard (1.1.0) <29 24 7 6 5 4 3 1>

42 0 0xffffff7f80a21000 0x3000 0x3000 org.voodoo.driver.PS2Mouse (1.2.0) <29 24 7 6 5 4 3 1>

44 0 0xffffff7f80984000 0x3000 0x3000 com.apple.AppleFSCompression.AppleFSCompressionTypeDataless (1.0.0d1) <7 6 4 3 2 1>

45 0 0xffffff7f809fb000 0x4000 0x4000 com.apple.AppleFSCompression.AppleFSCompressionTypeZlib (1.0.0d1) <6 4 3 2 1>

46 0 0xffffff7f80a24000 0x9000 0x9000 com.apple.BootCache (34) <7 6 5 4 3 1>

47 3 0xffffff7f80a2d000 0x2b000 0x2b000 com.apple.iokit.IONetworkingFamily (3.0) <7 6 5 4 3 1>

48 1 0xffffff7f80a58000 0x6000 0x6000 com.apple.driver.AppleUSBComposite (5.0.0) <26 4 3 1>

49 0 0xffffff7f80a5e000 0x5000 0x5000 com.apple.driver.AppleUSBMergeNub (5.1.5) <48 26 4 3 1>

50 0 0xffffff7f80a63000 0x16000 0x16000 com.apple.iokit.IOAHCIBlockStorage (2.2.0) <35 14 6 5 4 3 1>

51 5 0xffffff7f80a79000 0x2a000 0x2a000 com.apple.iokit.IOSCSIArchitectureModelFamily (3.5.1) <5 4 3 1>

52 0 0xffffff7f80aa3000 0xc000 0xc000 com.apple.iokit.IOAHCISerialATAPI (2.5.0) <51 35 5 4 3 1>

53 0 0xffffff7f809c9000 0x3000 0x3000 com.apple.driver.XsanFilter (404) <14 5 4 3 1>

54 0 0xffffff7f80aaf000 0x11000 0x11000 com.apple.iokit.IOUSBMassStorageClass (3.5.0) <51 26 14 5 4 3 1>

55 3 0xffffff7f80ac0000 0xd000 0xd000 com.apple.iokit.IOCDStorageFamily (1.7.1) <14 5 4 3 1>

56 2 0xffffff7f80acd000 0xb000 0xb000 com.apple.iokit.IODVDStorageFamily (1.7.1) <55 14 5 4 3 1>

57 1 0xffffff7f80ad8000 0xa000 0xa000 com.apple.iokit.IOBDStorageFamily (1.7) <56 55 14 5 4 3 1>

58 0 0xffffff7f80ae2000 0x1a000 0x1a000 com.apple.iokit.IOSCSIMultimediaCommandsDevice (3.5.1) <57 56 55 51 14 5 4 3 1>

59 0 0xffffff7f80afc000 0x7000 0x7000 com.apple.iokit.SCSITaskUserClient (3.5.1) <51 14 5 4 3 1>

60 0 0xffffff7f80b03000 0x15000 0x15000 com.apple.iokit.IOSCSIBlockCommandsDevice (3.5.1) <51 14 5 4 3 1>

61 10 0xffffff7f80b18000 0x37000 0x37000 com.apple.iokit.IOGraphicsFamily (2.3.4) <10 7 5 4 3>

62 1 0xffffff7f80b4f000 0x1d8000 0x1d8000 com.apple.kext.AMDSupport (8.0.0) <61 10 9 7 5 4 3 1>

63 0 0xffffff7f80d27000 0x41000 0x41000 com.apple.kext.AMD5000Controller (8.0.0) <62 61 10 9 5 4 3 1>

64 4 0xffffff7f80d68000 0x8000 0x8000 com.apple.driver.IOPlatformPluginFamily (5.2.0d16) <9 7 6 5 4 3>

65 0 0xffffff7f80d70000 0x3000 0x3000 com.apple.driver.AppleLPC (1.6.0) <64 10 5 4 3>

67 1 0xffffff7f80d73000 0x12000 0x12000 com.apple.driver.IOPlatformPluginLegacy (1.0.0) <64 9 7 6 5 4 3>

68 2 0xffffff7f80d85000 0xc000 0xc000 com.apple.driver.AppleSMC (3.1.3d11) <9 7 5 4 3>

69 0 0xffffff7f80d91000 0x10000 0x10000 com.apple.driver.ACPI_SMC_PlatformPlugin (1.0.0) <68 67 64 10 9 7 6 5 4 3>

70 1 0xffffff7f80da1000 0x2d000 0x2d000 com.apple.iokit.IO80211Family (312) <47 7 5 4 3 1>

71 0 0xffffff7f80dce000 0xcc000 0xcc000 com.apple.driver.AirPort.Atheros21 (424.14.5) <70 47 10 7 5 4 3 1>

72 4 0xffffff7f80e9a000 0x12000 0x12000 com.apple.iokit.IONDRVSupport (2.3.4) <61 10 7 5 4 3>

73 1 0xffffff7f809ff000 0x3000 0x3000 com.apple.driver.AppleGraphicsControl (3.2.6) <72 61 10 9 7 5 4 3 1>

74 0 0xffffff7f80eac000 0xc000 0xc000 com.apple.driver.ApplePolicyControl (3.2.6) <73 72 61 10 9 7 5 4 3 1>

75 1 0xffffff7f80eb8000 0xc000 0xc000 com.apple.iokit.IOHDAFamily (2.3.0f2) <5 4 3 1>

76 0 0xffffff7f80ec4000 0x14000 0x14000 com.apple.driver.AppleHDAController (2.3.0f2) <75 61 10 6 5 4 3 1>

77 0 0xffffff7f80ed8000 0x3000 0x3000 com.apple.driver.AppleSMCPDRC (1.0.0) <64 10 6 4 3>

78 0 0xffffff7f80edb000 0x5000 0x5000 com.apple.Dont_Steal_Mac_OS_X (7.0.0) <68 7 4 3 1>

79 0 0xffffff7f80ee0000 0x7000 0x7000 com.apple.kext.OSvKernDSPLib (1.6) <5 4>

83 1 0xffffff7f81046000 0x47000 0x47000 com.apple.iokit.IOAcceleratorFamily (19.0.26) <72 61 10 7 5 4 3 1>

84 0 0xffffff7f8108d000 0x3cd000 0x3cd000 com.apple.AMDRadeonAccelerator (1.0.0) <83 72 61 10 7 5 4 3 1>

86 0 0xffffff7f81463000 0x9b000 0x9b000 com.apple.iokit.IOBluetoothFamily (4.0.9f8) <26 7 5 4 3 1>

88 1 0xffffff7f81500000 0xe000 0xe000 com.apple.driver.AppleSMBusController (1.0.10d0) <37 10 9 5 4 3>

89 0 0xffffff7f8150e000 0xc000 0xc000 com.apple.driver.AppleMCCSControl (1.0.33) <88 61 10 9 7 5 4 3 1>

90 1 0xffffff7f8151a000 0xe000 0xe000 com.apple.iokit.IOSerialFamily (10.0.6) <7 6 5 4 3 1>

91 0 0xffffff7f81528000 0xa000 0xa000 com.apple.iokit.IOBluetoothSerialManager (4.0.9f8) <90 7 5 4 3 1>

92 0 0xffffff7f81532000 0x5000 0x5000 com.apple.driver.AppleUpstreamUserClient (3.5.10) <61 10 9 7 5 4 3 1>

93 0 0xffffff7f81537000 0x11000 0x11000 com.apple.iokit.IOSurface (86.0.2) <7 5 4 3 1>

94 0 0xffffff7f81548000 0x7000 0x7000 com.apple.iokit.IOUserEthernet (1.0.0d1) <47 6 5 4 3 1>

95 3 0xffffff7f8154f000 0x56000 0x56000 com.apple.filesystems.ntfs (3.10) <7 6 5 4 1>

96 1 0xffffff7f815a5000 0x5000 0x5000 com.apple.kext.triggers (1.0) <7 6 5 4 3 1>

97 0 0xffffff7f815aa000 0x9000 0x9000 com.apple.filesystems.autofs (3.0) <96 7 6 5 4 3 1>

 

result: no Qe/CI no Transparent bar!

 

look screen!

 

i com not more :hammer::wallbash: :wallbash:

post-1056614-0-31079900-1348595631_thumb.jpg

post-1056614-0-71670300-1348595668_thumb.jpg

Share this post


Link to post
Share on other sites

I have the same card in my laptop and just installed mountain lion and use Hoolock as my frame buffer the same as i used in lion but no QE/Ci in mountain lion but shows up as 5400 series 5. I guess it's the AMDFramebuffer i edit not ATIFramebuffer

As

com.apple.kext.AMD5000Controller

com.apple.kext.AMDSupport

com.apple.kext.AMDFramebuffer

are loaded there are no ATI kexts loaded.

Share this post


Link to post
Share on other sites

Just edit AMDRadeonAccelerator.kext go down to the cedar setting change the iopcimatch

 

<key>IOPCIMatch</key>

<string>0x68E01002</string>

To

 

<key>IOPCIMatch</key>

<string>0x68E11002</string>

Then repair permissions then reboot then full QE/CI

I'm using Hoolock for my Framebuffer.

post-166982-0-37958400-1348605741_thumb.png

Share this post


Link to post
Share on other sites

good morning meknb!

 

what kext have you? apple stock kext edit? or on osx86?

 

have you SL or ML?

 

what graphicChip have you ati 5430?

 

thank you!

 

mfg kasi

Share this post


Link to post
Share on other sites

hello meknb

 

your method not work for me!

 

please step for step of beginning!

 

which kext delete, which kext installed S/L/E?

 

what your boot loader and boot flags ?

 

what your pciroot option 1 or 0?

 

i despair

 

have good night!

 

mfg kasi

Share this post


Link to post
Share on other sites

Hi Kasi99 My card is 5430M but mountain lion reports it as HD5400 series 5 the only kext i edited is AMDRadeonAccelerator

My frame buffer is Hoolock pciRoot =0, What is your boot loader ?? Have you tried booting with a ATI rom in your extra folder?

Share this post


Link to post
Share on other sites

good morning meknb,

 

i have tried bootloader Chimera 1.11.1 and Chameleon-2.1svn-r2059 ! not work!

By PCI Root=0 have i Blackscreen after loading apple bootlogo with GraphicsEnabler=Yes

mfg Kasi

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×