Jump to content
nhart12

ASUS Zenbook Prime UX31A-DB51 Ultrabook - fixes, mods, tweaks, etc

1,056 posts in this topic

Recommended Posts

 

 

Yeah... I also thought Clover is the more advanced technology. I'm running Clover with OS X and Win7 multi-boot in GPT/UEFI partitions. And works quite well. It's also easy to backup all the settings in the EFI folder.

 

Are there any noticeable improvements in newer Clover version? (I'm still running on 1174)

 

Anything usefull for our Zenbooks? Maybe for IvyBridge PM?

Revision 1242
- there are many improvements in functionality but nothing special to mention
- more correct hardware detecting including CPU and memory
- new key GenerateIvyStates
- advanced scripts

 

Changelog: http://sourceforge.net/projects/cloverefiboot/files/

Things are added and bugs fixed at a furious pace in the Clover world so it is worth keeping up to date. I think you'll have to redo your configuration some from 1178 to the latest as they merged most of the configuration into the single config.plist file. There is now an updater/theme picker application as well as lots of themes. I've been working on changes for my HP but I plan to get back to the Zenbook and get it all up to date and look into fixing whatever doesn't work.

 

BTW, this is a more up-to-date log of changes for Clover:

 

http://www.projectosx.com/forum/index.php?showtopic=2656

 

Share this post


Link to post
Share on other sites
Advertisement

I think you'll have to redo your configuration some from 1178 to the latest as they merged most of the configuration into the single config.plist file.

 

So I would need to combine the config.plist

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
 <key>DropOemSSDT</key>
 <string>Yes</string>
 <key>DsdtName</key>
 <string>DSDT.aml</string>
 <key>GenerateCStates</key>
 <string>No</string>
 <key>GeneratePStates</key>
 <string>No</string>
</dict>
<key>KernelAndKextPatches</key>
<dict>
 <key>AppleRTC</key>
 <string>Yes</string>
 <key>AsusAICPUPM</key>
 <string>Yes</string>
 <key>KernelCpu</key>
 <string>Yes</string>
</dict>
<key>Pointer</key>
<dict>
 <key>Speed</key>
 <string>8</string>
</dict>
<key>SMBIOS</key>
<dict>
 <key>BiosVendor</key>
 <string>Apple Inc.</string>
 <key>ProductName</key>
 <string>MacBookPro8,1</string>
 <key>Family</key>
 <string>MacBook Pro</string>
 <key>SerialNumber</key>
 <string>C02F93FQDH2G</string>
 <key>Board-ID</key>
 <string>Mac-94245B3640C91C81</string>
</dict>
<key>PCI</key>
<dict>
 <key>HDAInjection</key>
 <string>No</string>
 <key>LpcTune</key>
 <string>No</string>
 <key>PCIRootUID</key>
 <string>0</string>
 <key>StringInjector</key>
 <string>No</string>
 <key>USBInjection</key>
 <string>Yes</string>
</dict>
<key>SystemParameters</key>
<dict>
 <key>BacklightLevel</key>
 <string>0xFFFF</string>
 <key>InjectSystemID</key>
 <string>Yes</string>
 <key>LegacyBoot</key>
 <string>PBR</string>
 <key>boot-args</key>
 <string>npci=0x3000 MountEFI=disk1 slide=0</string>
 <key>prev-lang:kbd</key>
 <string>en:0</string>
</dict>
</dict>
</plist>

 

and the refit.conf to a new combined config.plist?

Share this post


Link to post
Share on other sites

So I would need to combine the config.plist

 

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DropOemSSDT</key>
<string>Yes</string>
<key>DsdtName</key>
<string>DSDT.aml</string>
<key>GenerateCStates</key>
<string>No</string>
<key>GeneratePStates</key>
<string>No</string>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>AppleRTC</key>
<string>Yes</string>
<key>AsusAICPUPM</key>
<string>Yes</string>
<key>KernelCpu</key>
<string>Yes</string>
</dict>
<key>Pointer</key>
<dict>
<key>Speed</key>
<string>8</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>BiosVendor</key>
<string>Apple Inc.</string>
<key>ProductName</key>
<string>MacBookPro8,1</string>
<key>Family</key>
<string>MacBook Pro</string>
<key>SerialNumber</key>
<string>C02F93FQDH2G</string>
<key>Board-ID</key>
<string>Mac-94245B3640C91C81</string>
</dict>
<key>PCI</key>
<dict>
<key>HDAInjection</key>
<string>No</string>
<key>LpcTune</key>
<string>No</string>
<key>PCIRootUID</key>
<string>0</string>
<key>StringInjector</key>
<string>No</string>
<key>USBInjection</key>
<string>Yes</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>BacklightLevel</key>
<string>0xFFFF</string>
<key>InjectSystemID</key>
<string>Yes</string>
<key>LegacyBoot</key>
<string>PBR</string>
<key>boot-args</key>
<string>npci=0x3000 MountEFI=disk1 slide=0</string>
<key>prev-lang:kbd</key>
<string>en:0</string>
</dict>
</dict>
</plist>

 

and the refit.conf to a new combined config.plist?

 

This is my config.plist that I reconfigured and just tested on 1729 that gives you an idea. I don't think the DisableDrivers section is matching the correct names, but it worked anyway.

 


<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0//EN" "http://www.apple.com/DTDs/PropertyList-1.0.dtd">
<plist version="1.0">
<dict>
<key>ACPI</key>
<dict>
<key>DropOemSSDT</key>
<true/>
<key>DsdtName</key>
<string>dsdt.aml</string>
<key>EnableC6</key>
<true/>
<key>GenerateCStates</key>
<true/>
<key>GeneratePStates</key>
<true/>
<key>ResetAddress</key>
<string>0x64</string>
<key>ResetValue</key>
<string>0xFE</string>
</dict>
<key>DisableDrivers</key>
<dict>
<key>CsmVideoDxe-64</key>
<true/>
<key>EmuVariableUefi-64</key>
<true/>
<key>OsxLowMemFixDrv-64</key>
<true/>
</dict>
<key>GUI</key>
<dict>
<key>DebugLog</key>
<false/>
<key>HideEntries</key>
<dict>
<key>Duplicate</key>
<true/>
<key>ExternalUEFI</key>
<false/>
<key>Gentoo</key>
<false/>
<key>Grub</key>
<false/>
<key>InternalUEFI</key>
<false/>
<key>OSXInstall</key>
<false/>
<key>OpticalUEFI</key>
<true/>
<key>Recovery</key>
<false/>
<key>Ubuntu</key>
<false/>
<key>WindowsEFI</key>
<false/>
</dict>
<key>Mouse</key>
<dict>
<key>DoubleClick</key>
<integer>500</integer>
<key>Enabled</key>
<false/>
<key>Mirror</key>
<false/>
<key>Speed</key>
<integer>2</integer>
</dict>
<key>Theme</key>
<string>metal</string>
<key>Timeout</key>
<integer>10</integer>
<key>Volumes</key>
<dict>
<key>Hide</key>
<array>
<string>CLOVERMBR</string>
</array>
<key>Legacy</key>
<string>No</string>
</dict>
</dict>
<key>Graphics</key>
<dict>
<key>GraphicsInjector</key>
<false/>
</dict>
<key>KernelAndKextPatches</key>
<dict>
<key>AppleRTC</key>
<true/>
<key>AsusAICPUPM</key>
<true/>
<key>KernelCpu</key>
<true/>
<key>KextsToPatch</key>
<array>
<dict>
<key>Comment</key>
<string>Patch IOAHCIBlockStorage to enable SSD Trim</string>
<key>Find</key>
<data>
QVBQTEUgU1NEAA==
</data>
<key>Name</key>
<string>IOAHCIBlockStorage</string>
<key>Replace</key>
<data>
AAAAAAAAAAAAAA==
</data>
</dict>
</array>
</dict>
<key>PCI</key>
<dict>
<key>InjectClockID</key>
<true/>
<key>USBFixOwnership</key>
<true/>
<key>USBInjection</key>
<false/>
</dict>
<key>RtVariables</key>
<dict>
<key>LogEveryBoot</key>
<string>10</string>
<key>LogLineCount</key>
<string>5000</string>
<key>MountEFI</key>
<string>No</string>
</dict>
<key>SMBIOS</key>
<dict>
<key>BiosVendor</key>
<string>Apple Inc.</string>
<key>ProductName</key>
<string>MacBookPro9,2</string>
</dict>
<key>SystemParameters</key>
<dict>
<key>BacklightLevel</key>
<string>0xFFFF</string>
<key>boot-args</key>
<string>npci=0x3000 slide=0 arch=x86_64</string>
<key>prev-lang:kbd</key>
<string>en:0</string>
</dict>
</dict>
</plist>

Share this post


Link to post
Share on other sites

My only concern is Anyone here get fully function app store, icloud, etc?

 

I read the whole post and saw some one got working app store, icloud etc, such as Thomas1111, 68x

 

After searching around and I found you have to have a working ethernet card in the system and must set it to en0 otherwise app store ,icloud will never work.

 

 

But this laptop does not have a build in ethernet card, only wifi, how can you guys get fully function app store, icloud?

 

And I saw some of you replaced your wifi card with a apple brand wifi card, did that really help?

 

My MOBO has 2 LAN ports and there is no driver for the chipset so I bought a genus apple wifi card to get internet.

I did every possible solution(efi studio to add device ID, delete network....) that I can find and still cannot login app store, icloud etc.

 

Any advices?

 

Thanks

 

Sam

Share this post


Link to post
Share on other sites

My only concern is Anyone here get fully function app store, icloud, etc?

 

I read the whole post and saw some one got working app store, icloud etc, such as Thomas1111, 68x

 

After searching around and I found you have to have a working ethernet card in the system and must set it to en0 otherwise app store ,icloud will never work.

 

 

But this laptop does not have a build in ethernet card, only wifi, how can you guys get fully function app store, icloud?

 

And I saw some of you replaced your wifi card with a apple brand wifi card, did that really help?

 

My MOBO has 2 LAN ports and there is no driver for the chipset so I bought a genus apple wifi card to get internet.

I did every possible solution(efi studio to add device ID, delete network....) that I can find and still cannot login app store, icloud etc.

 

Any advices?

 

Thanks

 

Sam

 

You need to buy a compatible wireless card. If I were you, go for a BT + Wifi combo card (kext patching needed and hardware modding). MBA does not have a built-in ethernet yet it is able access to the App Store and iCloud.

Share this post


Link to post
Share on other sites

You need to buy a compatible wireless card. If I were you, go for a BT + Wifi combo card (kext patching needed and hardware modding). MBA does not have a built-in ethernet yet it is able access to the App Store and iCloud.

 

Exactly. I double checked my MBA, wifi card using en0.

 

But I bought this one Apple Macbook A1181 BCM94322MC Dual Band Wireless Card Tested Original

from ebay: http://www.ebay.com/...984.m1497.l2649

I think it is a compatible card, right? With native support and airdrop works OOB.

Share this post


Link to post
Share on other sites

Exactly. I double checked my MBA, wifi card using en0.

 

But I bought this one Apple Macbook A1181 BCM94322MC Dual Band Wireless Card Tested Original

from ebay: http://www.ebay.com/...984.m1497.l2649

I think it is a compatible card, right? With native support and airdrop works OOB.

 

It won't fit into a Zenbook. You need a half-mini PCIE wireless card.

 

Pick one from this list, http://i.imgur.com/AP72oDE.jpg

Share this post


Link to post
Share on other sites

Good news for anyone who wants to use the Chameleon bootloader. The latest revisions have fixes for the 3.25GB of RAM issue.

 

If you want to switch from Clover to Chameleon.

 

First download the folder (the file name does not have pkg) for Chameleon from here , http://www.osx86.net...2svn-r2233.html). Please note that any Chameleon revision greater than 2233 will have the memory fix.

Next download Chameleon Wizard from here, http://www.insanelym...for-chameleon/.

Also make sure to download my Extra folder, http://www.mediafire...az12j/Extra.zip .

 

Now let's install Chameleon via Chameleon Wizard.

Extract the Chameleon folder. Now open up Chameleon Wizard, then choose "Folder on disk".

 

Now choose the folder where you extracted the Chameleon folder. Next, select "Boot0hfs", and choose your target disk. Once you are sure of all the settings are correct, click "Install".

Once you have installed Chameleon, all you have to do is extract my Extra.zip and move my "Extra" folder to / (THE ROOT OF YOUR OSX DRIVE!).

 

Thank you for your EXTRA folder ! With your DSDT, i managed to get the keyboard backlight working with the FN driver from Dinesh !

 

Is your Atheros card working without any extra kext or are you using AirportAtheros40.kext to make it work ?

 

Thanks,

 

Adi

Share this post


Link to post
Share on other sites

Thank you for your EXTRA folder ! With your DSDT, i managed to get the keyboard backlight working with the FN driver from Dinesh !

 

Is your Atheros card working without any extra kext or are you using AirportAtheros40.kext to make it work ?

 

Thanks,

 

Adi

 

My card is natively supported. I didn't go for a wifi + BT combo card.

Share this post


Link to post
Share on other sites

My card is natively supported. I didn't go for a wifi + BT combo card.

 

Ah I see.. Perhaps that's my issue.. I was under the impression that it was to be natively supported by OS X with the proper DSDT patch.

 

Thanks for the info.

 

Adi

Share this post


Link to post
Share on other sites

Ah I see.. Perhaps that's my issue.. I was under the impression that it was to be natively supported by OS X with the proper DSDT patch.

 

Thanks for the info.

 

Adi

 

Take a look at this chart, http://i.imgur.com/AP72oDE.jpg, I do not take credit for it. Most of the half-mini Atheros card usually work either natively or via kext edits.

Share this post


Link to post
Share on other sites

To anyone who wants Ivy Bridge power management, you will need to do this:

 

1. Replace your AppleACPIPlatform kext with mine (it is the default one from 10.8)

2. Replace your DSDT with mine

3. Replace your battery kext with this, https://code.google..../downloads/list

4. You will also need to install the latest AsusNBWMI kext from http://forum.osxlati...asus-notebooks/ (DSDT edits are already done)

 

I have attached my AppleACPI and DSDT. Most of the FN keys work (F2, F7, F9 will not work). For extended battery life, I recommend using http://forum.osxlati...-battery-power/

 

Edit:

 

If anyone is interested in a new kext pack, I have attached it (attached are kexts which I used and software that will help install and monitor your system).

DSDT + AppleACPI.zip

Post-Install.zip

Share this post


Link to post
Share on other sites

To anyone who wants Ivy Bridge power management, you will need to do this:

 

1. Replace your AppleACPIPlatform kext with mine (it is the default one from 10.8)

2. Replace your DSDT with mine

3. Replace your battery kext with this, https://code.google..../downloads/list

4. You will also need to install the latest AsusNBWMI kext from http://forum.osxlati...asus-notebooks/ (DSDT edits are already done)

 

I have attached my AppleACPI and DSDT. Most of the FN keys work (F2, F7, F9 will not work). For extended battery life, I recommend using http://forum.osxlati...-battery-power/

 

Edit:

 

If anyone is interested in a new kext pack, I have attached it (attached are kexts which I used and software that will help install and monitor your system).

 

Hi 68x,

 

Did you make a recent change to your DSDT since the last time you uploaded it in a previous post in this thread ? Cause i assumed you didn't and i have skipped point 2 and I got a nice KP on boot..

 

After I reverted back my AppleACPI.kext, the KP went away..

 

Adi

 

EDIT : Scratch that. I replaced my DSDT with yours and I reapplied the AppleACPI.kext and I still get a KP.

Share this post


Link to post
Share on other sites

Hi 68x,

 

Did you make a recent change to your DSDT since the last time you uploaded it in a previous post in this thread ? Cause i assumed you didn't and i have skipped point 2 and I got a nice KP on boot..

 

After I reverted back my AppleACPI.kext, the KP went away..

 

Adi

 

EDIT : Scratch that. I replaced my DSDT with yours and I reapplied the AppleACPI.kext and I still get a KP.

 

Try the AppleACPI kext from the USB installer. I will be releasing another DSDT with proper FN key support soon. Also there were some battery issues that I faced, but that issue is also fixed.

 

On another note, I have made some progress on making the ambient light sensor work.

Share this post


Link to post
Share on other sites

To anyone who wants Ivy Bridge power management, you will need to do this:

 

1. Replace your AppleACPIPlatform kext with mine (it is the default one from 10.8)

2. Replace your DSDT with mine

3. Replace your battery kext with this, https://code.google..../downloads/list

4. You will also need to install the latest AsusNBWMI kext from http://forum.osxlati...asus-notebooks/ (DSDT edits are already done)

 

I have attached my AppleACPI and DSDT. Most of the FN keys work (F2, F7, F9 will not work). For extended battery life, I recommend using http://forum.osxlati...-battery-power/

 

Edit:

 

If anyone is interested in a new kext pack, I have attached it (attached are kexts which I used and software that will help install and monitor your system).

 Which SMBIOS model do you use?

Share this post


Link to post
Share on other sites

Well here's an update to my DSDT:

 

- Battery Fixes (battery charge doesn't get stuck at 89%)

- Ambient Light Sensor (partially works -> Keyboard light should change; Thanks to EmlyDinesh)

 

Note: The Ambient Light Sensor CANNOT be turned off by using Fn+A. It is turned on by default. If you want to enable/disable it, open the DSDT and look up the PINI method and change ALSC(One) to ALSC(Zero).

 

 

DSDT.aml.zip

Share this post


Link to post
Share on other sites

Well here's an update to my DSDT:

 

- Battery Fixes (battery charge doesn't get stuck at 89%)

- Ambient Light Sensor (partially works -> Keyboard light should change; Thanks to EmlyDinesh)

 

Note: The Ambient Light Sensor CANNOT be turned off by using Fn+A. It is turned on by default. If you want to enable/disable it, open the DSDT and look up the PINI method and change ALSC(One) to ALSC(Zero).

Been lurking around in this thread for quite a while now and I just want to personally thank you, the rest of the people in this thread working on it and EmlyDinesh for all your amazing work on this machine. You've really been a great help to make this laptop even better than it already was, and providing a lot of information and fixes to both making it stable and EmlyDinesh for making the trackpad amazing to use, and I hope you'll still be here helping out and providing great fixes when Mavericks comes out. I'll be sure to test out the ambient light sensor and see how it works. Great job, you deserve every bit of kudos I can possibly give.

Share this post


Link to post
Share on other sites

So I am new to this whole process. I have booted my ux31a with mountain lion and I have installed the chimera bootloader, which gives me the correct resolution and fixes my boot time. So I have installed the kexts in the first post and I have just about everything working it seems, exccept audio and my touch pad. Are there any fixes for the touch pad? Any of the kexts that I try make it lifeless (I can use it as a mouse but all that I get is moving, left and right click. No multitouch.)

 

Also could someone make a list from this thread for all of the most up to date kexts and dsdts that you guys are having success with? Trying to piece together 24 pages of it all while getting kernel panic every time is taking its toll on me. Thanks!

Share this post


Link to post
Share on other sites

The new ELAN touchpad driver in version 2.7.5 is amazingly good. http://forum.osxlatitude.com/index.php?/topic/1948-elan-touchpad-driver-mac-os-x/

 

Acceleration and inertial scrolling has been improved. And no need for smoothmouse anymore.

 

I just changed the setting AccelerationPrefValue in Info.plist from default AccelerationPrefValue = 0

to the value 1 or 4. This makes the trackpad fast and responsive.

Share this post


Link to post
Share on other sites

Well here's an update to my DSDT:

 

- Battery Fixes (battery charge doesn't get stuck at 89%)

- Ambient Light Sensor (partially works -> Keyboard light should change; Thanks to EmlyDinesh)

 

Note: The Ambient Light Sensor CANNOT be turned off by using Fn+A. It is turned on by default. If you want to enable/disable it, open the DSDT and look up the PINI method and change ALSC(One) to ALSC(Zero).

What is your CPU ? Is it by any chance the Core i7 one ? If yes, do you mind posting your SSDT files as well because for some reason, SLEEP on my UX31A only works sometimes.. Other times, it just locks up the laptop and I have to reboot it..

 

Thanks,

 

Adi

Share this post


Link to post
Share on other sites

So I now have audio and the touchpad working. I believe the last thing on my list is to get sleep working. If you have the SSDT for the ux31a with an i7 that will get sleep working I would be so thankful if you posted it.

Share this post


Link to post
Share on other sites

So I now have audio and the touchpad working. I believe the last thing on my list is to get sleep working. If you have the SSDT for the ux31a with an i7 that will get sleep working I would be so thankful if you posted it.

 

I second the request. I think the reason why sleep isn't working for me is that i have bad SSDT tables for my i7. I would also appreciate if anyone can post their SSDT tables in order to get sleep working.

 

Adi

Share this post


Link to post
Share on other sites

I just bought ASUS ZENBOOK PRIME UX32VD-R4010P with i7 3517U, 2x256 GB SSD, nvidia 620m, etc.

 

Downloaded iATKOS ML3U OSX.

 

And I am trying to install it to first 256 GB SSD.

 

I do not know what exactly to select in Customize options in iATKOS installer, which kexts, etc. to select to be able to boot the installed OSX.

 

Everytime I try to boot installed OSX, it gets stuck on something.

 

Could you give me step by step guide how to install OSX on my new zenbook, please?

 

I just updated BIOS firmware to latest 203 version.

It looks like it is UX32VDA, since no other firmware (UX32VD) is accepted. (I can not install 212 UX32VD firmware, since it requests UX32VDA type.)

And latest UX32VDA version is 203.

See here: https://www.asus.com/Notebooks_Ultrabooks/ASUS_ZENBOOK_UX32VD/#support_Download_36

(Version 202 was there from factory.)

Share this post


Link to post
Share on other sites

I can get here. But then it waits and does nothing. Any advice?

With -x -v boot parameters I can get here (third image). It waits there and does nothing.

 

Fourth screenshot is lspci -nn command.

post-51549-0-29723600-1373724827_thumb.jpg

post-51549-0-95256600-1373724982_thumb.jpg

post-51549-0-04867500-1373725291_thumb.jpg

post-51549-0-25287600-1373734501_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×