Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
scottiemedic

Installed 10.6.3 on Dell 1525, help to upgrade

7 posts in this topic

Recommended Posts

Ok, this is my first post and I've been doing a lot of reading and guides and upgrading info, but everytime I upgrade (trying to get to 10.6.8), something inevitably fails. So I thought I'd start over, get just my base system, then get some hints and tips about what avenue I should take.

 

My system:

Dell Inspiron 1525 laptop

Intel Core2Duo T7250 at 2.00GHz

2x2gb DDR2 RAM

Broadcom 9843x wifi (N and not stock card)

Intel 2gb Turbo Memory mPCIe

The dreaded X3100 graphics on a 965 chipset

IDE BluRay/DVD-Rw

SATA Seagate 750GB Momentus 7200RPM HDD

 

I seem to have QE/CI working (can open Front Row and Chess)

I have NOT placed a DSDT.aml file and am using the 'sleep trick' on boot up (I have a DSDT from when I tried this on 10.5.x 2 years ago.

I have done a pmset hibernatemode 0 to prevent sleep

 

I used iAtkos S3 v2 for the initial install, due to problems installing from SL DVD.

I used these Options on install:

Chameleon v2 RC5

USBBusFix

EHCIacquire

UHCIreset

/Extra Directory

fakesmc

Disabler

EVOreboot

SleepEnabler

USB patch

AHCI SATA driver

Voodoo PS/2

Voodoo Power

EVO Speedstep

Battery

Card Reader

TSC Sync

Intel EFI String

Natit (32 bit)

GMA X3100 with Frambuffer (32 bit)

Broadcom wireless

 

What I'm looking to gain from the forum:

 

About This Mac reports the CPU as 1.81GHz (even under load)

Sleep doesn't work

Want to get to 10.6.8

 

I am not HUGELY brilliant when it comes to OS X, but have played with Windows since 3.10, and am mainly doing this as a hobby and to play with programs like Aperture and Final Cut for photos/video of the family. I want to eventually get a MBP, but don't want to dish out 2Gs if the gains of photo/video aren't worth it.

 

I can post whatever screenshots, files (might need help finding them) or whatever other info needed for everyone to help. I've tried the ###### upgrade path, nocyzek and a couple others that I can't remember right off hand (can find them if needed).

 

What do you think, on a virgin system to get the best out of it? Should I go through upgrades individually (.4, .5, .6 etc) changing the sleep enabler and pmversion? Do I need to do anything special for my dsdt to make it 'more compatible' to the hardware I have (I had a base system when I put Leopard on it)? I'm an open book, up for suggestions...

 

Thanks everyone!!

Share this post


Link to post
Share on other sites

Delete-SleepEnabler,VoodooHDA(if use - get backup)

Backup kext(Later maybe needed)-Battery,Card Reader,Natit (32 bit),GMA X3100 with Frambuffer (32 bit),Broadcom wireless

Get software update from Apple :thumbsup_anim:

Share this post


Link to post
Share on other sites

the extra folder is always needed. copy and paste the kexts you want to backup to an another folder (ex. in desktop) then delete them from extra/extension folder or system/library/extension. after that use kext utility

Share this post


Link to post
Share on other sites

OK, thanks, one other thing. First reposter stated VooDooHDA if use get backup. Does that mean backup in same fashion or that I'll need an alternative? I do use voodoohda, just want to make sure it's compatible with .8.

 

I see the end of the 10.6.8 tunnel and it tastes like schnozberries!! Thanks!!

Share this post


Link to post
Share on other sites

I have the same configuration minus the bluray, followed this guide and my laptop is stuck in a black screen,i backed up the kexts to the desktop and rebooted after the update, (hope I didn't miss something...) What can I do to restore functionality? I'd also be interested in a 10.7 upgrade but am happy with 10.6.8. Thanks in advance!

 

Also, on a whim, I tried an external display, looks like I am getting a white screen

 

Update: Now I am getting the iAtkos screen but no icons or mouse, same thing happens in safe boot

Share this post


Link to post
Share on other sites

I can get it to boot in Single user mode too, and actually was able to get to the desktop for about 2 minutes with a wired mouse before it finally froze, I know I am close

 

Update: Ok, I have decided to reinstall 10.6.3, question can someone give me a step by step on the kext backup and deletion...at what point do i use kext utility? I know I am close...just need that one crucial step clarified...Thanks!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×