Jump to content
tanner

Acer Iconia W500 10.6 Guide

9 posts in this topic

Recommended Posts

Alright guys I have good news, bad news, and ok news. The good news is that iPortable x86 Snow is very easy to install(will leave a tutorial at the bottom), the bad news is that the Acer Iconia Tab W500's WLAN driver is only supported by Lion and Mountain Lion, unless someone can help me port it to Snow Leopard. Here is the W500's Wlan driver:

Some of you may know me from the thread "acer iconia w500" I have Snow Leopard Working on my Acer Iconia Tab W500

WIFI IS WORKING IN SNOW LEOPARD!!! HERE'S THE KEXT, INSTALL WITH KEXT UTILITY

IO80211Family.kext.zip

 

The ok news is that the WLAN driver(AR9002WB-1NG) is supported in 10.7.2 Lion OOB!

 

If someone could also help me create a USB stick to boot Lion 10.7.2 that would be great. I have tried anv_kernel, chocolate_kernel, and legacy_kernel, but all seem to have Kernel Panics. The mach_kernel is for intel and results in a black screen. We need a kernel and some kexts to prevent these kernel panics. iPortable X86 boots up fine, if we can use some kexts and especially kernels this will boot up Lion. Lion must be an install unless we copy the Library, System, etc, but lion must already be installed to copy these files.

 

How to Install Snow Leopard on Iconia W500:

Mac OS X is needed in order to install

1. Download iPortable by torrent, preferably 10.6.2

2. Partition the USB drive(atleast 8GB) with Master Boot Record and Mac OS X Extended(Journaled) 1 Partition

3. Run iportable x86 snow and copycatx will open, select backup and restore and also select your usb stick

4. Click the check mark once you click install, select iPortable x86 once it asks you where iPortable x86 is.

5. It should take about 20 minutes.

6. Once it's done click repair disk or the + icon

7. Once you open the application proceed to the install, BUT DO NOT INSTALL TO YOUR HARD DRIVE, select your usb stick and then install it.

8. Now your ready to boot the usb stick. Press F8 once the chameleon pops up and type -v busratio=8.

9. Once it boots you need to restore iportable to the SSD.

10. Create a partition atleast 10GB

11. Click on the partition and select restore.

12. For the source select iPortable x86 snow and for the destination select the partition you created.

13. Once it is done installing install the First aid icon or + icon in iportable snow and this time select the partition.

DONE! You have snow leopard now.

 

There are two ways we can get wifi to work:

Option 1: Port the wlan driver to snow leopard.

 

Option 2: Use Lion 10.7.2 which works OOB. In my opinion which would I like to use is option 1 because I dont need to create a usb stick which is harder than iportable.

 

 

Video before wifi:

 

I will post a video with wifi soon. Also keep up with my w500 videos I will make one about my SSD upgrade to a 64gb

Share this post


Link to post
Share on other sites
Advertisement

Hi i was going to restore with copycatx on 10.8.2, but as soon as i open up the copycatx, it asks me my username and password for authenticate. what should i do???

Share this post


Link to post
Share on other sites

Hi i was going to restore with copycatx on 10.8.2, but as soon as i open up the copycatx, it asks me my username and password for authenticate. what should i do???

Did you use the copycatx in iportable 10.6.2?

Share this post


Link to post
Share on other sites

i cant open copycatx. im on 10.6.3 and when ever i open copycatx it just has a box that says install and nothing else. like im not getting any screen where i can choose what to do. just a box that says install, close and more info or whatevr. so i click install and it freezes up and crashes, what do i do? the second picture is what happens after i click install

Share this post


Link to post
Share on other sites

i cant open copycatx. im on 10.6.3 and when ever i open copycatx it just has a box that says install and nothing else. like im not getting any screen where i can choose what to do. just a box that says install, close and more info or whatevr. so i click install and it freezes up and crashes, what do i do? the second picture is what happens after i click install

Are you using iportable's copycatx? I don't think iportable's copycatx needs to install, it's an application

 

i cant open copycatx. im on 10.6.3 and when ever i open copycatx it just has a box that says install and nothing else. like im not getting any screen where i can choose what to do. just a box that says install, close and more info or whatevr. so i click install and it freezes up and crashes, what do i do? the second picture is what happens after i click install

Another thing I can say is to download the latest version or just use the copycatx from the iportable.

Share this post


Link to post
Share on other sites

My w500 freezed on "netkas presents fakesmc, a kext which emulates smc device". Just like this.

093227jcu2acs828c8b28s.jpg.thumb.jpg

 

My w500 cpu is amd c60, maybe this cpu make the mistake.

Share this post


Link to post
Share on other sites

Have you tried Niresh's 10.7.3 V2 yet? It's supposed to work on AMD processors and includes an AMD kernel. I've tried to install it on my W500 without success. It keeps hanging with a message about legacy USB.

Share this post


Link to post
Share on other sites

Without assuming you or anyone else is the be all and end all of diagnosis, I'm hoping we can get this debugged:

 

 

iPortable 10.6.2 failed with included version of CopyCatX. Version 5 restored the image successfully. However, this build results in a kernel panic with the reason "Verification of clock speed failed".

 

10.6.7 threw all manners of errors. Let's get the earlier version fixed as I've not found a solution so far. This is confusing because I can only guess we are running an identical version on identical hardware.

 

Are there any alternative distrubitions with a chance of working? I have managed to get Kalyway installer disk to boot but not much further than that.

Share this post


Link to post
Share on other sites

i tried it on my acer iconia tab w500 and its not working

only thing i have different to your guide is my bios version v1.14

iam always stuck at booting after pci configarations ends

you can check my post for more info

http://www.insanelymac.com/forum/topic/307477-help-hackintosh-on-acer-iconia-tab-w500/


i managed to make copycat x  that came with iportable 10.6.2 to work on a vanilla lion vmware 10.7.4

copycat x 4 dont work on mavrics 10.9

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×