Jump to content
InsanelyMac Forum
  • Announcements

    • Allan

      Solution to create a topic or post.   04/24/2018

      Hello guys. The majority of you are having issues to create a topic or post here. This are a problem with our current theme InsanelyMac.  Now the theme will be the Default IPS. Sorry for any inconvenience.
RedJohn91

DSDT PATCH ATI RADEON HD 5770 XFX

Recommended Posts

Advertisement

Device (PCI0)

{

Name (_HID, EisaId ("PNP0A03"))

Name (_UID, Zero)

Name (_BBN, Zero)

Method (_S3D, 0, NotSerialized)

{

If (LEqual (OSFL, 0x02))

{

Return (0x02)

}

Else

{

Return (0x03)

}

}

 

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x04)

{

"AAPL,slot-name",

Buffer (0x08)

{

"PCI"

},

 

"device-id",

Unicode ("*")

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

 

Device (PEGP)

{

Name (_ADR, 0x00030000)

Name (_PRW, Package (0x02)

{

0x09,

0x05

})

Method (_STA, 0, NotSerialized)

{

Return (0x0F)

}

 

Device (GFX0)

{

Name (_ADR, Zero)

Name (_SUN, One)

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x0E)

{

"AAPL,slot-name",

Buffer (0x09)

{

"PCIe-1"

},

 

"@0,name",

Buffer (0x0D)

{

"ATY,Vervet"

},

 

"@1,name",

Buffer (0x0D)

{

"ATY,Vervet"

},

 

"@2,name",

Buffer (0x0D)

{

"ATY,Vervet"

},

 

"@3,name",

Buffer (0x0D)

{

"ATY,Vervet"

},

 

"model",

Buffer (0x13)

{

"ATI Radeon HD 5770"

},

 

"hda-gfx",

Buffer (0x0A)

{

"onboard-1"

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

 

Device (HDAU)

{

Name (_ADR, One)

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x02)

{

"hda-gfx",

Buffer (0x0A)

{

"onboard-1"

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

}

Share this post


Link to post
Share on other sites

Funziona?

 

Questa scheda e' riconoschiuta OOB da Lion

Aggiungi in o.c.b.p. Graphics Enabler - Yes

 

Fabio

 

Cos'è o.c.b.p ?

 

Per iLegend.

 

 

Device (P0P3)

{

Name (_ADR, 0x00030000)

Method (_PRW, 0, NotSerialized)

{

Return (GPRW (0x09, 0x04))

}

Method (_PRT, 0, NotSerialized)

{

If (PICM)

{

Return (AR03)

}

Return (PR03)

}

}

 

Questo è il codice della mia scheda video nel mio dsdt. Mi dici dove lo inserisco per la precisione? Non combacia

Share this post


Link to post
Share on other sites

Allora o.c.B.p. : org.chameleon.Boot.plist lo trovi nella cartella Extra

 

Il codice da te postato sei sicuro che e' della tua scheda video.

Comunque basta aggiungere : Graphics Enabler - Yes

 

Fabio

Share this post


Link to post
Share on other sites

Inserita l'iniezione della scheda.

 

In o.c.b.p. elimina la stringa oppure metti :

<key>GraphicsEnabler</key>
<string>No</string>

 

Fabio

Grazie mille Fabio. Poi mi dai una mano con l'hdmi audio?

Share this post


Link to post
Share on other sites

Non funziona fabio. Dal chimera carica ma carica all'infinito fino a quando viene fuori il segno del divieto. Ho fatto un dsdt normale e così funziona

Share this post


Link to post
Share on other sites

Per chimera devi chiedere al proprietario.

Per il resto come scheda e' riconosciuta nativamente, usa il boot di Chameleon e ti dovrebbe bastare solo aggiungere queste stringe in org.chameleon.Boot.plist senza iniezione nel dsdt.

 

GraphicsEnabler

Yes

EnableHDMIAudio

Yes

 

Fabio

Share this post


Link to post
Share on other sites
Guest
You are commenting as a guest. If you have an account, please sign in.
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoticons maximum are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Recently Browsing   0 members

    No registered users viewing this page.



  • Posts


    • Notebook Asus X550VX i7 - 7700hq
      GTX950MX - UHD630
      A1718086 - 025510ec ALC255 that works only on VoodooHDA 
      RTL8111 LAN Hwinfo
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL   Not work:
      1. White Screen Wake up   EDID not a asolution
      IOREG output http://www.mediafire.com/file/u7odzbaxa7bbb6a/ioregSaved.txt and EDID
      http://www.mediafire.com/file/hqlapgf4luwchdf/DisplayProductID-69c.plist Image https://ibb.co/faL5wx 2. Battery info status bar sometimes goes on / off like battery has off
      3. Crackle Sound using   earphone using VoodooHDA
             Still investigation using patched iomatch voodooha info.plist
             The sound card can’t be using AppleALC, no sound came out using layout 3, 13, 17, 18, 27, 28, 99
      I have  (Mald0n) DSDT thank you for maldon for helping me   http://www.mediafire.com/file/lmp5yy65rblx9ne/DSDTtitomaldon2.dsl   I have re-patched again for FnKeys and Brighness Key http://www.mediafire.com/file/5rs93ij0wco99s6/DSDTtitomaldon2editv2.aml

       
      codec dump linux
      https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view
       
       
      latest debug
      http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip
       
      clover and kext
      https://drive.google.com/open?id=1n5rHIw-jDPCgocWJtZ0AoVlqIi6Xc7XL
    • Guest Ricius89
      Ciao a tutti ragazzi, mi presento, sono Richy, ho 29 anni e sono della provincia di Torino. Appassionato di informatica e tutto ciò che riguarda l'ambito tech. Son sempre stato in Windows, questa è la mia seconda volta che installo OSx su pc, mi han sempre affascinato i sistemi Apple grazie a quei pregi che riescono a mettere in ombra quelle piccole lacune che comunque ancora ci sono.   Vi presento il mio pc. La configurazione è la seguente:   CASE: NZXT H440 White / Black Windowed ALIMENTATORE: Evga 500b 500W SCHEDA MADRE: Asus Z270-A Prime PROCESSORE: Intel core i7-6700k 4,00GHz DISSIPATORE: Lepa Exllusion 240mm a liquido RAM: 16Gb Gskill V Ripjaws 3200mHz ( 2x8Gb ) SCHEDA VIDEO: MSi GTX 980Ti 6Gb SCHEDA DI RETE WIFI: Asus WiFi PCE-N15 11n SSD: 2 x 120Gb Samsung MMCRE28G5MXP HDD: Samsung 1,5Tb HD154UI   OS: Windows 10 Pro x64 (OEM licence) OS 2: macOS x High Sierra   ILLUMINAZIONE: 1 x 1,5mt Strip LED rgb  CAVI: Prolunghe Sleeved Bianco / Viola 1 x scheda madre 1 x scheda video 1 x processore VENTOLE: 2 x 120mm Enermax LED White                3 x 120mm NZXT White / Black   Grazie a tutti.   PS: Vorrei registrarmi al sito, ma non mi fa registrare pur inserendo la risposta corretta nel form di registrazione, come mai?   Grazie ancora a tutti, buona serata!  Ciaoo
    • i'll check it, back to home in a few hours what boot problem u have?
    • Hey Allan,   sorry for late response, been working on putting new flooring in my house. Finally got around to my hackintosh again and reinstalled Sierra. Here is my new log with the runme app.    I did not install the NullCPUpowerManagement kext, I still get choppy video playback. Any idea why? Also seemed that didn't solved my issue. I did another Geekbench with really low scores again.     I will also include my clover folder to see if I'm missing something. Thanks for all the help man.   Send me AMPSs-iMac.zip CLOVER
    •   Thanks MaLd0n, but is the file put at the path /EFI/Clover/ACPI/patched ?

      I have put the aml in the above path but can't solve the boot problem.
×