Jump to content
Sign in to follow this  
Followers 0
Mr.D.

Best gaming Mouse/Controler?

1 post in this topic

Recommended Posts

The only PC game I currently play is WoW. This is also my first MMO game ever. I am a big fan of FPS, but haven't played them on anything but a console in a long time.

 

 

So now that my hackintosh is nearly complete, I am wondering about a good mouse/controller for WoW. I'm not against buying a dedicated device, but a decent mouse would be nice to have as well. I hear a lot of talk about the Razr... some good, some bad. I also hear a lot about the MX series from Logitec (I have an POS logitec right now actually).

 

 

I was basically mocked by the support guy at Blizzard when I asked how to make the keyboard movement less jerky - he called me a 'keyboard turner' and said that most people who are FPS fans have a hard time with the switch to movement with the mouse. He's a douche for mocking me, but he's also right. I am so used to the upside down T of 'esdf' for movement that I am having a hard time adjusting. I am hoping that a better mouse will help. I am also open to a joystick, but not a game pad as that takes both hands.

 

 

So what is the best mouse (or joystick) for gaming? Oh, and let me rephrase... the best, economical mouse (or joystick) for gaming. By economical, I mean less than a benjamin.

 

 

Thanks y'all!

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By bvine
      Games List
      Specifications
       
      System: HP Elitebook 6930p (Laptop)
      Operating-system: OSX86 10.5.4 Retail Install
      Graphics: ATI HD 3450 Mobility identified but without QE/CI operating.
       
      Drivers for Radeon HD: https://code.google.com/archive/p/osx86-driver-radeonhd/
       
      Games
       
      Game
      Version
      Universal
      Size
      Note
       
       
       
      AquaMan
      [0.3]
      PowerPC
      732 KB
       
      Coblyn
      [3.1.0]
      Intel
      3,4 MB
       
      Cube
      [2005_08_29]
      PowerPC
      Only work in window mode
       
       
      Emperor´s Mahjong
      [1.0.14]
      ?
      7,2 MB
       
      Mari0
      [1.6]
      Intel
      19,2 MB
      32 Bit Mode in prefs work
       
      Mummy Maze Deluxe
      [1.1.1, v5]
      PowerPC
      7,2 MB
       
      NotPacMan
      ?
      ?
      ?
       
      NotTetris
      ?
      Universial
      18,5 MB
       
      Oolite
      [1.65]
      Universal
      30,9 MB
       
      OpenLieroX
      [0.5.8 rc 3]
      Universal
      253,5 MB
      Worms copy
       
      OpenSonic
      [0.1.4]
      Universal
      15 MB
       
      Order of Twilight
      [1.0]
      Intel
      17,8 MB
      32 Bit Mode in prefs
       
      Ortho Robot
      ?
      Universal
      19,1 MB
       
      Outer- Rim Pod Digger
      Demo
      PowerPC
      18,6 MB
      No Sound. Video error?
       
      Pingus
      [0.7.6]
      Intel
      32,6 MB
      Lemmings copy
       
      Soltaire XL
      [1.1.8]
      Universal
      1,2 MB
       
      Vacation Quest
      Demo
      Universal
      53,9 MB
       
      Wolfenstein 3D (1992)
      [0.72]
      Universal
      11,9 MB
       
       
       
      DOSBOX 0.74
       
      DOSBox make almost every older dos game workable. Downside are have to know some dos commands and where to find them on keyboard(see Example for how to type it in DOSBox). Some games need to be setup
       
      Example: mount c ~/myfolder (myfolder)
      =
      mount c (shift+<) (-) myfolder
      &
      c (shift+ the key next right to "L")

      More commands:
      cd (name of catalouge)
      dir
      dir * .exe
       
       
      DOSBox Games
       
      Cilivization
      Cilivization 3
      Command & Conquer
      Dark Castle
      Doom II
      Keen 4
      Leasure Suit Larry
      Need 4 Speed
      Oregon Trail Deluxe
      Epic Pinball 2.1 (Demo)
      Quest For Glory
      The Settlers Gold Edition
      Sim Ant
      Sim City
      Sim City 2
      Starwars
      Theme Hospital
       
       
       
      Still up for try new games and add them to list, if any interested with same setup feel free to add in!
    • By theconnactic
      Hi, nice people!
       
      As some of you (hopefully) know by now, i've been very active these days in this community, trying to help building momentum for AMD hackintoshing, so we AMD users (again, hopefully) someday manage to have at least the opportunity to have an up-to-date OSX install (yeah, i'm talking about Mountain Lion).
       
      Meanwhile, i decided to downgrade from the handicapped Lion installation thad i used to have, since it was 32-bit only and some key features of Lion are 64-bit, to Snow Leopard, which i could get full-featured. All that was a smooth and somehow enjoyable process, and now i have 10.6.8, running stable with 64-bit user land, all peripherals working (well, almost all of them, as you'll see) and sleep working flawlessly.
       
      Seriously, it could be a really awesome build, and my Geekbench score in fact exceeds anything i got running Windows 7. But, as has been proven for so long, in hackintoshes, specially AMD ones, the sweet always comes with the sour. I told you that my peripherals are almost working, and i say working because of my nVidia Geforce G210. Yes, it got QE/CI. Yes, all three outs are working nicely, and even HDMI audio worked oob. The card is CUDA compatible, and CUDA drivers are up-to-date. Movies play smoothly. What is making the trouble?
       
      Games!
       
      Not all of them. Only the most cool ones. Oh, i can play App Store's Jet Dudes, Lep's World or U-Boot silly windowed games, and full screen games like Forest Zombies or Battle Monkeys. Ultraviolet Dawn appears to work either windowed or full-screen. Uberstrike also didn't give me any issues untill now. But games like Amnesia, Trine 2, Jason vs Zombies and the supposedly low profile Kindom Chronicles are a certainty to make my whole system crash. Heck, even the said Forest Zombies did it at least once, as well as Crazy Monster Truck Escape a couple of times.
       
      the symptoms are the following: after some minutes into the game, usually less than ten, the game will crash giving me a black screen with no sound, and my HDD led starts to show no activity. The system don't reboot or give me a panic, just stay frozen like that. My only option is a hard reboot.
       
      At first, i thought the problem could be related to those games being 32-bit, since they used to work with my 32-bit only 10.7.4 with no issues, and i had to use the amd_insn_patcher to get my 10.6.8 to run both 32-bit and 64-bit user mode. I could be an instability inherent to the patch, so i tried to boot with -legacy flag, but the crashes continued to happen.
       
      Investigating a solution, i tried using other combinations of audio and video resolution. Changed for VGA and DVI monitors and tried both my built-in Via Audio and my KX-driven Soundblaster to no improvement. In a last ditch attempt, i simply removed CUDA drivers and re-tried all of the other troubleshootin methods i'd already used, to no avail.
       
      Then i remembered to look in the Console logs. Funny i waited so long to do it, since it's the first thing i myself recommend for anyone. Anyway, the common messages i found at the times the crashes happened were these two: KGCErrorFailure (always) and CGSGetWindowBounds: Invalid connection (sometimes).
       
      I google a lot, and, when i found i was running in circles with it and couldn't find a solution for my specific situation, since these error messages seems to be also related to other issues, i decided to bring it here, in the hopes someone could point me a light at the end of the tunnel here.
       
      Here's an excerpt of my last WindowServer log at the exact time the system crashed for the last time (testing with Amnesia.app):
       
       
      Oct 28 22:47:45 [75] kCGErrorIllegalArgument: CGXMoveWindowListToWorkspace: invalid window id: 66
      Oct 28 22:47:47 [75] kCGErrorIllegalArgument: CGXMoveWindowListToWorkspace: invalid window id: 67
      Oct 28 22:47:50 [75] kCGErrorIllegalArgument: CGXMoveWindowListToWorkspace: invalid window id: 68
      Oct 28 22:47:55 [75] kCGErrorIllegalArgument: CGXSetWindowListTags: Operation on a window 0x6 not owned by caller loginwindow
      Oct 28 22:47:57 [75] dict count after removing entry for window 0x5d is 0
      Oct 28 22:48:17 [75] CGXRestartSessionWorkspace: session workspace exited for session 256 ( on console )
      Oct 28 22:48:17 [75] loginwindow connection closed; closing server.
      Oct 28 22:50:10 [72] Server is starting up
      Oct 28 22:50:48 [72] CGXMappedDisplayStart: Display0 : no display alias property
      Oct 28 22:50:48 [72] CGXMappedDisplayStart: Display1 : no display alias property
      Oct 28 22:50:50 [72] GLCompositor: GL renderer id 0x01022614, GL mask 0x00000003, accelerator 0x00003123, unit 0, caps 0x00000003, vram 1024 MB
      Oct 28 22:50:50 [72] GLCompositor: GL renderer id 0x01022614, GL mask 0x00000003, texture units 8, texture max 8192, viewport max {8192, 8192} extensions 0x0000000f
      Oct 28 22:50:50 [72] agc_attach: Couldn't find any matches
      Oct 28 22:50:50 [72] CGXPerformInitialDisplayConfiguration
      Oct 28 22:50:50 [72] Display 0x43000000: MappedDisplay Unit 0; Vendor 0x410c Model 0x0 S/N 0; online enabled (0,0)[1920 x 1080], Rotation 0, base addr 0x106100000
      Oct 28 22:50:50 [72] Display 0x3f003d: MappedDisplay Unit 1; Vendor 0xffffffff Model 0xffffffff S/N -1; offline enabled (2944,0)[1 x 1], Rotation 0, base addr 0x106100000
      Oct 28 22:50:52 [72] Display 0x43000000: MappedDisplay Unit 0; ColorProfile "HD 709-A" (MD5 58a7456cff434584b31ed0a11f2da7be)
      Oct 28 22:51:45 [72] kCGErrorFailure: MPHWFill: failed (-536870212)
      Oct 28 22:53:51 [72] kCGErrorFailure: MPHWFill: failed (-536870212)
       
       
      Thanks in advance!
    • By roopt
      Hello,
       
      I finished installing OS X 10.7 Lion a few weeks ago. Things have been going well until recently, as when I play Java games (like Minecraft) and ejecting the drive using the key on the Apple USB Aluminum Keyboard, kernel panic might occur (It does not always happen).
       
      The message shows that com.apple.ATIRadeonX3000 is the culprit. Attached is a screenshot I took when the Kernel Panic happened.
       
      My computer configuration:
      Intel Core i7-930 2.8GHz
      Gigabyte GA-X58A-UD3R Rev 2.0 (FF BIOS)
      6GB of RAM
      Sapphire ATI Radeon HD5850 1GB
       
      Any help would be appreciated. Thank you so much!

×