Jump to content
jeffc2009

G73SW ML 10.8.2 Install

398 posts in this topic

Recommended Posts

Change your smbios to imac13,1.  Youtube working.

Great job ellnic.  I have been busy working, not alot of play time.  I guess you have clover figured out?  I used my old files to get a working system.  Changed smbios from macpro to imac13,1 to get system stable.  Still trying to figure out the brightness issue, not sure what's going on there.

 

hdmi was a dsdt edit to get it working.

 

I am using the iMac13,2 SMBIOS - same result. I didn't realise that the HDMI audio was a DSDT edit, did you do it manually or use a patch and DSDT editor?

 

In regards to clover, I have some stuff working but I wouldn't say it's suitable for release. It's a different animal to chameleon. Maybe we could put our heads together and figure it out? Drop me a PM and I can send back what I have so far :)

Share this post


Link to post
Share on other sites
Advertisement

I posted the LCD brightness method on the 10.9 guide Jeff posted if it will help anybody.

Share this post


Link to post
Share on other sites

Thanks asusg73.  I'll give it a try...

No problem...let me know how it goes

Share this post


Link to post
Share on other sites

You need to add HID EisaId under pnlf...i attached a screenshot so you can see what to add. Do you want to test my dsdt as a quicker way?

DSDT.tiff

Share this post


Link to post
Share on other sites

It worked, thanks!!! Was there a guide that you used to figure this out? 

Sure was...its on the OSX latitude forum. The asus fn hotkey driver from EmlyDinesh. Make sure your boot loader saves the backlight levels in nvram. You can verify by going into terminal and typing "nvram -p" without the quotes. At the bottom you will see the current backlight level value. If that works then find my mac setting will be remembered on boot and it will help iMessages if you use it.

Sure was...its on the OSX latitude forum. The asus fn hotkey driver from EmlyDinesh. Make sure your boot loader saves the backlight levels in nvram. You can verify by going into terminal and typing "nvram -p" without the quotes. At the bottom you will see the current backlight level value. If that works then find my mac setting will be remembered on boot and it will help iMessages if you use it.

EDIT: i got the efi string from the forum but the dsdt edits i got from a guy that tried to write a generic backlight driver that would work without dsdt, but it wouldnt work if you had a nvidia card since the gpu handled the brightness, additional info must be injected which is the purpose of the efi string. 

Share this post


Link to post
Share on other sites

Awesome find.  I will have to change my install package.


what kext's are you using?  Did you get battery icon working?

Been there done that! In a few posts back, i posted an installer called ireddybattery. Heres the download: iReddyBattery.pkg.zip


 

 

Been there done that! In a few posts back, i posted an installer called ireddybattery. Heres the download:

 

What else don't you have working? My hack is about 97% done. 10.8.5 was 100% working.

Share this post


Link to post
Share on other sites

I think that's it.  Extremely happy with this new system.  Thank you very much for help.

Glad to have helped. Enjoy. So am i...dont think I'm ever going back to 10.8 for a while. Mavericks feels like a more modernized snow leopard. How is battery life on your system?

Share this post


Link to post
Share on other sites

Battery life sucks on these beasts.

Haha but I get 3 hours on mine though...way better life than windows. And i use my hack in college and it lasts through the classes. Maybe something is not patched right?

Share this post


Link to post
Share on other sites

I noticed my battery is getting worse in windows 7, might be time to buy a new battery.  Last time I had timed it was watching a movie that was like 2hr 15mins long and I had like 5% left.  I bought my back in 2010.  Currently I have my eyes on MSI GS70, maybe for Christmas. Or after my oldest graduates from college next may.

Share this post


Link to post
Share on other sites

I noticed my battery is getting worse in windows 7, might be time to buy a new battery.  Last time I had timed it was watching a movie that was like 2hr 15mins long and I had like 5% left.  I bought my back in 2010.

2010? I thought the g73JH's where during '10? I jut know that early '11 there was a recall for the cougar point chipsets that had to do with the data ports reliability and the ones after the fix (like mine) get a sticker that says new revision. Ive noticed that the big secret with other laptops with better battery life actually have a bigger battery than the g73's. If just a little more battery space was given, the g73's might have reached close to 5hrs of usage. And Sandy bridge was introduced in Jan. of 2011...

Share this post


Link to post
Share on other sites

2010? I thought the g73JH's where during '10? I jut know that early '11 there was a recall for the cougar point chipsets that had to do with the data ports reliability and the ones after the fix (like mine) get a sticker that says new revision. Ive noticed that the big secret with other laptops with better battery life actually have a bigger battery than the g73's. If just a little more battery space was given, the g73's might have reached close to 5hrs of usage. And Sandy bridge was introduced in Jan. of 2011...

Maybe it was may of 2011.  Hell when you work all the time.  Everything gets confusing after a while...

Share this post


Link to post
Share on other sites

Maybe it was may of 2011.  Hell when you work all the time.  Everything gets confusing after a while...

I here ya no worries...well enjoy your system! And thanks a lot for taking the time to write this guide!

I was thinking about putting in a gtx 660m in the g73 but nobody had any luck with the kepler cards in osx. Battery life gets increased even more with a kepler card and runs cooler.

Share this post


Link to post
Share on other sites

Ah ok. The under screen blue led is for the JH models on the SW models, the blue bar is there but no led's are in it. All you have to check for is if the card is half sized or it might not fit properly. If they are then you're set.

Of course. Why not? But its a full height card so I'm not sure if it will fit properly.

ok just getting back to this, looking for a Wifi abgn or ac with BT4.0 half size card. Would love to have one that works OOB. as i do not have a dsdt. (im lost on that who process)

Share this post


Link to post
Share on other sites

Hey there! I was wondering if any of you guys are still around...

 

I have a G73SW-BST6, and I'm missing just a few functions that should be working...

 

Installed 10.8.5, installed Enoch, used the Dec10.zip extras folder, and the last DSDT posted. I'm currently up and running, everything works perfectly, the speedstep appears to work, the sound works well, sleep works...I haven't tested HDMI yet, but my issue now is screen backlight and GPU 'speedstepping'.

 

No matter what I try, I can't get the backlight keys (F5/F6) to adjust the backlight. Also, my GPU is locked into max speed (675Mhz), which really wrecks battery life, and makes a ton of heat. I'm suspecting the problem is that most G73SW comps run a 1.5GB 460m. Mine is the cheapo one, its only 1GB. As much as I've messed with Hackintoshes over time, I still don't know correct ways around DSDT patches and whatnot. What do I need to do to get these things working?

 

(I've tried the efi string? that was in the 10.9 topic early on, but I guess it didn't change much because it was probably for the 1.5GB 460m (they have different device ids))

Also, side note: What Wifi/BT cards do you have that work? I know I need to get an Atheros/Broadcom, but I currently just have the Intel chip...which one do I need to buy?

 

Thanks,

Atarian

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By FCU4ever
      I’ve succesfull installed Mac OS Sierra 10.12.6 on my Asus G73sw.
      Specifications:
      - Intel 2630QM-I7 / HM65
      - Nvidia Geforce GTX460m

       So what is needed to install Sierra on a Asus G73sw?
      1)       Install Clover with Mac OS Sierra on a bootable USB
      2)       Copy FakeSMC.kext , USBInjectAll.kext and VoodooPS2Controller to USB\EFI\CLOVER\kexts\Other\ folder
      3)       Copy HFSPlus-64 , CsmVideoDxe-64 (needed full resolution in Clover) and OsxAptioFixDrv-64 to USB\EFI\CLOVER\drivers64UEFI\ folder
      4)       Install Mac OS Sierra
       
      After the installation you reach the desktop.

      FIRST install Clover with the following settings:
                      - Installation for UEFI motherboards
                      - Install Clover in the ESP
                      - Drivers64UEFI -> OsxAptioFixDrv-64
                      - Drivers64UEFI -> CsmVideoDxe-64
                      - Install RC scripts on targetvolume
                      - Install Clover preference panel
       
      Copy HFSPlus-64 to EFI/CLOVER/drivers64UEFI/ folder
       
      After that, install the following kexts with your favorite kext installer:

                      - FakeSMC.kext                    ->            Always needed
                      - VoodooPS2Controller          ->            Needed to use your keyboard
                      - USBInjectAll                      ->            Needed to use USB2.0 ports
                      - ACPIBatteryManager          ->            Shows batterystatus
                      - AsusNBFnKeys                  ->            Needed to use FN keys
                      - AppleALC + Lilu                ->            Needed to get audio working
                      - RealtekRTL8111               ->            Needed to get LAN working (can’t test, LAN card defect)
       
      As last, copy the DSDT (many thanks to MaLd0n for creating the DSDT file) file to EFI/CLOVER/ACPI/PATCHED/
       
      Reboot and see what is working:
       
      -          Nvidia Geforce GTX460m         ->            Config.plist
      -          Wifi                                       ->            DSDT
      -          Audio                                    ->            DSDT + AppleALC + Lilu
      -          USB2.0                                  ->            USBInjectall
      -          Batterypercentage                  ->            DSDT
      -          Asus FN keys                         ->            AsusNBFnKeys
       
      And what is not working:
       
      -          USB3.0 (Fresco Logic xHCI(USB3))
      -          Keyboard backlight
      -          Brightness FN key
      -          Cardreader
      -          Bluetooth
       
      As last, I’m unable to generate a SSDT with ssdtPRGen.sh from Piker-Alpha. I’ve got the following error (see attached picture):
       
      The MacBookPro10,1 SMBios has an board-ID that is not compatible with my Sandy Bridge laptop. So I tried a few things:
      -          Change the SMBios to MacBookPro8,2
                 Reboot -> Black screen
      -          Changed the SMBIOS to MacBookPro8,2 and add the below to KextToPatch
                 com.apple.driver.AppleGraphicsDevicePolicy
                 BA050000 00
                 BA000000 00
                 Prevent AGDP from loading
                 Reboot -> Apple bar won’t load
      -         Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2
                Reboot -> Apple bar load but get a blackscreen
      -         Changed the SMBIOS to MacBookPro8,2 and changed productname to iMac13,2 and add the below to KextToPatch
                 com.apple.driver.AppleGraphicsDevicePolicy
                 BA050000 00
                 BA000000 00
                 Prevent AGDP from loading
                Reboot -> laptop boots good
       
      With the MacBookPro8,2 SMBIOS and the changed productname I’m still unable to generate an SSDT.
       
      So, can someone help me to:
       
      -          Generate a correct SSDT
      -          Get USB3.0 working
      -          Get Keyboard backlight working
      -          Get Brightness FN key working
      -          Get Cardreader working
      -          Get Bluetooth working
       

      USB files.zip
      After installation files.zip
    • By achot
      Hi everybody
       
      I want to share with you my hackintosh build,
       
      its a  ASUS G73SW laptop.
        The laptop works perfectly, the only big problem that I need to finde a fix for is the Audio:
       
      (ALC269) Clover detect it as : "Intel Cougar Point HDA Controller [8086][1C20]"
       
       
      Used the folowing : 
       
      * macOS Sierra app, downloaded from the App store
       
      * Clover UEFI Bootloader :
       
      * USB 8GB
       
      Clover boot flags : npci=0x2000
       
      Aditional options are :
       
      injectNvidia and loadVBios,
       
      Patch Vbios and InjectEDID
       
      needed for fullscreen resolution in clover boot menu.
       
      SMBIOS : MacBookPro10,1 
       
      The additional kexts needed are :
       
      FakeSMC.kext 
      FakePCIID_Broadcom_WiFi.kext
      VoodooPS2Controller.kext
      VoodooTSCSync.kext
      ACPIBatteryManager.kext
       
      Thats it
       
      Of caurse we also need DSDT patches.... 
       
      I am sharing with you my EFI Folder
      and the Kexts that I mentioned above
       
      Working list : 
       
      GPU ( GTX 460m and GTX 560m)
      Wifi
      Blueatooth
      Battery Percentage
      Asus FN Keys
      USB 2.0
      USB 3.0
      HDMI
      VGA
       
      Not Working List :
       
      Audio ALC269 G73
      Sleep (caused by the webcam detected as a usb connected device)
      Brightness controll ( works perfectly with nv_disable flag, it is cause by the Injectnvidia)
       
      Unknown :
       
      SpeedStep ( how can I check that ?)
      Keyboard backlight ( my keyboard backlight is broken so can't test )
       
       
       
      This thread is made in order to get a fully working hackintosh for this laptop,
       
      I want to get a fully working system with DSDT only (if possible) , in order to bring a easy to install and 100% compatibility for all G73sw owners
       
      Priority is to fix the Audio, it was working with 10.9 patched appleHDA and ioaudiofamily kexts.
      However it was working with 10.12.3 and older clover release only
       
      I lost audio after updating to newer version of clover, which I reverted and got audio working again, than after 10.12.4 update
      it wasnt working anymore, so we need a new clover version which automaticly cancels the posibility to get the audio from those 2 kexts
       
      beside geting it working, it was in bad quality, and the reason of that is the non use of the front bass which shuld be working in the same time as the speakers to get decent sound .
       
      I trayed also to patch the original AppleHDA.kext with AppleHDAPatcher, but it  does not work, however that patcher app has the script for the G73 laptop audio codec " ALC 269 G73" 
      which can be helpefull for applehda patching for sierra 
       
      I would like to ask to everybody that has the ability to patch AppleHDA , for that codec to write in this thread so we can get it working 
       
      I will update this thread with every possible fixes
       
      PS: sorry for my bad english, if a corrector can help out so we make this clean, that will be nice 
       
      Cheers
       
      EFI.zip
      Kexts.zip
      DSDT.dsl.zip
×