Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
iPeris

HP PAVILION G6 2160 Hackintosh Compatible?

3 posts in this topic

Recommended Posts

Hey everyone I was wondering if my notebook is compatible with Mac OS X Mountain Lion, or to be a Hackintosh at all.

 

HP Pavilion G6-2160 (15,6")

CPU: AMD A6-4400M (2.70 GHz)

RAM: 4 GB DDR3

Graphics: AMD Radeon HD 7520G and 7670M, 1 GB

Ethernet: Ethernet LAN 10/100.

WLAN: 802.11b/g/n

 

If it is compatible I would like some help with Kexts. Thanks!

Share this post


Link to post
Share on other sites

Hi I just installed osx on my g6 (its the exact same as urs)

 

here is what I did:

 

-got hazard 10.6.6i

-Restored it on my 8gb partiot flex

-used "NetbookInstallerUtillity on the USB Drive"

 

Then it booted on the bootloader (It wont boot unless the netbook utility works successfully, because it may not work and you would have to restore the usb again)

AFTER IT BOOTS

Use arrow keys to navigate to Hazard Snow Leopard Dvd 10.6.6i and type -v -x cpus=1 busratio=20

 

If it works, then go to disk utility and format whatever disk you want to Mac OS, EXTENDED (Journaled)

WARNING: Disk Utility might say your disk is disk0s2 or something similar (Which means) the disk doesn't have a name so it would be much easier if you name your disks

(EX (C:) Windows (D:) OSX (F:) Recovery (J:) System reserved)

then click customize and select legacy kernel, all other drivers don't work :/

 

IF IT DOESNT BOOT

 

1.unplug everything but the charger and the usb drive and retry

 

2. make sure there is a bit of unallocated space on your drive (shrink one of your drives by 1.5 GB) (Unallocated means there is no partition or format and the space is not being used) This can fix still waiting for root device issue

 

3. try changing your boot flags (example change busratio=20 to busratio=21, or you can add different boot flags like -s -f arch=i386 and many other bootflags)

 

and if all goes well then would will have mac os on your g6.

 

for kext and other info I have no idea :/

 

 

 

EDIT:

 

Alright here are the things that dont work

 

-internal speakers

-wifi

-multi touch on the track pad

-external displays

-some usb hardware

-SD card slot

-Webcam

-Dvd drive doesn't open

 

BUT AFTER ALL ITS STILL USABLE

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • You can try this one here 2.9.0 let me know if its better for you ?   VoodooHDA.kext.zip
    •   Boot option name retrieval 1) Locate the booter image as explained blow. 2) Locate ".contentDetails" in the parent folder 2.1) if unsuccessful, locate ".disk_label.contentDetails" in the parent folder 2.2) if unsuccessful, retrieve the volume's name   HFS Boot 1) Retrieve blessed file via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L41 1.1) if unsuccessful, retrieve blessed folder via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L45, append "\\boot.efi". NOTE: This is broken in the latest binary I checked. 1.2) if unsuccessful, use the following hard-coded paths: "\System\Library\CoreServices\boot.efi", "\EFI\APPLE\{ARCH}\BOOT.EFI", <StandardEfiPath>, "\\boot.efi" in this order 2) FV2 Recovery does not follow the usual practice because it is not shown by BootPicker anyway. Determine it via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleBless.h#L49, verify it does not match 1).   APFS Boot 1) Determine the APFS Volume Info (and hencefor detect whether it is APFS in the first place) via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L54 1.1) Determine the APFS Container Info via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L36 1.2) Verify the Volume Role via https://github.com/CupertinoNet/EfiPkg/blob/development/Include/Guid/AppleApfsInfo.h#L51 1.3) Retrieve blessed file analoguous to HFS 1). NOTE: This step and 1.3.1) are broken in the binary I checked, hencefor it does not happen, but is probably supposed to. 1.3.1) if unsuccessful, retrieve blessed folder and append the booter name the same way as in HFS 1.2) 1.4) (if unsuccessful,) locate all Volumes that are part of the same container, check whether the current Preboot partition has folders named by the just located Volumes' GUIDs and append the hard-coded paths from HFS 1.2) if existant 2) Recovery detection works the same way as 1.4), just for a Recovery instead of a Preboot volume
    • Got garbled sound in earphone    Notebook Asus X550VX i7 - 7700hq with ALC255 not working with applealc  layout id  3, 13, 17, 18, 27, 28, 99 its is working with VoodooHDA but the new one 2.9.1 it much has low volume, but bad sound in earphone     codec dump linux https://drive.google.com/file/d/1pg2y76WvFYsO8vFY-2B_2OLyKMmkQ8Tg/view     latest debug http://www.mediafire.com/file/2pjny4eq5r64ed8/debug_1383 (1).zip  
    • For F6 Bios, which DSDT is the one i should use? I´m a little confused in the Mass of DSDT here ;-).   Great Thread by the Way.   Another Question: I have 2 960Pro inside my Rig (one with OS X, one with Windows 10). When i try to mount my EFI on OS X NVMe the system freezes... :-(   DWhen i unplug the Windows NVMe everything is fine an it mounts the EFI.   Anybody an idea?   Tried the upper Port on the Board (OS X) & the middle / lower Port, in the Middle it mounts the EFI in the lower it freezes.   But i need the middle Port for an SATA M.2 SSD :-D... Even when i plug the Windows NVMe into an PCIe Adapter Card it freezes at the point i mount the EFI.   I´m mounting with Clover Configurator.     Thank You guys.
    •   Just add "ngfxsubmit=0" to config.plist to disable the fix within nvidiafixup


×