Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

Sign in to follow this  

Major issues with Intel DG45ID

4 posts in this topic

Recommended Posts

HI there


I hope one of you can help me because after 3 days of working on this I am now out of options, tried forum search but nothing


I have an Intel DG45ID with 4GB of RAM and Core2Duo 2.66MHz CPU


I have been trying to get Mountain Lion or indeed Lion on this with limited success, I can get a booting Lion install if I use the inbuilt GMA graphics however as soon as I plug in a PCIe Graphics card it instantly stops booting and hangs on [PCI configuration begin].


The inbult graphics are unsupported GMA x4500hd


I have tried playing with just about every boot option, I have tried installing with iatkos l2, ###### and myHack


I created a custom DSDT by booting into windows and patched it figuring it had to be something to do with the BIOS but no joy


npci=0x2000 and npci=0x3000 dont work


rolled back IOPCIFamily.kext and AppleACPIPlatfrom.kext from 10.6.7 again with no joy


have tried with three sperate graphics cards 1 ATI and 2 nvidia same result



any ideas? Am I missing something simple?

Share this post

Link to post
Share on other sites

What are you using for a graphics card? The 8400? Seems to me with a working good DSDT file, you should be ok. I scanned the forums and there are plenty of builds with that motherboard that worked on Snow Leopard or Lion, so I suggest you check out those threads first and see what they did to fix their problems.

Share this post

Link to post
Share on other sites

I know that this topic is two years old, but I figured I would add what I did; just in case someone stumbles on this like I did. I used " -v PCIRootUID=1 npci=0x2000 " boot flags in that order (without the quotes) Otherwise it wouldn't boot at all.

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.