Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.

  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Sign in to follow this  
Ibanezbass

Still waiting for root device -- USBF error; HP Envy 6t

4 posts in this topic

Recommended Posts

So I've now tried Lion and ML. ML gives me a USBF error that says the EHCI cannot take control from the BIOS. Then I get the infamous "Still waiting for root device".

My hardware:

HP Envy 6t-1000

Core i5 2467m

HD 3000 + Radeon HD 7670m

6 GB DDR3 1600 (@1333)

2 USB 3.0 + 1 USB 2.0

 

What I've tried:

Flags:

cpus=1 (required; kernel panic without)

GraphicsEnabler=no (required; freezes without)

-f

both npci

All PCIRootUID options

UseKernelCache=no

USBBusFix=yes

 

Tried a different IOUSBFamily/IOPCIFamily

Tried to unplug and replug the Flash Drive.

 

Out of ideas... Anyone have an idea?

Thanks

 

PS. I have NO changable bios options. I am using the USB 2.0 port.

 

Edit: Seems that I can use the arch=i386 in the Lion installer to get it to load. So, why am I not loading the USB kext in 64 bit arch?

Share this post


Link to post
Share on other sites

Did you try all USB 2.0 ports? On my Lenovo L530, only the very first USB 2.0 port did its job; on every other 2.0 port, I got the "still waiting for root device" message

Share this post


Link to post
Share on other sites

Open terminal and type;

 

cp -pr /Volumes/USBNAME/System/Library/Extensions/*ATA* /Volumes/MLPARTITIONNAME/System/Library/Extensions/.

chown -R root:wheel /Volumes/MLPARTITIONNAME/System/Library/Extensions/*ATA*

chmod -R 755 /Volumes/MLPARTITIONNAME/System/Library/Extensions/*ATA*

 

Restart with -f

Share this post


Link to post
Share on other sites

How can you do that when you can't enter the installation utility? As far as I'm concerned, I couldn't open terminal because the still waiting for root device message appeared before the partitions could be "loaded" and therefore before the installation utility could star.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×