Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
taikentsuken

[SAMSUNG Series 9] Problem to install : Still waiting for root device

23 posts in this topic

Recommended Posts

Hello,

 

At first, excuse my english cause i'm french.

 

I recently bought a Samsung Series 9 NP900X3A.

 

I try to install mountain lion with usb key but i have the apple logo with a disabled sign.

 

So i tried to install with boot -v but all the time i have the same message : "Still waiting for root device".

 

I tried to change some parameters but nothing as change...

 

Please, see the attached screens :

 

boot -v : only

 

29779d1346148537t-samsung-series-9-problem-install-still-waiting-root-device-mac-boot-v.jpg

 

boot -x-v with PCIRootUID=0 GraphicsEnabler=No

 

29780d1346148538t-samsung-series-9-problem-install-still-waiting-root-device-mac-boot-x-v.jpg

 

About my configuration :

 

###### : 1.5.3 with 2 options (Laptop & Legacy USB actived)

OSX : Mountain Lion from Mac AppStore

USB : Corsair 8Go FlashVoyager

Laptop : Samsung Series 9 NP900X3A

BIOS : Default except First Boot (USB HDD)

Partition SSD Disk : 1 Partition NTFS empty

 

How can i do ?

 

Thanks a lot for helping me, i try everthing for 3 days now.

Share this post


Link to post
Share on other sites

put in USB/Extra/Extensions and use this boot flag: -f -v GraphicsEnabler=No npci=ox2000

 

 

 

 

5. IMPORTANT: Set “SATA RAID/AHCI Mode” to “AHCI”

6. Go back (ESC), go to Power Management

7. Set the ACPI Suspend Type to S3(STR)

8. Set HPET Mode to 64-bit mode

9. Save and Exit, by pressing F10

Share this post


Link to post
Share on other sites

ok, is correct, but you are boot from USB 3.0!!!!! change for a Port USB 2.0 or this not work, your device id for your controller Sata is ok in AppleAHCI.kext see here: 8086 1c03 , your bios is set for AHCI !!!!!!!!!

 

 

<key>Intel6SeriesAHCI</key>

<dict>

<key>CFBundleIdentifier</key>

<string>com.apple.driver.AppleAHCIPort</string>

<key>Chipset Name</key>

<string>6 Series Chipset</string>

<key>IOClass</key>

<string>AppleIntelPchSeriesAHCI</string>

<key>IONameMatch</key>

<array>

<string>pci8086,1c02</string>

<string>pci8086,1c03</string>

</array>

Share this post


Link to post
Share on other sites

It work :)

 

Now how can i do to choose drivers & boot with [url=&quot;http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/&quot;]#####[/url]?

 

Cause i don't have Display lighting (the screen seems black)

- keyboard is detect as default (no rightclick, wirhless touch, light etc...)

- wireless doesn't work

- sound doesn't work

 

Thanks a lot :)

Share this post


Link to post
Share on other sites

ok, this because your partition is not active, try active partitition with commands from Terminal app, open Terminal app an put sudo -s

passw

 

put this i386 folder in the desktop

 

 

Look for your boot partition's identifier (diskXsY):

 

 

diskutil list : EX: disk0s2 in this example is disk0s2 see for your disk

 

Get root access:

sudo su

 

cd /Users/your user/Desktop/i386

 

Install boot0 to the MBR:

 

./fdisk440 -f boot0 -u -y /dev/rdisk0

 

Install boot1h to the bootsector of the boot partition:

 

dd if=boot1h of=/dev/rdisk0s2

 

Copy the file "boot" to the partition:

 

cp boot /

 

Set the partition active:

 

./fdisk440 -e /dev/rdisk0

 

p <-----> (print a list on screen)

f 2 <-----> (makes partition 2 active) see your Partition

w <-----> (write to disk)

y <-----> (yes)

reboot

 

 

i386.zip

Share this post


Link to post
Share on other sites

When i put cp boot/ it ask me : usage cp [-R [-H etc...]

 

And what can i do with :

 

p <-----> (print a list on screen)

f 2 <-----> (makes partition 2 active) see your Partition

w <-----> (write to disk)

y <-----> (yes)

reboot

 

?

Share this post


Link to post
Share on other sites

cd /Users/your user/Desktop/i386

 

cp boot /

 

 

or

 

cp -R boot /

 

 

or copy and paste, see it is only one space in the command for copy : cp space boot space /

 

 

Set the partition active:

 

./fdisk440 -e /dev/rdisk0 enter

p enter <-----> (print a list on screen)

f 2 enter <-----> (makes partition 2 active)

w enter <-----> (write to disk)

y enter <-----> (yes)

reboot

Share this post


Link to post
Share on other sites

sh-3.2# ./fdisk440 -e /dev/rdisk

rdisk0 rdisk0s1 rdisk0s2 rdisk1 rdisk1s1

sh-3.2# ./fdisk440 -e /dev/rdisk0

Enter 'help' for information

fdisk: 1> p

Disk: /dev/rdisk0 geometry: 15566/255/63 [250069680 sectors]

Offset: 0 Signature: 0xAA55

Starting Ending

#: id cyl hd sec - cyl hd sec [ start - size]

------------------------------------------------------------------------

1: EE 1023 254 63 - 1023 254 63 [ 1 - 250069679] GPT

2: 00 0 0 0 - 0 0 0 [ 0 - 0] unused

3: 00 0 0 0 - 0 0 0 [ 0 - 0] unused

4: 00 0 0 0 - 0 0 0 [ 0 - 0] unused

fdisk: 1> f 2

Partition 2 marked active.

fdisk:*1>

 

I put w and y to reboot but after reboot, i have the same black display. Only boot on usb key.

 

Install boot1h to the bootsector of the boot partition:

 

dd if=boot1h of=/dev/rdiskX0s2 you make en error on X0 just 0

Share this post


Link to post
Share on other sites

look your bios if your hard drive is set for boot (first, Boot Priority)

 

 

 

ok, its true, this is my error, but you can see this!!!! No!!! this is for make a example for you, my bootloader work very well, now I edit this .

Share this post


Link to post
Share on other sites

I tried every links that i found on google or Ifire member but my hackintosh doesn't boot without the usb key.

 

I have only a blinking black screen.

 

Please see the last method that i tried :

 

mini_839243fdisk.jpg

 

I don't understand why cause when i boot from ###### and choose the MLion partition (Samsung SSD), it boot perfectly and don't crash.

 

Configuration :

Chameleon-2.1svn-r2048.pkg.zip

Boot : HDD Samsung 128 SSD

EFI : Enabled or not

 

Thanks for helping me :)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.



×