Jump to content
Welcome to InsanelyMac Forum

Register now to gain access to all of our features. Once registered and logged in, you will be able to contribute to this site by submitting your own content or replying to existing content. You'll be able to customize your profile, receive reputation points as a reward for submitting content, while also communicating with other members via your own private inbox, plus much more! This message will be removed once you have signed in.


Post-Installation fixes on a Lenovo L530

6 posts in this topic

Recommended Posts

Hey guys,


I've succesfully installed ML on my Lenovo L530 thanks to this gude http://www.insanelym...pic=280756&st=0 :) The system is booting without problems, but some things are not working.


-Wifi (will never work though I think since it's a intel centrino card)


-Internal keyboard and touchpad

-Display (only available resolution is 1024x768, even though the display's 1600x900) and afaik the Intel HD 4000 should be supported natively)



The USB 2.0 Ports work nicely - haven't tested the 3.0 one yet. Despite that, I can't find any problems (gotta admit though haven't had the opportunity to test the whole system). I've extracted my DSDT and added the smbios File I used installing ML. Furthermore, I've run SystemInfo and it showed me a few Intel devices. Since the software itself only produced 0-byte files extracing the devices, I hat to create a list myself.


I've already tried the voodoo ps2 driver, but unfortunately to no avail. For my Ethernet-Card (apparently a Realtek RTL8111F) I've already thried this driver. The card gets recognized in the Mac-Systeminfo, but I somehow can't connect to my router. In the Network-screen it says connected, but I can cleary see in my router-settings that my notebook didn't connect. It didn't work via DHCP and using manual settings didn't help either.


I've attached the files I've extracted and I'm hoping you guys can help me :)


Greets Pillendreher


Share this post

Link to post
Share on other sites

Fixed the display issue by setting 1600x900 as resolution in Chameleon. Still can't get touchpad&keyboard working though..tried "ApplePS2Controller.kext" and "AppleACPIPS2Nub.kext" resulting in blocking my USB keyboard...

Share this post

Link to post
Share on other sites

Thx pal. I've already booted into Windows and deleted the kexts from Windows before I've read your answer :) How can use your way if I can't log in?




I've managed to get my keyboard working thanks to this post. Trackpad still isn't working though.


Thanks to this thread, I've got the battery icon running and I don't have that annyoing CMOS error (just before Chameleon would start) anymore :)


I think I'll make a little guide on how to install ML on a L530 after I'm done with fixing stuff ;)


EDIT: Got the trackpad working by planting "ApplePS2Trackpad.kext" in the extensions-directory. Unfortunately, it's recognised as a mouse and not as a trackpad. Is there any solution for this out there?

Share this post

Link to post
Share on other sites

Fixed the ethernet card :)


You need the "RealtekR1000SL" driver *click*. From all the kexts offered to you, you choose /AVX (SandyBridge : IvyBridge)/x86_64-i386/RealtekR1000SL.kext . The normal AVX kext (without the i386 addition) didn't work for me.

Share this post

Link to post
Share on other sites

Got hardware-acceleration working on the Intel HD 4000 by injecting this string into the org.chameleon.Boot.plist :)


ig-platform-id: 01660004, Stolen RAM for FB: 32MB, Pipes: 3, Ports: 1, FBMem: 1


Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.