Jump to content
InsanelyMac Forum
Sign in to follow this  
cubo

[ML 10.8.1] sound of ALC1200 (Asus P6T) not fully working

Recommended Posts

I can't get the audio of my Asus P6T (just p6t: no deluxe, se, etc) to fully work.

I know that it use ALC1200 (don't know if I have to use 885, 887, 889 etc)

I've tried several guide but I always have some problems:

 

1- Only OUT line is working, can't get my microphone to work.

2- When I insert my headset on the front panel the sound doesn't switch automatically, i've to manually set to use headset from Preferences. (Still only OUT is working)

 

Right now i'm using an AppleHDA.kext and at least I can hear sounds.

 

I've tried several HDEF patch to my DSDT but with no success.

 

I've attached my DSDT (clean verion, without HDEF) and the AppleHDA.kext that i'm using right now.

 

If you need other info just ask and i'l update my post.

 

Thanks for your help.

AppleHDA.kext.zip

DSDT_originale.aml.zip

Share this post


Link to post
Share on other sites
Advertisement

What's your hardware id?

 

If I'm correct:

vendor: 10EC

device: 0888

 

So probably is Realtek ALC888/1200?

Share this post


Link to post
Share on other sites

Ok, now that I know that I have ALC888 I've replaced the AppleHDA.kext with the kext for Legacy ALC888 (without dsdt patch).

 

Now I have audio with automatic switch speakers <-> headphones

 

Also microphone is working.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.



×