Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
eXtink

Reboot during loading kexts when installin Mountain Lion

10 posts in this topic

Recommended Posts

Hello everyone,

 

I've seen this kind of topic before on this forum, but I didn't found any solution for it.

 

My problem is that when I try to install Mountain Lion on my pc that during the loading off all the kexts the system gets rebooted. This doesn't happen during a specific kext and it happens without any warning/kernel panic.

Lion runs just fine on my pc and I was able to install Mountain Lion before, but now it won't load the install anymore.

 

My pc information:

- Intel E8400

- GTX 275

- MSI P45 neo2

- P45

- ICH10R

- JMicron 363

- ALC888

 

Below I've attached the /Extra folders I tried to use during the installation. I've used the [url="http://www.insanelymac.com/forum/topic/279450-why-insanelymac-does-not-support-tonymacx86/"]#####[/url] instalation method, the myHack one and the manual with building your own USB boot drive using my /Extra folder I'm using off 10.7

 

Also I've tried the following arguments:

-f

-v

-x

-f -v busratio=20 GraphicsEnabler=No npci=0x2000

-x -f -v busratio=20 GraphicsEnabler=No npci=0x2000 cpus=1

 

 

Hope someone will be able to help me,

eXtink

Extra_10.7.zip

Extra_10.8_myHack.zip

Extra_10.8_UniBeast.zip

Share this post


Link to post
Share on other sites

Happened with me. Tried a lot of things and then finally recreated the installer partition. Thereafter, the system booted into the installer successfully.

 

Give it a shot and share the results here.

Share this post


Link to post
Share on other sites

-x -f -v are your best friends when booting installer. Stick to the make your own method, but redoing it to be sure nothing got missed wouldn't hurt. To the fabulous trio of boot flags above, also add npci=0x3000 and/or PCIRootID=1, don't think you should need busratio or cpus=x. If over 4gb of ram either remove some or use maxmem=4096 flag (verify syntax on that one first, I don't know it off hand)

Share this post


Link to post
Share on other sites

Okay.....

 

I remade my install USB, nothing!

Did all those arguments and combinations with all those, nothing!

 

It's strange that I can easily run the Lion installer, but not the Mountain Lion installer

Share this post


Link to post
Share on other sites

I've remade my USB boot drive with the latest version of chameleon r2050, tried all of the arguments but still nothing.

But I was able to capture the latest kernel kext getting loaded before the reboot. Check the attachement below

post-1047859-0-61990800-1346085052_thumb.png

Share this post


Link to post
Share on other sites

Okay, I've got the very last line printed before the system gets rebooted.

 

Manualy built the USB boot

-x -f -v

/Extra of existing system running 10.7

 

post-1047859-0-30389000-1346104532_thumb.jpg

Share this post


Link to post
Share on other sites

It is at that point Chameleon passes off booting process to OSX/Darwin which should take over to finish booting. This is obviously not happening. Chameleon revision not suitable for ML is usual cause, but you are running lasted revision as you said. I don't have solution atm and have to leave for work now, but maybe knowing that help you find out?

Share this post


Link to post
Share on other sites

I already did found out that would be the problem, but it didn't. So I did all the necessary steps again: BIOS, formatting HDD and creating USB boot drive. This was the third time I did this and voila! It worked. Why? I don't know! I think that something was wrong in the BIOS.....

 

But this topic can be closed now.

 

 

ps: eep357: thanks for the help!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

  • Posts

    • Hi,Bergui.  I am certainly happy you finally solved your problem  but I am confused.  What you did is what you were supposed to do to do to begin with.  What were you doing before? You mean you were creating your USB with something else than a Mac? 
    • Is there a simple guide somewhere that explains what to do to to help out testing your ssdt's? I got clover configurator, ioregexplorer and some basic knowledge but it's hard to find out where to start.  Also... if I was about to apply an ssdt... is it easily reversible or do I have do an reinstall every time I screw up?   Edit: Admire your work by the way. I've been google'n this for years. Hat's off! 
    •   Hi Maldon, great guide! I got my old Dell 780 (LGA775) running High Sierra 10.13.4 nicely, thank you!   I have no audio and I see where you mention "Device HDEF + AppleALC + Lilu". I have AppleALC + Lilu in my KEXT folder but not sure what "Device HDEF" is. 
      Also when it goes to sleep it takes like 2 minutes to wake. I have a Q9400 quad core + Nvidia Quadro FX580 but don't have a DSDT for it. Can you help me with a DSDT?   Here are my RunMe Results https://drive.google.com/file/d/1Duv3XYyW4UhziDVVWdquwxYcGQ-D5tvm/view?usp=sharing   SPECS: Dell 780 MT, Q9400 2.66GHz Core2Quad Core, Nvidia Quadro FX580 
    • I've tried these several methods of booting into clover, but it still skips. I even double checked that i was using your Clover folder. Bios settings should be the same too... this is getting really strange here.


×