Jump to content
eep357

[How-to] Software RAID-0 in Mountain Lion on ICHx/JMicron/Marvell/ASMedia

26 posts in this topic

Recommended Posts

thanks for the info, really appreciate it. yeah i bought the ASM1061 for only $11 (free shipping) so it wouldn't hurt so much if I get another one.

 

BTW, here is my AJA score launched using LaunchAsRoot app.

 

SSDRAID0_2B.png

Hi tot,

 

i tried to connect 2 SSD's with 1 ASM controller and second the one on the MOBO. im getting 500mb/s read/write but i cannot boot from this raid setup...i tried everything and its not working. when i connect the SSD's to the same controller i can boot up raid...have you manage to boot with the setup i did?

Share this post


Link to post
Share on other sites
Advertisement

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

  • Similar Content

    • By dukzcry
      Here's my driver for LSI MegaRAID SAS family of controllers called SASMegaRAID.kext. This one was requested few times at InsanelyMac and other Mac-related communities.
      Download link https://github.com/dukzcry/osx-goodies/releases or https://www.insanelymac.com/forum/files/file/306-sasmegaraidkext/
      F.A.Q.:
      Q: I can't manage controller via supplied utility
      A: Only monitoring functional is supported, management is done via controller BIOS
      Q: Any chance to make cards based on SAS2208 chip work?
      A: Not currently, the chip belongs to the same family, but it requires a lot of handling different from common handling for supported cards.
      Q: The driver loads but my device doesn't show up anywhere in profiler. What should I do?
      A: Try inverting "PreferMSI" key value. It's under "Settings" dictionary in kext's plist. 
      Q: macOS doesn't see my volumes
      A: Set them as virtual (logical) disks in controller's BIOS. If no luck try "Uncontiguous enumeration.zip" version. See full issue report https://www.insanelymac.com/forum/forums/topic/285197-driver-for-lsi-megaraid-sas-family/?do=findComment&comment=1987665
      Q: Is it possible to push more from my setup?
      A: It may be.
      The plist from "Unsafe settings unlocked.zip" allows tweaking of dangerous options. Before playing with them you need to detach all HDDs with critical data and attach some spare HDD for doing the tweaks. The "MaxSGL" option is number of scatter gather list entries you controller can handle. The "MaxTransferSize" determines the maximum size of data transfer (in bytes) per request your controller can catch. If you set them to some enormously big value then they will be truncated to the max values your hardware can achieve (may still be not safe enough for successful data transfers). "MaxTransferSizePerSegment" does the same but for a single SGL entry (will never be larger than MaxTransferSize). For the tests you need to stick to the system.log and start a transfer of a >= 100gb data. If the settings you set are inappropriate, you'll see the I/O errors.
      Q: My Mac stopped to go sleep after i've loaded your kext.
      A: This is awaited. See https://www.insanelymac.com/forum/forums/topic/285197-driver-for-lsi-megaraid-sas-family/?do=findComment&comment=1986269 Use kext from "Unsafe settings unlocked.zip" and set "AllowSleep" key to true.
      Q: Your driver doesn't work for me. Are there any alternatives?
      A: Yes there is one https://www.insanelymac.com/forum/forums/topic/314799-guide-z820-el-capitan-the-great-guide-sucess/?do=findComment&comment=2556863
      Q: I get "mfiutil: mfi_open: not such file or directory" error
      A: It maybe that unit number of you device is not 0 (which is default). Try the following:
      $ ls /dev/mfi?
      /dev/mfi2
      $ sudo mfiutil -u 2
    • By dukzcry
      This is kext for LSI MegaRAID SAS family of controllers
      Topic: https://www.insanelymac.com/forum/topic/285197-driver-for-lsi-megaraid-sas-family/
       
    • By Dallastyle
      Hello Insanelymac,
      I've successfully installed Mac OS X Sierra on 2 32gb flash drives with them as a JBOD Raid. I can only get into the hackintosh if I use another USB flash drive with Clover installed on it. I've tried using a clover installer however that just installs on my Raid Disk. I've also noticed that when I open clover configurator, there are 2 EFI partitions but both of them were empty. I've tried moving the contents of the EFI on my Raid disk that clover installed but my BIOS does not detect it. Also when I use the other flash drive to boot into clover, there is another volume called "BOOT OS X" right next to my Raid Disk Volume that I use to boot from. I just want to install and boot off of my Raid usb flash drives. Really running out of options, Thanks guys.
×