Jump to content

RAID 0 on 4 ssd's - Windows 7/ Mountain Lion?

17 posts in this topic

Recommended Posts

i have 4 ssd's - 2 striped raid 0 arrays. one set is running mountain lion in apple's software raid config, and the other i want to run windows 7 in raid. i have an asus p6t, it has a jmicron sata raid setup. when i config bios to use the jmicron raid setup, it doesn't have native AHCI, so i can't boot into mountain lion without disabling the hardware RAID config for windows. anyone have any ideas on how to configure this to work?

Link to comment
Share on other sites

I don't see how having windows hardware raid would prevent Apple software raid from booting other than both the win drives not being accessible in OSX. Wouldn't it be the same result if you completely disabled the jmicron controller in BIOS before booting apple soft raid?


btw: I'm booting ML on 2 SSD RAID-0, with one drive on Marvell sata 3 controller and another on ASMedia sata 3 PCIe card, this configuration proved to be the fastest possible because both drives weren't on the same bus at the same time. approx 800mb/s read vs 500mb/s read when both on same controller

  • Like 1
Link to comment
Share on other sites

That happens because changing to RAID mode changes the device ID of the controller, as you can see here:



You must make the same modification or use an injector/legacy kext.


Also I believe that Chameleon needs to be installed to a partition that's not part of the software RAID?

Use a USB flash drive or a third, non-raided drive.

Link to comment
Share on other sites

Edit: OK, I just went all out and did the whole write up, why do half right?


Ah yes, but let me clarify what I was mean, and if it doesn't work then my bad. I know the soft raid part does, but haven't tried with windows in hardware RAID. OP, I know you probably already know all this, but added extra details for others who may find it useful. No changes to the intel controller, since there are 2 separate SATA controllers available. First, Intel, which should stay in AHCI (Enhanced) mode as normal:

e4283_P6T.pdf (page 82 of 188).png

Then separate Jmicron controller for Windows RAID:

e4283_P6T.pdf (page 111 of 188)-1.png

Set to "Super Speed Mode" aka RAID-0 (ooh, sounds fast!)

e4283_P6T.pdf (page 112 of 188).png

And get Jmicron drivers for Windows from ASUS:

ASUS - Motherboards- ASUS P6T.png

It's possible Windows may not like booting from this RAID controller, but OSX shouldn't care as long as your soft raid is running on the Intel ICH10. Chameleon would be installed to each drives hidden "boot OSX" partition along with /Extra on each and kernel cache will be built on each. OSX cannot boot without kernel cache, i.e. -f, or will get error mach_kernel not found. In /Extra folder of each "boot OSX" partition, in org.chameleon.boot.plist, you must include additional kernel flag

rd=uuid boot-uuid="UUID of your RAID array here, use Disk Utility and select array the Get Info"

Get UUID here:

Mikuru.jpgInformation_ Mikuru.jpg

Most the boot process takes place from the cache, then once the soft raid kexts are loaded, system can then find the array to finish booting, without this you will get "still waiting on root device"


Here is my entire org.chameleon.Boot.plist so you can get an idea of how it should look:



Chameleon along with your Extra folder and updated org.chameleon.Boot.plist all need to be installed onto the boot helper partitions, which are hidden by default and called "Boot OS X", or have seen them without space too like "Boot OSX". They are not striped and are not part of the RAID array, making them readable by the BIOS and by Chameleon. ML RAID array must be created in ML Disk Utility, not Lion. The ML installer also will throw an error if you try to do a clean install direct to RAID, so will need to boot into working ML and clone it to your array. To install Chameleon to the "Boot OS X" helper partitions, First find out the disk # for each one using Terminal and diskutil command and make note of the Disk #, the partition #'s will always follow the same layout where "Boot OS X" will be partition 3( s3 ):

diskutil list

Make note of the disk # for each drive that will make up your array ( rdiskX ) where X is the drive #

Rather than run the Chameleon installer, install the 3 needed Chameleon boot files manually. They are; boot, boot0 and boot1h. If you have Chameleon package installer, they can be extracted to the desktop with Pacifist, or if you grab the binary you can just copy them right over. Either way, put them on the desktop for now along with Extra folder and edited org.chameleon.Boot.plist inside of it along with usual contents like DSDT. The last bit will all be done in terminal. For demonstration purposes, I assume my first hard drive of the array is rdisk1 and the 2nd is rdisk2, substitute with your own BSD drive number obtained via diskutil above.


cd to desktop:

cd ~/Desktop

enter root

sudo -s

install boot0 to MBR, we don't need to worry about partition # here:

fdisk -f boot0 -u -y /dev/rdisk1

fdisk -f boot0 -u -y /dev/rdisk2

Then to install boot1h

dd if=boot1h of=/dev/rdisk1s3

dd if=boot1h of=/dev/rdisk2s3

then need to mount one of the helper partitions to copy our remaining files over, and once done, unmount it then repeat the process for the 2nd helper partition:

diskutil mount disk1s3

cp boot /Volumes/Boot\ OS\ X/

cp -R Extra /Volumes/Boot\ OS\ X/

diskutil unmount disk1s3

then repeat for other partition, will condense into short version cause this post is getting long:

diskutil mount disk2s3
cp boot /Volumes/Boot\ OS\ X/
cp -R Extra /Volumes/Boot\ OS\ X/
diskutil unmount disk2s3

Here's what mounted Boot OSX partition should look like:

Boot OS X.png

Now you can have either drive listed as your boot device in BIOS, and pick either Boot OSX partition from Chameleon's boot menu, and your RAID will boot either way

  • Like 1
Link to comment
Share on other sites

Mine is set up completely opposite, where none of my boot drivers are on Intel ICH10 controller, so should be able to hardware RAID it for windows and still boot OSX from non-Intel SATA controller

Mac Pro.jpg


Nice work eep.


What's this I've heard about having Chameleon on a "helper partition" on Software RAID systems then?

I will add that part :)


Edit: There, all for you GV! :)

  • Like 1
Link to comment
Share on other sites

That needs to be up in lights, framed and pinned. Or at least put in a FAQ. Excellent work. Now...where are the moderators of this forum when you need them??
Probably take out the ASUS/Windows HW RAID specific part at the beginning?
Link to comment
Share on other sites

Yeah maybe change it a little. But just leave this here the way it is.


Copy the guide to a new post here, it's your baby, it's better if you do it yourself so that you can change things later if you want:


Then I'll pin it.


With a nice title like [How-to] Software RAID on JMicron/ICHx or something like that.

Link to comment
Share on other sites

it's already framed in my house GV as eep was the one who helped me get my software raid0 up and running on ML. His guide couldn't be any straight forward unless he came to your house and did the install himself.

Hmm, for a small fee...... :)
Link to comment
Share on other sites

Thx eep. I've gotten it to work on the intel Sata ports via apple software raid, but not the jmicron ports. For some reason only one of my jmicron ports are working. I'm no at my computer now, but I'll try different configurations. The biggest problem I'm having is that windows requires a hardware raid, so I can't dual boot as easily with chameleon.


Good write up,

Link to comment
Share on other sites

Hm, it looks like you have to put JMicron controller to AHCI mode when booting OSX?


Some of us Asus users have JMicron in legacy IDE mode, we need AHCI, but that can not be changed in BIOS. Fortunately, that can be fixed from DSDT. See here for links for more info, maybe it will be of some help. You can even try the kext for the start to see if it will work.


Link to comment
Share on other sites

e4283_P6T.pdf (page 97 of 188).png

Also set this to AHCI, I know it says eSATA and PATA, but you never know, could be something spooky going on there. Default is IDE and don't see how it could hurt to change it to AHCI either way

Link to comment
Share on other sites


  • Create New...