Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
Moviemakergr

10.8.2 Beta > a Strange ? Update for hackint0sh machines

164 posts in this topic

Recommended Posts

Today along with the version 10.8.1 apple was given and 10.8.2 for devs

Those extra careful try this 10.8.2 version has changes maybe associated with smbios and the computer will not start.

Whoever finds exactly why and what is needed to overcome this difficulty please posting in this thread.

 

"It is obvious that the challenges returned to hackint0sh community"

Share this post


Link to post
Share on other sites

Then, should be inside /S/L/E/FakeSMC.kext/Plugins/ + rebuild caches + repair permissions with Disk Utility.

Thanks .. confirmed But why it happens ?

 

And another thing if you know please , all mobo with 7 series chipset have the indication Unknown AHCI Standard Controller on sata system info ?

Share this post


Link to post
Share on other sites

no problems here. The oembios.kext is fakesmc plugin used in slices/projectosx branch of fakesmc. Kozlek's branch available here does not use that plugin, so should be fine using his version for full functionality for now

Share this post


Link to post
Share on other sites
And another thing if you know please , all mobo with 7 series chipset have the indication Unknown AHCI Standard Controller on sata system info ?
Which are the specifications of your hardware? Probably is fixable by a DSDT patch (device-id), but depends of your chipset - platform, to fake a vanilla (compatible) SATA - AHCI controller, see in "Usual patches": http://olarila.com/f....php?f=19&t=634

Share this post


Link to post
Share on other sites

---

the same prob i get on netbook samsung n102

 

any help for us thanks

Did you read any of the posts after that? It's already been said how to fix :)

Share this post


Link to post
Share on other sites

10.8.2 must be targeted possibly for the new iMAC's which will have Ivy Bridge and Nvidia Graphics maybe to solve some issues we see now with the Fermi and Kepler 104 chips whichever they decide to use?

 

I would think a release date once 10.8.2 is released.

Share this post


Link to post
Share on other sites

hello

 

i have installed no issues for now

 

only replace applehda for my alc

 

good hack

 

Olá artur, podes partilhar AppeHDA original desta versao beta 10.8.2 sem modificaçoes? Agradecido.

Share this post


Link to post
Share on other sites

olá

 

aki está applehda original

 

AppleHDA.kext_10.8.2.zip

 

bom hack

 

Muito obrigado artur, vou tentar aplicar o patch a ver se funciona bem ;)

 

Artur, reparei que você removeu a pasta resources, mas já editei e está a funcionar na minha mobo. Partilho-a se alguém precisar. Obrigado

 

é necessário alteração em DSDT:

 

Device (HDEF)

{

Name (_ADR, 0x001B0000)

Method (_PRW, 0, NotSerialized)

{

Return (Package (0x02)

{

0x0D,

0x05

})

}

 

Method (_DSM, 4, NotSerialized)

{

Store (Package (0x04)

{

"layout-id",

Buffer (0x04)

{

0x0C, 0x00, 0x00, 0x00

},

 

"PinConfigurations",

Buffer (One)

{

0x00

}

}, Local0)

DTGP (Arg0, Arg1, Arg2, Arg3, RefOf (Local0))

Return (Local0)

}

}

AppleHDA ALC888.10.8.2.zip

Share this post


Link to post
Share on other sites

I update yesterday 10.8.2 (12C31a)

 

Base was made myHack 3.1 (=removed 3 kext, and returned back AppleHDA 2.11)

 

After update, I must delete 2 same kext, which myHack removed from early. I do not find

third kext. I must remove OemSMBIOS.kext, which belongs to FakeSMC.

 

First boot with -v -f parameter in Chameleon.

 

Works well.

 

 

T -.-

Share this post


Link to post
Share on other sites

Hi i found this bootflag for chameleon documentation:

 

io=0xffffffff -v

booting 10.8.2

Registering: IOService:/

waitForSystemMapper

Backtrace

Kernel Extensions in backtrace:

com.apple.driverAppleACPIPlatform (1.6)

dependency: com.apple.iokit.IOACPIFamily (1.4)

dependency: com.apple.iokit.IOPCIFamily (2.7.1)

any idea?

Share this post


Link to post
Share on other sites

Hi i found this bootflag for chameleon documentation:

 

 

io=0xffffffff -v

 

booting 10.8.2

Registering: IOService:/

waitForSystemMapper

Backtrace

Kernel Extensions in backtrace:

com.apple.driverAppleACPIPlatform (1.6)

dependency: com.apple.iokit.IOACPIFamily (1.4)

dependency: com.apple.iokit.IOPCIFamily (2.7.1)

 

 

any idea?

 

 

chameleon not recognize ACPI

 

ACPI: System State [s0 S3 S4 S5]

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×