Jump to content
  • Announcements

    • Allan

      Forum Rules   04/13/2018

      Hello folks! As some things are being fixed, we'll keep you updated. Per hour the Forum Rules don't have a dedicated "Tab", so here is the place that we have our Rules back. New Users Lounge > [READ] - InsanelyMac Forum Rules - The InsanelyMac Staff Team. 
blak24

upgraded from Lion...

119 posts in this topic

Recommended Posts

Hello everybody, yesterday I created the USB bootable modified image of Mountain Lion, then I installed it over my Lion hackintosh to preserve my files/installed programs.. well, the installation was fine, but now I can't boot Mountain Lion. for the first 2-3 times, in verbose mode, it seemed to boot, but it was stuck for about 5-10 minutes with the last string saying "AppleIntel1000e: runs 100Mbps RX/TX" or something like that. then, from my windows 7 HD booted up, I tried to modify/cancel some kext in system/library/extensions copying the kexts from Lion (which was working very well). note that the kexts from Lion were copied by me yesterday before installation. then, with the old ketxs from mountain lion copied, I tried to boot, but it was stuck at the first black screen with white strings... before the initialization of tha MAC framework it reboots without any error message... I tried to recopy the new kexts from mountain lion, but I had no luck, same problem: at the first black screen it reboots without any error message... what's happened?

 

P.S: please note my hardware config: Asus P8Z68-V Gen3, i2500k, HD6970, 8gb ram... in Lion everything worked like a charm... icon_e_confused.gif

 

EDIT: I saw that before it reboots without errors, the last file he reads is the AppleHDA1062 into system/library/extensions... what's this file?

Share this post


Link to post
Share on other sites

I tried, but it just stopped in the image below... any other ideas? note that I can modify/cancel/add .kext files from windows...

post-584062-0-59920700-1345569217_thumb.jpg

Share this post


Link to post
Share on other sites

Your picture indicates a video problem, next step in the normal progression is transfer to the Mac desktop. What usually works here is to set GraphiceEnabler=Yes and try different framebuffers at boot.

 

For example: at the boot prompt, type -v AtiConfig=Gibba then hit Return. If that doesn't work reboot and substitute a different FB for Gibba. Others you can try are: Lotus, Muskgrass, Juniper, Cypress etc.

 

If you have a copy of Chameleon Wizard there are a number of FBs listed there you can try. You will probably find more than one that works. Chose the best one for your card and add that as a Flag in the org.chameleon.boot.plist.

Share this post


Link to post
Share on other sites

so first I should try with -v GraphicsEnabler=yes? if that doesn't work I should try -v aticonfig=gibba or other "names"? the fact is that I have an Intel HD3000 integrated GPU in the i5 2500k... and I'm using this one. to use the hd6970 I will have to install some other drivers when I will be able to reach the desktop... I will try

 

EDIT: that image was picked booting with -v -f -UseKernelCache=No... if I use the commands you gave me, for example: -v GraphicsEnabler=Yes (assuming that this shuold be one of the correct commands toghether with AtiConfig=Gibba ecc...), the result is the following image

post-584062-0-17222300-1345572802_thumb.jpg

Share this post


Link to post
Share on other sites

First try booting with PCIRootUID=0 -x -f -v

if that dont work try booting in single user mode (-s) and when root appears type these lines

 

mount -uw /

cd System/Library/Extensions

mkdir IntelBack

mv AppleIntelHD* IntelBack/

mv AppleIntelSNB* IntelBack/

exit

 

And see if you can boot.

Share this post


Link to post
Share on other sites

before trying this, it booted in safe mode, just typed -v -x... what should I install with Multi++beast now? or maybe I should first try to boot without using safe mode? (why multi++beast is covered from words?)

Share this post


Link to post
Share on other sites

this software is crapware, and read this :

 

We don't just "hate" them. We don't hate anybody. We want to keep moral standards high, safeguard genuine developers, and certainly we don't steal from our users

 

http://www.insanelym...howtopic=279451

 

And let me stress once again:

http://prasys.info/2...ymac-seriously/

Share this post


Link to post
Share on other sites

Because it's from a website that we (insanelymac) do not support. There's a topic on it if you want to read why. But back to your installation problem, I don't, nor have I ever used their (the blocked words) software to install any version of Mac on any of the PCs I've done. So I can't help you. BUT, there is a few guides on here if you're interested. I have a guide up that I used for my gf's Dell and my MSi you see in my signature. I'm actually on my MSi right now.

Share this post


Link to post
Share on other sites

first, sorry for that. second, if you have other suggestions to help me installing kext to make the hd3000 recognized correctly and get sound working I'm happy to do this way! the problem is that it only boots in safe mode... can I always boot in safe mode without any problem? if it's so, the remaining things that don't work are audio and the integrated HD3000 in my 2500k, because mountain lion recognizes my hd6970...

Share this post


Link to post
Share on other sites

one moment I have medicine for this

 

this for HD 3000 10.8 ML

 

 

http://www.insanelym...l=&fromsearch=1

 

 

Use this terminal comands for backup your kexts and install news kexts from this link.

 

 

cd /

mkdir kext_backup

cd /System/Library/Extensions

mv AppleIntelHD* AppleIntelSNB* ATI* GeForce* NVDA*/kext_backup

rm -rf /System/Library/Caches/*

exit

Share this post


Link to post
Share on other sites

I don't even have sound on mine yet. lol.. I'm still working out a couple kinks in my system. Well, 2 actually are the main ones, audio, and flickery graphics. lol

Share this post


Link to post
Share on other sites

UPDATE: I'm trying your method iFire.. in the meanwhile a question: why every time I have to type -v -x ecc... in the boot menù my keyboard is recognized 1 time out of 10? (for example)... I often have to restart and try again until the boot loader recognize the keyboard...

Share this post


Link to post
Share on other sites

I'm thinking that has to do with the -x which is safe boot. If I boot in safe boot my touch pad no longer works, and in a couple installation tries my keyboard wouldn't work. Try booting without -x maybe?

Share this post


Link to post
Share on other sites

I'm thinking that has to do with the -x which is safe boot. If I boot in safe boot my touch pad no longer works, and in a couple installation tries my keyboard wouldn't work. Try booting without -x maybe?

no.. because the problem is BEFORE the booting process...

Share this post


Link to post
Share on other sites

well, as I said, the bootloader is reading my keyboard 1 time out of 5... if I'm lucky... every time I have to restart my pc using the button hoping the keyboard will work... other updates: I will try this (I know it comes from tonymac, but it could be good, because I haven't to use ###### or other things)

Since many of you have issues getting your AMD Radeon HD 6000 series card to work in Mountain Lion (when it worked great in Lion), I decided to make this guide.

 

Credits: Haysphere

 

Part 1: Setting up the ###### Drive

1. Insert your ###### Flash Drive into a working Mac. Maybe your MacBook Pro, working Lion installation, etc.

2. Run this command in terminal to unhide files "defaults write com.apple.finder AppleShowAllFiles 1" (copy and paste that into terminal and hit enter)

3. Force Finder to quit. You can do this in activity monitor. It will automatically restart.

4. Open Finder and navigate to your ###### Drive

5. Navigate to System/Library/Extensions

6. MAKE A BACKUP OF the kext "ATI6000Controller.kext" and then DELETE it.

 

Part 2: Booting from your ###### Drive

1. Boot from your ###### drive like you usually would. Use the command "GraphicsEnabler=No" in order to boot into Mountain Lion Installer

2. Install Mountain Lion as you usually would

3. After installation, bootup Mountain Lion by booting into your flash drive and then booting into ML, using the command "GraphicsEnabler=No"

4. Copy the ATI6000Controller.kext kext to your new desktop

5. Run ###### (Download: http://www.tonymacx86.com/downloads.php?do=cat&id=3)

6. Reboot

 

Now your graphics should work. I have two monitors (Apple Cinema Display and another 25" 1080p monitor) running with full graphics acceleration Very fast and no lag!

 

For those wondering, I fixed my machine in my sig by replacing the parts with the exact same things. Not everything blew. I now run a surge protector on my phone line and computer.

 

You're welcome!

 

to get my HD6970 working, so I will reinstall ML... yesterday evening I had no luck recognizing my HD3000... another problem: I'm installing ML without a bootloader, so I have to boot with the bootloader taken from the USB flash drive used for the installation... yesterday I tried then to install a bootloader to boot directly from HDD and not from flash drive, I tried chimera and chameleon, but both of them gave me always a kernel panic... the only way to boot up the system was using the bootloader from the flash drive (a different version of chameleon I suppose) and booting in safe mode. any ideas? I'm thinkin on giving up with this... nothing seems to work as it should...

 

EDIT: tried that. the positive thing is that now I can boot WITHOUT safe mode... the bad thing is that if I try to boot directly with my hd6970 I just have a white screen without anything else... (I had this problem in Lion... never solved it)

Share this post


Link to post
Share on other sites

hello black24, what problem you have?

ok, if you boot -x not load kext for your keyboard, and all kexts have install in S/LE, configure your boot.plist with this flag UseKernelCache=Yes

Share this post


Link to post
Share on other sites

hello black24, what problem you have?

ok, if you boot -x not load kext for your keyboard, and all kexts have install in S/LE, configure your boot.plist with this flag UseKernelCache=Yes

hello! :)

the problem with my keyboard is that I can't write! it isn't recognized at all! so I can't boot because I can't select my HDD... don't know why... 1 hour ago I tried again and I had to reset the pc using the button almost 15 times.. I lost 10 minutes... finally my keyboard worked and I was able to boot..

 

NOW, I reinstalled ML to follow that steps to get hd6970 BOOT with ML... but I just have a white screen... as I wrote in the edited post above yours, the good thing is that now I can boot without -x, just -v and GraphicsEnabler=No and it works... (graphicsenabler because if I don't do that, my hd6970 gives me the white screen...) now I will try to boot with the integrated HD3000, but I don't think it will be recognized...

Share this post


Link to post
Share on other sites

my keyboard is USB... in bios it works perfectly... how can i post the extra folder? that located in *HDD name*? just make a zip file of it?

 

EDIT: problems... just problems... reinstalled ATI6000 controller.kext using kextwizard... well, now, even if I boot with graphicsenabler=no or without it I get a white screen...

if I boot with my integrated graphics HD3000, it can't boot because it is stuck at the same problem of yesterday... (it's the same photo I took yesterday because it is stuck always there...)

 

EDIT 2: where is the extra folder? can I see it from windows? because I can't now...

 

EDIT 3: well, I'm thinking... I have NO bootloader installed in the HDD... I have no smbios.plist etc... for now, I always boot with my flash drive which has got chameleon... maybe the extra folder is created by the bootloader? (I'm asking because I don't know :D )

post-584062-0-39375300-1345628395_thumb.jpg

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


  • Recently Browsing   0 members

    No registered users viewing this page.

×