Jump to content
Sign in to follow this  
Alfabl0s

Proper Audio kext no more :(

5 posts in this topic

Recommended Posts

Hi guys,

I've just installed ML on my M50Vn. Everything works except for audio.

About 1 year ago, or so, I installed Snow Leopard (Everything was all righ, even audio and Wi-Fi), but after a short time I decided to go back to linux due to stability issues; now I've come back to OS X, and here we are with Mountain Lion. I can say this OS rocks on my laptop, but still I can't get audio working. The thing is, I had some audio Kext in SL (It's VoodooHDA but I can't check the version, although I still have the file), and I don't know whether they're good for ML or not: I haven't tried it yet because I don't want trouble booting (500Gb HD with just 1 partition, which I installed ML on).

Yesterday I tried to install VoodooHDA 0.2.2 (newer versions were unstable, so the place I got them from wrote) but still no audio.

 

What I ask you is:

- Is It safe for me to install the old kext I have, which worked with Snow Leopard?

- Do you know, any kext I could try?

This is what my laptop's configuration is reported to be by ASUS website:

 

Chip Audio compatibile integrato Azalia, con effetto 3D & full duplex (Integrated Azalia-compatible audio chip; 3D effect and Full Duplex)

 

Built-in Intel® High Definition audio compliant audio chip (no need to translate

:))

 

ALTEC LANCING co-brand speakers

 

Altoparlanti e microfono integrati (integrated speakers and microphone)

 

Support Dolby® Home Theatre

 

 

I'll attach my old kext so you can check it out.

 

Thank you

Antonio

Share this post


Link to post
Share on other sites
Advertisement

We need to know what exact sound chip is that... it should be some ALCXXX (XXX = the numbers)

 

Also, I think you didn't attached your old kext.

Share this post


Link to post
Share on other sites

Where can I check the exact model of my audio chip? Of course, according to OS X I have none :P

 

You're right, maybe because it was not in zip (or maybe just because I forgot to click on "Attach this file" XD). Here we go!

VoodooHDA.kext.zip

Share this post


Link to post
Share on other sites

I thought I can read your exact ALC model from your old kext, but sadly I can't.

Do you have Windows installed on your machine? If yes, use AIDA64 or something like that to get your exact sound chip type.

Share this post


Link to post
Share on other sites

no Windows anymore :)

Old kext worked with ML as well. I'd like to post a guide but the way I used to install ML is banished from this forum :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Recently Browsing   0 members

    No registered users viewing this page.

×