Jump to content
future_ex_kid

DSDT patch for TOSHIBA Satellite L750

230 posts in this topic

Recommended Posts

Hello

 

I am an owner of a Toshiba satellite l750-1GN Laptop ( http://www.toshibame.../50058?pageid=4 ) . I have ML installed through Unibe@@t anddd.... it seems that it is working well , i have ethernet and wifi kexts installed , graphics seem to be working BUT i have no sound, HDMI , VGA , USB 3.0 and i need to unplug after i shut down in order to boot up and of course the missing DSDT . The thing is i am a newbie to the hackintosh world ( i am into things for about a week ) and i have no ideas regarding DSDTs and that's why i am asking in this section , it would be too cool if i just had to copy and paste files since you guys have already worked this out.What is of paramount importance is that i am close to a deadline for a presentation at school and i need audio to be working , everything else is secondary .

 

Spkone

 

Follow my post above and replace extra/ssdt.aml with the one attached here for your processor.

 

https://dl.dropbox.c...T 2430m.aml.zip

 

Anyway i suggest you to create a installer with the extra folder provided and do a retail clean install without Unicrap goodies, then install both drivers provided (voodoohda and voodoobattery) and copy extra folder to main partition (of course chameleon has to be installed also).

Share this post


Link to post
Share on other sites
Advertisement

The Legacy injector injects SPeedstep Data into Acpi_SMC_PlatformPlugin.kext and Graphics power management into AppleGraphicsPowerManagement.kext

 

 

This Cuda Benchmark failed till i did patch the driver in 10.8.3

 

http://www.insanelym...-07-march-2013/

 

I think we have a native speedstep with patched BIOS? And full function of VGA with dsdt. Maybe I should get a try that kext and also voodoohda for HDMI audio.

Share this post


Link to post
Share on other sites

Thank you for responding !

 

How am I gonna create this installer , and how am I going to do a retail install without using #####(i have ML bought from the app store)?

Also ,up until now,I did everything , from Chimera to keyboard kexts through ##### due to the simplicity it provided , so ,I am gonna need a little bit of extra guidance here ..sorry for the lack of knowledge

Spkone

Share this post


Link to post
Share on other sites

As I can see whe have two different ways to get our goal tranduyquangs one uses original apples patched kexts and pere uses vodoos ones for batery and sound. I would prefer to get as much hard as posible recognised by system information. But as far as i know if you use original apple kexts they can be erased with system updates.

 

Perhaps to determine wich approach gets better performance from our hardware both of you can make some brenchmarks to work together to achieve the best hackintosh.

 

I will delete powermanagement kext and see what happens

Share this post


Link to post
Share on other sites

Thank you for responding !

 

How am I gonna create this installer , and how am I going to do a retail install without using #####(i have ML bought from the app store)?

Also ,up until now,I did everything , from Chimera to keyboard kexts through ##### due to the simplicity it provided , so ,I am gonna need a little bit of extra guidance here ..sorry for the lack of knowledge

Spkone

 

 

Use Myhack. :)

Share this post


Link to post
Share on other sites

As I can see whe have two different ways to get our goal tranduyquangs one uses original apples patched kexts and pere uses vodoos ones for batery and sound. I would prefer to get as much hard as posible recognised by system information. But as far as i know if you use original apple kexts they can be erased with system updates.

 

Perhaps to determine wich approach gets better performance from our hardware both of you can make some brenchmarks to work together to achieve the best hackintosh.

 

I will delete powermanagement kext and see what happens

 

There is some ways to obtain hackinosh working, you can choose which kext/way that you like. For more exp and for getting a better performance hackintosh I recommend that you should try all and figure out the best way. Cheer :moil:

Share this post


Link to post
Share on other sites

Use Myhack. :)

 

When i replace the extra folder with yours , when booting , after the bootloader bar finishes unloading( in order to get extra boot options ) i get a white screen , the one you get with the apple logo , but i get it just "white" without the apple logo and it freezes there :D , i haven't pached the bios though as i am afraid i will do something wrong . Is that the freezing problem ?

 

 

Spkone

 

 

Edit : Wrong Alert , everything is fine :D

Share this post


Link to post
Share on other sites

When i replace the extra folder with yours , when booting , after the bootloader bar finishes unloading( in order to get extra boot options ) i get a white screen , the one you get with the apple logo , but i get it just "white" without the apple logo and it freezes there :D , i haven't pached the bios though as i am afraid i will do something wrong . Is that the freezing problem ?

 

 

Spkone

 

 

Edit : Wrong Alert , everything is fine :D

 

When you finish install and replace the extra folder located into your hard disk, you will have to know this:

 

Myhack installs myhack.kext into system/library/extensions, wich include nullcpupowermanagement.kext, wich avoids kernel panic on your system, but also makes speedstep unavaliable.

 

You have to erase myhack.kext, and patch appleintelcpupowermanagement.kext or patch your bios to unlock powermanagement. There is a lot of information about this on the forum.

Share this post


Link to post
Share on other sites

When you finish install and replace the extra folder located into your hard disk, you will have to know this:

 

Myhack installs myhack.kext into system/library/extensions, wich include nullcpupowermanagement.kext, wich avoids kernel panic on your system, but also makes speedstep unavaliable.

 

You have to erase myhack.kext, and patch appleintelcpupowermanagement.kext or patch your bios to unlock powermanagement. There is a lot of information about this on the forum.

 

I have a sound issue . After installing the VoodooHDA Kext everything worked fine , but when i start the laptop every time the sound card and the audio jack are missing as audio outputs and there is only the HDMI digital audio ( after connecting HDMI cable to stream sth for ex ). I once fixed this using my hack " remove problematix extensions " and removing the kext and reinstalling it , but it happened again after connecting to the tv ( using HDMI only as video source , i used the jack to play sound this time ) . I fixed it again , but i dont want this to happen any time . Any suggestions ?

Share this post


Link to post
Share on other sites

I have a sound issue . After installing the VoodooHDA Kext everything worked fine , but when i start the laptop every time the sound card and the audio jack are missing as audio outputs and there is only the HDMI digital audio ( after connecting HDMI cable to stream sth for ex ). I once fixed this using my hack " remove problematix extensions " and removing the kext and reinstalling it , but it happened again after connecting to the tv ( using HDMI only as video source , i used the jack to play sound this time ) . I fixed it again , but i dont want this to happen any time . Any suggestions ?

 

This haven´t happend to me ever.... I don´t know what to advice you. :(

 

 

EDIT: I have been working on my DSDT and SSDT and also reworking osrom´s kext disabler to disable this kexts: AppleHDA, ApplePolicyControl, AppleTyMCEDriver and AppleUpstreamUserClient.

 

I have found on several systems installed with myhack a kernel panic after updating related to one of those kexts, this disabler will take care of them.

 

In case you want to use AppleHDA just open info.plist on /extra/kextsdisabler.kext and erase Applehda related entries.

 

Link: https://dl.dropbox.com/u/384839/OsX86/Toshiba%20L750%20ML%2010.8.zip

 

I have improved stability and overall system performance, measured with Cinebench from 2.35 to 2.55.

 

Enjoy.

Share this post


Link to post
Share on other sites

@pere: what code did you edit/rectify in your new dsdt?

 

Just started everything from scratch, seems there was an error somewhere, just applied standart patches and the ones specific to our lappys.

Share this post


Link to post
Share on other sites

6a00d8341d4dc653ef01348895f9a8970c-800wi

 

Good news for Toshiba L750 owners… Maverick DP1 working.

Use attached extra folder and drivers with lastest Myhack installer.

Create your own serial number on Smbios.plist with lizard and remember to erase myhack.kext from s/l/e after install.

 

I have replaced the extra folder inside myhack just to be sure everything is at it should.

 

Enjoy.

 

Extra for L750

Share this post


Link to post
Share on other sites

6a00d8341d4dc653ef01348895f9a8970c-800wi

 

Good news for Toshiba L750 owners… Maverick DP1 working.

Use attached extra folder and drivers with lastest Myhack installer.

Create your own serial number on Smbios.plist with lizard and remember to erase myhack.kext from s/l/e after install.

 

I have replaced the extra folder inside myhack just to be sure everything is at it should.

 

Enjoy.

 

Extra for L750

Wow, you updated to 10.9? Are your lappy working good? How about wake up and sleep? HDMI sound?

Share this post


Link to post
Share on other sites

Bluetooth still not working, the rest it is.

 

I haven´t tried sleep and wake, but i do have problems with it on 10.8.4.

 

HDMI working with voodoohda.

Share this post


Link to post
Share on other sites

Can Nvidia web drivers be installed? I have tried but I cant even get the installer to work, neither to exchange it with any type of graphic card

Share this post


Link to post
Share on other sites

Good news: I haven't installed 10.9 DP1 because my Macos partition is only 20 Gb, so there is only 7 Gb free after installed OS. Therefore I cannot create 10.9 DP1 install usb (I tried 3 times but did not success due to Macos partiton only have about 100Mb left when it's running Myhack app). Then I did a fresh install of 10.8.4 with Extra folder given by pere (only change my ssdt and smbios). I also intalled newest Cuda driver, patch OpenCL, run freefixapp. My hackintosh now can sleep and wake up normally. For additional patch script and freefixapp plz prefer to link below:

 

 

Do try to patch and have fun. Cheer to Tos L75x hackintosh users!

Share this post


Link to post
Share on other sites

Why freezefix? We don´t need this fix on our Nvidia cards.

I am not sure about that so that I just run that app. The important thing is my lap can sleep and wake up. A remaining problem that when I shutdown while AC is on then I cannot power up lappy again. I have to remove AC and battery and then put those back to power up. Do you have any idea on that issue?

Share this post


Link to post
Share on other sites

Hi pere, I've tried connect to my TV but HDMI sound did not work. I used all your Extra folder except ssdt and SMBIOS (because I saw  some strange code in ur smbios.plist that might be not suitable with my lappy), any advices for me to enable HDMI sound?

 

Your smbios:

<key>SMbiosdate</key>
	<string>14/01/2010</string>
	<key>SMbiosversion</key>
	<string>MBP81.88Z.00C1.B03.0802271651</string>
	<key>SMboardproduct</key>
	<string>Mac-F42386C8</string>
	<key>SMcputype</key>
	<string>1537</string>
	<key>SMexternalclock</key>
	<string>1333</string>
	<key>SMfamily</key>
	<string>MacBook Pro</string>
	<key>SMmanufacter</key>
	<string>Apple</string>
	<key>SMmaximalclock</key>
	<string>2.29GHz</string>
	<key>SMmemmanufacter_1</key>
	<string>Samsung</string>
	<key>SMmemmanufacter_2</key>
	<string>Samsung</string>
	<key>SMmempart_1</key>
	<string>M471B5773DH0-CH9</string>
	<key>SMmempart_2</key>
	<string>M471B5773DH0-CH9</string>
	<key>SMmemserial_1</key>
	<string>001DD429</string>
	<key>SMmemserial_2</key>
	<string>001DD30C</string>
	<key>SMmemspeed</key>
	<string>1333</string>
	<key>SMmemtype</key>
	<string>24</string>
	<key>SMproductname</key>
	<string>MacBookPro8,1</string>
	<key>SMserial</key>
	<string>UseYOurOwn</string>
	<key>SMsystemversion</key>
	<string>1.0</string>

This is mine:

<key>EnableHDMIAudio</key>
	<string>Yes</string>
	<key>SMbiosdate</key>
	<string>04/22/11</string>
	<key>SMbiosvendor</key>
	<string>Apple Inc.</string>
	<key>SMbiosversion</key>
	<string>MBP81.88Z.0047.B0E.1104221557</string>
	<key>SMboardproduct</key>
	<string>Mac-94245B3640C91C81</string>
	<key>SMfamily</key>
	<string>MacBook Pro</string>
	<key>SMmanufacturer</key>
	<string>Apple Inc.</string>
	<key>SMproductname</key>
	<string>MacBookPro8,1</string>
	<key>SMserial</key>
	<string>C02JH153DH2G</string>
	<key>SMsystemversion</key>
	<string>1.0</string>

Share this post


Link to post
Share on other sites

The key <key>EnableHDMIAudio</key> goes into org.chameleon.boot.plist not in smbios.plist

 

Also, go to Audio-midi setup on utilities folder and change the frequency from whatever it is to 48000hz in all audio outputs.

 

Then select second HDMI audio output as audio output in sound pref pane.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.

×